source: projects/specs/branches/6/lib/libu/libuser/libuser-vl.spec @ 1901

Revision 1901, 18.6 KB checked in by Takemikaduchi, 14 years ago (diff)

rebuild with rpm-4.8.1

Line 
1%define WITH_SELINUX 0
2%define python %(python -c 'import sys;print(sys.version[0:3])')
3
4
5Name: libuser
6Version: 0.56.9
7Release: 4%{?_dist_release}
8Summary: A user and group account administration library.
9Summary(ja): ユーザアカウントとグループアカウントを管理するライブラリ
10Group: System Environment/Base
11License: LGPL
12URL: https://fedorahosted.org/libuser/
13Source: libuser-%{version}.tar.bz2
14Patch0: libuser-selinux.patch
15BuildRoot: %{_tmppath}/%{name}-root
16BuildRequires: pam-devel
17BuildRequires: popt
18BuildRequires: python-devel
19BuildRequires: gtk-doc
20BuildRequires: linuxdoc-tools
21BuildRequires: pkgconfig
22BuildRequires: glib2-devel
23BuildRequires: popt-devel
24#BuildPrereq: cyrus-sasl-devel, openldap-devel
25
26%description
27The libuser library implements a standardized interface for manipulating
28and administering user and group accounts.  The library uses pluggable
29back-ends to interface to its data sources.
30
31Sample applications modeled after those included with the shadow password
32suite are included.
33
34%package devel
35Group: Development/Libraries
36Summary: Files needed for developing applications which use libuser.
37Requires: %{name} = %{version}-%{release}
38
39%description devel
40The libuser-devel package contains header files, static libraries, and other
41files useful for developing applications with libuser.
42
43%prep
44%setup -q
45%if %{WITH_SELINUX}
46#SELinux
47%patch0 -p1 -b .selinux
48%endif
49
50%build
51CFLAGS="$RPM_OPT_FLAGS -fPIC" ; export CFLAGS
52%configure \
53        --with-python-version=%{python} \
54        --with-python-path=%{_includedir}/python%{python} \
55        --with-html-dir=%{_datadir}/gtk-doc/html \
56        --with-pic
57make
58
59%clean
60rm -fr $RPM_BUILD_ROOT
61
62%install
63rm -fr $RPM_BUILD_ROOT
64make install DESTDIR=$RPM_BUILD_ROOT
65
66rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
67
68LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%{_libdir}:${LD_LIBRARY_PATH}
69export LD_LIBRARY_PATH
70
71# Verify that all python modules load, just in case.
72pushd $RPM_BUILD_ROOT/%{_libdir}/python%{python}/site-packages/
73python%{python} -c "import libuser"
74popd
75
76# remove .la
77rm -f $RPM_BUILD_ROOT%{_libdir}/libuser/*.la
78rm -f $RPM_BUILD_ROOT%{_libdir}/python%{python}/site-packages/*.la
79         
80
81%find_lang %{name}
82
83%post -p /sbin/ldconfig
84
85%postun -p /sbin/ldconfig
86
87%files -f %{name}.lang
88%defattr(-,root,root)
89%doc AUTHORS COPYING NEWS README TODO docs/*.txt python/modules.txt
90%config(noreplace) %{_sysconfdir}/libuser.conf
91
92%attr(0755,root,root) %{_bindir}/*
93%attr(0755,root,root) %{_libdir}/python%{python}/site-packages/*.so
94%attr(0755,root,root) %{_libdir}/*.so.*
95%dir %attr(0755,root,root) %{_libdir}/%{name}
96%attr(0755,root,root) %{_libdir}/%{name}/*.so
97#%attr(0644,root,root) %{_libdir}/%{name}/*.la
98%attr(0755,root,root) %{_sbindir}/*
99
100%files devel
101%defattr(-,root,root)
102%attr(0755,root,root) %dir %{_includedir}/libuser
103%attr(0644,root,root) %{_includedir}/libuser/*
104#attr(0644,root,root) %{_libdir}/*.la
105%attr(0755,root,root) %{_libdir}/*.so
106#%attr(0644,root,root) %{_mandir}/man3/*
107%attr(0644,root,root) %{_mandir}/man5/*
108
109%attr(0644,root,root) %{_libdir}/pkgconfig/*
110
111%{_datadir}/gtk-doc/html/*
112%{_mandir}/man1/*
113
114%changelog
115* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.56.9-4
116- rebuild with rpm-4.8.1 for pkg-config file
117
118* Sun Feb 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.56.9-3
119- add BuildRequires: pkgconfig, glib2-devel, popt-devel
120
121* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.56.9-2
122- rebuild for python-2.6
123
124* Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.56.9-1
125- new upstream release
126
127* Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 0.53.8-3
128- rebuilt with python-2.5.2
129- removed *.la
130
131* Mon Jun  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.53.8-2
132- applied new versioning policy
133
134* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.53.8-1vl1
135- new upstream release
136
137* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 0.51.7-7vl3
138- rebuild with python-2.4.1-0vl1
139
140* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 0.51.7-7vl2
141- rebuild with python-2.3.3-0vl1
142
143* Thu Apr 15 2004 Shu KONNO <owa@bg.wakwak.com> 0.51.7-7vl1.1
144- rebuild with python-2.3.3-0vl0.3 (for TestPkg)
145
146* Sat Apr 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.51.7-7vl1
147- resync to fedora
148
149* Sat Jan 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.51.2-1vl1
150- initial build for Vine Linux
151
152* Wed Dec 11 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51.2-1
153- degrade gracefully
154- build with --with-pic and -fPIC
155- remove unpackaged man page
156
157* Tue Aug 27 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51.1-2
158- translation updates
159
160* Wed Jul 24 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51.1-1
161- doc updates -- cvs tree moved
162- language updates
163- disallow weird characters in account names
164
165* Sun May 26 2002 Tim Powers <timp@redhat.com>
166- automated rebuild
167
168* Mon May 20 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51-1
169- files: ignore blank lines in files
170- libuser: disallow creation of accounts with names containing whitespace,
171  control characters, or non-ASCII characters
172
173* Tue Apr 16 2002 Nalin Dahyabhai <nalin@redhat.com> 0.50.2-1
174- refresh translations
175- fix a heap-corruption bug in the python bindings
176
177* Mon Apr 15 2002 Nalin Dahyabhai <nalin@redhat.com> 0.50-1
178- bump version
179- refresh translations
180
181* Thu Mar 14 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.102-1
182- ldap: cache an entity's dn in the entity structure to try to speed things up
183
184* Mon Mar 11 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.101-3
185- rebuild in new environment
186
187* Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.101-2
188- add missing buildreqs on cyrus-sasl-devel and openldap-devel (#59456)
189- translation refresh
190
191* Fri Mar  1 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.101-1
192- fix python bindings of enumerateFull functions
193- adjust prompter wrapping to not error out on successful returns
194
195* Thu Feb 28 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.100-1
196- be more careful about printing error messages
197- fix refreshing after adding of accounts
198- ldap: try to use a search to convert names to DNs, and only fall back to
199  guessing if it turns up nothing
200- files: fix an off-by-one in removal of entries
201
202* Mon Feb 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.99-1
203- refresh translations
204- fix admin() constructor comments in the python module
205
206* Thu Feb 21 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.98-1
207- automatically refresh entities after add, modify, setpass, removepass,
208  lock, and unlock operations
209- remove debug spewage when creating and removing mail spools
210- files: fix saving of multi-valued attributes
211- rename MEMBERUID attribute for groups to MEMBERNAME
212
213* Wed Feb 20 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.97-1
214- files: fix bug in removals
215- ldap: revert attempts at being smart at startup time, because it makes UIs
216  very messy (up the three whole dialogs just to start the ldap stuff!)
217
218* Sun Feb 16 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.96-1
219- fix thinko in dispatch routines
220
221* Wed Feb 13 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.95-1
222- lgroupmod: fix thinko
223
224* Thu Jan 31 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.94-2
225- rebuild in new environment
226
227* Tue Jan 29 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.93-1
228- move shadow initialization for groups to the proper callback
229- rework locking in the files module to not require that files be writable
230
231* Tue Jan 29 2002 Nalin Dahyabhai <nalin@redhat.com>
232- expose lu_strerror()
233- add various typedefs for types used by the library
234
235* Mon Jan 28 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.92-1
236- add removepass() functions
237
238* Thu Jan 24 2002 Nalin Dahyabhai <nalin@redhat.com>
239- lchfn,lchsh,lpasswd - reorder PAM authentication calls
240- include API docs in the package
241
242* Thu Jan 24 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.91-1
243- ldap: finish port to new API
244- sasl: finish port to new API (needs test)
245- libuser: don't commit object changes before passing data to service
246  functions which might need differing data sets to figure out what to
247  change (for example, ldap)
248
249* Thu Jan 17 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.90-1
250- bind the internal mail spool creation/removal functions for python
251
252* Wed Jan 16 2002 Nalin Dahyabhai <nalin@redhat.com>
253- renamed the python module
254- revamped internals to use gobject's gvalues and gvaluearrays instead of
255  glists of cached strings
256- add enumeration-with-data functions to the C library
257
258* Mon Jan 07 2002 Florian La Roche <Florian.LaRoche@redhat.de>
259- require linuxdoc-tools instead of sgml-tools for rawhide
260
261* Tue Nov 13 2001 Nalin Dahyabhai <nalin@redhat.com>
262- fixup build files to allow building for arbitrary versions of python
263
264* Wed Aug 29 2001 Nalin Dahyabhai <nalin@redhat.com> 0.32-1
265- link the python module against libpam
266- attempt to import the python modules at build-time to verify dependencies
267
268* Tue Aug 28 2001 Nalin Dahyabhai <nalin@redhat.com> 0.31-1
269- fix a file-parsing bug that popped up in 0.29's mmap modifications
270
271* Mon Aug 27 2001 Nalin Dahyabhai <nalin@redhat.com> 0.30-1
272- quotaq: fix argument order when reading quota information
273- user_quota: set quota grace periods correctly
274- luseradd: never create home directories for system accounts
275
276* Tue Aug 21 2001 Nalin Dahyabhai <nalin@redhat.com>
277- add da translation files
278- update translations
279
280* Tue Aug 21 2001 Nalin Dahyabhai <nalin@redhat.com> 0.29-1
281- add an explicit build dependency on jade (for the docs)
282
283* Mon Aug 20 2001 Nalin Dahyabhai <nalin@redhat.com>
284- HUP nscd on modifications
285- userutil.c: mmap files we're reading for probable speed gain
286- userutil.c: be conservative with the amount of random data we read
287- docs fixes
288
289* Wed Aug 15 2001 Nalin Dahyabhai <nalin@redhat.com> 0.28-1
290- apps: print usage on errors
291- lnewusers.c: initialize groups as groups, not users
292- lnewusers.c: set passwords for new accounts
293- luseradd.c: accept group names in addition to IDs for the -g flag
294- luseradd.c: allow the primary GID to be a preexisting group
295
296* Tue Aug 14 2001 Nalin Dahyabhai <nalin@redhat.com> 0.27-1
297- add ko translation files
298- files.c: fix a heap corruption bug in lock/unlock (#51750)
299- files.c: close a memory leak in reading of files
300
301* Mon Aug 13 2001 Nalin Dahyabhai <nalin@redhat.com>
302- files.c: remove implementation limits on lengths of lines
303
304* Thu Aug  9 2001 Nalin Dahyabhai <nalin@redhat.com> 0.26-1
305- lusermod: change user name in groups the user is a member of during renames
306- lgroupmod: change primary GID for users who are in the group during renumbers
307- ldap.c: handle new attributes more gracefully if possible
308- add ru translation files
309
310* Tue Aug  7 2001 Nalin Dahyabhai <nalin@redhat.com> 0.25.1-1
311- rename the quota source files to match the library, which clears up a
312  file conflict with older quota packages
313- add ja translation files
314
315* Thu Aug  2 2001 Nalin Dahyabhai <nalin@redhat.com>
316- add lu_ent_clear_all() function
317
318* Thu Aug  2 2001 Nalin Dahyabhai <nalin@redhat.com> 0.25-1
319- close up some memory leaks
320- add the ability to include resident versions of modules in the library
321
322* Wed Aug  1 2001 Nalin Dahyabhai <nalin@redhat.com> 0.24-4
323- fix incorrect Py_BuildValue invocation in python module
324
325* Tue Jul 31 2001 Nalin Dahyabhai <nalin@redhat.com> 0.24-3
326- stop leaking descriptors in the files module
327- speed up user creation by reordering some checks for IDs being in use
328- update the shadowLastChanged attribute when we set a password
329- adjust usage of getXXXXX_r where needed
330- fix assorted bugs in python binding which break prompting
331
332* Mon Jul 30 2001 Nalin Dahyabhai <nalin@redhat.com> 0.23-1
333- install sv translation
334- make lpasswd prompt for passwords when none are given on the command line
335- make sure all user-visible strings are marked for translation
336- clean up some user-visible strings
337- require PAM authentication in lchsh, lchfn, and lpasswd for non-networked modules
338
339* Fri Jul 27 2001 Nalin Dahyabhai <nalin@redhat.com>
340- print uids and gids of users and names in lid app
341- fix tree traversal in users_enumerate_by_group and groups_enumerate_by_users
342- implement enumerate_by_group and enumerate_by_user in ldap module
343- fix id-based lookups in the ldap module
344- implement islocked() method in ldap module
345- implement setpass() method in ldap module
346- add lchfn and lchsh apps
347- add %%d substitution to libuser.conf
348
349* Thu Jul 26 2001 Nalin Dahyabhai <nalin@redhat.com> 0.21-1
350- finish adding a sasldb module which manipulates a sasldb file
351- add users_enumerate_by_group and groups_enumerate_by_users
352
353* Wed Jul 25 2001 Nalin Dahyabhai <nalin@redhat.com>
354- luserdel: remove the user's primary group if it has the same name as
355  the user and has no members configured (-G disables)
356- fixup some configure stuff to make libuser.conf get generated correctly
357  even when execprefix isn't specified
358
359* Tue Jul 24 2001 Nalin Dahyabhai <nalin@redhat.com> 0.20-1
360- only call the auth module when setting passwords (oops)
361- use GTrees instead of GHashTables for most internal tables
362- files: complain properly about unset attributes
363- files: group passwords are single-valued, not multiple-valued
364- add lpasswd app, make sure all apps start up popt with the right names
365
366* Mon Jul 23 2001 Nalin Dahyabhai <nalin@redhat.com> 0.18-1
367- actually make the new optional arguments optional
368- fix lu_error_new() to actually report errors right
369- fix part of the python bindings
370- include tools in the binary package again
371- fixup modules so that password-changing works right again
372- add a "key" field to prompt structures for use by apps which like to
373  cache these things
374- add an optional "mvhomedir" argument to userModify (python)
375
376* Fri Jul 20 2001 Nalin Dahyabhai <nalin@redhat.com> 0.16.1-1
377- finish home directory population
378- implement home directory moving
379- change entity get semantics in the python bindings to allow default values for .get()
380- add lu_ent_has(), and a python has_key() method to Entity types
381- don't include tools in the binary package
382- add translated strings
383
384* Thu Jul 19 2001 Nalin Dahyabhai <nalin@redhat.com>
385- lib/user.c: catch and ignore errors when running stacks
386- lusermod: fix slightly bogus help messages
387- luseradd: when adding a user and group, use the gid of the group
388  instead of the user's uid as the primary group
389- properly set the password field in user accounts created using
390  auth-only auth modules (shadow needs "x" instead of "!!")
391- implement home directory removal, start on population
392
393* Wed Jul 18 2001 Nalin Dahyabhai <nalin@redhat.com>
394- fix group password setting in the files module
395- setpass affects both auth and info, so run both stacks
396
397* Tue Jul 17 2001 Nalin Dahyabhai <nalin@redhat.com>
398- make the testbed apps noinst
399
400* Mon Jul 16 2001 Nalin Dahyabhai <nalin@redhat.com>
401- fix errors due to uninitialized fields in the python bindings
402- add kwargs support to all python wrappers
403- add a mechanism for passing arguments to python callbacks
404
405* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
406- stub out the krb5 and ldap modules so that they'll at least compile again
407 
408* Tue Jul 10 2001 Nalin Dahyabhai <nalin@redhat.com>
409- don't bail when writing empty fields to colon-delimited files
410- use permissions of the original file when making backup files instead of 0600
411
412* Fri Jul  6 2001 Nalin Dahyabhai <nalin@redhat.com>
413- finish implementing is_locked methods in files/shadow module
414- finish cleanup of the python bindings
415- allow conditional builds of modules so that we can build without
416  all of the prereqs for all of the modules
417
418* Thu Jun 21 2001 Nalin Dahyabhai <nalin@redhat.com>
419- add error reporting facilities
420- split public header into pieces by function
421- backend cleanups
422
423* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
424- make %%{name}-devel require %%{name} and not %%{name}-devel
425
426* Fri Jun 15 2001 Nalin Dahyabhai <nalin@redhat.com>
427- clean up quota bindings some more
428- finish most of the ldap bindings
429- fix a subtle bug in the files module that would show up when renaming accounts
430- fix mapping methods for entity structures in python
431
432* Thu Jun 14 2001 Nalin Dahyabhai <nalin@redhat.com>
433- get bindings for prompts to work correctly
434- clean up some of the add/remove semantics (set source on add)
435- ldap: implement enumeration
436- samples/enum: fix the argument order
437
438* Wed Jun 13 2001 Nalin Dahyabhai <nalin@redhat.com>
439- clean up python bindings for quota
440
441* Tue Jun 12 2001 Nalin Dahyabhai <nalin@redhat.com> 0.11
442- finish up python bindings for quota support
443
444* Sun Jun 10 2001 Nalin Dahyabhai <nalin@redhat.com>
445- finish up quota support libs
446
447* Fri Jun  8 2001 Nalin Dahyabhai <nalin@redhat.com>
448- start quota support library to get some type safety
449
450* Thu Jun  7 2001 Nalin Dahyabhai <nalin@redhat.com>
451- start looking at quota manipulation
452
453* Wed Jun  6 2001 Nalin Dahyabhai <nalin@redhat.com>
454- add functions for enumerating users and groups, optionally per-module
455- lusermod.c: -s should specify the shell, not the home directory
456
457* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com> 0.10
458- finish the python bindings and verify that the file backend works again
459
460* Wed May 30 2001 Nalin Dahyabhai <nalin@redhat.com>
461- remove a redundant check which was breaking modifications
462
463* Tue May 29 2001 Nalin Dahyabhai <nalin@redhat.com>
464- finish adding setpass methods
465
466* Wed May  2 2001 Nalin Dahyabhai <nalin@redhat.com> 0.9
467- get a start on some Python bindings
468
469* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com> 0.8.2
470- make binary-incompatible change in headers
471
472* Mon Apr 30 2001 Nalin Dahyabhai <nalin@redhat.com> 0.8.1
473- add doxygen docs and a "doc" target for them
474
475* Sat Jan 20 2001 Nalin Dahyabhai <nalin@redhat.com> 0.8
476- add a "quiet" prompter
477- add --interactive flag to sample apps and default to using quiet prompter
478- ldap: attempt a "self" bind if other attempts fail
479- krb5: connect to the password-changing service if the user principal has
480  the NULL instance
481
482* Wed Jan 10 2001 Nalin Dahyabhai <nalin@redhat.com>
483- the great adding-of-the-copyright-statements
484- take more care when creating backup files in the files module
485
486* Wed Jan  3 2001 Nalin Dahyabhai <nalin@redhat.com> 0.7
487- add openldap-devel as a buildprereq
488- krb5: use a continuous connection
489- krb5: add "realm" config directive
490- ldap: use a continuous connection
491- ldap: add "server", "basedn", "binddn", "user", "authuser" config directives
492- ldap: actually finish the account deletion function
493- ldap: don't send cleartext passwords to the directory
494- fix naming attribute for users (should be uid, not gid)
495- refine the search-by-id,convert-to-name,search-by-name logic
496- fix handling of defaults when the config file is read in but contains no value
497- implement an LDAP information store
498- try to clean up module naming with libtool
499- luseradd: pass plaintext passwords along
500- luseradd: use symbolic attribute names instead of hard-coded
501- lusermod: pass plaintext passwords along
502- lgroupadd: pass plaintext passwords along
503- lgroupmod: pass plaintext passwords along
504- add libuser as a dependency of libuser-devel
505
506* Tue Jan  2 2001 Nalin Dahyabhai <nalin@redhat.com> 0.6
507- initial packaging
Note: See TracBrowser for help on using the repository browser.