source: projects/specs/branches/6/lib/libt/libtorrent-rasterbar/libtorrent-rasterbar-vl.spec @ 2529

Revision 2529, 12.8 KB checked in by owa, 13 years ago (diff)

rebuilt with libboost-1.45.0

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4Name:           libtorrent-rasterbar
5Version:        0.15.4
6Release:        3%{?_dist_release}
7Summary:        A C++ BitTorrent library aiming to be the best alternative
8Summary(ja):    最良の代替手段となることを目指す C++ BitTorrent ライブラリ
9
10Group:          System Environment/Libraries
11License:        BSD
12URL:            http://www.rasterbar.com/products/libtorrent/
13
14Source0:        http://downloads.sourceforge.net/libtorrent/libtorrent-rasterbar-%{version}.tar.gz
15Source1:        %{name}-COPYING.Boost
16Source2:        %{name}-COPYING.zlib
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19
20BuildRequires:  asio-devel
21BuildRequires:  libboost-devel libboost-filesystem libboost-program-options
22BuildRequires:  libboost-python libboost-regex libboost-system libboost-thread
23BuildRequires:  libtool
24BuildRequires:  python-devel
25BuildRequires:  python-setuptools
26BuildRequires:  zlib-devel
27## Necessary for 'rename'...
28BuildRequires:  util-linux-ng
29
30## The following is taken from it's website listing...mostly.
31%description
32%{name} is a C++ library that aims to be a good alternative to all
33the other BitTorrent implementations around. It is a library and not a full
34featured client, although it comes with a few working example clients.
35
36Its main goals are to be very efficient (in terms of CPU and memory usage) as
37well as being very easy to use both as a user and developer.
38
39
40%package        devel
41Summary:        Development files for %{name}
42Summary(ja):    %{name} の開発ファイル
43Group:          Development/Libraries
44License:        BSD and zlib and Boost
45Requires:       %{name} = %{version}-%{release}
46Requires:       pkgconfig
47## Same include directory. :(
48Conflicts:      libtorrent-devel
49## Needed for various headers used via #include directives...
50Requires:       asio-devel
51Requires:       libboost-devel
52Requires:       openssl-devel
53
54%description    devel
55The %{name}-devel package contains libraries and header files for
56developing applications that use %{name}.
57
58The various source and header files included in this package are licensed
59under the revised BSD, zlib/libpng, and Boost Public licenses. See the various
60COPYING files in the included documentation for the full text of these
61licenses, as well as the comments blocks in the source code for which license
62a given source or header file is released under.
63
64
65%package        examples
66Summary:        Example clients using %{name}
67Summary(ja):    %{name} で使用する模範クライアント
68Group:          Applications/Internet
69License:        BSD
70Requires:       %{name} = %{version}-%{release}
71
72%description    examples
73The %{name}-examples package contains example clients which intend to
74show how to make use of its various features. (Due to potential
75namespace conflicts, a couple of the examples had to be renamed. See the
76included documentation for more details.)
77
78
79%package        python
80Summary:        Python bindings for %{name}
81Summary:        %{name} の Python バインディング
82Group:          Development/Languages
83License:        Boost
84Requires:       %{name} = %{version}-%{release}
85
86%description    python
87The %{name}-python package contains Python language bindings (the 'libtorrent'
88module) that allow it to be used from within Python applications.
89
90
91%prep
92%setup -q -n "libtorrent-rasterbar-%{version}"
93## The RST files are the sources used to create the final HTML files; and are
94## not needed.
95rm -f docs/*.rst
96## Ensure that we get the licenses installed appropriately.
97install -p -m 0644 COPYING COPYING.BSD
98install -p -m 0644 %{SOURCE1} COPYING.Boost
99install -p -m 0644 %{SOURCE2} COPYING.zlib
100## Finally, ensure that everything is UTF-8, as it should be.
101iconv -t UTF-8 -f ISO_8859-15 AUTHORS -o AUTHORS.iconv
102mv AUTHORS.iconv AUTHORS
103
104
105%build
106## XXX: Even with the --with-asio=system configure option, the stuff in
107## the local include directory overrides that of the system. We don't like
108## local copies of system code. :)
109rm -rf include/libtorrent/asio*
110%configure --disable-static                             \
111        --enable-examples                               \
112        --enable-python-binding                         \
113        --with-zlib=system \
114        --with-boost-libdir=%{_libdir}                          \
115        ;
116#       --with-boost-filesystem=boost_filesystem-gcc41-mt-1_36 \
117#       --with-boost-program_options=boost_program_options-gcc41-mt-1_36 \
118#       --with-boost-python=mt                          \
119#       --with-boost-regex=boost_regex-gcc41-mt-1_36    \
120#       --with-boost-system=boost_system-gcc41-mt-1_36  \
121#       --with-boost-thread=boost_thread-gcc41-mt-1_36  \
122#       --with-zlib=system
123## Use the system libtool to ensure that we don't get unnecessary RPATH
124## hacks in our final build.
125make %{?_smp_mflags} LIBTOOL=%{_bindir}/libtool
126pushd bindings/python
127        ## Fix the interpreter for the example clients
128        sed -i -e 's:^#!/bin/python$:#!/usr/bin/python:' {simple_,}client.py
129popd
130
131
132%check
133make check
134
135
136%install
137rm -rf %{buildroot}
138## Ensure that we preserve our timestamps properly.
139export CPPROG="%{__cp} -p"
140make install DESTDIR=%{buildroot} INSTALL="%{__install} -c -p"
141## Do the renaming due to the somewhat limited %%_bindir namespace.
142rename client torrent_client %{buildroot}%{_bindir}/*
143
144## Install the python binding module.
145pushd bindings/python
146        %{__python} setup.py install -O1 --skip-build --root %{buildroot}
147popd
148
149
150%clean
151rm -rf %{buildroot}
152
153
154%post -p /sbin/ldconfig
155
156
157%postun -p /sbin/ldconfig
158
159
160%files
161%defattr(-,root,root,-)
162%doc AUTHORS ChangeLog COPYING README
163%exclude %{_libdir}/*.la
164%{_libdir}/libtorrent-rasterbar.so.*
165## Unfortunately (even with the "--disable-static" option to the %%configure
166## invocation) our use of the system libtool creates static libraries at build
167## time, so we must exclude them here.
168%exclude %{_libdir}/*.a
169
170%files  devel
171%defattr(-,root,root,-)
172%doc COPYING.Boost COPYING.BSD COPYING.zlib docs/
173%{_libdir}/pkgconfig/libtorrent-rasterbar.pc
174%{_includedir}/libtorrent/
175%{_libdir}/libtorrent-rasterbar.so
176
177%files examples
178%{_bindir}/*torrent*
179%{_bindir}/enum_if
180
181%files  python
182%defattr(-,root,root,-)
183%doc AUTHORS ChangeLog COPYING.Boost bindings/python/{simple_,}client.py
184%{python_sitearch}/python_libtorrent-%{version}-py?.?.egg-info
185%{python_sitearch}/libtorrent.so
186
187
188%changelog
189* Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> - 0.15.4-3
190- rebuilt with libboost-1.45.0
191
192* Mon Jan 17 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.4-2
193- rebuilt with openssl-1.0.0c
194- deleted unrecognized configure option (--with-asio)
195
196* Tue Oct 19 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.4-1
197- new upstream release
198
199* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.15.3-2
200- rebuild with rpm-4.8.1 for pkg-config file
201
202* Tue Sep 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.3-1
203- new upstream release
204
205* Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.2-1
206- new upstream release
207
208* Sun Jul 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.1-1
209- new upstream release
210
211* Sun Mar 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.0-1
212- new upstream release
213
214* Thu Mar 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.14.9-1
215- new upstream release
216- applied new naming policy to spec
217
218* Mon Feb 08 2010 Shu KONNO <owa@bg.wakwak.com> 0.14.8-2
219- rebuilt with new toolchain, python-2.6.4-3
220
221* Sun Jan 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.14.8-1
222- new upstream release
223
224* Thu Dec 3 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.14.7-1
225- new upstream release
226
227* Tue Sep 22 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.14.6-1
228- initial build for VineSeed
229
230* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.14.4-3
231- rebuilt with new openssl
232
233* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.14.4-2
234- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
235
236* Tue Jun 02 2009 Peter Gordon <peter@thecodergeek.com> - 0.14.4-1
237- Update to new upstream release (0.14.4).
238- Drop outdated Boost patch.
239
240* Fri May 08 2009 Peter Gordon <peter@thecodergeek.com> - 0.14.3-2
241- Rebuild for the Boost 1.39.0 update.
242
243* Mon Apr 27 2009 Peter Gordon <peter@thecodergeek.com> - 0.14.3-1
244- Update to new upstream bug-fix release (0.14.3).
245
246* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.14.2-2
247- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
248
249* Fri Feb 20 2009 Peter Gordon <peter@thecodergeek.com> - 0.14.2-1
250- Update to new upstream bug-fix release (0.14.2)
251- Drop Python 2.6 and configure fix patches (fixed upstream):
252  - python26.patch
253  - configure-dont-use-locate.patch
254
255* Fri Jan 16 2009 Peter Gordon <peter@thecodergeek.com> - 0.14.1-2
256- Rebuild for the soname bump in openssl-0.9.8j
257
258* Mon Jan 05 2009 Peter Gordon <peter@thecodergeek.com> - 0.14.1-1
259- Update to new upstream release (0.14.1)
260- Add asio-devel as runtime dependency for the devel subpackage (#478589)
261- Add patch to build with Python 2.6:
262  + python26.patch
263- Add patch to make the configure script use the proper python include
264  directory instead of calling locate, as that can cause failures in a chroot
265  with no db file (and is a bit silly in the first place):
266  + configure-dont-use-locate.patch
267- Drop manual setup.py for building the python module (fixed upstream):
268  - setup.py
269- Update Source0 URL back to SourceForge's hosting.
270- Reenable the examples, since the Makefiles are fixed.
271
272* Fri Dec 19 2008 Petr Machata <pmachata@redhat.com> - 0.13.1-7
273- Rebuild for boost-1.37.0.
274
275* Wed Dec 17 2008 Benjamin Kosnik  <bkoz@redhat.com> - 0.13.1-6
276- Rebuild for boost-1.37.0.
277
278* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.13.1-5
279- Fix locations for Python 2.6
280
281* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.13.1-4
282- Rebuild for Python 2.6
283
284* Thu Nov 20 2008 Peter Gordon <peter@thecodergeek.com>
285- Update Source0 URL, for now.
286
287* Wed Sep  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.13.1-3
288- fix license tag
289
290* Mon Jul 14 2008 Peter Gordon <peter@thecodergeek.com> - 0.13.1-2
291- Add python bindings in a -python subpackage.
292
293* Mon Jul 14 2008 Peter Gordon <peter@thecodergeek.com> - 0.13.1-1
294- Update to new upstream release (0.13.1): Contains an incompatible ABI/API
295  bump.
296- Drop GCC 4.3 patch (fixed upstream):
297  - gcc43.patch
298- Disable building the examples for now. (Attempted builds fail due to missing
299  Makefile support.)
300- Drop the source permissions and pkgconfig file tweaks (fixed upstream).
301
302* Sat Feb 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.12.1-1
303- Update to new upstream bug-fix release (0.12.1)
304- Rebuild for GCC 4.3
305- Drop security fix patch (merged upstream):
306  - svn1968-bdecode_recursive-security-fix.patch
307- Add GCC 4.3 build fixes (based on patch from Adel Gadllah, bug 432778):
308  + gcc43.patch
309
310* Mon Jan 28 2008 Peter Gordon <peter@thecodergeek.com> - 0.12-3
311- Add upstream patch (changeset 1968) to fix potential security vulnerability:
312  malformed messages passed through the bdecode_recursive routine could cause
313  a potential stack overflow.
314  + svn1968-bdecode_recursive-security-fix.patch
315
316* Fri Aug 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
317- Rebuild against new Boost libraries.
318
319* Thu Jun 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
320- Update to new upstream release (0.12 Final)
321- Split examples into a subpackage. Applications that use rb_libtorrent
322  don't need the example binaries installed; and splitting the package in this
323  manner is a bit more friendly to multilib environments. 
324
325* Sun Mar 11 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-0.rc1
326- Update to new upstream release (0.12 RC).
327- Forcibly use the system libtool to ensure that we remove any RPATH hacks.
328
329* Sun Jan 28 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-5
330- Fix installed pkgconfig file: Strip everything from Libs except for
331  '-ltorrent', as its [libtorrent's] DSO will ensure proper linking to other
332  needed libraries such as zlib and boost_thread. (Thanks to Michael Schwendt
333  and Mamoru Tasaka; bug #221372)
334
335* Sat Jan 27 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-4
336- Clarify potential licensing issues in the -devel subpackage:
337  + COPYING.zlib
338  + COPYING.Boost
339- Add my name in the Fedora-specific documentation (README-renames.Fedora) and
340  fix some spacing issues in it.
341- Strip the @ZLIB@ (and thus, the extra '-lz' link option) from the installed
342  pkgconfig file, as that is only useful when building a statically-linked
343  libtorrent binary.
344- Fix conflict: The -devel subpackage should conflict with the -devel
345  subpackage of libtorrent, not the main package.
346- Preserve timestamps in %%install.
347
348* Wed Jan 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-3
349- Fix License (GPL -> BSD)
350- Don't package RST (docs sources) files.
351- Only make the -devel subpackage conflict with libtorrent-devel.
352- Rename some of the examples more appropriately; and add the
353  README-renames.Fedora file to %%doc which explains this.
354
355* Fri Jan 05 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-2
356- Add Requires: pkgconfig to the -devel subpackage since it installs a .pc
357  file.
358
359* Wed Jan 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
360- Initial packaging for Fedora Extras
Note: See TracBrowser for help on using the repository browser.