source: projects/specs/branches/6/lib/libt/libtorch/libtorch-vl.spec @ 521

Revision 521, 3.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define name libtorch
2%define archive Torch3
3%define version 3.1
4%define release 1%{?_dist_release}
5%define major 3
6%define minor 0.0
7
8Summary: Machine-learning library
9Summary(ja): 機械学習ライブラリ
10Name: %{name}
11Version: %{version}
12Release: %{release}
13Source0: %{archive}src.tgz
14Patch0: torch3_3.1-0.diff
15License: BSD
16Group: System Environment/Libraries
17URL: http://www.torch.ch/
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20
21Vendor: Project Vine
22Distribution: Vine Linux
23
24%description
25* A lot of things in gradient machines, that is, machines which could be learned
26  with a gradient descent. This includes multi-layered perceptrons, radial basis
27  functions, mixtures of experts, convolutional networks and even time-delay
28  neural networks. In fact a lot of "modules" are available that you can plug as
29  you want to get what you need.
30* Support vector machines, in classification and regression. As fast as the old
31  stand-alone program SVMTorch II, but with the powerful environment of the
32  library.
33* Ensemble models such as bagging or adaboost.
34* Non-parametric models such as K-nearest-neighbors, Parzen regression and
35  Parzen density estimator.
36* Distributions stuff, like Kmeans, Gaussian mixture models, hidden Markov
37  models, input-output hidden Markov models, and Bayes classifier.
38* Speech recognition tools (Embedded training and large vocabulary decoding).
39
40%package devel
41Summary: Development files for Torch: Machine-learning library
42Group: Development/Libraries
43Requires: libtorch
44
45%description devel
46Development files for Torch: Machine-learning library.
47
48%prep
49%setup -q -n %{archive}
50%patch0 -p1
51
52%build
53%__make depend
54%__make
55
56%install
57rm -rf ${RPM_BUILD_ROOT}
58%__install -D -m 0644 lib/%{name}.a ${RPM_BUILD_ROOT}%{_libdir}/libtorch.a
59%__install -m 0644 lib/%{name}.so.%{major}.%{minor} ${RPM_BUILD_ROOT}%{_libdir}
60%__install -d ${RPM_BUILD_ROOT}%{_includedir}/torch
61%__install -m 0644 */*.h ${RPM_BUILD_ROOT}%{_includedir}/torch
62cd ${RPM_BUILD_ROOT}%{_libdir}
63%__ln_s %{name}.so.%{major}.%{minor} %{name}.so.%{major}
64%__ln_s %{name}.so.%{major}.%{minor} %{name}.so
65
66%clean
67rm -rf ${RPM_BUILD_ROOT}
68
69%files
70%defattr(-,root,root)
71%doc ChangeLog LICENSE
72%{_libdir}/%{name}.so.*
73
74%files devel
75%defattr(-,root,root)
76%{_libdir}/%{name}.a
77%{_libdir}/%{name}.so
78%{_includedir}/torch/*.h
79
80%changelog
81* Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 3.1-1vl5
82- applied new versioning policy, spec in utf-8
83- use macros for library and include path
84
85* Sat Jun 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1-0vl2
86- rebuilt with new toolchain
87
88* Sat Mar 11 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 3.1-0vl1
89- add Summary(ja)
90
91* Thu Mar 9 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 3.1-0vl0.5
92- change package name from torch to libtorch
93- add Patch0 (from Debian stable)
94- add devel package
95
96* Tue Dec 27 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 3.1-0vl0.4
97- integrate devel package into main package
98
99* Sat Dec 24 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 3.1-0vl0.3
100- add version dependencies to -devel package
101
102* Sat Dec 24 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 3.1-0vl0.2
103- add -devel package
104
105* Sat Dec 24 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 3.1-0vl0.1
106- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.