source: projects/specs/branches/6/lib/libt/libtool/libtool-vl.spec @ 10316

Revision 10316, 20.3 KB checked in by Takemikaduchi, 8 years ago (diff)

for Vine6.5

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define gcc_version 4.9.3
4
5Summary: The GNU Portable Library Tool
6Summary(ja): GNU ポータブルライブラリツール
7Name:    libtool
8Version: 2.4.6
9Release: 1%{?_dist_release}
10License: GPLv2+ and LGPLv2+ and GFDL
11Group:   Development/Tools
12URL:     http://www.gnu.org/software/libtool/
13
14Source:  http://ftp.gnu.org/gnu/libtool/libtool-%{version}.tar.xz
15Patch0:  libtool-2.4.6-rpath.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18Requires(post):  /sbin/install-info
19Requires(preun): /sbin/install-info
20
21BuildRequires: autoconf >= 2.59, automake >= 1.9.2, texinfo, help2man
22Requires: autoconf >= 2.58, automake >= 1.4
23# make sure we can configure all supported langs
24BuildRequires: gcc, gcc-c++, libstdc++-devel, gcc-gfortran
25#BuildRequires: gcc-java
26# /usr/bin/libtool includes paths within gcc's versioned directories
27# Libtool must be rebuilt whenever a new upstream gcc is built
28Requires: gcc = %{gcc_version}
29
30Requires: autoconf >= 2.50, automake >= 1.4p1, m4, perl
31Requires: libtool-ltdl = %{version}-%{release}, mktemp
32
33Vendor: Project Vine
34Distribution: Vine Linux
35
36%description
37GNU Libtool is a set of shell scripts which automatically configure UNIX and
38UNIX-like systems to generically build shared libraries. Libtool provides a
39consistent, portable interface which simplifies the process of using shared
40libraries.
41
42If you are developing programs which will use shared libraries, but do not use
43the rest of the GNU Autotools (such as GNU Autoconf and GNU Automake), you
44should install the libtool package.
45
46The libtool package also includes all files needed to integrate the GNU
47Portable Library Tool (libtool) and the GNU Libtool Dynamic Module Loader
48(ltdl) into a package built using the GNU Autotools (including GNU Autoconf
49and GNU Automake).
50
51This package includes a modification from the original GNU Libtool to allow
52support for multi-architecture systems, such as the AMD64 Opteron and the Intel
5364-bit Xeon.
54
55%description -l ja
56GNU Libtoolは、UNIX及びUNIXライクなアーキテクチャで共有ライブラリを汎用的
57にビルドするための設定を自動化するシェルスクリプトのセットです。libtoolは、
58共有ライブラリを利用する工程を単純化する首尾一貫した移植可能なインターフェー
59スを提供します。
60
61もし、GNU Autotools (GNU Autoconf および GNU Automake) を使わずに共有ライ
62ブラリを利用するプログラムを開発するなら、libtool パッケージをインストール
63する必要があります。
64
65このパッケージの Libtool は、AMD64 や Intel EM64T などのマルチアーキテクチャ
66システムをサポートするために、オリジナルのGNU Libtoolから変更が施されています。
67
68
69%package ltdl
70Summary:  Runtime libraries for GNU Libtool Dynamic Module Loader
71Summary(ja): GNU Libtool ダイナミックモジュールローダのランタイムライブラリ
72Group:    System Environment/Libraries
73Provides: libtool-libs = %{version}-%{release}
74Obsoletes: libtool-libs < 1.5.20
75License:  LGPL
76Requires(post):  /sbin/ldconfig
77Requires(postun):  /sbin/ldconfig
78
79
80%description ltdl
81The libtool-ltdl package contains the GNU Libtool Dynamic Module Loader, a
82library that provides a consistent, portable interface which simplifies the
83process of using dynamic modules.
84
85These runtime libraries are needed by programs that link directly to the
86system-installed ltdl libraries; they are not needed by software built using the
87rest of the GNU Autotools (including GNU Autoconf and GNU Automake).
88
89%description -l ja ltdl
90libtool-ltdl パッケージにはGNU Libtool 動的モジュールローダのランタイムライ
91ブラリが含まれています。GNU Libtool 動的モジュールローダは、動的モジュールを
92利用する工程を単純化する首尾一貫した移植可能なインターフェースを提供します。
93
94
95%package ltdl-devel
96Summary: Tools needed for development using the GNU Libtool Dynamic Module Loader
97Summary(ja): GNU Libtool ダイナミックモジュールローダを使った開発に必要なファイル群
98Group:    Development/Libraries
99Requires: libtool-ltdl = %{version}-%{release}
100License:  LGPL
101
102
103%description ltdl-devel
104Static libraries and header files for development with ltdl.
105
106%description -l ja ltdl-devel
107ltdlを使った開発に必要なスタティックライブラリおよびヘッダファイル
108
109
110## to build compat32 for x86_64 architecture support
111%package -n compat32-%{name}-ltdl
112Summary: Runtime libraries for GNU Libtool Dynamic Module Loader
113Group: System Environment/Libraries
114%description -n compat32-%{name}-ltdl
115The libtool-ltdl package contains the GNU Libtool Dynamic Module Loader, a
116library that provides a consistent, portable interface which simplifies the
117process of using dynamic modules.
118
119%package -n compat32-%{name}-ltdl-devel
120Summary: Tools needed for development using the GNU Libtool Dynamic Module Loader
121Group: Development/Libraries
122Requires: compat32-%{name}-ltdl = %{version}-%{release}
123%description -n compat32-%{name}-ltdl-devel
124Static libraries and header files for development with ltdl.
125
126
127%prep
128%setup -q
129%patch0 -p1
130
131
132%build
133
134autoreconf -v
135
136export CC=gcc
137export CXX=g++
138export F77=gfortran
139export CFLAGS="$RPM_OPT_FLAGS -fPIC"
140# dumb redhat-rpm-config replaces config.{sub,guess} with ancient ones in %%configure, use ./configure instead:
141./configure --prefix=%{_prefix} --exec-prefix=%{_prefix} --bindir=%{_bindir} --sbindir=%{_sbindir} --sysconfdir=%{_sysconfdir} --datadir=%{_datadir} --includedir=%{_includedir} --libdir=%{_libdir} --libexecdir=%{_libexecdir} --localstatedir=%{_localstatedir} --mandir=%{_mandir} --infodir=%{_infodir}
142# build not smp safe:
143make #%{?_smp_mflags}
144
145
146#check
147#make check VERBOSE=yes > make_check.log 2>&1 || (cat make_check.log && false)
148
149
150%install
151rm -rf %{buildroot}
152make install DESTDIR=$RPM_BUILD_ROOT
153rm -f %{buildroot}%{_infodir}/dir
154rm -f %{buildroot}%{_libdir}/libltdl.{a,la}
155
156
157%clean
158rm -rf %{buildroot}
159
160
161%post
162/sbin/install-info %{_infodir}/libtool.info.gz %{_infodir}/dir || :
163
164%preun
165if [ "$1" = 0 ]; then
166   /sbin/install-info --delete %{_infodir}/libtool.info.gz %{_infodir}/dir || :
167fi
168
169%post ltdl -p /sbin/ldconfig
170
171%postun ltdl -p /sbin/ldconfig
172
173%post -n compat32-%{name}-ltdl
174/sbin/ldconfig
175
176%postun -n compat32-%{name}-ltdl
177/sbin/ldconfig
178
179
180%files
181%defattr(-,root,root)
182%doc AUTHORS COPYING NEWS README THANKS TODO ChangeLog
183%{_bindir}/libtool
184%{_bindir}/libtoolize
185%{_datadir}/aclocal/*.m4
186%{_datadir}/libtool
187%{_infodir}/libtool.info*.gz
188%{_mandir}/man1/libtool.1.gz
189%{_mandir}/man1/libtoolize.1.gz
190
191%files ltdl
192%defattr(-,root,root)
193%doc libltdl/COPYING.LIB libltdl/README
194%{_libdir}/libltdl.so.*
195
196%files ltdl-devel
197%defattr(-,root,root)
198%{_libdir}/libltdl.so
199%{_includedir}/ltdl.h
200%{_includedir}/libltdl/*
201
202%if %{build_compat32}
203## to build compat32 for x86_64 architecture support
204%files -n compat32-%{name}-ltdl
205%defattr(-,root,root)
206%{_libdir}/libltdl.so.*
207
208%files -n compat32-%{name}-ltdl-devel
209%defattr(-,root,root)
210%{_libdir}/libltdl.so
211%endif
212
213
214%changelog
215* Sat May 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.6-1
216- update to 2.4.6
217- merge with VineSeed package
218
219  * Sat May 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.6-1
220  - new upstream release
221  - update Patch0 (libtool-2.4.6-rpath.patch)
222
223  * Mon Nov 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.2-4
224  - rebuild with gcc-4.8.2-1
225
226  * Tue Oct 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.2-3
227  - rebuild with gcc-4.8.1-2
228
229  * Mon Sep 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.2-2
230  - rebuild with gcc-4.8.1
231  - add BuildRequires: help2man
232
233  * Sat Dec 03 2011 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.2-1
234  - new upstream release
235
236  * Mon Nov 28 2011 NAKAMURA Kenta <kenta@vinelinux.org> 2.4-2
237  - rebuilt with gcc-4.6.2
238
239  * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4-1
240  - new upstream release
241  - update Patch0
242
243* Sun Mar 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6b-2
244- rebuilt with gcc-4.4.5
245
246* Sat Feb 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.2.6b-1
247- new upstream release
248
249* Mon Jan 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6a-4
250- rebuilt with gcc-4.4.3-1 (w/o gcc-java)
251
252* Tue May 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.6a-3
253- remove comment before compat32 scriptlet to avoid scriptlet failure.
254
255* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.6a-2
256- removed %%if !%%{build_compat32} case condition
257
258* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.6a-1
259- update to 2.2.6a
260- remove libltdl static library
261
262* Wed Jun 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.26-3
263- updated to 1.5.26, importing changes from Fedora 1.5.26-2
264- new versioning policy; spec in UTF-8
265- define gcc_version to 4.1.2 for Vine
266
267* Wed May 30 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.22-0vl4
268- rebuilt with gcc-4.1.2-0vl10 (gcc -dumpversion begets 4.1.2, not 4.1.3)
269
270* Tue May 22 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.22-0vl3
271- remove BuildRequires: libstdc++3-devel
272- add Requres: libtool-ltdl instead of libtool-libs
273
274* Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.22-0vl2
275- rebuilt with gcc4 (F77=gfortran now)
276- import Patch2 and Patch3 from FC6 1.5.22-6.1
277
278  - Thu Jun 29 2006 Karsten Hopp <karsten@redhat.de> 1.5.22-6
279  - detect gcc path at runtime instead of requiring one specific version
280
281  - Thu Jun 29 2006 Karsten Hopp <karsten@redhat.de> 1.5.22-5
282  - miscellaneous upstream fixes
283
284* Sat Sep 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.22-0vl1
285- new upstream release
286
287* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.5.20-0vl4
288- moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
289- changed '%postun -p /sbin/ldconfig' to '%postun' and /sbin/ldconfig command
290
291* Thu Feb 02 2006 Shu KONNO <owa@bg.wakwak.com> 1.5.20-0vl3
292- added compat32-* packages for x86_64 architecture support
293
294* Mon Oct 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.20-0vl2
295- add Japanese Summaries and descriptions
296
297* Mon Oct 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.20-0vl1
298- new upstream release
299
300* Tue Aug 16 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.18-3vl1
301- updated to 1.5.18 based on Fedora package
302  * Sun Feb  6 2005 Daniel Reed <djr@redhat.com> 1.5.12.multilib2-3.4.3
303  - update to the 1.5.12 bugfix release
304  - Makes use of $datarootdir, which is necessary for Autoconf >= 2.60.
305  - Correctly skip hppa, x86_64, and s390* in tests/demo-nopic.test.
306  - Interpret `include' statements in toplevel ld.so.conf file.
307  - While "parsing" /etc/ld.so.conf, skip comments.
308  - add dependency on gcc version; /usr/bin/libtool hardcodes paths into
309    gcc's internal directories
310  - replace "libtool-libs" with "libtool-ltdl" and "libtool-ltdl-devel"
311  * Tue Oct 26 2004 Daniel Reed <djr@redhat.com> 1.5.10-1
312  - update to the 1.5.10 bugfix release
313    - obsoletes libtool-1.4-nonneg.patch
314    - obsoletes libtool-1.5-libtool.m4-x86_64.patch
315    - obsoletes libtool-1.4.2-multilib.patch
316    - obsoletes libtool-1.4.2-demo.patch
317    - obsoletes libtool-1.5-testfailure.patch
318  * Thu May 13 2004 Thomas Woerner <twoerner@redhat.com> - 1.5.6-2
319  - compile libltdl.a PIC
320
321* Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.6-0vl2
322- rebuild with gcc-3.3.5
323
324* Sun May  2 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-0vl1
325- new upstream release
326
327* Fri Feb 20 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.5.2-2vl1
328- merged with fedora-1.5.2-2
329  * Mon Jan 26 2004 Jens Petersen <petersen@redhat.com> - 1.5.2-1
330  - update to 1.5.2 bugfix release
331  - update libtool-1.5-libtool.m4-x86_64.patch
332  - nolonger need libtool-1.5-mktemp.patch, libtool-1.5-expsym-linux.patch,
333    libtool-1.5-readonlysym.patch, libtool-1.5-relink-libdir-order-91110.patch,
334    libtool-1.5-AC_PROG_LD_GNU-quote-v-97608.patch and libtool-1.5-nostdlib.patch
335
336  * Tue Oct 28 2003 Jens Petersen <petersen@redhat.com> - 1.5-8
337  - update libtool-1.4.2-multilib.patch to also deal with powerpc64 (#103316)
338    [Joe Orton]
339
340* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-5vl1
341- merged with rawhide 1.5-5
342  * Mon Dec 09 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.3-2vl2
343  - based on 1.4.3-2 from Rawhide and built for Vine Linux
344  - added BuildPreReq: automake14
345
346* Thu Jul 17 2003 Jens Petersen <petersen@redhat.com> - 1.5-5
347- bring back libtool-1.4.2-demo.patch to disable nopic tests on amd64
348  and s390x again
349
350* Tue Jul 15 2003 Owen Taylor <otaylor@redhat.com>
351- Fix misapplied chunk for expsym-linux patch
352
353* Tue Jul  8 2003 Jens Petersen <petersen@redhat.com> - 1.5-4
354- remove the quotes around LD in AC_PROG_LD_GNU (#97608)
355  [reported by twaugh]
356- use -nostdlib also when linking with g++ and non-GNU ld in
357  _LT_AC_LANG_CXX_CONFIG [reported by fnasser, patch by aoliva]
358- use %%configure with CC and CXX set
359
360* Thu Jun 12 2003 Jens Petersen <petersen@redhat.com> - 1.5-3
361- don't use %%configure since target options caused libtool to assume
362  i386-redhat-linux-gcc instead of gcc for CC (reported by Joe Orton)
363- add libtool-1.5-relink-libdir-order-91110.patch to fix order of lib dirs
364  searched when relinking (#91110) [patch from Joe Orton]
365
366* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
367- rebuilt
368
369* Thu May  1 2003 Jens Petersen <petersen@redhat.com> - 1.5-1
370- update to 1.5
371- no longer override config.{guess,sub} for rpmbuild %%configure,
372  redhat-rpm-config owns those now
373- update and rename libtool-1.4.2-s390_x86_64.patch to
374  libtool-1.5-libtool.m4-x86_64.patch since s390 now included
375- buildrequire autoconf and automake, no longer automake14
376- skip make check on s390 temporarily
377- no longer skip demo-nopic.test on x86_64, s390 and s390x
378- from Owen Taylor
379  - add libtool-1.4.2-expsym-linux.patch (#55607) [from James Henstridge]
380  - add quoting in mktemp patch
381  - add libtool-1.5-readonlysym.patch
382  - add libtool-1.5-testfailure.patch workaround
383  - relink patch no longer needed
384
385* Sat Feb 08 2003 Florian La Roche <Florian.LaRoche@redhat.de> - 1.4.3-5
386- add config.guess and config.sub, otherwise old versions of
387  these files can creep into /usr/share/libtool/
388
389* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
390- rebuilt
391
392* Mon Jan 13 2003 Jens Petersen <petersen@redhat.com> 1.4.3-3
393- fix mktemp to work when running mktemp fails (#76602)
394  [reported by (Oron Peled)]
395- remove info dir file, don't exclude it
396- fix typo in -libs description (#79619)
397- use buildroot instead of RPM_BUILD_ROOT
398
399* Tue Jan 07 2003 Karsten Hopp <karsten@redhat.de> 1.4.3-2.2
400- use lib64 on s390x, too.
401
402* Thu Dec  5 2002 Jens Petersen <petersen@redhat.com>
403- add comment to explain why we use an old Automake for building
404- buildrequire automake14
405
406* Sat Nov 23 2002 Jens Petersen <petersen@redhat.com>
407- add --without check build option to allow disabling of "make check"
408- exclude info dir file rather than removing
409
410* Sat Nov 23 2002 Jens Petersen <petersen@redhat.com> 1.4.3-2
411- define SED in ltmain.sh for historic ltconfig files
412- define macro AUTOTOOLS to hold automake-1.4 and aclocal-1.4, and use it
413- leave old missing file for now
414- general spec file cleanup
415  - don't copy install files to demo nor mess with installed ltdl files
416  - don't need to run make in doc
417  - force removal of info dir file
418  - don't need to create install prefix dir
419  - don't bother gzipping info files ourselves
420
421* Mon Nov 18 2002 Jens Petersen <petersen@redhat.com> 1.4.3-1
422- update to 1.4.3
423- remove obsolete patches (test-quote, dup-deps, libtoolize-configure.ac)
424- apply the multilib patch to just the original config files
425- update x86_64/s390 patch and just apply to original config files
426- use automake-1.4 in "make check" for demo-make.test to pass!
427- remove info dir file that is not installed
428- make autoreconf update missing
429
430* Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com>  1.4.2-12.2
431- Added s390x and x64_64 support.
432
433* Fri Oct  4 2002 Nalin Dahyabhai <nalin@redhat.com> 1.4.2-12.1
434- rebuild
435
436* Fri Sep 13 2002 Nalin Dahyabhai <nalin@redhat.com>
437- patch to find the proper libdir on multilib boxes
438 
439* Mon Aug 19 2002 Jens Petersen <petersen@redhat.com> 1.4.2-12
440- don't include demo in doc, specially now that we "make check" (#71609)
441
442* Tue Aug 13 2002 Jens Petersen <petersen@redhat.com> 1.4.2-11
443- don't hardcode "configure.in" in libtoolize (#70864)
444  [reported by bastiaan@webcriminals.com]
445- make check, but not on ia64
446
447* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.4.2-10
448- automated rebuild
449
450* Thu May 23 2002 Tim Powers <timp@redhat.com> 1.4.2-9
451- automated rebuild
452
453* Fri Apr 26 2002 Jens Petersen <petersen@redhat.com> 1.4.2-8
454- add old patch from aoliva to fix relinking when installing into a buildroot
455- backport dup-deps fix from cvs stable branch
456
457* Wed Mar 27 2002 Jens Petersen <petersen@redhat.com> 1.4.2-7
458- run ldconfig in postin and postun
459
460* Thu Feb 28 2002 Jens Petersen <petersen@redhat.com> 1.4.2-6
461- rebuild in new environment
462
463* Tue Feb 12 2002 Jens Petersen <petersen@redhat.com> 1.4.2-5
464- revert filemagic and archive-shared patches following cvs (#54887)
465- don't change "&& test" to "-a" in ltmain.in
466
467* Wed Jan 09 2002 Tim Powers <timp@redhat.com> 1.4.2-4
468- automated rebuild
469
470* Mon Dec  3 2001 Jens Petersen <petersen@redhat.com> 1.4.2-3
471- test quoting patch should be on ltmain.in not ltmain.sh (#53276)
472- use file_magic for Linux ELF (#54887)
473- allow link against an archive when building a shared library (#54887)
474- include ltdl.m4 in manifest (#56671)
475
476* Wed Oct 24 2001 Jens Petersen <petersen@redhat.com> 1.4.2-2
477- added URL to spec
478
479* Tue Sep 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.4.2-1
480- 1.4.2 - sync up with autoconf...
481
482* Thu Jul  5 2001 Bernhard Rosenkraenzer <bero@redhat.de> 1.4-8
483- extend s390 patch to 2 more files
484- s/Copyright/License/
485
486* Wed Jul 04 2001 Karsten Hopp <karsten@redhat.de>
487- add s390 patch for deplibs_check_method=pass_all
488
489* Tue Jun 12 2001 Florian La Roche <Florian.LaRoche@redhat.de>
490- add patches from Tim Waugh #42724
491
492* Mon Jun 11 2001 Florian La Roche <Florian.LaRoche@redhat.de>
493- add patches from cvs mainline
494
495* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
496- fix a "test" bug in ltmain.sh
497
498* Sun Jun 03 2001 Florian La Roche <Florian.LaRoche@redhat.de>
499- disable the post commands to modify /usr/share/doc/
500
501* Sat May 12 2001 Owen Taylor <otaylor@redhat.com>
502- Require automake 1.4p1
503
504* Wed May 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
505- update to libtool 1.4
506- adjust or remove patches
507
508* Thu Jul 13 2000 Elliot Lee <sopwith@redhat.com>
509- Fix recognition of ^0[0-9]+$ as a non-negative integer.
510
511* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
512- automatic rebuild
513
514* Fri Jul  7 2000 Nalin Dahyabhai <nalin@redhat.com>
515- patch to use mktemp to create the tempdir
516- use %%configure after defining __libtoolize to /bin/true
517
518* Mon Jul  3 2000 Matt Wilson <msw@redhat.com>
519- subpackage libltdl into libtool-libs
520
521* Sun Jun 18 2000 Bill Nottingham <notting@redhat.com>
522- running libtoolize on the libtool source tree ain't right :)
523
524* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
525- FHS packaging.
526
527* Thu Jun  1 2000 Nalin Dahyabhai <nalin@redhat.com>
528- update to 1.3.5.
529
530* Fri Mar  3 2000 Jeff Johnson <jbj@redhat.com>
531- add prereqs for m4 and perl inorder to run autoconf/automake.
532
533* Mon Feb 28 2000 Jeff Johnson <jbj@redhat.com>
534- functional /usr/doc/libtool-*/demo by end-user %post procedure (#9719).
535
536* Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
537- update to 1.3.4.
538
539* Mon Dec  6 1999 Jeff Johnson <jbj@redhat.com>
540- change from noarch to per-arch in order to package libltdl.a (#7493).
541
542* Thu Jul 15 1999 Jeff Johnson <jbj@redhat.com>
543- update to 1.3.3.
544
545* Mon Jun 14 1999 Jeff Johnson <jbj@redhat.com>
546- update to 1.3.2.
547
548* Tue May 11 1999 Jeff Johnson <jbj@redhat.com>
549- explicitly disable per-arch libraries (#2210)
550- undo hard links and remove zero length file (#2689)
551
552* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
553- update to 1.3.
554
555* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
556- disable the --cache-file passing to ltconfig; this breaks the older
557  ltconfig scripts found around.
558
559* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
560- auto rebuild in the new build environment (release 2)
561
562* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
563- update to 1.2f
564
565* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
566- completed arm patch
567- added patch to make it more arm-friendly
568- upgrade to version 1.2d
569
570* Thu May 07 1998 Donnie Barnes <djb@redhat.com>
571- fixed busted group
572
573* Sat Jan 24 1998 Marc Ewing <marc@redhat.com>
574- Update to 1.0h
575- added install-info support
576
577* Tue Nov 25 1997 Elliot Lee <sopwith@redhat.com>
578- Update to 1.0f
579- BuildRoot it
580- Make it a noarch package
Note: See TracBrowser for help on using the repository browser.