source: projects/specs/branches/6/lib/libs/libssh2/libssh2-vl.spec @ 10044

Revision 10044, 4.4 KB checked in by iwamoto, 8 years ago (diff)

libssh2: fix CVE-2015-1782, CVE-2016-0787

Line 
1Summary:        A library implementing the SSH2 protocol
2Summary(ja):    SSH2 プロトコルを実装するためのライブラリ
3Name:           libssh2
4Version:        1.2.7
5Release:        2%{?_dist_release}
6
7Group:          System Environment/Libraries
8License:        BSD
9URL:            http://www.libssh2.org/
10Source0:        http://downloads.sourceforge.net/libssh2/%{name}-%{version}.tar.gz
11BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
12
13Patch100:       CVE-2015-1782.patch
14Patch110:       CVE-2016-0787.patch
15
16BuildRequires:  openssl-devel
17BuildRequires:  zlib-devel   
18
19Vendor:         Project Vine
20Distribution:   Vine Linux
21
22%description
23libssh2 is a library implementing the SSH2 protocol as defined by
24Internet Drafts: SECSH-TRANS(22), SECSH-USERAUTH(25),
25SECSH-CONNECTION(23), SECSH-ARCH(20), SECSH-FILEXFER(06)*,
26SECSH-DHGEX(04), and SECSH-NUMBERS(10).
27
28
29%package        devel
30Summary:        Development files for %{name}
31Summary(ja):    %{name} の開発ファイル
32Group:          Development/Libraries
33Requires:       %{name} = %{version}-%{release}
34
35%description    devel
36The %{name}-devel package contains libraries and header files for
37developing applications that use %{name}.
38
39%package        docs
40Summary:        Documentation for %{name}
41Summary(ja):    %{name} のドキュメント
42Group:          Development/Libraries
43Requires:       %{name} = %{version}-%{release}
44
45%description    docs
46The %{name}-docs package contains man pages and examples for
47developing applications that use %{name}.
48
49
50%prep
51%setup -q
52
53%patch100 -p1 -b .CVE-2015-1782
54%patch110 -p1 -b .CVE-2016-0787
55
56# make sure things are UTF-8...
57for i in ChangeLog NEWS ; do
58    iconv --from=ISO-8859-1 --to=UTF-8 $i > new
59    mv new $i
60done
61
62%build
63%configure --disable-static --enable-shared
64
65make %{?_smp_mflags}
66
67
68%install
69rm -rf %{buildroot}
70
71make install DESTDIR=%{buildroot} INSTALL="install -p"
72find %{buildroot} -name '*.la' -exec rm -f {} +
73
74# clean things up a bit for packaging
75( cd example && make clean )
76rm -rf example/simple/.deps
77find example/ -type f '(' -name '*.am' -o -name '*.in' ')' -exec rm -v {} +
78
79%check
80(cd tests && make check)
81
82%clean
83rm -rf %{buildroot}
84
85
86%post -p /sbin/ldconfig
87
88%postun -p /sbin/ldconfig
89
90
91%files
92%defattr(-,root,root,-)
93%doc AUTHORS ChangeLog COPYING README NEWS
94%{_libdir}/*.so.*
95
96%files docs
97%defattr(-,root,root,-)
98%doc COPYING HACKING example/
99%{_mandir}/man?/*
100
101%files devel
102%defattr(-,root,root,-)
103%doc COPYING
104%{_includedir}/*
105%{_libdir}/*.so
106%{_libdir}/pkgconfig/libssh2.pc
107
108%changelog
109* Fri Feb 26 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.7-2
110- add Patch100 for fix CVE-2015-1782
111- add Patch110 for fix CVE-2016-0787
112- add Distri/Vendor tags
113
114* Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.7-1
115- new upstream release
116- fix %%files
117
118* Tue Sep 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-1
119- initial build for Vine Linux
120
121* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.0-4
122- rebuilt with new openssl
123
124* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-3
125- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
126
127* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-2
128- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
129
130* Mon Feb 16 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.0-1
131- update to 1.0
132
133* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.18-8
134- rebuild with new openssl
135
136* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.18-7
137- Autorebuild for GCC 4.3
138
139* Wed Dec 05 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-6
140- rebuild for new openssl...
141
142* Tue Nov 27 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-5
143- bump
144
145* Tue Nov 27 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-4
146- add INSTALL arg to make install vs env. var
147
148* Mon Nov 26 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-3
149- run tests; don't package test
150
151* Sun Nov 18 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-2
152- split docs into -docs (they seemed... large.)
153
154* Tue Nov 13 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-1
155- update to 0.18
156
157* Sun Oct 14 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.17-1
158- update to 0.17
159- many spec file changes
160
161* Wed May 23 2007 Sindre Pedersen Bjørdal <foolish[AT]guezz.net> - 0.15-0.2.20070506
162- Fix release tag
163- Move manpages to -devel package
164- Add Examples dir to -devel package
165
166* Sun May 06 2007 Sindre Pedersen Bjørdal <foolish[AT]guezz.net> - 0.15-0.20070506.1
167- Initial build
Note: See TracBrowser for help on using the repository browser.