source: projects/specs/branches/6/lib/libs/libsmbios/libsmbios-vl.spec @ 3684

Revision 3684, 14.1 KB checked in by daisuke, 13 years ago (diff)

libsmbios: update to 2.2.26

Line 
1# pkg/libsmbios.spec.  Generated from libsmbios.spec.in by configure.
2# required by suse build system
3# norootforbuild
4
5# these are all substituted by autoconf
6%define major 2
7%define minor 2
8%define micro 26
9%define extra %{nil}
10%define pot_file  libsmbios
11%define lang_dom  libsmbios-2.2-x86_64
12%define release_version 2.2.26
13
14%define release_name libsmbios
15
16Name: %{release_name}
17Version: %{release_version}
18Release: 1%{?_dist_release}
19License: GPLv2+ or OSL 2.1
20Summary: Libsmbios C/C++ shared libraries
21Summary(ja): Libsmbios C/C++ shared libraries
22Group: System Environment/Libraries
23Source: http://linux.dell.com/libsmbios/download/libsmbios/libsmbios-%{version}/libsmbios-%{version}.tar.bz2
24URL: http://linux.dell.com/libsmbios/main
25Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
26BuildRequires: strace libxml2-devel gcc-c++ gettext doxygen cppunit-devel pkgconfig python-devel
27
28# libsmbios only ever makes sense on intel compatible arches
29# no DMI tables on ppc, s390, etc.
30ExclusiveArch: x86_64 ia64 %{ix86}
31
32Vendor: Project Vine
33Distribution: Vine Linux
34Packager: shaolin, daisuke
35
36
37%description
38Libsmbios is a library and utilities that can be used by client programs to get
39information from standard BIOS tables, such as the SMBIOS table.
40
41This package provides the C-based libsmbios library, with a C interface.
42
43This package also has a C++-based library, with a C++ interface. It is not
44actively maintained, but provided for backwards compatibility. New programs
45should use the libsmbios C interface.
46
47
48%package -n python-smbios
49Summary: Python interface to Libsmbios C library
50Summary(ja): Python interface to Libsmbios C library
51Group: System Environment/Libraries
52Requires: %{release_name} = %{version}-%{release}
53Requires: python
54
55%description -n python-smbios
56This package provides a Python interface to libsmbios
57
58%package -n smbios-utils
59Summary: Meta-package that pulls in all smbios binaries and python scripts
60Summary(ja): Meta-package that pulls in all smbios binaries and python scripts
61Group: Applications/System
62Requires: smbios-utils-bin
63Requires: smbios-utils-python
64
65%description -n smbios-utils
66This is a meta-package that pulls in the binary libsmbios executables as well
67as the python executables.
68
69%package -n smbios-utils-bin
70Summary: Binary utilities that use libsmbios
71Summary(ja): Binary ユーティリティ that use libsmbios
72Group: Applications/System
73Requires: %{release_name} = %{version}-%{release}
74
75%description -n smbios-utils-bin
76Get BIOS information, such as System product name, product id, service tag and
77asset tag.
78
79%package -n smbios-utils-python
80Summary: Python executables that use libsmbios
81Summary(ja): Python executables that use libsmbios
82Group: Applications/System
83Requires: python-smbios = %{version}-%{release}
84
85%description -n smbios-utils-python
86Get BIOS information, such as System product name, product id, service tag and
87asset tag. Set service and asset tags on Dell machines. Manipulate wireless
88cards/bluetooth on Dell laptops. Set BIOS password on select Dell systems.
89Update BIOS on select Dell systems. Set LCD brightness on select Dell laptops.
90
91# name the devel package libsmbios-devel regardless of package name, per suse/fedora convention
92%package -n libsmbios-devel
93Summary: Development headers and archives
94Summary(ja): Development headers and archives
95Group: Development/Libraries
96Requires: %{release_name} = %{version}-%{release}
97
98%description -n libsmbios-devel
99Libsmbios is a library and utilities that can be used by client programs to get
100information from standard BIOS tables, such as the SMBIOS table.
101
102This package contains the headers and .a files necessary to compile new client
103programs against libsmbios.
104
105%prep
106
107%setup -q -n libsmbios-%{version}
108find . -type d -exec chmod -f 755 {} \;
109find doc src -type f -exec chmod -f 644 {} \;
110chmod 755 src/cppunit/*.sh
111
112%build
113# this line lets us build an RPM directly from a git tarball
114# and retains any customized version information we might have
115[ -e ./configure ] || ./autogen.sh --no-configure
116
117mkdir _build
118cd _build
119echo '../configure "$@"' > configure
120chmod +x ./configure
121
122%configure
123
124mkdir -p out/libsmbios_c
125mkdir -p out/libsmbios_c++
126make %{?_smp_mflags} 2>&1 | tee build-%{_arch}.log
127
128echo \%doc _build/build-%{_arch}.log > buildlogs.txt
129
130%install
131rm -rf %{buildroot}
132mkdir %{buildroot}
133
134cd _build
135TOPDIR=..
136make install DESTDIR=%{buildroot} INSTALL="%{__install} -p"
137mkdir -p %{buildroot}/%{_includedir}
138cp -a $TOPDIR/src/include/*  %{buildroot}/%{_includedir}/
139cp -a out/public-include/*  %{buildroot}/%{_includedir}/
140rm -f %{buildroot}/%{_libdir}/lib*.{la,a}
141find %{buildroot}/%{_includedir} out/libsmbios_c++ out/libsmbios_c -exec touch -r $TOPDIR/configure.ac {} \;
142
143mv out/libsmbios_c++  out/libsmbios_c++-%{_arch}
144mv out/libsmbios_c    out/libsmbios_c-%{_arch}
145
146rename %{pot_file}.mo %{lang_dom}.mo $(find %{buildroot}/%{_datadir} -name %{pot_file}.mo)
147%find_lang %{lang_dom}
148
149touch files-yum-dellsysid
150touch files-smbios-utils-python
151touch files-python-smbios
152
153# backwards compatible:
154ln -s %{_sbindir}/dellWirelessCtl %{buildroot}/%{_bindir}/dellWirelessCtl
155ln -s smbios-sys-info %{buildroot}/%{_sbindir}/getSystemId
156ln -s smbios-wireless-ctl %{buildroot}/%{_sbindir}/dellWirelessCtl
157ln -s smbios-lcd-brightness %{buildroot}/%{_sbindir}/dellLcdBrightness
158ln -s smbios-rbu-bios-update %{buildroot}/%{_sbindir}/dellBiosUpdate
159
160cat > files-python-smbios <<-EOF
161        %doc COPYING-GPL COPYING-OSL README
162        %{python_sitelib}/*
163EOF
164
165cat > files-smbios-utils-python <<-EOF
166        %doc COPYING-GPL COPYING-OSL README
167        %doc src/bin/getopts_LICENSE.txt src/include/smbios/config/boost_LICENSE_1_0_txt
168        %doc doc/pkgheader.sh
169        %dir %{_sysconfdir}/libsmbios
170        %config(noreplace) %{_sysconfdir}/libsmbios/*
171       
172        # python utilities
173        %{_sbindir}/smbios-sys-info
174        %{_sbindir}/smbios-token-ctl
175        %{_sbindir}/smbios-passwd
176        %{_sbindir}/smbios-wakeup-ctl
177        %{_sbindir}/smbios-wireless-ctl
178        %{_sbindir}/smbios-rbu-bios-update
179        %{_sbindir}/smbios-lcd-brightness
180       
181        # symlinks: backwards compat
182        %{_sbindir}/dellLcdBrightness
183        %{_sbindir}/getSystemId
184        %{_sbindir}/dellWirelessCtl
185        %{_sbindir}/dellBiosUpdate
186        # used by HAL in old location, so keep it around until HAL is updated.
187        %{_bindir}/dellWirelessCtl
188       
189        # data files
190        %{_datadir}/smbios-utils
191EOF
192
193%clean
194rm -rf %{buildroot}
195
196%post   -n %{release_name}   -p /sbin/ldconfig
197%postun -n %{release_name}   -p /sbin/ldconfig
198
199%files -f _build/%{lang_dom}.lang
200%defattr(-,root,root,-)
201%{_libdir}/libsmbios_c.so.*
202%{_libdir}/libsmbios.so.*
203
204%files -n libsmbios-devel -f _build/buildlogs.txt
205%defattr(-,root,root,-)
206%doc COPYING-GPL COPYING-OSL README src/bin/getopts_LICENSE.txt src/include/smbios/config/boost_LICENSE_1_0_txt
207%{_includedir}/smbios
208%{_includedir}/smbios_c
209%{_libdir}/libsmbios.so
210%{_libdir}/libsmbios_c.so
211%{_libdir}/pkgconfig/*.pc
212%doc _build/out/libsmbios_c++-%{_arch}
213%doc _build/out/libsmbios_c-%{_arch}
214
215%files -n smbios-utils
216# opensuse 11.1 enforces non-empty file list :(
217%defattr(-,root,root,-)
218%doc COPYING-GPL COPYING-OSL README
219# no other files.
220
221%files -n smbios-utils-bin
222%defattr(-,root,root,-)
223%doc COPYING-GPL COPYING-OSL README
224%doc src/bin/getopts_LICENSE.txt src/include/smbios/config/boost_LICENSE_1_0_txt
225%doc doc/pkgheader.sh
226#
227# legacy C++
228%{_sbindir}/dellBiosUpdate-compat
229%{_sbindir}/dellLEDCtl
230%ifnarch ia64
231%{_sbindir}/dellMediaDirectCtl
232%endif
233#
234# new C utilities
235%{_sbindir}/smbios-state-byte-ctl
236%{_sbindir}/smbios-get-ut-data
237%{_sbindir}/smbios-upflag-ctl
238%{_sbindir}/smbios-sys-info-lite
239
240%files -n python-smbios -f _build/files-python-smbios
241%defattr(-,root,root,-)
242
243%files -n smbios-utils-python -f _build/files-smbios-utils-python
244%defattr(-,root,root,-)
245
246
247%changelog
248* Sun Apr 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.26-1
249- merged with upstream package
250  * Sat May 24 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.1-3
251  - initial build for Vine Linux
252
253* Mon Sep 27 2010 Matt Domsch <mdomsch@fedoraproject.org> - 2.2.26-3
254- build for Fedora 15
255
256* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 2.2.19-2
257- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
258
259* Fri Jul 06 2010 Michael Brown <michael-e_brown at dell.com> - 2.2.26-1
260- implement CSV export of token settings from smbios-token-ctl
261
262* Fri Jul 06 2010 Michael Brown <michael-e_brown at dell.com> - 2.2.25-1
263- Fix breakage resulting from improperly fixing up constructors for MemoryAccess/CmosAccess. Fixes CLI utilities.
264
265* Fri Jun 11 2010 Michael Brown <michael-e_brown at dell.com> - 2.2.23-1
266- Fixup ABI break where a couple functions that should have been exported were not marked.
267
268* Thu Jun 10 2010 Michael Brown <michael-e_brown at dell.com> - 2.2.22-1
269- Fixup bug in reading asset and service tag where it A) read checksum from wrong location and B) used wrong comparison check to validate it
270- enable service tag SET for machines that still set service tag in CMOS
271- ABI/API - change to -fvisibility=hidden for libsmbios_c.so.*, mark public api's. This removes all non-public symbols that were not formerly part of the ABI from the dynamic link table.
272
273* Mon May 18 2009 Matt Domsch <Matt_Domsch@dell.com> - 2.2.16-3
274- split yum plugin into yum-dellsysid package
275
276* Mon Mar 24 2009 Michael E Brown <michael_e_brown at dell.com> - 2.2.16-1
277- add gcc 4.4 support
278
279* Mon Mar 24 2009 Michael E Brown <michael_e_brown at dell.com> - 2.2.15-1
280- update to lastest upstream.
281- fixes bug in bios update on systems with versions like x.y.z.
282
283* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.13-2
284- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
285
286* Tue Feb 3 2009 Michael E Brown <michael_e_brown at dell.com> - 2.2.12-1
287- Add feature to turn on debugging printf()'s without recompiling by setting
288  certain environment variables:
289    LIBSMBIOS_C_DEBUG_OUTPUT_ALL    -- all debugging output
290        or, per module:
291    LIBSMBIOS_C_DEBUG_CONSTRUCTOR_C
292    LIBSMBIOS_C_DEBUG_SYSINFO_C
293    LIBSMBIOS_C_DEBUG_SMBIOS_C
294    LIBSMBIOS_C_DEBUG_TOKEN_C
295    LIBSMBIOS_C_DEBUG_MEMORY_C
296    LIBSMBIOS_C_DEBUG_CMOS_C
297    LIBSMBIOS_C_DEBUG_SMI_C
298
299* Mon Feb 2 2009 Michael E Brown <michael_e_brown at dell.com> - 2.2.12-1
300- Add pkgconfig files to -devel
301- fixup yum plugin to not parse certain data that causes a crash on some machines (Optiplex 755, others may be affected)
302
303* Thu Jan 15 2009 Michael E Brown <michael_e_brown at dell.com> - 2.2.8-1
304- revert change in upstream renaming rpm to libsmbios2
305
306* Thu Jan 15 2009 Michael E Brown <michael_e_brown at dell.com> - 2.2.7-1
307- change source to bz2 format
308- Update to latest upstream release. Many changes in the new release:
309  - python interface
310  - libsmbios_c interface almost fully implemented
311  - libsmbios c++ interface deprecated
312
313* Tue Oct 28 2008 Michael E Brown <michael_e_brown at dell.com> - 2.2.0-1
314- Spec updates
315
316* Mon Apr 21 2008 Michael E Brown <michael_e_brown at dell.com> - 2.0.1-2.1
317- obsolete libsmbios-libs as well
318
319* Mon Mar 3 2008 Michael E Brown <michael_e_brown at dell.com> - 2.0.1-2
320- properly obsolete older versions
321
322* Wed Feb 13 2008 Michael E Brown <michael_e_brown at dell.com> - 2.0.1
323- Fixup GCC 4.3 compile issues.
324
325* Wed Jan 9 2008 Michael E Brown <michael_e_brown at dell.com> - 2.0.0
326- ABI incompatible, minor API changes
327- sync up libsmbios soname with version #
328- move binaries to /usr/sbin as they are only runnable by root
329- drop libsmbiosxml lib as it was mostly unused.
330- drop autotools generated files out of git and add autogen.sh
331- drop tokenCtl binary-- pysmbios has a *much* improved version
332
333* Wed Aug 22 2007 Michael E Brown <michael_e_brown at dell.com> - 0.13.9
334- Fix a couple of failure-to-check-return on fopen. most were unit-test code
335  only, but two or three were in regular code.
336- Add hinting to the memory class, so that it can intelligently close /dev/mem
337  file handle when it is not needed (which is most of the time). it only
338  leaves it open when it is scanning, so speed is not impacted.
339
340* Tue Aug 6 2007 Michael E Brown <michael_e_brown at dell.com> - 0.13.8
341- new upstream
342
343* Tue Apr 3 2007 Michael E Brown <michael_e_brown at dell.com> - 0.13.6
344- critical bugfix for dellBiosUpdate utility for packet mode
345- autoconf/automake support for automatically building docs
346- more readable 'make' lines by splitting out env vars
347- remove run_cppunit option... always run unit tests.
348- update autoconf/automake utilities to latest version
349- fix LDFLAGS to not overwrite user entered LDFLAGS
350- add automatic doxygen build of docs
351- fix urls of public repos
352- remove yum repo page in favor of official page from docs
353- split dmi table entry point from smbios table entry point
354- support legacy _DMI_ tables
355- fix support for EFI-based imacs without proper _SM_ anchor
356
357* Tue Mar 20 2007 Michael E Brown <michael_e_brown at dell.com> - 0.13.5
358- rpmlint cleanups
359- Add dellLEDCtl binary
360- update AUTHORS file to add credit for dellLEDCtl
361- update doc/DellToken.txt to add a few more useful tokens.
362- updated build system to create documentation
363- skip cppunit dep on .elX builds (not in EPEL yet)
364
365* Mon Mar 12 2007 Michael E Brown <michael_e_brown at dell.com> - 0.13.4-1
366- Added dellWirelessCtl binary
367- Added 'static' makefile target to build static binaries and clean them as well
368- fix for signed/unsigned bug in probes binary. CPU temp misreported
369- simplify interface for DELL_CALLING_INTERFACE_SMI, autodetect Port/Magic
370- document all of the tokens for controlling wireless on dell notebooks
371- enums for SMI args/res to make code match docs better (cbRES1 = res[0], which
372  was confusing.
373- helper functions isTokenActive() and activateToken() to simplify token API.
374- Added missing windows .cpp files to the dist tarball for those who compile
375  windows from dist tarball vs source control
376- Add support for EFI based machines without backwards compatible smbios table
377  entry point in 0xF0000 block.
378- Added wirelessSwitchControl() and wirelessRadioControl() API for newer
379  laptops.
380- fixed bug in TokenDA activate() code where it wasnt properly using SMI
381  (never worked, but apparently wasnt used until now.)
382
383* Tue Oct 3 2006 Michael E Brown <Michael_E_Brown@Dell.com> - 0.13.0-1
384- autotools conversion
385- add Changelog
386
387* Tue Sep 26 2006 Michael E Brown <michael_e_brown at dell.com> - 0.12.4-1
388- Changes per Fedora Packaging Guidelines to prepare to submit to Extras.
389- Add in a changelog entry per Fedora Packaging Guidelines...
390
Note: See TracBrowser for help on using the repository browser.