source: projects/specs/branches/6/lib/libr/librep/librep-vl.spec @ 6364

Revision 6364, 4.7 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild or update packages

Line 
1%define __libtoolize :
2
3Name:        librep
4Version:     0.16.1
5Release:     2%{?_dist_release}
6Summary:     An embeddable LISP environment
7Summary(ja): 組込み LISP 環境
8License:     GPL
9Group:       Development/Languages
10Source:      http://download.sourceforge.net/librep/librep-%{version}.tar.gz
11Patch10:     librep-0.14-mipsel.patch
12URL:         http://librep.sourceforge.net/
13Buildroot:   %{_tmppath}/%{name}-%{version}-root
14BuildRequires: gmp-devel >= 4.1
15BuildRequires: gdbm-devel readline-devel texinfo
16Requires(pre):      /sbin/install-info
17Requires:    gdbm >= 1.8
18
19Vendor: Project Vine
20Distribution: Vine Linux
21Packager: Ryoichi INAGAKI <ryo1@bc.wakwak.com>
22
23%description
24This is a lightweight Lisp environment for UNIX. It contains a Lisp
25interpreter, byte-code compiler and virtual machine. Applications may
26use the Lisp interpreter as an extension language, or it may be used
27for standalone scripts.
28
29Originally inspired by Emacs Lisp, the language dialect combines many
30of the elisp features while trying to remove some of the main
31deficiencies, with features from Common Lisp and Scheme.
32
33%description -l ja
34librep は UNIX 向け軽量 Lisp 環境です.Lisp インタプリタ,バイトコード
35コンパイラ,仮想マシンが収められています.アプリケーションから Lisp
36インタプリタを機能拡張言語として使うことも出来ますし,単純にスタンドアロンの
37スクリプト環境として使うことも出来ます.
38
39元々は Emacs Lisp に影響を受けつつ,elisp に欠けている機能を補う為に
40Common Lisp や Scheme 等の機能を取り入れています.
41
42
43%package devel
44Summary:     librep include files and link libraries
45Summary(ja): librep 用インクルードファイルとライブラリ
46Group:       Development/Languages
47Requires:    %{name} = %{version}
48
49
50%description devel
51Link libraries and C header files for librep development.
52
53%description devel -l ja
54librep 開発用ライブラリと C ヘッダファイル
55
56
57%prep
58%setup -q
59#%patch10 -p1 -b .mipsel
60
61
62%build
63
64LC_ALL=""
65LINGUAS=""
66LANG=""
67export LC_ALL LINGUAS LANG
68
69%ifarch ppc
70%configure --with-readline --with-stack-direction=1
71%else
72%configure --with-readline --with-extra-cflags=-fstrength-reduce
73%endif
74make host_type=%{_target_platform}
75
76
77%install
78[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
79make install \
80    host_type=%{_target_platform} \
81    DESTDIR=$RPM_BUILD_ROOT \
82    aclocaldir=%{_datadir}/aclocal \
83    infodir=%{_infodir}
84gzip -9nf $RPM_BUILD_ROOT%{_infodir}/librep*
85
86
87%post
88/sbin/ldconfig
89/sbin/install-info %{_infodir}/librep.info.gz %{_infodir}/dir
90
91
92%preun
93if [ "$1" = 0 ]; then
94    /sbin/install-info --delete %{_infodir}/librep.info.gz %{_infodir}/dir
95fi
96
97
98%postun -p /sbin/ldconfig
99
100
101%clean
102[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
103
104
105%files
106%defattr(-,root,root)
107%doc NEWS README THANKS TODO BUGS
108%{_bindir}/rep
109%{_bindir}/rep-remote
110%{_libdir}/librep.so.*
111%{_datadir}/rep/%{version}
112%{_libexecdir}/rep/%{version}/%{_target_platform}
113%{_infodir}/librep*
114
115
116%files devel
117%defattr(-,root,root)
118%{_bindir}/rep-config
119%{_bindir}/rep-xgettext
120%{_bindir}/repdoc
121%{_libdir}/librep.so
122%{_includedir}/rep.h
123%{_includedir}/rep_*.h
124%{_libexecdir}/rep/%{_target_platform}/libtool
125%{_libexecdir}/rep/%{_target_platform}/rules.mk
126%{_libexecdir}/rep/%{_target_platform}/install-aliases
127%{_libexecdir}/rep/%{_target_platform}/rep_config.h
128%{_datadir}/aclocal/rep.m4
129
130
131%changelog
132* Sun Jun 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.1-2
133- rebuild with Vine6 environment
134
135* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 0.16.1-1vl5
136- applied new versioning policy, spec in utf-8
137
138* Tue Aug 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.16.1-0vl6
139- small fix for configure script
140
141* Sat Aug 25 2007 Shu KONNO <owa@bg.wakwak.com> 0.16.1-0vl5
142- s/Copyright/License/
143
144* Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.16.1-0vl4
145- rebuilt with readline-4.3
146
147* Mon Jan 20 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.16.1-0vl3
148- rebuilt against gmp-4.1
149
150* Sat Nov  9 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16.1-0vl2
151- update to 0.16.1
152- remove Patch10
153- add %define __libtoolize (If it isn't, sawfish can't compile...)
154
155* Mon Jul 16 2001 Daisuke SUZUKi <daisuke@linux.or.jp> 0.14-0vl1
156- update to 0.14
157- add Patch10 for mipsel
158
159* Sun May 20 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
160- 0.13.6-1vl1
161- built for Vine Linux
162
163* Tue Jun 13 2000 John Harper <john@dcs.warwick.ac.uk>
164- use better macros
165
166* Wed Nov 10 1999 Michael K. Johnson <johnsonm@redhat.com>
167- post{,un} use -p
168
169* Mon Sep 13 1999 Aron Griffis <agriffis@bigfoot.com>
170- 0.5 spec file update: added buildroot
Note: See TracBrowser for help on using the repository browser.