source: projects/specs/branches/6/lib/libp/libproxy/libproxy-vl.spec @ 7974

Revision 7974, 7.7 KB checked in by iwamoto, 10 years ago (diff)

update: libproxy

Line 
1Summary:        A library handling all the details of proxy configuration
2Name:           libproxy
3Version:        0.4.6
4Release:        3%{?_dist_release}
5
6Group:          System Environment/Libraries
7License:        LGPLv2+
8URL:            http://code.google.com/p/libproxy/
9Source0:        http://libproxy.googlecode.com/files/libproxy-%{version}.tar.gz
10Patch1:         libproxy-0.4.6-mozjs.patch
11Patch2:         libproxy-0.4.6-new-mozjs.patch
12Patch100:       libproxy-0.4.6_CVE-2012-4505.patch
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14
15BuildRequires:  python-devel
16#Virtual Provides - We need either mozjs or WebKit
17Requires: %{name}-pac >= %{version}
18#
19Requires: libproxy-python = %{version}-%{release}
20Requires: libproxy-bin = %{version}-%{release}
21
22BuildRequires:  cmake
23# gnome
24BuildRequires:  GConf2-devel
25# mozjs
26BuildRequires:  js-devel
27# NetworkManager
28BuildRequires:  NetworkManager-devel
29BuildRequires:  dbus-devel
30# webkit (gtk)
31BuildRequires:  WebKit-gtk-devel
32# kde
33BuildRequires:  kdelibs-devel
34BuildRequires:  libXmu-devel
35BuildRequires:  libX11-devel
36
37Vendor:         Project Vine
38Distribution:   Vine Linux
39
40%description
41libproxy offers the following features:
42
43    * extremely small core footprint (< 35K)
44    * no external dependencies within libproxy core
45      (libproxy plugins may have dependencies)
46    * only 3 functions in the stable external API
47    * dynamic adjustment to changing network topology
48    * a standard way of dealing with proxy settings across all scenarios
49    * a sublime sense of joy and accomplishment
50
51Non-default rpmbuild options:
52--with webkit:           Enable WebKit-gtk support
53
54
55%package        bin
56Summary:        Binary to test %{name}
57Group:          Applications/System
58Requires:       %{name} = %{version}-%{release}
59
60%description    bin
61The %{name}-bin package contains the proxy binary for %{name}
62
63%package        python
64Summary:        Binding for %{name} and python
65Group:          System Environment/Libraries
66Requires:       %{name} = %{version}-%{release}
67
68%description    python
69The %{name}-python package contains the python binding for %{name}
70
71%package        gnome
72Summary:        Plugin for %{name} and gnome
73Group:          System Environment/Libraries
74Requires:       %{name} = %{version}-%{release}
75
76%description    gnome
77The %{name}-gnome package contains the %{name} plugin for gnome.
78
79%package        kde
80Summary:        Plugin for %{name} and kde
81Group:          System Environment/Libraries
82Requires:       %{name} = %{version}-%{release}
83
84%description    kde
85The %{name}-kde package contains the %{name} plugin for kde.
86
87%package        mozjs
88Summary:        Plugin for %{name} and mozjs
89Group:          System Environment/Libraries
90Requires:       %{name} = %{version}
91# Tweak this according to the current gecko-libs version
92# Requires:       gecko-libs >= %{gecko_version}
93Provides:       %{name}-pac = %{version}-%{release}
94
95%description    mozjs
96The %{name}-mozjs package contains the %{name} plugin for mozjs.
97
98%package        webkit
99Summary:        Plugin for %{name} and webkit
100Group:          System Environment/Libraries
101Requires:       %{name} = %{version}
102Provides:       %{name}-pac = %{version}-%{release}
103
104%description    webkit
105The %{name}-webkit package contains the %{name} plugin for
106webkit.
107
108%package        devel
109Summary:        Development files for %{name}
110Group:          Development/Libraries
111Requires:       %{name} = %{version}-%{release}
112Requires:       pkgconfig
113
114%description    devel
115The %{name}-devel package contains libraries and header files for
116developing applications that use %{name}.
117
118
119%prep
120%setup -q
121%patch1 -p1 -b .mozjs185
122%patch2 -p1 -b .new-mozjs
123%patch100 -p1 -b .CVE-2012-4505
124
125%build
126%cmake \
127        -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
128        -DMODULE_INSTALL_DIR=%{_libdir}/%{name}/%{version}/modules \
129        -DWITH_PERL=OFF \
130   .
131make VERBOSE=1 %{?_smp_mflags}
132make %{?_smp_mflags}
133
134
135%install
136rm -rf $RPM_BUILD_ROOT
137make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
138find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
139
140
141%clean
142rm -rf $RPM_BUILD_ROOT
143
144
145%post -p /sbin/ldconfig
146
147%postun -p /sbin/ldconfig
148
149
150%files
151%defattr(-,root,root,-)
152%doc AUTHORS COPYING README
153%{_libdir}/*.so.*
154%dir %{_libdir}/%{name}
155%dir %{_libdir}/%{name}/%{version}
156%dir %{_libdir}/%{name}/%{version}/modules
157%{_libdir}/%{name}/%{version}/modules/network_networkmanager.so
158
159%files bin
160%defattr(-,root,root,-)
161%{_bindir}/proxy
162
163%files python
164%defattr(-,root,root,-)
165%{python_sitearch}/libproxy.py
166
167%files gnome
168%defattr(-,root,root,-)
169%{_libdir}/%{name}/%{version}/modules/config_gnome.so
170%{_libexecdir}/pxgconf
171
172%files kde
173%defattr(-,root,root,-)
174%{_libdir}/%{name}/%{version}/modules/config_kde4.so
175
176%files mozjs
177%defattr(-,root,root,-)
178%{_libdir}/%{name}/%{version}/modules/pacrunner_mozjs.so
179
180%files webkit
181%defattr(-,root,root,-)
182%{_libdir}/%{name}/%{version}/modules/pacrunner_webkit.so
183
184%files devel
185%defattr(-,root,root,-)
186%{_includedir}/proxy.h
187%{_libdir}/*.so
188%{_libdir}/pkgconfig/libproxy-1.0.pc
189%{_datadir}/cmake/Modules/Findlibproxy.cmake
190
191
192%changelog
193* Mon Nov  5 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.4.6-3
194- add patch100 for fix CVE-2012-4505 (pac file)
195- add Vendor/Distri tags
196- delete R: gecko-libs in mozjs
197
198* Mon Nov 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.6-2
199- add Patch1,2 to build with js-1.8.5
200
201* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.6-1
202- new upstream release
203- drop Patch0
204- add BuildRequires: cmake, kdelibs-devel
205- fix %files (from %{_libdir}/%{name}/%{version}/plugins to %{_libdir}/%{name}/%{version}/modules)
206
207* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.3-5
208- rebuild with rpm-4.8.1 for pkg-config file
209
210* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.2.3-4
211- rebuild with python-2.6
212
213* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-3
214- rebuild with gecko-1.9.1
215
216* Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-2
217- rebuild with WebKit-gtk-1.0.0-8.svn41944
218
219* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-1
220- initial build for Vine Linux
221
222* Mon Mar  9 2009 kwizart < kwizart at gmail.com > - 0.2.3-10
223- Rebuild for webkit
224- Raise requirement for xulrunner to 1.9.1
225
226* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-9
227- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
228
229* Thu Jan 22 2009 kwizart < kwizart at gmail.com > - 0.2.3-8
230- Merge NetworkManager module into the main libproxy package
231- Main Requires the -python and -bin subpackage
232 (splitted for multilibs compliance).
233
234* Fri Oct 24 2008 kwizart < kwizart at gmail.com > - 0.2.3-7
235- Disable Gnome/KDE default support via builtin modules.
236 (it needs to be integrated via Gconf2/neon instead).
237
238* Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-6
239- Disable Obsoletes.
240- Requires ev instead of evr for optionnals sub-packages.
241
242* Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-5
243- Use conditionals build.
244
245* Mon Sep 15 2008 kwizart < kwizart at gmail.com > - 0.2.3-4
246- Remove plugin- in the name of the packages
247
248* Mon Aug  4 2008 kwizart < kwizart at gmail.com > - 0.2.3-3
249- Move proxy.h to libproxy/proxy.h
250  This will prevent it to be included in the default include path
251- Split main to libs and util and use libproxy to install all
252
253* Mon Aug  4 2008 kwizart < kwizart at gmail.com > - 0.2.3-2
254- Rename binding-python to python
255- Add Requires: gecko-libs >= %%{gecko_version}
256- Fix some descriptions
257- Add plugin-webkit package
258 
259* Fri Jul 11 2008 kwizart < kwizart at gmail.com > - 0.2.3-1
260- Convert to Fedora spec
261
262* Fri Jun 6 2008 - dominique-rpm@leuenberger.net
263- Updated to version 0.2.3
264* Wed Jun 4 2008 - dominique-rpm@leuenberger.net
265- Extended spec file to build all available plugins
266* Tue Jun 3 2008 - dominique-rpm@leuenberger.net
267- Initial spec file for Version 0.2.2
268
Note: See TracBrowser for help on using the repository browser.