source: projects/specs/branches/6/lib/libp/libpng/libpng-vl.spec @ 9857

Revision 9857, 13.9 KB checked in by iwamoto, 8 years ago (diff)

libpng: update to 1.2.55 with security fix

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of functions for manipulating PNG image format files.
4Summary(ja): PNG画像形式ファイル操作用の関数ライブラリ
5Name: libpng
6Version: 1.2.55
7Release: 1%{_dist_release}
8License: distributable
9Group: System Environment/Libraries
10Source: ftp://ftp.simplesystems.org/pub/libpng/png/src/%{name}-%{version}.tar.xz
11# security patches
12# Patch100: libpng-1.2.xx_CVE-2011-3026.patch
13# Patch110: libpng-1.2.xx_CVE-2011-3045.patch
14# Patch120: libpng-1.2.xx_CVE-2011-3048.patch
15Patch130: libpng-1.2.50-CVE-2013-7353.patch
16Patch140: libpng-1.2.50-CVE-2013-7354.patch     
17Patch141: libpng-1.2.51_pngset_limit.h.patch
18
19Buildroot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires(pre): zlib-devel
21Requires: zlib
22URL: http://www.libpng.org/pub/png/
23%define LIBVER 3.%{version}
24Epoch: 2
25
26Vendor: Project Vine
27Distribution: Vine Linux
28
29%description
30The libpng package contains a library of functions for creating and
31manipulating PNG (Portable Network Graphics) image format files.  PNG
32is a bit-mapped graphics format similar to the GIF format.  PNG was
33created to replace the GIF format, since GIF uses a patented data
34compression algorithm.
35
36Libpng should be installed if you need to manipulate PNG format image
37files.
38
39%description -l ja
40libpng パッケージには PNG (Portable Network Graphics) 形式の
41画像ファイルを作成/操作する為のライブラリが収められています.
42PNG はビットマップの画像形式で,GIF によく似ています.
43GIF が 特許保護された LZW データ圧縮アルゴリズムを利用している為,
44PNG は GIF の代替画像形式として生まれました.
45
46PNG 形式の画像ファイルを扱う場合は libpng をインストールして下さい.
47
48%package devel
49Summary: Development tools for programs to manipulate PNG image format files.
50Summary(ja): PNG 形式画像ファイルを扱うプログラム向け開発ツール
51Group: Development/Libraries
52Requires: libpng = %{epoch}:%{version}-%{release}
53Requires: zlib-devel
54
55%description devel
56The libpng-devel package contains the header files necessary for
57developing programs using the PNG (Portable Network Graphics) library.
58
59%description devel -l ja
60libpng-devel パッケージには,PNG (Portable Network Graphics) ライブラリを
61使ったプログラムを開発するのに必要なヘッダファイルが収められています.
62
63%package static
64Summary: Static library for %{name}
65Summary(ja): %{name} のスタティックライブラリ
66Group: Development/Libraries
67Requires: libpng-devel = %{epoch}:%{version}-%{release}
68
69%description static
70The libpng-static package contains the static library for libpng.
71
72
73## to build compat32 for x86_64 architecture support
74%package -n compat32-%{name}
75Summary: A library of functions for manipulating PNG image format files.
76Summary(ja): PNG画像形式ファイル操作用の関数ライブラリ
77Group: System Environment/Libraries
78
79%description -n compat32-%{name}
80The libpng package contains a library of functions for creating and
81manipulating PNG (Portable Network Graphics) image format files.  PNG
82is a bit-mapped graphics format similar to the GIF format.  PNG was
83created to replace the GIF format, since GIF uses a patented data
84compression algorithm.
85
86Libpng should be installed if you need to manipulate PNG format image
87files.
88
89%package -n compat32-%{name}-devel
90Summary: Development tools for programs to manipulate PNG image format files.
91Summary(ja): PNG 形式画像ファイルを扱うプログラム向け開発ツール
92Group: Development/Libraries
93Requires: libpng = %{epoch}:%{version}-%{release}, libpng-devel = %{epoch}:%{version}-%{release}
94Requires: compat32-zlib-devel
95
96%description -n compat32-%{name}-devel
97The libpng-devel package contains the header files and static
98libraries necessary for developing programs using the PNG (Portable
99Network Graphics) library.
100
101If you want to develop programs which will manipulate PNG image format
102files, you should install libpng-devel.  You'll also need to install
103the libpng package.
104
105#'
106%prep
107%setup -q
108
109# security patches
110# %patch100 -p1 -b .CVE-2011-3026
111# %patch110 -p1 -b .CVE-2011-3045
112# %patch120 -p1 -b .CVE-2011-3048
113%patch130 -p0 -b .CVE-2013-7353
114%patch140 -p0 -b .CVE-2013-7354
115%patch141 -p0 -b .limit.h
116
117%build
118#./autogen.sh
119%configure
120%__make %{?_smp_mflags}
121
122%install
123[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
124%makeinstall
125
126# remove unneeded files
127%__rm -f %{buildroot}%{_libdir}/libpng*.la
128
129%post -p /sbin/ldconfig
130
131%postun -p /sbin/ldconfig
132
133%post -n compat32-%{name} -p /sbin/ldconfig
134
135%postun -n compat32-%{name} -p /sbin/ldconfig
136
137%clean
138[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
139
140%files
141%defattr(-,root,root)
142%doc *.txt example.c README TODO CHANGES
143%{_libdir}/libpng*.so.*
144%{_mandir}/man5/*
145
146%files devel
147%defattr(-,root,root)
148%{_bindir}/libpng-config
149%{_bindir}/libpng12-config
150%{_includedir}/*
151%{_libdir}/libpng*.so
152%{_libdir}/pkgconfig/*
153%{_mandir}/man3/*
154
155%files static
156%defattr(-,root,root)
157%{_libdir}/libpng*.a
158
159## to build compat32 for x86_64 architecture support
160%if %{build_compat32}
161%files -n compat32-%{name}
162%defattr(-,root,root)
163%{_libdir}/libpng*.so.*
164
165%files -n compat32-%{name}-devel
166%defattr(-,root,root)
167%{_libdir}/libpng*.a
168%{_libdir}/libpng*.so
169%{_libdir}/pkgconfig/*
170%endif
171
172%changelog
173* Sat Dec  5 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.55-1vl6
174- new upstream release 1.2.55 with security fixes 
175
176* Thu Nov 26 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.54-1vl6
177- new upstream release 1.2.54 with security fixes
178
179* Mon Jun 23 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.51-2vl6
180- drop Ob: libpng12 from main and devel packages
181- fix compat32-devel dependensy (zlib-devel -> compat32-zlib-devel)
182
183* Sun May 18 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.51-1vl6
184- new upstream release 1.2.51
185- drop old patches (are inculuded in new release)
186- add Patch130 for fix CVE-2013-7353
187- add Patch140 for fix CVE-2013-7354
188- add Patch141 to fix build err
189
190* Sat Apr 28 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.46-3vl6
191- add patch110 for fix CVE-2011-3045
192- add patch120 for fix CVE-2011-3048 (png_set_text2())
193
194* Sat Feb 18 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.46-2
195- add patch100 for fix CVE-2011-3026
196
197* Wed Jul 13 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.46-1
198- new upstream release with security fix (VU#819894)
199- add Vendor/Distri tags
200
201* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2:1.2.44-3
202- build with rpm-4.8.1-1 for pkg-config file
203
204* Sun Jul 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.44-2
205- sync with Vine Linux 5 updates release
206  * Tue Jun 29 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.44-1
207  - new upstream release with security fix (CVE-2010-1205)
208
209* Thu Apr 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.43-2
210- sync with Vine Linux 5 updates release
211  * Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.43-1
212  - new upstream release with security fix (CVE-2010-0205)
213
214* Wed Jan 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.42-1
215- new upstream release with security fix
216
217* Tue Jun  9 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.37-1
218- new upstream release with security fix
219
220* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2:1.2.35-2
221- split static library to libpng-static
222  - needed by tuxonice-userui
223
224* Wed Feb 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.35-1
225- new upstream release with security fix (CVE-2009-0040)
226
227* Mon Nov 03 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.33-1
228- new upstream release
229
230* Thu Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.32-2
231- spec file in UTF-8
232
233* Thu Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.32-1
234- new upstream release with security fix (CVE-2008-3964)
235
236* Sat May 03 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.28-1
237- new upstream release with security fix (CVE-2008-1382)
238- added running autogen.sh before configure
239- new versioning policy
240
241* Sun Feb 24 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.25-0vl1
242- new upstream release
243
244* Thu Jan 24 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2:1.2.24-0vl2
245- removed %%if !%%{build_compat32} case condition
246
247* Mon Jan 21 2008 Kazutaka HARADA <Kazutaka@dc4.so-net.ne.jp> 2:1.2.24-0vl1
248- new upstream release
249
250* Wed Oct 10 2007 Shu KONNO <owa@bg.wakwak.com> 2:1.2.21-0vl1
251- new upstream release
252
253* Fri May 18 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2:1.2.18-0vl1
254- new upstream release (CVE-2007-2445)
255
256* Sun Dec 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2:1.2.14-0vl1
257- new upstream release
258- drop obsolete patch100
259
260* Fri Nov 24 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.12-0vl1.1
261- add Patch100 for fix CVE-2006-5793.patch
262
263* Sat Jul 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.12-0vl1
264- [SECURITY] new upstream release
265  - potential buffer overrun in chunk error processing (CVE-2006-3334)
266- use %%configure, %%makeinstall
267- drop unneeded patch10
268
269* Sun Jun 18 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl7
270- rebuilt with glibc-2.3.3-3vl14
271
272* Tue Feb 28 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.8-0vl6
273- fixed libdir path in libpng.pc
274
275* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.8-0vl5
276- fixed %postun (missing to build as scriptlet by invalid comment)
277
278* Thu Feb 09 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.8-0vl4
279- added compat32-* packages for x86_64 architecture support
280- added CC='gcc -m32' to make when build_compat32
281- added LIBPATH=%{_libdir} to make
282
283* Thu Feb 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.8-0vl3
284- rebuild
285
286* Wed Dec 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.8-0vl2
287- rebuild for VineSeed
288
289* Wed Dec 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.8-0vl1
290- new upstream release (bug fix)
291
292* Mon Sep 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
293- new upstream release
294
295* Tue Aug 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl0.rc3
296- update to 1.2.6rc3
297- add Requires: zlib-devel to libpng-devel.
298
299* Tue Aug 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl0.rc2
300- update to 1.2.6rc2
301
302* Sun Aug 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl0.rc1
303- update to 1.2.6rc1
304- add patch10 to correct directory name in libpng.pc
305- clean spec file
306
307* Tue Jul  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl4
308- added Patch4 from Redhat WS updates
309  * Mon Jun 14 2004 Matthias Clasen <mclasen@redhat.com> 1.2.2-23
310  - Reinstate and improve the transfix patch which got lost sometime ago,
311    but is still needed for CAN-2002-1363 (#125934)
312
313* Sun Dec 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.5-0vl3
314- rebuild with new toolchain
315- use License tag
316- change URL
317
318* Tue Apr 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.5-0vl2
319- added Obsoletes: libpng12-devel for libpng-devel
320
321* Mon Apr 14 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.5-0vl1
322- change package name from libpng12 to libpng
323- revised install and files section
324- remove all patches
325- define LIBVER 3.%{version}
326- add Obsoletes: libpng12
327
328* Sat Mar  1 2003 Kazuhisa TAKEI <takei@vinelinux.org> 1.2.25-0vl5
329- new upstream version
330- change package name to libpng12
331- conflicts libpng-devel(1.0.5) and libpng12-devel
332
333* Sat Dec 14 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.15-0vl3
334- added Patch200 for linking libz shared lib
335- include libpng*-config
336
337* Sat Dec 14 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.15-0vl2
338- added missing libraries in the file list
339
340* Thu Nov 12 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.15-0vl1
341- update to 1.0.15
342- now, security patch were merged source.
343
344* Wed Aug 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.12-0vl3
345- added another security patch to preserve libpng from processing too wide
346  image files (a patch itself extracted from DSA 140-2)
347
348* Fri Aug 02 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.12-0vl2
349- added a patch to fix buffer overflow (Patch100)
350
351* Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
352- 1.0.12-0vl1
353- updated 1.0.12
354
355* Tue Jan 09 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
356- 1.0.7-0vl3
357- use better macros
358- added Japanese summary and description
359
360* Tue Jul 18 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
361- 1.0.7-0vl2
362- oops, spec was in Shift-JIS... Fixed it.
363
364* Mon Jul  3 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
365- update to 1.0.7
366
367* Tue Mar 21 2000 Nalin Dahyabhai <nalin@redhat.com>
368- update to 1.0.6
369
370* Mon Mar 13 2000 Nalin Dahyabhai <nalin@redhat.com>
371- change serial to Epoch to get dependencies working correctly
372
373* Fri Feb 11 2000 Nalin Dahyabhai <nalin@redhat.com>
374- move buildroot and add URL
375
376* Sat Feb  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
377- strip library
378- rebuild to compress man pages
379
380* Sun Nov 21 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
381- 1.0.5
382- some tweaks to spec file to make updating easier
383- handle RPM_OPT_FLAGS
384
385* Mon Sep 20 1999 Matt Wilson <msw@redhat.com>
386- changed requires in libpng-devel to include serial
387- corrected typo
388
389* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
390- auto rebuild in the new build environment (release 2)
391
392* Sun Feb 07 1999 Michael Johnson <johnsonm@redhat.com>
393- rev to 1.0.3
394
395* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
396- build for 6.0
397
398* Wed Sep 23 1998 Cristian Gafton <gafton@redhat.com>
399- we are Serial: 1 now because we are reverting the 1.0.2 version from 5.2
400  beta to this prior one
401- install man pages; set defattr defaults
402
403* Thu May 07 1998 Prospector System <bugs@redhat.com>
404- translations modified for de, fr, tr
405
406* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
407- devel subpackage moved to Development/Libraries
408
409* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
410- upgraded to 1.0.1
411- added buildroot
412
413* Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
414- updated to new version
415- spec file cleanups
416
417* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
418- built against glibc
419
Note: See TracBrowser for help on using the repository browser.