source: projects/specs/branches/6/lib/libp/libpng/libpng-vl.spec @ 8596

Revision 8596, 13.6 KB checked in by iwamoto, 10 years ago (diff)

libpng: drop Ob:libpng12

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of functions for manipulating PNG image format files.
4Summary(ja): PNG画像形式ファイル操作用の関数ライブラリ
5Name: libpng
6Version: 1.2.51
7Release: 2%{_dist_release}
8License: distributable
9Group: System Environment/Libraries
10Source: ftp://ftp.simplesystems.org/pub/libpng/png/src/%{name}-%{version}.tar.xz
11# security patches
12# Patch100: libpng-1.2.xx_CVE-2011-3026.patch
13# Patch110: libpng-1.2.xx_CVE-2011-3045.patch
14# Patch120: libpng-1.2.xx_CVE-2011-3048.patch
15Patch130: libpng-1.2.50-CVE-2013-7353.patch
16Patch140: libpng-1.2.50-CVE-2013-7354.patch     
17Patch141: libpng-1.2.51_pngset_limit.h.patch
18
19Buildroot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires(pre): zlib-devel
21Requires: zlib
22URL: http://www.libpng.org/pub/png/
23%define LIBVER 3.%{version}
24Epoch: 2
25
26Vendor: Project Vine
27Distribution: Vine Linux
28
29%description
30The libpng package contains a library of functions for creating and
31manipulating PNG (Portable Network Graphics) image format files.  PNG
32is a bit-mapped graphics format similar to the GIF format.  PNG was
33created to replace the GIF format, since GIF uses a patented data
34compression algorithm.
35
36Libpng should be installed if you need to manipulate PNG format image
37files.
38
39%description -l ja
40libpng パッケージには PNG (Portable Network Graphics) 形式の
41画像ファイルを作成/操作する為のライブラリが収められています.
42PNG はビットマップの画像形式で,GIF によく似ています.
43GIF が 特許保護された LZW データ圧縮アルゴリズムを利用している為,
44PNG は GIF の代替画像形式として生まれました.
45
46PNG 形式の画像ファイルを扱う場合は libpng をインストールして下さい.
47
48%package devel
49Summary: Development tools for programs to manipulate PNG image format files.
50Summary(ja): PNG 形式画像ファイルを扱うプログラム向け開発ツール
51Group: Development/Libraries
52Requires: libpng = %{epoch}:%{version}-%{release}
53Requires: zlib-devel
54
55%description devel
56The libpng-devel package contains the header files necessary for
57developing programs using the PNG (Portable Network Graphics) library.
58
59%description devel -l ja
60libpng-devel パッケージには,PNG (Portable Network Graphics) ライブラリを
61使ったプログラムを開発するのに必要なヘッダファイルが収められています.
62
63%package static
64Summary: Static library for %{name}
65Summary(ja): %{name} のスタティックライブラリ
66Group: Development/Libraries
67Requires: libpng-devel = %{epoch}:%{version}-%{release}
68
69%description static
70The libpng-static package contains the static library for libpng.
71
72
73## to build compat32 for x86_64 architecture support
74%package -n compat32-%{name}
75Summary: A library of functions for manipulating PNG image format files.
76Summary(ja): PNG画像形式ファイル操作用の関数ライブラリ
77Group: System Environment/Libraries
78
79%description -n compat32-%{name}
80The libpng package contains a library of functions for creating and
81manipulating PNG (Portable Network Graphics) image format files.  PNG
82is a bit-mapped graphics format similar to the GIF format.  PNG was
83created to replace the GIF format, since GIF uses a patented data
84compression algorithm.
85
86Libpng should be installed if you need to manipulate PNG format image
87files.
88
89%package -n compat32-%{name}-devel
90Summary: Development tools for programs to manipulate PNG image format files.
91Summary(ja): PNG 形式画像ファイルを扱うプログラム向け開発ツール
92Group: Development/Libraries
93Requires: libpng = %{epoch}:%{version}-%{release}, libpng-devel = %{epoch}:%{version}-%{release}
94Requires: compat32-zlib-devel
95
96%description -n compat32-%{name}-devel
97The libpng-devel package contains the header files and static
98libraries necessary for developing programs using the PNG (Portable
99Network Graphics) library.
100
101If you want to develop programs which will manipulate PNG image format
102files, you should install libpng-devel.  You'll also need to install
103the libpng package.
104
105#'
106%prep
107%setup -q
108
109# security patches
110# %patch100 -p1 -b .CVE-2011-3026
111# %patch110 -p1 -b .CVE-2011-3045
112# %patch120 -p1 -b .CVE-2011-3048
113%patch130 -p0 -b .CVE-2013-7353
114%patch140 -p0 -b .CVE-2013-7354
115%patch141 -p0 -b .limit.h
116
117%build
118#./autogen.sh
119%configure
120%__make %{?_smp_mflags}
121
122%install
123[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
124%makeinstall
125
126# remove unneeded files
127%__rm -f %{buildroot}%{_libdir}/libpng*.la
128
129%post -p /sbin/ldconfig
130
131%postun -p /sbin/ldconfig
132
133%post -n compat32-%{name} -p /sbin/ldconfig
134
135%postun -n compat32-%{name} -p /sbin/ldconfig
136
137%clean
138[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
139
140%files
141%defattr(-,root,root)
142%doc *.txt example.c README TODO CHANGES
143%{_libdir}/libpng*.so.*
144%{_mandir}/man5/*
145
146%files devel
147%defattr(-,root,root)
148%{_bindir}/libpng-config
149%{_bindir}/libpng12-config
150%{_includedir}/*
151%{_libdir}/libpng*.so
152%{_libdir}/pkgconfig/*
153%{_mandir}/man3/*
154
155%files static
156%defattr(-,root,root)
157%{_libdir}/libpng*.a
158
159## to build compat32 for x86_64 architecture support
160%if %{build_compat32}
161%files -n compat32-%{name}
162%defattr(-,root,root)
163%{_libdir}/libpng*.so.*
164
165%files -n compat32-%{name}-devel
166%defattr(-,root,root)
167%{_libdir}/libpng*.a
168%{_libdir}/libpng*.so
169%{_libdir}/pkgconfig/*
170%endif
171
172%changelog
173* Mon Jun 23 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.51-2vl6
174- drop Ob: libpng12 from main and devel packages
175- fix compat32-devel dependensy (zlib-devel -> compat32-zlib-devel)
176
177* Sun May 18 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.51-1vl6
178- new upstream release 1.2.51
179- drop old patches (are inculuded in new release)
180- add Patch130 for fix CVE-2013-7353
181- add Patch140 for fix CVE-2013-7354
182- add Patch141 to fix build err
183
184* Sat Apr 28 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.46-3vl6
185- add patch110 for fix CVE-2011-3045
186- add patch120 for fix CVE-2011-3048 (png_set_text2())
187
188* Sat Feb 18 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.46-2
189- add patch100 for fix CVE-2011-3026
190
191* Wed Jul 13 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.46-1
192- new upstream release with security fix (VU#819894)
193- add Vendor/Distri tags
194
195* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2:1.2.44-3
196- build with rpm-4.8.1-1 for pkg-config file
197
198* Sun Jul 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.44-2
199- sync with Vine Linux 5 updates release
200  * Tue Jun 29 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.44-1
201  - new upstream release with security fix (CVE-2010-1205)
202
203* Thu Apr 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.43-2
204- sync with Vine Linux 5 updates release
205  * Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.43-1
206  - new upstream release with security fix (CVE-2010-0205)
207
208* Wed Jan 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.42-1
209- new upstream release with security fix
210
211* Tue Jun  9 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.37-1
212- new upstream release with security fix
213
214* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2:1.2.35-2
215- split static library to libpng-static
216  - needed by tuxonice-userui
217
218* Wed Feb 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.35-1
219- new upstream release with security fix (CVE-2009-0040)
220
221* Mon Nov 03 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.33-1
222- new upstream release
223
224* Thu Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.32-2
225- spec file in UTF-8
226
227* Thu Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.32-1
228- new upstream release with security fix (CVE-2008-3964)
229
230* Sat May 03 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.28-1
231- new upstream release with security fix (CVE-2008-1382)
232- added running autogen.sh before configure
233- new versioning policy
234
235* Sun Feb 24 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.25-0vl1
236- new upstream release
237
238* Thu Jan 24 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2:1.2.24-0vl2
239- removed %%if !%%{build_compat32} case condition
240
241* Mon Jan 21 2008 Kazutaka HARADA <Kazutaka@dc4.so-net.ne.jp> 2:1.2.24-0vl1
242- new upstream release
243
244* Wed Oct 10 2007 Shu KONNO <owa@bg.wakwak.com> 2:1.2.21-0vl1
245- new upstream release
246
247* Fri May 18 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2:1.2.18-0vl1
248- new upstream release (CVE-2007-2445)
249
250* Sun Dec 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2:1.2.14-0vl1
251- new upstream release
252- drop obsolete patch100
253
254* Fri Nov 24 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.12-0vl1.1
255- add Patch100 for fix CVE-2006-5793.patch
256
257* Sat Jul 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.12-0vl1
258- [SECURITY] new upstream release
259  - potential buffer overrun in chunk error processing (CVE-2006-3334)
260- use %%configure, %%makeinstall
261- drop unneeded patch10
262
263* Sun Jun 18 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl7
264- rebuilt with glibc-2.3.3-3vl14
265
266* Tue Feb 28 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.8-0vl6
267- fixed libdir path in libpng.pc
268
269* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.8-0vl5
270- fixed %postun (missing to build as scriptlet by invalid comment)
271
272* Thu Feb 09 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.8-0vl4
273- added compat32-* packages for x86_64 architecture support
274- added CC='gcc -m32' to make when build_compat32
275- added LIBPATH=%{_libdir} to make
276
277* Thu Feb 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.8-0vl3
278- rebuild
279
280* Wed Dec 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.8-0vl2
281- rebuild for VineSeed
282
283* Wed Dec 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.8-0vl1
284- new upstream release (bug fix)
285
286* Mon Sep 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
287- new upstream release
288
289* Tue Aug 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl0.rc3
290- update to 1.2.6rc3
291- add Requires: zlib-devel to libpng-devel.
292
293* Tue Aug 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl0.rc2
294- update to 1.2.6rc2
295
296* Sun Aug 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl0.rc1
297- update to 1.2.6rc1
298- add patch10 to correct directory name in libpng.pc
299- clean spec file
300
301* Tue Jul  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl4
302- added Patch4 from Redhat WS updates
303  * Mon Jun 14 2004 Matthias Clasen <mclasen@redhat.com> 1.2.2-23
304  - Reinstate and improve the transfix patch which got lost sometime ago,
305    but is still needed for CAN-2002-1363 (#125934)
306
307* Sun Dec 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.5-0vl3
308- rebuild with new toolchain
309- use License tag
310- change URL
311
312* Tue Apr 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.5-0vl2
313- added Obsoletes: libpng12-devel for libpng-devel
314
315* Mon Apr 14 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.5-0vl1
316- change package name from libpng12 to libpng
317- revised install and files section
318- remove all patches
319- define LIBVER 3.%{version}
320- add Obsoletes: libpng12
321
322* Sat Mar  1 2003 Kazuhisa TAKEI <takei@vinelinux.org> 1.2.25-0vl5
323- new upstream version
324- change package name to libpng12
325- conflicts libpng-devel(1.0.5) and libpng12-devel
326
327* Sat Dec 14 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.15-0vl3
328- added Patch200 for linking libz shared lib
329- include libpng*-config
330
331* Sat Dec 14 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.15-0vl2
332- added missing libraries in the file list
333
334* Thu Nov 12 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.15-0vl1
335- update to 1.0.15
336- now, security patch were merged source.
337
338* Wed Aug 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.12-0vl3
339- added another security patch to preserve libpng from processing too wide
340  image files (a patch itself extracted from DSA 140-2)
341
342* Fri Aug 02 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.12-0vl2
343- added a patch to fix buffer overflow (Patch100)
344
345* Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
346- 1.0.12-0vl1
347- updated 1.0.12
348
349* Tue Jan 09 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
350- 1.0.7-0vl3
351- use better macros
352- added Japanese summary and description
353
354* Tue Jul 18 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
355- 1.0.7-0vl2
356- oops, spec was in Shift-JIS... Fixed it.
357
358* Mon Jul  3 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
359- update to 1.0.7
360
361* Tue Mar 21 2000 Nalin Dahyabhai <nalin@redhat.com>
362- update to 1.0.6
363
364* Mon Mar 13 2000 Nalin Dahyabhai <nalin@redhat.com>
365- change serial to Epoch to get dependencies working correctly
366
367* Fri Feb 11 2000 Nalin Dahyabhai <nalin@redhat.com>
368- move buildroot and add URL
369
370* Sat Feb  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
371- strip library
372- rebuild to compress man pages
373
374* Sun Nov 21 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
375- 1.0.5
376- some tweaks to spec file to make updating easier
377- handle RPM_OPT_FLAGS
378
379* Mon Sep 20 1999 Matt Wilson <msw@redhat.com>
380- changed requires in libpng-devel to include serial
381- corrected typo
382
383* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
384- auto rebuild in the new build environment (release 2)
385
386* Sun Feb 07 1999 Michael Johnson <johnsonm@redhat.com>
387- rev to 1.0.3
388
389* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
390- build for 6.0
391
392* Wed Sep 23 1998 Cristian Gafton <gafton@redhat.com>
393- we are Serial: 1 now because we are reverting the 1.0.2 version from 5.2
394  beta to this prior one
395- install man pages; set defattr defaults
396
397* Thu May 07 1998 Prospector System <bugs@redhat.com>
398- translations modified for de, fr, tr
399
400* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
401- devel subpackage moved to Development/Libraries
402
403* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
404- upgraded to 1.0.1
405- added buildroot
406
407* Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
408- updated to new version
409- spec file cleanups
410
411* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
412- built against glibc
413
Note: See TracBrowser for help on using the repository browser.