source: projects/specs/branches/6/lib/libp/libpng/libpng-vl.spec @ 6050

Revision 6050, 12.9 KB checked in by iwamoto, 12 years ago (diff)

libpng: security fixes (CVE-2011-3045,CVE-2011-3048)

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of functions for manipulating PNG image format files.
4Summary(ja): PNG画像形式ファイル操作用の関数ライブラリ
5Name: libpng
6Version: 1.2.46
7Release: 3%{_dist_release}
8License: distributable
9Group: System Environment/Libraries
10Source: ftp://ftp.simplesystems.org/pub/libpng/png/src/%{name}-%{version}.tar.bz2
11Patch100: libpng-1.2.xx_CVE-2011-3026.patch
12Patch110: libpng-1.2.xx_CVE-2011-3045.patch
13Patch120: libpng-1.2.xx_CVE-2011-3048.patch
14
15Buildroot: %{_tmppath}/%{name}-%{version}-root
16BuildPrereq: zlib-devel
17Requires: zlib
18URL: http://www.libpng.org/pub/png/
19%define LIBVER 3.%{version}
20Epoch: 2
21Obsoletes: libpng12
22
23Vendor: Project Vine
24Distribution: Vine Linux
25
26%description
27The libpng package contains a library of functions for creating and
28manipulating PNG (Portable Network Graphics) image format files.  PNG
29is a bit-mapped graphics format similar to the GIF format.  PNG was
30created to replace the GIF format, since GIF uses a patented data
31compression algorithm.
32
33Libpng should be installed if you need to manipulate PNG format image
34files.
35
36%description -l ja
37libpng パッケージには PNG (Portable Network Graphics) 形式の
38画像ファイルを作成/操作する為のライブラリが収められています.
39PNG はビットマップの画像形式で,GIF によく似ています.
40GIF が 特許保護された LZW データ圧縮アルゴリズムを利用している為,
41PNG は GIF の代替画像形式として生まれました.
42
43PNG 形式の画像ファイルを扱う場合は libpng をインストールして下さい.
44
45%package devel
46Summary: Development tools for programs to manipulate PNG image format files.
47Summary(ja): PNG 形式画像ファイルを扱うプログラム向け開発ツール
48Group: Development/Libraries
49Requires: libpng = %{epoch}:%{version}-%{release}
50Requires: zlib-devel
51Obsoletes: libpng12-devel
52
53%description devel
54The libpng-devel package contains the header files necessary for
55developing programs using the PNG (Portable Network Graphics) library.
56
57%description devel -l ja
58libpng-devel パッケージには,PNG (Portable Network Graphics) ライブラリを
59使ったプログラムを開発するのに必要なヘッダファイルが収められています.
60
61%package static
62Summary: Static library for %{name}
63Summary(ja): %{name} のスタティックライブラリ
64Group: Development/Libraries
65Requires: libpng-devel = %{epoch}:%{version}-%{release}
66
67%description static
68The libpng-static package contains the static library for libpng.
69
70
71## to build compat32 for x86_64 architecture support
72%package -n compat32-%{name}
73Summary: A library of functions for manipulating PNG image format files.
74Summary(ja): PNG画像形式ファイル操作用の関数ライブラリ
75Group: System Environment/Libraries
76
77%description -n compat32-%{name}
78The libpng package contains a library of functions for creating and
79manipulating PNG (Portable Network Graphics) image format files.  PNG
80is a bit-mapped graphics format similar to the GIF format.  PNG was
81created to replace the GIF format, since GIF uses a patented data
82compression algorithm.
83
84Libpng should be installed if you need to manipulate PNG format image
85files.
86
87%package -n compat32-%{name}-devel
88Summary: Development tools for programs to manipulate PNG image format files.
89Summary(ja): PNG 形式画像ファイルを扱うプログラム向け開発ツール
90Group: Development/Libraries
91Requires: libpng = %{epoch}:%{version}-%{release}, libpng-devel = %{epoch}:%{version}-%{release}
92Requires: zlib-devel
93
94%description -n compat32-%{name}-devel
95The libpng-devel package contains the header files and static
96libraries necessary for developing programs using the PNG (Portable
97Network Graphics) library.
98
99If you want to develop programs which will manipulate PNG image format
100files, you should install libpng-devel.  You'll also need to install
101the libpng package.
102
103#'
104%prep
105%setup -q
106%patch100 -p1 -b .CVE-2011-3026
107%patch110 -p1 -b .CVE-2011-3045
108%patch120 -p1 -b .CVE-2011-3048
109
110%build
111#./autogen.sh
112%configure
113%__make %{?_smp_mflags}
114
115%install
116[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
117%makeinstall
118
119# remove unneeded files
120%__rm -f %{buildroot}%{_libdir}/libpng*.la
121
122%post -p /sbin/ldconfig
123
124%postun -p /sbin/ldconfig
125
126%post -n compat32-%{name} -p /sbin/ldconfig
127
128%postun -n compat32-%{name} -p /sbin/ldconfig
129
130%clean
131[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
132
133%files
134%defattr(-,root,root)
135%doc *.txt example.c README TODO CHANGES
136%{_libdir}/libpng*.so.*
137%{_mandir}/man5/*
138
139%files devel
140%defattr(-,root,root)
141%{_bindir}/libpng-config
142%{_bindir}/libpng12-config
143%{_includedir}/*
144%{_libdir}/libpng*.so
145%{_libdir}/pkgconfig/*
146%{_mandir}/man3/*
147
148%files static
149%defattr(-,root,root)
150%{_libdir}/libpng*.a
151
152## to build compat32 for x86_64 architecture support
153%if %{build_compat32}
154%files -n compat32-%{name}
155%defattr(-,root,root)
156%{_libdir}/libpng*.so.*
157
158%files -n compat32-%{name}-devel
159%defattr(-,root,root)
160%{_libdir}/libpng*.a
161%{_libdir}/libpng*.so
162%{_libdir}/pkgconfig/*
163%endif
164
165%changelog
166* Sat Apr 28 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.46-3vl6
167- add patch110 for fix CVE-2011-3045
168- add patch120 for fix CVE-2011-3048 (png_set_text2())
169
170* Sat Feb 18 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.46-2
171- add patch100 for fix CVE-2011-3026
172
173* Wed Jul 13 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.46-1
174- new upstream release with security fix (VU#819894)
175- add Vendor/Distri tags
176
177* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2:1.2.44-3
178- build with rpm-4.8.1-1 for pkg-config file
179
180* Sun Jul 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.44-2
181- sync with Vine Linux 5 updates release
182  * Tue Jun 29 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.44-1
183  - new upstream release with security fix (CVE-2010-1205)
184
185* Thu Apr 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.43-2
186- sync with Vine Linux 5 updates release
187  * Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.43-1
188  - new upstream release with security fix (CVE-2010-0205)
189
190* Wed Jan 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.42-1
191- new upstream release with security fix
192
193* Tue Jun  9 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.37-1
194- new upstream release with security fix
195
196* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2:1.2.35-2
197- split static library to libpng-static
198  - needed by tuxonice-userui
199
200* Wed Feb 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.35-1
201- new upstream release with security fix (CVE-2009-0040)
202
203* Mon Nov 03 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.33-1
204- new upstream release
205
206* Thu Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.32-2
207- spec file in UTF-8
208
209* Thu Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.32-1
210- new upstream release with security fix (CVE-2008-3964)
211
212* Sat May 03 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2:1.2.28-1
213- new upstream release with security fix (CVE-2008-1382)
214- added running autogen.sh before configure
215- new versioning policy
216
217* Sun Feb 24 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2:1.2.25-0vl1
218- new upstream release
219
220* Thu Jan 24 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2:1.2.24-0vl2
221- removed %%if !%%{build_compat32} case condition
222
223* Mon Jan 21 2008 Kazutaka HARADA <Kazutaka@dc4.so-net.ne.jp> 2:1.2.24-0vl1
224- new upstream release
225
226* Wed Oct 10 2007 Shu KONNO <owa@bg.wakwak.com> 2:1.2.21-0vl1
227- new upstream release
228
229* Fri May 18 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2:1.2.18-0vl1
230- new upstream release (CVE-2007-2445)
231
232* Sun Dec 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2:1.2.14-0vl1
233- new upstream release
234- drop obsolete patch100
235
236* Fri Nov 24 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.12-0vl1.1
237- add Patch100 for fix CVE-2006-5793.patch
238
239* Sat Jul 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.12-0vl1
240- [SECURITY] new upstream release
241  - potential buffer overrun in chunk error processing (CVE-2006-3334)
242- use %%configure, %%makeinstall
243- drop unneeded patch10
244
245* Sun Jun 18 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl7
246- rebuilt with glibc-2.3.3-3vl14
247
248* Tue Feb 28 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.8-0vl6
249- fixed libdir path in libpng.pc
250
251* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.8-0vl5
252- fixed %postun (missing to build as scriptlet by invalid comment)
253
254* Thu Feb 09 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.8-0vl4
255- added compat32-* packages for x86_64 architecture support
256- added CC='gcc -m32' to make when build_compat32
257- added LIBPATH=%{_libdir} to make
258
259* Thu Feb 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.8-0vl3
260- rebuild
261
262* Wed Dec 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.8-0vl2
263- rebuild for VineSeed
264
265* Wed Dec 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.8-0vl1
266- new upstream release (bug fix)
267
268* Mon Sep 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
269- new upstream release
270
271* Tue Aug 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl0.rc3
272- update to 1.2.6rc3
273- add Requires: zlib-devel to libpng-devel.
274
275* Tue Aug 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl0.rc2
276- update to 1.2.6rc2
277
278* Sun Aug 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl0.rc1
279- update to 1.2.6rc1
280- add patch10 to correct directory name in libpng.pc
281- clean spec file
282
283* Tue Jul  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl4
284- added Patch4 from Redhat WS updates
285  * Mon Jun 14 2004 Matthias Clasen <mclasen@redhat.com> 1.2.2-23
286  - Reinstate and improve the transfix patch which got lost sometime ago,
287    but is still needed for CAN-2002-1363 (#125934)
288
289* Sun Dec 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.5-0vl3
290- rebuild with new toolchain
291- use License tag
292- change URL
293
294* Tue Apr 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.5-0vl2
295- added Obsoletes: libpng12-devel for libpng-devel
296
297* Mon Apr 14 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.5-0vl1
298- change package name from libpng12 to libpng
299- revised install and files section
300- remove all patches
301- define LIBVER 3.%{version}
302- add Obsoletes: libpng12
303
304* Sat Mar  1 2003 Kazuhisa TAKEI <takei@vinelinux.org> 1.2.25-0vl5
305- new upstream version
306- change package name to libpng12
307- conflicts libpng-devel(1.0.5) and libpng12-devel
308
309* Sat Dec 14 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.15-0vl3
310- added Patch200 for linking libz shared lib
311- include libpng*-config
312
313* Sat Dec 14 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.15-0vl2
314- added missing libraries in the file list
315
316* Thu Nov 12 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.15-0vl1
317- update to 1.0.15
318- now, security patch were merged source.
319
320* Wed Aug 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.12-0vl3
321- added another security patch to preserve libpng from processing too wide
322  image files (a patch itself extracted from DSA 140-2)
323
324* Fri Aug 02 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.12-0vl2
325- added a patch to fix buffer overflow (Patch100)
326
327* Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
328- 1.0.12-0vl1
329- updated 1.0.12
330
331* Tue Jan 09 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
332- 1.0.7-0vl3
333- use better macros
334- added Japanese summary and description
335
336* Tue Jul 18 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
337- 1.0.7-0vl2
338- oops, spec was in Shift-JIS... Fixed it.
339
340* Mon Jul  3 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
341- update to 1.0.7
342
343* Tue Mar 21 2000 Nalin Dahyabhai <nalin@redhat.com>
344- update to 1.0.6
345
346* Mon Mar 13 2000 Nalin Dahyabhai <nalin@redhat.com>
347- change serial to Epoch to get dependencies working correctly
348
349* Fri Feb 11 2000 Nalin Dahyabhai <nalin@redhat.com>
350- move buildroot and add URL
351
352* Sat Feb  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
353- strip library
354- rebuild to compress man pages
355
356* Sun Nov 21 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
357- 1.0.5
358- some tweaks to spec file to make updating easier
359- handle RPM_OPT_FLAGS
360
361* Mon Sep 20 1999 Matt Wilson <msw@redhat.com>
362- changed requires in libpng-devel to include serial
363- corrected typo
364
365* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
366- auto rebuild in the new build environment (release 2)
367
368* Sun Feb 07 1999 Michael Johnson <johnsonm@redhat.com>
369- rev to 1.0.3
370
371* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
372- build for 6.0
373
374* Wed Sep 23 1998 Cristian Gafton <gafton@redhat.com>
375- we are Serial: 1 now because we are reverting the 1.0.2 version from 5.2
376  beta to this prior one
377- install man pages; set defattr defaults
378
379* Thu May 07 1998 Prospector System <bugs@redhat.com>
380- translations modified for de, fr, tr
381
382* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
383- devel subpackage moved to Development/Libraries
384
385* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
386- upgraded to 1.0.1
387- added buildroot
388
389* Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
390- updated to new version
391- spec file cleanups
392
393* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
394- built against glibc
395
Note: See TracBrowser for help on using the repository browser.