source: projects/specs/branches/6/lib/libp/libpcap/libpcap-vl.spec @ 1826

Revision 1826, 15.1 KB checked in by inagaki, 14 years ago (diff)

update: libpcap, tcpdump

Line 
1%define pcap_major 1
2%define pcap_minor 1
3%define pcap_subminor 1
4%define libpcap_ver %{pcap_major}.%{pcap_minor}.%{pcap_subminor}
5
6Name: libpcap
7Summary: A system-independent interface for user-level packet capture.
8Summary(ja): ユーザレベルでパケットをキャプチャするインターフェイス
9Version: %{libpcap_ver}
10Release: 2%{?_dist_release}
11Epoch: 1
12
13Group: System Environment/Libraries
14# XXX epoch is necessary to obsolete tcpdump-3.4a5
15License: BSD
16URL: http://www.tcpdump.org/
17
18Source0: http://www.tcpdump.org/release/libpcap-%{libpcap_ver}.tar.gz
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: kernel-headers >= 2.2.0
22BuildRequires: flex >= 2.4
23BuildRequires: bison
24BuildRequires: openssl-devel
25BuildRequires: libnl-devel
26Requires: kernel >= 2.2.0
27
28Vendor: Project Vine
29Distribution: Vine Linux
30
31%description
32Libpcap provides a portable framework for low-level network
33monitoring. Libpcap can provide network statistics collection,
34security monitoring and network debugging. Since almost every system
35vendor provides a different interface for packet capture, the libpcap
36authors created this system-independent API to ease in porting and to
37alleviate the need for several system-dependent packet capture modules
38in each application.
39
40Install libpcap if you need to do low-level network traffic monitoring
41on your network.
42
43%description -l ja
44Libpcap は低レベルでネットワークをモニタするためのポータブルなフレーム
45ワークを提供します.Libpcap はネットワークの統計を収集したり,セキュリ
46ティの為のモニタリングやネットワークのデバッグなどの用途に使用できます.
47ほぼ全てのシステムベンダがパケットのキャプチャに異なるインターフェイス
48を提供していたので,libpcap の作者は 移植性を良くして 各々のアプリケー
49ションにおける数々のシステムに依存したパケットキャプチャモジュールを
50可能にするために,このシステムに依存しない API を作成しました.
51
52ネットワークの低レベルのトラフィックを監視する必要がある場合,libpcap
53をインストールして下さい.
54
55%package devel
56Summary:  Development package for %{name}
57Summary(ja): %{name} の開発用ファイル
58Group:    Development/Libraries
59Requires: %{name} = %{epoch}:%{version}-%{release}
60
61%description devel
62The %{name}-devel package contains the files needed for development
63with %{name}.
64
65%description devel -l ja
66%{name}-devel パッケージには,%{name} を使った開発に必要なファイルが
67含まれています.
68
69%prep
70%setup -q
71
72%build
73%configure
74DEFS="-g -D_U_=\"\" -fPIC -DHAVE_CONFIG_H"
75%ifarch alpha sparc sparc64
76DEFS="$DEFS -DHAVE_ETHER_HOSTTON=1 -DLBL_ALIGN=1"
77%endif
78make DEFS="$DEFS"
79
80%install
81rm -rf $RPM_BUILD_ROOT
82mkdir -p $RPM_BUILD_ROOT%{_libdir}
83mkdir -p $RPM_BUILD_ROOT%{_bindir}
84
85make DESTDIR=$RPM_BUILD_ROOT install
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%post -p /sbin/ldconfig
91 
92%postun -p /sbin/ldconfig
93
94%files
95%defattr(-,root,root)
96%doc README CHANGES
97%{_libdir}/libpcap.so.*
98
99%files devel
100%defattr(-,root,root)
101%{_bindir}/pcap-config
102%{_includedir}/pcap*.h
103%dir %{_includedir}/pcap
104%{_includedir}/pcap/*
105%{_libdir}/libpcap.so
106%{_libdir}/libpcap.a
107%{_mandir}/man1/*
108%{_mandir}/man3/*
109%{_mandir}/man5/*
110%{_mandir}/man7/*
111
112%changelog
113* Sat Sep 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:1.1.1-2
114- fixed header file location <BTS:994>
115- added URL tag
116
117* Sun May 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:1.1.1-1
118- new upstream release
119- dropt Patch50
120- built with new toolchain
121- added BR: libnl-devel
122
123* Fri Apr 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:1.0.0-2vl5
124- split devel package
125
126* Wed Oct 29 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1:1.0.0-1vl5
127- new upstream release
128- update Patch50 to fit 1.0.0
129
130* Mon Apr 14 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1:0.9.8-2vl5
131- add BuildRequires: flex >= 2.4, bison
132
133* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.9.8-1vl5
134- new upstream release
135
136* Sat Sep  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.9.7-0vl1
137- new upstream release
138
139* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.9.6-0vl1
140- new upstream release
141
142* Sun Aug 21 2005 Satoshi MACHINO <machino@vinelinux.org> 1:0.9.3-0vl1
143- new upstream release
144
145* Sun Jun 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.8.3-0vl1
146- new upstream release
147
148* Sat Oct 11 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:0.7.2-0vl1
149- updated to 0.7.2
150- dropped patch52
151- s/Copyright/License/
152
153* Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:0.7.1-0vl1
154- libpcap standalone package splitted from tcpdump
155
156* Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.7.1-0vl1
157- update to new upstream release tcpdump 3.7.1
158- drop unneeded patches
159- use autoconf213, automake14
160- split arpwatch
161
162* Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.6.2-13vl2
163- add patch16 to fix  print_bgp security bug
164  - errata 20030221-3
165
166* Wed Jun 12 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.6.2-13vl1
167- merged with 3.6.2-13
168- fix buffer overflow for errata
169  * Thu May 16 2002 Harald Hoyer <harald@redhat.de> 12:3.6.2-13
170  - added official 3.6.3 fix
171  - fixed 6.2 compat #63113
172  * Wed Jan 23 2002 Harald Hoyer <harald@redhat.de> 12:3.6.2-12
173  - tcpdump-3.6.2-snaplen.patch added to fix #55145
174  * Tue Dec 18 2001 Harald Hoyer <harald@redhat.de> 12:3.6.2-10
175  - took old purge patch for filters
176  - fixed #54225,#58346
177  - drop root by default #49635
178  - fixed #54593
179  - fixed #57711
180
181* Thu Oct 25 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp>
182- 3.6.2-9vl1
183- used PRM macros
184- changed File Name to Package Name in Prereq tag
185- marged 3.6.2-9 (RedHat7.2)
186
187  * Tue Jan 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
188  - 3.4-19vl2
189  - use better macros
190 
191  * Thu Sep 21 2000 Yoshihiro Kajiki <kajiki@ylug.org>
192  - add libpcap-0.4-guy-gerald.patch to fix the timeout problem (by Ethereal)
193  - add Japanese summarys and descriptions
194  - modify spec file to build as a normal user
195 
196  * Thu Feb 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
197  - Compile shared libpcap with -fPIC (Bug #6342)
198 
199  * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
200  - fix descriptions
201  - man pages are compressed
202 
203  * Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
204  - remove sparc64 SIOCGIFNAME hack, not needed with (at least) kernel 2.2.12-40.
205  - upgrade to ANK ss991030 snapshot with pcap magic fix (#6773).
206  - add getprotobyname lookup (#6725).
207  - getservbyname port lookup appears functional (#7569).
208  - remove uid 2090 backdoor (sorry Dave) (#7116).
209 
210  * Thu Sep 09 1999 Cristian Gafton <gafton@redhat.com>
211  - fox the pcap.h header
212 
213  * Fri Aug 20 1999 Jeff Johnson <jbj@redhat.com>
214  - prevent segfault on obscure spoofed ip header (#4634).
215 
216  * Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
217  - add defattr to arpwatch (#4591).
218 
219  * Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
220  - initscript munging
221
222  * Sun Aug  8 1999 Jeff Johnson <jbj@redhat.com>
223  - add -DWORDS_BIGINDIAN to tcpdump compile on sparc sparc61.
224 
225  * Tue Aug  3 1999 Jeff Johnson <jbj@redhat.com>
226  - include A. Kuznetsov's patches to libpcap/tcpdump.
227  - added arpsnmp to package (#3258).
228  - arp2ethers written for different of awk (#4326).
229
230  * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
231  - auto rebuild in the new build environment (release 10)
232
233  * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
234  - strip binaries.
235 
236  * Wed Jan 13 1999 Bill Nottingham <notting@redhat.com>
237  - autoconf fixes for arm
238
239  * Tue Sep 29 1998 Jeff Johnson <jbj@redhat.com>
240  - libpcap description typo.
241
242  * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
243  - fix arpwatch summary line.
244 
245  * Mon Aug 17 1998 Jeff Johnson <jbj@redhat.com>
246  - enable arpwatch
247 
248  * Mon Aug  3 1998 Jeff Johnson <jbj@redhat.com>
249  - separate package for libpcap.
250  - update tcpdump to 3.4, libpcap to 0.4.
251  - added arpwatch (but disabled for now)
252 
253  * Thu May 07 1998 Prospector System <bugs@redhat.com>
254  - translations modified for de, fr, tr
255 
256  * Sat May  2 1998 Alan Cox <alan@rehat.com>
257  - Added the SACK printing fix so you can dump Linux 2.1+.
258 
259  * Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
260  - updated to release 3.4a5
261  - uses a buildroot and %attr
262 
263  * Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
264  - built against glibc
265
266* Fri Aug 31 2001 Harald Hoyer <harald@redhat.de> 12:3.6.2-9
267- took better fix for #52654 from tcpdump cvs
268
269* Thu Aug 30 2001 Harald Hoyer <harald@redhat.de> 11:3.6.2-8
270- fixed #52654
271
272* Thu Jul 19 2001 Harald Hoyer <harald@redhat.de> 10:3.6.2-7
273- added shared library to libpcap (#47174)
274- afs printing security patch (#49294)
275
276* Wed Jun 20 2001 Harald Hoyer <harald@redhat.de>
277- use initgroups, instead of setgroups
278
279* Mon Jun 18 2001 Harald Hoyer <harald@redhat.de>
280- added dropgroup patches (#44563)
281
282* Mon May 07 2001 Harald Hoyer <harald@redhat.de>
283- switched to Pekka's tcpdump-3.6.2 package
284- incremented epoch
285
286* Sat Apr 14 2001 Pekka Savola <pekkas@netcore.fi>
287- fix building of tcpslice on glibc 2.2.2 (time.h)
288- disable /etc/init.d requirement and fix %post scripts in arpwatch
289
290* Wed Feb 14 2001 Harald Hoyer <harald@redhat.de>
291- glibc sys/time -> time include patch
292
293* Wed Feb  7 2001 Trond Eivind Glomsr <teg@redhat.com>
294- Add space to this check
295
296* Wed Feb 07 2001 Harald Hoyer <harald@redhat.com>
297- added check for presence of /etc/sysconfig/arpwatch (#23172)
298
299* Wed Feb  7 2001 Pekka Savola <pekkas@netcore.fi>
300- update to 3.6.2, 0.6.2 and new CVS of tcpslice.
301- i18n'ize arpwatch init script
302
303* Fri Feb  2 2001 Trond Eivind Glomsr <teg@redhat.com>
304- i18nize initscript
305
306* Mon Jan 29 2001 Harald Hoyer <harald@redhat.com>
307- fixed EINTR stopping for e.g. SIGSTOP. (#22008)
308- added -u option for tcpdump (#20231)
309- new arpwatch version (#23172)
310- added "all" and "one" interface for -i (#20907)
311- added arpwatch sysconfig (#23172)
312
313* Mon Jan 22 2001 Harald Hoyer <harald@redhat.com>
314- more (potential) overflows in libpcap. #21373
315- documentation fix for #20906
316
317* Sun Jan 14 2001 Pekka Savola <pekkas@netcore.fi>
318- use --enable-ipv6
319- Add two patches from CVS to enhance 802.2 printing, and more importantly,
320  to be able to specify 'no stp'
321
322* Sat Jan 13 2001 Pekka Savola <pekkas@netcore.fi>
323- Make SMB printing output a lot more quiet unless in verbose mode.
324- Make -n resolve port/protocol numbers but not hostnames, -nn for no
325  resolving at all
326- Separate droproot patch from a more generic man/usage fix one
327- Add non-promiscuous mode -by default patch, but don't apply it by default
328
329* Thu Jan 11 2001 Pekka Savola <pekkas@netcore.fi>
330- Update to tcpdump 3.6.1 and libpcap 0.6.1 releases.
331
332* Mon Jan  8 2001 Pekka Savola <pekkas@netcore.fi>
333- Update to 20010108 CVS, disable some upstreamed patches.
334- Change some additional .1 pages to .8.
335- Add droproot patch, some --usage and man page fixes.
336
337* Mon Jan  1 2001 Pekka Savola <pekkas@netcore.fi>
338- Initial packaging with latest tcpdump.org CVS tcpdump-3.6 and libpcap-0.6.
339- add earlier print-domain.c, the latest is segfaulting
340- don't unnecesessarily include snprintf.o, it didn't compile with gcc 2.96 anyway
341- don't use savestr, require openssl, tweak tweak tweak
342- add tcpslice, patch it a bit for egcs detection
343
344* Sun Dec 31 2000 Pekka Savola <pekkas@netcore.fi>
345- tcpdump: spice up the manpage about interfaces
346- tcpdump: add 'all' and 'any' keywords to -i, saner default behaviour.
347- upgrade arpwatch to 2.1a10
348
349* Sun Nov 26 2000 Jeff Johnson <jbj@redhat.com>
350- more (potential) overflows in libpcap.
351
352* Sun Nov 12 2000 Jeff Johnson <jbj@redhat.com>
353- eliminate still more buffer overflows (from FreeBSD) (#20069).
354
355* Thu Nov  2 2000 Jeff Johnson <jbj@redhat.com>
356- eliminate more buffer overflows (from FreeBSD) (#20069).
357- 802.1q ether type incorrect (#19850).
358- add -u flag to drop arpwatch privs (#19696).
359
360* Sun Oct 15 2000 Jeff Johnson <jbj@redhat.com>
361- updated ethercodes.dat
362
363* Thu Oct 12 2000 Jeff Johnson <jbj@redhat.com>
364- fix arpwatch tmp race (#18943).
365
366* Fri Aug 11 2000 Bill Nottingham <notting@redhat.com>
367- fix condrestart
368
369* Fri Aug 11 2000 Jeff Johnson <jbj@redhat.com>
370- correct arpsnmp man pages (#15442).
371- don't print harmless ENOPROTOOPT message (#13518).
372
373* Fri Aug  4 2000 Jeff Johnson <jbj@redhat.com>
374- rebuild with final kernel headers (#13518).
375
376* Sat Jul 22 2000 Jeff Johnson <jbj@redhat.com>
377- add STP patch (#14112).
378
379* Fri Jul 14 2000 Matt Wilson <msw@redhat.com>
380- source /etc/init.d/functions
381- back out /etc/init.d/arpwatch, place file in /etc/rc.d
382- move initscript to /etc/init.d
383- changed initscript to use start() and stop() functions
384- added condrestart to init script
385- added %%post %%preun %%postun scripts to register arpwatch script
386- added Prereq: for all things needed in post/preun/postun
387
388* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
389- automatic rebuild
390
391* Tue Jul 11 2000 Jeff Johnson <jbj@redhat.com>
392- updated man page and help (pekkas@netcore.fi) (#10739 et al).
393
394* Sun Jun 18 2000 Jeff Johnson <jbj@redhat/com>
395- FHS packaging.
396
397* Tue May  9 2000 Bill Nottingham <notting@redhat.com>
398- minor tweaks for ia64 (prototypes)
399
400* Thu Feb 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
401- Compile shared libpcap with -fPIC (Bug #6342)
402
403* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
404- fix descriptions
405- man pages are compressed
406
407* Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
408- remove sparc64 SIOCGIFNAME hack, not needed with (at least) kernel 2.2.12-40.
409- upgrade to ANK ss991030 snapshot with pcap magic fix (#6773).
410- add getprotobyname lookup (#6725).
411- getservbyname port lookup appears functional (#7569).
412- remove uid 2090 backdoor (sorry Dave) (#7116).
413
414* Thu Sep 09 1999 Cristian Gafton <gafton@redhat.com>
415- fox the pcap.h header
416
417* Fri Aug 20 1999 Jeff Johnson <jbj@redhat.com>
418- prevent segfault on obscure spoofed ip header (#4634).
419
420* Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
421- add defattr to arpwatch (#4591).
422
423* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
424- initscript munging
425
426* Sun Aug  8 1999 Jeff Johnson <jbj@redhat.com>
427- add -DWORDS_BIGINDIAN to tcpdump compile on sparc sparc61.
428
429* Tue Aug  3 1999 Jeff Johnson <jbj@redhat.com>
430- include A. Kuznetsov's patches to libpcap/tcpdump.
431- added arpsnmp to package (#3258).
432- arp2ethers written for different of awk (#4326).
433
434* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
435- auto rebuild in the new build environment (release 10)
436
437* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
438- strip binaries.
439
440* Wed Jan 13 1999 Bill Nottingham <notting@redhat.com>
441- autoconf fixes for arm
442
443* Tue Sep 29 1998 Jeff Johnson <jbj@redhat.com>
444- libpcap description typo.
445
446* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
447- fix arpwatch summary line.
448
449* Mon Aug 17 1998 Jeff Johnson <jbj@redhat.com>
450- enable arpwatch
451
452* Mon Aug  3 1998 Jeff Johnson <jbj@redhat.com>
453- separate package for libpcap.
454- update tcpdump to 3.4, libpcap to 0.4.
455- added arpwatch (but disabled for now)
456
457* Thu May 07 1998 Prospector System <bugs@redhat.com>
458- translations modified for de, fr, tr
459
460* Sat May  2 1998 Alan Cox <alan@rehat.com>
461- Added the SACK printing fix so you can dump Linux 2.1+.
462
463* Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
464- updated to release 3.4a5
465- uses a buildroot and %attr
466
467* Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
468- built against glibc
Note: See TracBrowser for help on using the repository browser.