source: projects/specs/branches/6/lib/libo/libopenraw/libopenraw-vl.spec @ 4130

Revision 4130, 7.3 KB checked in by iwaim, 13 years ago (diff)

libopenraw-0.0.8-1

Line 
1Summary:        Decode camera RAW files
2Name:           libopenraw
3Version:        0.0.8
4Release:        1%{?_dist_release}
5License:        LGPLv3+
6Group:          System Environment/Libraries
7URL:            http://libopenraw.freedesktop.org/wiki
8Source0:        http://libopenraw.freedesktop.org/download/%{name}-%{version}.tar.gz
9# upstream patch 1b15acdcfdc4664bc6c0be473cb6e096071a4e62 adds support
10# for certain PEF files and fixes a crash when opening such files
11Patch0:         0001-Support-partially-PEF-from-Pentax-K20D.patch
12# upstream patch 22287584fbfa4657098ee997957a6c4fc972a53b to
13# properly decompress CFA from certain cameras (patch slightly modified
14# to omit patching README)
15Patch1:         0001-Properly-decompress-CFA-from-Canon-7D-5DMkII-500D-1D.patch
16# https://bugs.freedesktop.org/show_bug.cgi?id=31088
17Patch2:         libopenraw-0.0.8-pixbufloaderdir.patch
18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
20
21BuildRequires:  libtool autoconf automake
22BuildRequires:  libboost-devel
23BuildRequires:  libboost-test
24BuildRequires:  exempi-devel >= 1.99.5
25BuildRequires:  gtk2-devel
26BuildRequires:  curl-devel
27BuildRequires:  libjpeg-devel
28BuildRequires:  libxml2-devel
29
30Vendor: Project Vine
31Distribution: Vine Linux
32
33%description
34libopenraw is an ongoing project to provide a free software
35implementation for camera RAW files decoding. One of the main reason is
36that dcraw is not suited for easy integration into applications, and
37there is a need for an easy to use API to build free software digital
38image processing application.
39
40%package gnome
41Summary:        GUI components of %{name}
42Group:          System Environment/Libraries
43
44Requires:       %{name} = %{version}-%{release}
45
46%description gnome
47The %{name}-gnome package contains gui components of %{name}.
48
49%package devel
50Summary:        Development files for %{name}
51Group:          Development/Libraries
52
53Requires:       %{name} = %{version}-%{release}
54Requires:       pkgconfig
55
56%description devel
57The %{name}-devel package contains libraries and header files for
58developing applications that use %{name}.
59
60%package gnome-devel
61Summary:        Development files for %{name}-gnome
62Group:          Development/Libraries
63
64Requires:       %{name}-gnome = %{version}-%{release}
65Requires:       %{name}-devel = %{version}-%{release}
66Requires:       pkgconfig
67
68%description    gnome-devel
69The %{name}-gnome-devel package contains libraries and header files for
70developing applications that use %{name}-gnome.
71
72%package pixbuf-loader
73Summary:        RAW image loader for GTK+ applications
74Group:          System Environment/Libraries
75
76Requires:       gtk2
77Requires:       %{name} = %{version}-%{release}
78Requires(post):   gdk-pixbuf2
79Requires(postun): gdk-pixbuf2
80
81%description pixbuf-loader
82%{name}-pixbuf-loader contains a plugin to load RAW images, as created by
83digital cameras, in GTK+ applications.
84
85%prep
86%setup -q
87%patch1 -p1 -b CFA-decrompress-fix
88%patch0 -p1 -b pef-crash-fix
89%patch2 -p1 -b pixbufloaderdir
90
91%build
92autoreconf -i -f
93%configure --disable-static --enable-gnome
94
95# Omit unused direct shared library dependencies.
96sed --in-place --expression 's! -shared ! -Wl,--as-needed\0!g' libtool
97
98make %{?_smp_mflags}
99
100%check
101make check
102
103%install
104rm -rf $RPM_BUILD_ROOT
105
106make install DESTDIR=$RPM_BUILD_ROOT
107find $RPM_BUILD_ROOT -type f -name "*.la" -delete
108
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112%post -p /sbin/ldconfig
113
114%postun -p /sbin/ldconfig
115
116%post gnome -p /sbin/ldconfig
117
118%postun gnome -p /sbin/ldconfig
119
120%post pixbuf-loader
121gdk-pixbuf-query-loaders-%{__isa_bits} --update-cache || :
122
123
124%postun pixbuf-loader
125gdk-pixbuf-query-loaders-%{__isa_bits} --update-cache || :
126
127%files
128%defattr(-,root,root,-)
129%doc AUTHORS
130%doc ChangeLog
131%doc COPYING
132%doc NEWS
133%doc README
134%doc TODO
135%{_libdir}/%{name}.so.*
136
137%files gnome
138%defattr(-,root,root,-)
139%{_libdir}/%{name}gnome.so.*
140
141%files devel
142%defattr(-,root,root,-)
143%{_libdir}/%{name}.so
144%{_libdir}/pkgconfig/%{name}-1.0.pc
145
146%dir %{_includedir}/%{name}-1.0
147%{_includedir}/%{name}-1.0/%{name}/*.h
148
149%files gnome-devel
150%defattr(-,root,root,-)
151%{_libdir}/%{name}gnome.so
152%{_libdir}/pkgconfig/%{name}-gnome-1.0.pc
153
154%dir %{_includedir}/%{name}-1.0/%{name}-gnome
155%{_includedir}/%{name}-1.0/%{name}-gnome/gdkpixbuf.h
156
157%files pixbuf-loader
158%defattr(-,root,root,-)
159%{_libdir}/gdk-pixbuf-2.0/*/loaders/*.so
160
161%changelog
162* Mon Jun 13 2011 IWAI, Masaharu <iwai@alib.jp> 0.0.8-1
163- initial build for Vine Linux
164
165* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.8-5
166- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
167
168* Sun Oct 24 2010 Christian Krause <chkr@fedoraproject.org> - 0.0.8-4
169- fix %%post and %%postun scripts and install directory for
170  pixbuf-loader
171
172* Sun Oct 24 2010 Christian Krause <chkr@fedoraproject.org> - 0.0.8-3
173- add upstream patch 22287584fbfa4657098ee997957a6c4fc972a53b to
174  properly decompress CFA from certain cameras (BZ 624283)
175
176* Wed Sep 08 2010 Christian Krause <chkr@fedoraproject.org> - 0.0.8-2
177- add upstream patch 1b15acdcfdc4664bc6c0be473cb6e096071a4e62
178  to support certain PEF files and to fix a crash when opening
179  such files (BZ 606898)
180
181* Sat Dec 05 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.0.8-1
182- Version bump to 0.0.8.
183  * Fixed a huge memory leak. (FreeDesktop Bugzilla #21435)
184  * cfa output should write the data in PGM as big endian.
185  * Better handling of Canon CR2 "slices" to fix crasher with Canon
186    450D/Digital Rebel XSi files (and possibly others).
187  * Added new API or_rawfile_new_from_memory() to load a Raw file from a
188    memory buffer.
189  * Added new API or_rawfile_get_typeid() and the associated consts.
190  * Added new API or_rawdata_get_minmax().
191  * Added new API or_get_file_extensions().
192  * Added new API or_rawfile_get_rendered_image() to get a rendered image.
193  * Added new API or_bitmapdata_*().
194  * New GdkPixbuf loader.
195  * Decompress NEF files.
196- License changed to LGPLv3 or later.
197- Missing includes fixed by upstream.
198- Replaced 'BuildRequires: chrpath glib2-devel' with 'BuildRequires:
199  exempi-devel libcurl-devel'.
200- Added 'Requires: gtk2' to pixbuf-loader for directory ownership.
201- Added a %%check stanza.
202
203* Fri Jul 24 2009 Release Engineering <rel-eng@fedoraproject.org> - 0.0.5-4
204- Autorebuild for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
205
206* Wed Feb 25 2009 Caolán McNamara <caolanm@redhat.com> - 0.0.5-3
207- add stdio.h for fopen and friends
208
209* Wed Feb 25 2009 Release Engineering <rel-eng@fedoraproject.org> - 0.0.5-2
210- Autorebuild for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
211
212* Tue Mar 04 2008 Trond Danielsen <trond.danielsen@gmail.com> - 0.0.5-1
213- New upstream version.
214
215* Wed Feb 20 2008 Release Engineering <rel-eng@fedoraproject.org> - 0.0.4-3
216- Autorebuild for GCC 4.3
217
218* Wed Jan 30 2008 Trond Danielsen <trond.danielsen@gmail.com> - 0.0.4-2
219- Added missing dependency on libxml
220
221* Wed Jan 30 2008 Trond Danielsen <trond.danielsen@gmail.com> - 0.0.4-1
222- New upstream version.
223
224* Fri Dec 28 2007 Trond Danielsen <trond.danielsen@gmail.com> - 0.0.3-1
225- New upstream version.
226- Updated license tag.
227- Fixed rpath error.
228
229* Thu May 03 2007 Trond Danielsen <trond.danielsen@gmail.com> - 0.0.2-5
230- Added unowned directory to list of files.
231- Changed license from GPL to LGPL.
232
233* Wed May 02 2007 Trond Danielsen <trond.danielsen@gmail.com> - 0.0.2-4
234- Moved gui components to a separate package.
235
236* Tue May 01 2007 Trond Danielsen <trond.danielsen@gmail.com> - 0.0.2-3
237- Added missing BuildRequirement.
238
239* Mon Apr 30 2007 Trond Danielsen <trond.danielsen@gmail.com> - 0.0.2-2
240- Added missing BuildRequirement.
241
242* Sun Apr 29 2007 Trond Danielsen <trond.danielsen@gmail.com> - 0.0.2-1
243- Inital version.
Note: See TracBrowser for help on using the repository browser.