source: projects/specs/branches/6/lib/libm/libmicrohttpd/libmicrohttpd-vl.spec @ 2553

Revision 2553, 5.6 KB checked in by kazutaka, 13 years ago (diff)

self-build-xbmc と関連パッケージを追加

Line 
1Summary: Lightweight library for embedding a webserver in applications
2Name: libmicrohttpd
3Version: 0.9.2
4Release: 1%{?_dist_release}
5Group: Development/Libraries
6License: LGPLv2+
7BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
8URL: http://www.gnu.org/software/libmicrohttpd/
9Source0: ftp://ftp.gnu.org/gnu/libmicrohttpd/%{name}-%{version}.tar.gz
10#Patch0: %{name}-0.9.2-fix-https-tests.patch
11
12BuildRequires:  autoconf, automake, libtool
13BuildRequires:  curl-devel
14BuildRequires:  gnutls-devel
15BuildRequires:  libgcrypt-devel
16BuildRequires:  graphviz
17BuildRequires:  doxygen
18
19Requires(post): info
20Requires(preun): info
21
22%description
23GNU libmicrohttpd is a small C library that is supposed to make it
24easy to run an HTTP server as part of another application.
25Key features that distinguish libmicrohttpd from other projects are:
26
27* C library: fast and small
28* API is simple, expressive and fully reentrant
29* Implementation is http 1.1 compliant
30* HTTP server can listen on multiple ports
31* Support for IPv6
32* Support for incremental processing of POST data
33* Creates binary of only 25k (for now)
34* Three different threading models
35
36%package devel
37Summary:        Development files for libmicrohttpd
38Group:          Development/Libraries
39Requires:       %{name} = %{version}-%{release}
40
41%description devel
42Development files for libmicrohttpd
43
44%package doc
45Summary:        Documentation for libmicrohttpd
46Group:          Documentation
47Requires:       %{name} = %{version}-%{release}
48
49%description doc
50Doxygen documentation for libmicrohttpd and some example source code
51
52%prep
53%setup -q
54#patch0 -p1 -b .explicit-dso
55
56# The doxygen file contains references to /home/grothoff/svn/libmicrohttpd/... replace these with .
57sed s/\\/home\\/grothoff\\/svn\\/libmicrohttpd/./ doc/Doxyfile > tmp
58unlink doc/Doxyfile
59mv tmp doc/Doxyfile
60
61%build
62# Required because patches modify .am files
63# autoreconf --force
64%configure --disable-static --with-gnutls
65make %{?_smp_mflags}
66doxygen doc/Doxyfile
67
68# Disabled for now due to problems reported at
69# https://gnunet.org/bugs/view.php?id=1619
70#check
71#make check %{?_smp_mflags}
72
73%install
74rm -rf %{buildroot}
75make install DESTDIR=%{buildroot}
76
77rm -f %{buildroot}%{_libdir}/libmicrohttpd.la
78rm -f %{buildroot}%{_infodir}/dir
79
80# Install some examples in /usr/share/doc/libmicrohttpd-${version}/examples
81mkdir examples
82install -m 644 src/examples/*.c examples
83
84# Install the doxygen documentation in /usr/share/doc/libmicrohttpd-${version}/html
85cp -R doc/doxygen/html html
86
87%clean
88rm -rf %{buildroot}
89
90%post doc
91/sbin/install-info %{_infodir}/microhttpd.info.gz %{_infodir}/dir || :
92/sbin/install-info %{_infodir}/microhttpd-tutorial.info.gz %{_infodir}/dir || :
93
94%preun doc
95if [ $1 = 0 ] ; then
96/sbin/install-info --delete %{_infodir}/microhttpd.info.gz %{_infodir}/dir || :
97/sbin/install-info --delete %{_infodir}/microhttpd-tutorial.info.gz %{_infodir}/dir || :
98fi
99
100%post -p /sbin/ldconfig
101%postun -p /sbin/ldconfig
102
103%files
104%defattr(-,root,root,-)
105%doc COPYING
106%{_libdir}/libmicrohttpd.so.*
107
108%files devel
109%defattr(-,root,root,-)
110%{_includedir}/microhttpd.h
111%{_libdir}/libmicrohttpd.so
112%{_libdir}/pkgconfig/libmicrohttpd.pc
113
114%files doc
115%doc AUTHORS README ChangeLog
116%doc examples
117%doc html
118%defattr(-,root,root,-)
119%{_mandir}/man3/libmicrohttpd.3.gz
120%{_infodir}/microhttpd.info.gz
121%{_infodir}/microhttpd-tutorial.info.gz
122
123%changelog
124* Mon Jan 17 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.9.2-1
125- initial build for Vine Linux based on fedora development
126
127* Tue Nov 16 2010 Tim Niemueller <tim@niemueller.de> - 0.9.2-3
128- Add missing BR gnutls-devel and libgcrypt-devel
129- Added patch to fix test apps (NSS instead of GnuTLS/OpenSSL curl,
130  implicit DSO linking)
131- Disable test cases for now due to false errors, reported upstream
132
133* Tue Nov 16 2010 Tim Niemueller <tim@niemueller.de> - 0.9.2-2
134- Re-enable HTTPS, configure flags had unexpected result
135
136* Sun Nov  7 2010 Tim Niemueller <tim@niemueller.de> - 0.9.2-1
137- Update to 0.9.2
138
139* Sun Jun  4 2010 Erik van Pienbroek <epienbro@fedoraproject.org> - 0.4.6-1
140- Update to 0.4.6
141
142* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.2-2
143- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
144
145* Tue Jul 21 2009 Erik van Pienbroek <epienbro@fedoraproject.org> - 0.4.2-1
146- Update to version 0.4.2
147- Drop upstreamed patch
148
149* Fri Feb 27 2009 Erik van Pienbroek <info@nntpgrab.nl> - 0.4.0a-1
150- Update to version 0.4.0a
151- Drop upstreamed patch
152- Added a new patch to fix a 64bit issue
153- The -devel package now contains a pkgconfig file
154- The configure script is now run with '--enable-messages --enable-https'
155- Made the -doc subpackage noarch (F11+)
156
157* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-2
158- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
159
160* Sat Feb 14 2009 Erik van Pienbroek <info@nntpgrab.nl> - 0.4.0-1
161- Update to version 0.4.0
162- This version introduces a API bump (which is required for
163  supporting large files on 32bit environments)
164- The license issues we had with version 0.3.1 of this package (as
165  discussed in #457924) are resolved in this version. The license
166  of this package is now changed to LGPLv2+
167- Added a patch to fix two testcases on 64bit environments (upstream bug #1454)
168
169* Sat Sep 6 2008 Erik van Pienbroek <info@nntpgrab.nl> - 0.3.1-3
170- Changed license to GPLv3+ and added some comments
171  regarding the license issues with this package
172
173* Sun Aug 10 2008 Erik van Pienbroek <info@nntpgrab.nl> - 0.3.1-2
174- Changed license to LGPLv2+
175- Moved the COPYING file to the main package
176
177* Tue Aug 5 2008 Erik van Pienbroek <info@nntpgrab.nl> - 0.3.1-1
178- Initial release
179
Note: See TracBrowser for help on using the repository browser.