source: projects/specs/branches/6/lib/libm/libmemcached/libmemcached-vl.spec @ 6127

Revision 6127, 7.4 KB checked in by tomop, 12 years ago (diff)

libmemcached-1.0.7-2

Line 
1%global with_tests       %{?_with_tests:1}%{!?_with_tests:0}
2
3Name:      libmemcached
4Summary:   Client library and command line tools for memcached server
5Version:   1.0.7
6Release:   2%{?_dist_release}
7License:   BSD
8Group:     System Environment/Libraries
9URL:       http://libmemcached.org/
10# Original sources:
11#   http://launchpad.net/libmemcached/1.0/%{version}/+download/libmemcached-%{version}.tar.gz
12# The source tarball must be repackaged to remove the Hsieh hash
13# code, since the license is non-free.  When upgrading, download the new
14# source tarball, and run "./strip-hsieh.sh <version>" to produce the
15# "-exhsieh" tarball.
16Source0:   libmemcached-%{version}-exhsieh.tar.gz
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
19BuildRequires: cyrus-sasl-devel
20BuildRequires: flex bison
21%if %{with_tests}
22BuildRequires: memcached
23%endif
24BuildRequires: libevent-devel
25
26Vendor: Project Vine
27Distribution: Vine Linux
28Packager: tomop
29
30%description
31libmemcached is a C/C++ client library and tools for the memcached server
32(http://memcached.org/). It has been designed to be light on memory
33usage, and provide full access to server side methods.
34
35It also implements several command line tools:
36
37memcapable  Checking a Memcached server capibilities and compatibility
38memcat      Copy the value of a key to standard output
39memcp       Copy data to a server
40memdump     Dumping your server
41memerror    Translate an error code to a string
42memexist    Check for the existance of a key
43memflush    Flush the contents of your servers
44memparse    Parse an option string
45memping     Test to see if a server is available.
46memrm       Remove a key(s) from the server
47memslap     Generate testing loads on a memcached cluster
48memstat     Dump the stats of your servers to standard output
49memtouch    Touches a key
50
51
52%package devel
53Summary: Header files and development libraries for %{name}
54Group: Development/Libraries
55Requires: %{name}%{?_isa} = %{version}-%{release}
56Requires: pkgconfig
57Requires: cyrus-sasl-devel%{?_isa}
58
59%description devel
60This package contains the header files and development libraries
61for %{name}. If you like to develop programs using %{name},
62you will need to install %{name}-devel.
63
64
65%prep
66%setup -q
67
68mkdir examples
69cp -p tests/*.{cc,h} examples/
70
71# Will be regenerated during build
72rm -f libmemcached/csl/{parser,scanner}.cc
73
74# Temporary fix for SASL detection
75sed -i -e s/ax_cv_sasl/ac_enable_sasl/ configure
76
77
78%build
79# option --with-memcached=false to disable server binary check (as we don't run test)
80%configure --disable-static \
81%if ! %{with_tests}
82   --with-memcached=false
83%endif
84
85make %{_smp_mflags}
86
87
88%install
89rm -rf %{buildroot}
90make install  DESTDIR="%{buildroot}" AM_INSTALL_PROGRAM_FLAGS=""
91
92
93%check
94%if %{with_tests}
95# test suite cannot run in mock (same port use for memcache servers on all arch)
96# All tests completed successfully
97# diff output.res output.cmp fails but result depend on server version
98make test
99%else
100echo 'Test suite disabled (missing "--with tests" option)'
101%endif
102
103
104%clean
105rm -rf %{buildroot}
106
107
108%post
109/sbin/ldconfig
110
111
112%postun
113/sbin/ldconfig
114 
115
116%files
117%defattr (-,root,root,-)
118%doc AUTHORS COPYING README THANKS TODO ChangeLog
119%{_bindir}/mem*
120%exclude %{_libdir}/lib*.la
121%{_libdir}/libhashkit.so.2*
122%{_libdir}/libmemcached.so.10*
123%{_libdir}/libmemcachedprotocol.so.0*
124%{_libdir}/libmemcachedutil.so.2*
125%{_mandir}/man1/mem*
126
127
128%files devel
129%defattr (-,root,root,-)
130%doc examples
131%{_includedir}/libmemcached
132%{_includedir}/libmemcached-1.0
133%{_includedir}/libhashkit
134%{_includedir}/libhashkit-1.0
135%{_includedir}/libmemcachedprotocol-0.0
136%{_includedir}/libmemcachedutil-1.0
137%{_libdir}/libhashkit.so
138%{_libdir}/libmemcached.so
139%{_libdir}/libmemcachedprotocol.so
140%{_libdir}/libmemcachedutil.so
141%{_libdir}/pkgconfig/libmemcached.pc
142%{_mandir}/man3/libmemcached*
143%{_mandir}/man3/libhashkit*
144%{_mandir}/man3/memcached*
145%{_mandir}/man3/hashkit*
146
147
148%changelog
149* Thu May 03 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.7-2
150- built for Vine Linux.
151
152* Sun Apr 22 2012 Remi Collet <remi@fedoraproject.org> - 1.0.7-1
153- update to 1.0.7
154- regenerate parser using flex/bison (#816766)
155
156* Sun Apr 22 2012 Remi Collet <remi@fedoraproject.org> - 1.0.6-2
157- workaround for SASL detection
158
159* Sat Apr 21 2012 Remi Collet <remi@fedoraproject.org> - 1.0.6-1
160- update to 1.0.6
161- soname bump to libmemcached.so.10 and libhashkit.so.2
162
163* Sat Mar 03 2012 Remi Collet <remi@fedoraproject.org> - 1.0.4-1
164- update to 1.0.4
165- soname bump to libmemcached.so.9
166- update description
167
168* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-3
169- Rebuilt for c++ ABI breakage
170
171* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-2
172- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
173
174* Thu Oct 27 2011 Remi Collet <remi@fedoraproject.org> - 1.0.2-1
175- update to 1.0.2
176
177* Sun Oct 16 2011 Remi Collet <remi@fedoraproject.org> - 0.53-1
178- update to 0.53
179
180* Sat Sep 17 2011 Remi Collet <remi@fedoraproject.org> - 0.52-1
181- update to 0.52
182
183* Sun Jul 31 2011 Remi Collet <remi@fedoraproject.org> - 0.51-1
184- update to 0.51 (soname bump libmemcached.so.8)
185
186* Thu Jun 02 2011 Remi Collet <Fedora@famillecollet.com> - 0.49-1
187- update to 0.49
188- add build option : --with tests
189
190* Mon Feb 28 2011 Remi Collet <Fedora@famillecollet.com> - 0.47-1
191- update to 0.47
192- remove patch merged upstream
193
194* Sun Feb 20 2011 Remi Collet <Fedora@famillecollet.com> - 0.46-2
195- patch Makefile.in instead of include.am (to avoid autoconf)
196- donc requires pkgconfig with arch
197
198* Fri Feb 18 2011 Remi Collet <Fedora@famillecollet.com> - 0.46-1
199- update to 0.46
200
201* Sat Feb 12 2011 Remi Collet <Fedora@famillecollet.com> - 0.44-6
202- arch specific requires
203
204* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.44-5
205- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
206
207* Wed Nov 24 2010 Joe Orton <jorton@redhat.com> - 0.44-4
208- repackage source tarball to remove non-free Hsieh hash code
209
210* Sat Oct 02 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-3
211- improves SASL patch
212
213* Sat Oct 02 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-2
214- enable SASL support
215
216* Fri Oct 01 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-1
217- update to 0.44
218- add soname version in %%file to detect change
219
220* Fri Jul 30 2010 Remi Collet <Fedora@famillecollet.com> - 0.43-1
221- update to 0.43
222
223* Wed Jul 07 2010 Remi Collet <Fedora@famillecollet.com> - 0.42-1
224- update to 0.42
225
226* Tue May 04 2010 Remi Collet <Fedora@famillecollet.com> - 0.40-1
227- update to 0.40 (new soname for libmemcached.so.5)
228- new URI (site + source)
229
230* Sat Mar 13 2010 Remi Collet <Fedora@famillecollet.com> - 0.38-1
231- update to 0.38
232
233* Sat Feb 06 2010 Remi Collet <Fedora@famillecollet.com> - 0.37-1
234- update to 0.37 (soname bump)
235- new libhashkit (should be a separated project in the futur)
236
237* Sun Sep 13 2009 Remi Collet <Fedora@famillecollet.com> - 0.31-1
238- update to 0.31
239
240* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.30-2
241- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
242
243* Sun Jun 14 2009 Remi Collet <Fedora@famillecollet.com> - 0.30-1
244- update to 0.30
245
246* Tue May 19 2009 Remi Collet <Fedora@famillecollet.com> - 0.29-1
247- update to 0.29
248
249* Fri May 01 2009 Remi Collet <Fedora@famillecollet.com> - 0.28-2
250- add upstream patch to disable nonfree hsieh hash method
251
252* Sat Apr 25 2009 Remi Collet <Fedora@famillecollet.com> - 0.28-1
253- Initial RPM from Brian Aker spec
254- create -devel subpackage
255- add %%post %%postun %%check section
256
Note: See TracBrowser for help on using the repository browser.