source: projects/specs/branches/6/lib/libg/libgnomeuimm/libgnomeuimm-vl.spec @ 1859

Revision 1859, 3.9 KB checked in by iwaim, 14 years ago (diff)

build with rpm 4.8.1-1; see [VineSeed:21798]

Line 
1Summary:        A C++ interface for libgnomeui
2Name:           libgnomeuimm
3Version:        2.28.0
4Release:        2%{?_dist_release}
5License:        LGPL
6Group:          System Environment/Libraries
7Source:         ftp://download.sourceforge.net/gtkmm/%{name}-%{version}.tar.bz2
8URL:            http://gtkmm.sourceforge.net/
9BuildRoot:      %{_tmppath}/%{name}-%{version}-root
10BuildRequires:  libgnomeui-devel >= 2.7.1
11BuildRequires:  libgnomemm-devel >= 2.16.0
12BuildRequires:  libgnomecanvasmm-devel >= 2.6.0
13BuildRequires:  gconfmm-devel >= 2.6.0
14BuildRequires:  libglademm2-devel >= 2.4.0
15BuildRequires:  gnome-vfsmm-devel >= 2.16.0
16BuildRequires:  libSM-devel
17
18%description
19This package provides a C++ interface for GnomeUI.  It is a subpackage
20of the Gtk-- project.  The interface provides a convenient interface for C++
21programmers to create Gnome GUIs with GTK+'s flexible object-oriented
22framework.
23
24%package        devel
25Summary:        Headers for developing programs that will use libgnomeuimm.
26Group:          Development/Libraries
27Requires:       %{name} = %{version}
28Requires:       libgnomeui-devel >= 2.7.1
29Requires:       libgnomemm-devel >= 2.16.0
30Requires:       libgnomecanvasmm-devel >= 2.6.0
31Requires:       gconfmm-devel >= 2.6.0
32Requires:       libglademm2-devel >= 2.4.0
33Requires:       gnome-vfsmm-devel >= 2.16.0
34
35%description    devel
36This package contains the headers that programmers will need to develop
37applications which will use Gnome--, part of Gtk-- the C++ interface to
38the GTK+ (the Gimp ToolKit) GUI library.
39
40%prep
41%setup -q
42
43%build
44# ...hope this can be removed soon
45%ifarch alpha
46        ARCH_FLAGS="--host=alpha-linux-gnu"
47%endif
48
49export CXXFLAGS="$RPM_OPT_FLAGS -shared -fPIC"
50%configure --enable-shared --disable-static --enable-docs
51make %{?_smp_mflags}
52
53if [ "$SMP" != "" ]; then
54  make -j$SMP "MAKE=make -j$SMP"
55  make
56else
57  make
58fi
59
60%install
61if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
62%makeinstall
63find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
64
65
66%post -p /sbin/ldconfig
67
68%postun -p /sbin/ldconfig
69
70%clean
71if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
72
73%files
74%defattr(-, root, root)
75%doc AUTHORS COPYING ChangeLog INSTALL NEWS README
76%{_libdir}/*.so.*
77
78%files  devel
79%defattr(-, root, root)
80%{_includedir}/libgnomeuimm-2.6
81#{_libdir}/*.la
82#{prefix}/lib/*.a # uncomment this one for static libs
83%{_libdir}/*.so
84%{_libdir}/libgnomeuimm-2.6
85%{_libdir}/pkgconfig/*.pc
86
87%changelog
88* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.28.0-2
89- build with rpm-4.8.1-1 for pkg-config file
90
91* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
92- new upstream release
93- add BuildRequires: libSM-devel
94
95* Sat Oct  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.0-1vl5
96- new upstream release
97
98* Fri Sep 19 2008 Shu KONNO <owa@bg.wakwak.com> 2.18.0-1vl5
99- applied new versioning policy
100
101* Sat Jun  2 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.18.0-0vl4
102- build all object files with -fPIC so that sharlib is PIC
103
104* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl3
105- rebuilt without libstdc++2_10
106
107* Sun May 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl2
108- rebuilt with new toolchain
109- added -shared option to CXXFLAGS
110
111* Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl1
112- new upstream release
113
114* Sat Nov  4 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.0-1vl1
115- initial build for Vine Linux
116
117* Sun Dec 21 2003 Eric Bourque <ericb@computer.org>
118- fixed dependency to gtkmm2 instead of gtkmm
119
120* Thu Sep 25 2003 Eric Bourque <ericb@computer.org>
121- updated for libgnomeuimm-2.0
122
123* Tue Mar 20 2001 Eric Bourque <ericb@computer.org>
124- added gnome--.m4 to files devel section
125
126* Sat Mar 10 2001 Herbert Valerio Riedel <hvr@gnu.org>
127- improved examples.conf
128- fixed example build problems
129
130* Thu May 11 2000 Herbert Valerio Riedel <hvr@gnu.org>
131- removed lib/gtkmm from files section
132- removed empty obsolete tags
133
134* Sun Jan 30 2000 Karl Einar Nelson <kenelson@sourceforge.net>
135- adapted from gtk--.spec
Note: See TracBrowser for help on using the repository browser.