source: projects/specs/branches/6/lib/libg/libgnomeprint/libgnomeprint-vl.spec @ 6738

Revision 6738, 12.9 KB checked in by Takemikaduchi, 12 years ago (diff)

fix R:libxml2

Line 
1## this could go, it's really just so we notice if the soname changes
2%define sover 0
3
4%define gettext_package libgnomeprint-2.2
5
6%define glib2_base_version 2.26.0
7%define glib2_version %{glib2_base_version}
8%define pango_version 1.28.2
9%define libxml2_version 2.7.7
10%define libart_lgpl_version 2.3.16
11%define libbonobo_version 2.32.0
12%define freetype_version 2.3.7
13%define gtk_doc_version 1.1
14
15Summary: Printing library for GNOME.
16Summary(ja): GNOME プリントライブラリ
17Name:           libgnomeprint
18Version:        2.18.8
19Release:        2%{?_dist_release}
20License:        LGPL
21Group:          System Environment/Libraries
22Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/2.18/%{name}-%{version}.tar.bz2
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-root
25BuildRequires: glib2-devel >= %{glib2_version}
26BuildRequires: pango-devel >= %{pango_version}
27BuildRequires: libxml2-devel >= %{libxml2_version}
28BuildRequires: libart_lgpl-devel >= %{libart_lgpl_version}
29BuildRequires: libbonobo-devel >= %{libbonobo_version}
30BuildRequires: freetype2 >= %{freetype_version}
31BuildRequires: gtk-doc >= %{gtk_doc_version}
32BuildRequires: libgnomecups-devel >= 0.2.0
33BuildRequires: bison
34BuildRequires: flex
35
36Requires: libgnomecups >= 0.1.13-0vl2
37Requires: urw-fonts
38Requires: ghostscript
39Requires: ghostscript-fonts
40Requires: libxml2
41Requires: perl
42
43
44%description
45GNOME (GNU Network Object Model Environment) is a user-friendly set of
46applications and desktop tools to be used in conjunction with a window
47manager for the X Window System. The gnome-print package contains
48libraries and fonts needed by GNOME applications for printing.
49
50You should install the gnome-print package if you intend to use any of
51the GNOME applications that can print. If you would like to develop
52GNOME applications that can print you will also need to install the
53gnome-print devel package.
54
55%package devel
56Summary: Libraries and include files for developing GNOME applications.
57Summary(ja): libgnomeprint のライブラリとヘッダファイル
58Group: Development/Libraries
59
60Requires: %{name} = %{version}-%{release}
61Requires: glib2-devel >= %{glib2_version}
62Requires: pango-devel >= %{pango_version}
63Requires: libxml2-devel >= %{libxml2_version}
64Requires: libart_lgpl-devel >= %{libart_lgpl_version}
65Requires: libbonobo-devel >= %{libbonobo_version}
66Requires: freetype2 >= %{freetype_version}
67
68%description devel
69GNOME (GNU Network Object Model Environment) is a user-friendly set of
70applications and desktop tools to be used in conjunction with a window
71manager for the X Window System. The gnome-print-devel package
72includes the libraries and include files needed for developing
73applications that use the GNOME printing capabilities.
74
75You should install the gnome-print-devel package if you would like to
76develop GNOME applications that will use the GNOME print capabilities.
77You do not need to install the gnome-print-devel package if you just
78want to use the GNOME desktop environment.
79
80%prep
81%setup -q -n %{name}-%{version}
82
83%build
84%configure --disable-font-install --disable-gtk-doc
85make
86
87%install
88rm -rf $RPM_BUILD_ROOT
89
90# It would probably be cleaner to use install DESTDIR=$RPM_BUILD_ROOT
91# instead of %%makeinstall with this hack.
92%makeinstall
93
94# remove unpackaged files
95rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
96rm -f $RPM_BUILD_ROOT%{_libdir}/libgnomeprint/%{version}/modules/*.{a,la}
97rm -f $RPM_BUILD_ROOT%{_libdir}/libgnomeprint/%{version}/modules/*/*.{a,la}
98
99%clean
100rm -rf $RPM_BUILD_ROOT
101
102%post -p /sbin/ldconfig
103
104%postun -p /sbin/ldconfig
105
106%files
107%defattr(-, root, root)
108%doc AUTHORS COPYING ChangeLog NEWS README
109%dir %{_libdir}/libgnomeprint/%{version}
110%{_libdir}/libgnomeprint/%{version}/modules/*.so
111%{_libdir}/libgnomeprint/%{version}/modules/transports/*.so
112%{_libdir}/libgnomeprint/%{version}/modules/filters/*.so
113%{_libdir}/libgnomeprint*.so.*
114%{_datadir}/libgnomeprint
115%{_datadir}/locale/*/LC_MESSAGES/*.mo
116
117%files devel
118%defattr(-, root, root)
119%{_libdir}/libgnomeprint*.so
120%{_libdir}/*.a
121%{_includedir}/*
122%{_libdir}/pkgconfig/*.pc
123%{_datadir}/gtk-doc
124
125%changelog
126* Sat Aug 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.8-2
127- change Requires: libxml2 instead of libxml
128
129* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.8-1
130- new upstream release
131
132* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.18.7-2
133- build with rpm-4.8.1-1 for pkg-config file
134
135* Thu Apr 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.7-1
136- new upstream release
137- add BuildRequires: bison, flex
138
139* Wed Mar 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.6-1
140- new upstream release
141
142* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.5-1
143- new upstream release
144- build with gtk+2.14
145
146* Tue Mar 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1vl5
147- new upstream release
148- removed BuildRequires: automake17
149
150* Wed Dec 12 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
151- new upstream release
152
153* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl2
154- rebuilt with new toolchain/environment
155
156* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
157- new upstream release
158
159* Fri May 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl3
160- changed Group to System Environment/Libraries
161
162* Sat Apr 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
163- add missing filter modules to %%files
164- remove unneeded static modules
165
166* Wed Sep 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
167- new upstream release
168
169* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
170- new upstream release
171
172* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.0-0vl1
173- new upstream release
174
175* Sun Jul  3 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.3-0vl1
176- new upstream version
177- drop all patches that are now upstream.
178
179* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
180- new upstream version
181- drop all patches that are now upstream.
182
183* Wed Mar 02 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-0vl1
184- new upstream release
185- updated patch7,8 from Fedora Development
186- added Japanese summary to devel package
187
188* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0.1-0vl1
189- new upstream release
190- add patch7,8 from fc
191
192* Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
193- add Patch11 from bugzilla.gnome.org to support ttc font's multiple face.
194
195* Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
196- new upstream release
197
198* Mon Sep 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
199- new upstream release
200
201* Sun Sep 14 2003 KAZUKI SHIMURA <rito@pos.to> 2.3.1-0vl2
202- Oops, spec was in Shift_JIS. Fixed.
203
204* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl1
205- new upstream release
206
207* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1.3-0vl1
208- new upstream release
209
210* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
211- new upstream release
212
213* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
214- new upstream release
215
216* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.8-0vl1
217- new upstream release
218
219* Thu Jan  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
220- new upstream release
221
222* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.6-0vl1
223- new upstream release
224
225* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
226- add patch1 to recognize .ttc font as TrueType font.
227
228* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
229- add %%{_datadir}/libgnomeprint for %%files
230
231* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
232- new upstream release
233
234* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
235- build for Vine Linux
236- new upstream release from gnome-2.1.4
237
238* Thu Aug 15 2002 Akira TAGOH <tagoh@redhat.com> 1.116.0-2
239- libgnomeprint-1.116.0-correctps.patch: applied to fix the invalid PostScript.
240
241* Tue Aug 13 2002 Akira TAGOH <tagoh@redhat.com> 1.116.0-1
242- libgnomeprint-1.116.0-perfprint.patch: applied to fix the printing
243  performance issue. (#66715)
244
245* Fri Jul 12 2002 Akira TAGOH <tagoh@redhat.com> 1.115.0-5
246- includes redhat-update-gnome-font-install2 script. (#66899)
247- fix the install path for fontmap.
248- add some directory owners.
249
250* Thu Jul 11 2002 Tim Powers <timp@redhat.com>
251- rebuilt
252
253* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
254- 1.115.0
255- include gtk-doc docs
256- move pkg-config files to -devel package
257
258* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
259- rebuild in different environment
260
261* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
262- 1.114.0
263
264* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
265- rebuild in different environment
266
267* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
268- rebuild in different environment
269- add bonobo-activation requires to make build system happy
270
271* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
272- 1.113.0
273
274* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
275- rebuild for new libraries
276
277* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
278- 1.112.0
279
280* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
281- 1.111.0
282
283* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
284- Version 1.110.0
285
286* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
287- automake14
288
289* Mon Jan  7 2002 Havoc Pennington <hp@redhat.com>
290- 1.109.0.90 snap
291- remove .options patch which is upstream
292- remove .nofontmaps patch, upstream uses sysconfdir sometimes now
293  and has --disable-font-install configure option
294- remove .fontmapdir, now fixed upstream
295
296* Tue Nov 27 2001 Havoc Pennington <hp@redhat.com>
297- rebuild due to build system fuckup
298
299* Tue Nov 27 2001 Havoc Pennington <hp@redhat.com>
300- cvs snap 1.106.0.90, glib 1.3.11
301
302* Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
303- new cvs snap, rebuild for glib 1.3.10, remove bogus gtk dep
304
305* Tue Oct  9 2001 Havoc Pennington <hp@redhat.com>
306- remove epoch screwup
307
308* Mon Oct  8 2001 Havoc Pennington <hp@redhat.com>
309- libgnomeprint package based on the gnome-print package
310
311* Mon Oct  8 2001 Havoc Pennington <hp@redhat.com>
312- use 0.30 tarball
313
314* Sat Sep 22 2001 Havoc Pennington <hp@redhat.com>
315- new cvs snap, with headers moved
316
317* Wed Aug 15 2001 Owen Taylor <otaylor@redhat.com>
318- Back out freetype change, for now, until we can get it in upstream.
319- Move gnome-print/<ver>/profiles back to datadir, and remove the %config.
320  Making them %config doesn't seem compatible with locating them
321  in gnome-print/<ver>.
322
323* Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-5
324- no replace profiles.
325
326* Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-4
327- Move profiles directory to /etc/gnome-print/<ver>/profiles/
328
329* Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-3
330- Add freetype support patch. (Bug#50360)
331
332* Sat Jul 21 2001 Owen Taylor <otaylor@redhat.com>
333- Add missing directory
334
335* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
336- Upgrade to 0.29
337- Don't install run-gnome-font-install (#48466), run gnome-font-install directly.
338- Add BuildPrereq and make -devel package require gdk-pixbuf-devel
339- Make libgnomeprint package require gnome-print package; otherwise
340  packages requiring libgnomeprint might not get a runtime environment
341- Add Prereq on ghostscript, since run-gnome-font-install parses output of 'gs -h'
342
343* Mon Jul 16 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
344- Kill output from run-gnome-font-install
345- s/Copyright/License/
346- Add post/postun scripts for the libgnomeprint subpackage
347
348* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
349- Bump release + rebuild.
350
351* Fri Apr 20 2001 Jonathan Blandford <jrb@redhat.com>
352- new version (0.28)
353
354* Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
355- Rebuild for GTK+-1.2.9 include paths
356
357* Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
358- langify
359- patch it to compile (didn't include locale.h when needed)
360- use %%{_tmppath}
361
362* Fri Feb 23 2001 Akira TAGOH <tagoh@redhat.com>
363- Fixed font problem for Japanese.
364- Fixed library dependency on VFlib (Bug#28331)
365
366* Wed Feb 21 2001 Philipp Knirsch <pknirsch@redhat.de>
367- Fixed bugzilla bug #27417, simple specfile %post fix.
368
369* Sun Feb 18 2001 Akira TAGOH <tagoh@redhat.com>
370- Fixed PostScript broken.
371- Added autoheader,automake,autoconf stuff.
372
373* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
374- add libtoolize to make porting to new archs easy
375
376* Tue Feb 06 2001 Akira TAGOH <tagoh@redhat.com>
377- Updated Japanese patch for Gnumeric.
378  Created dummy .afm.
379
380* Mon Feb 05 2001 Akira TAGOH <tagoh@redhat.com>
381- Fixed gdk_fontset_load().
382- Added Japanese patch for Gnumeric.
383
384* Fri Feb 02 2001 Akira TAGOH <tagoh@redhat.com>
385- Added Japanese patch.
386  Fixed Print and Preview with Japanese.
387
388* Fri Dec 29 2000 Matt Wilson <msw@redhat.com>
389- 0.25
390
391* Sat Aug 19 2000 Preston Brown <pbrown@redhat.com>
392- added "|| true" to %%post so that if font-install screws up we don't get a
393  bad exit status.  gnome-font-install expects that the directory specified by
394  HOME env. var is writable, but it isn't always if you install with 'sudo'
395  or the equivalent.  bad. bad. bad.
396
397* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
398- Up Epoch and release
399
400* Fri Jul 14 2000 Matt Wilson <msw@redhat.com>
401- redirect %%post script output to /dev/null
402
403* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
404- automatic rebuild
405
406* Thu Jun 29 2000 Owen Taylor <otaylor@redhat.com>
407- Spec file fixes
Note: See TracBrowser for help on using the repository browser.