source: projects/specs/branches/6/lib/libg/libgnomecanvasmm/libgnomecanvasmm-vl.spec @ 1859

Revision 1859, 3.1 KB checked in by iwaim, 14 years ago (diff)

build with rpm 4.8.1-1; see [VineSeed:21798]

Line 
1Summary:        A C++ interface for libgnomecanvas
2Name:           libgnomecanvasmm
3Version:        2.26.0
4Release:        2%{?_dist_release}
5License:        LGPL
6Group:          System Environment/Libraries
7Source:         ftp://download.sourceforge.net/gtkmm/%{name}-%{version}.tar.bz2
8URL:            http://gtkmm.sourceforge.net/
9BuildRoot:      %{_tmppath}/%{name}-%{version}-root
10Requires:       gtkmm2 >= 2.4.0
11Requires:       libgnomecanvas >= 2.6.0
12BuildRequires:  gtkmm2-devel >= 2.4.0
13BuildRequires:  libgnomecanvas-devel >= 2.6.0
14
15%description
16This package provides a C++ interface for GnomeUI.  It is a subpackage
17of the gnomemm project.  The interface provides a convenient interface for C++
18programmers to create Gnome GUIs with GTK+'s flexible object-oriented
19framework.
20
21%package        devel
22Summary:        Headers for developing programs that will use libgnomecanvasmm.
23Group:          Development/Libraries
24Requires:       %{name} = %{version}
25Requires:       gtkmm2-devel >= 2.4.0
26Requires:       libgnomecanvas-devel >= 2.6.0
27
28%description    devel
29This package contains the headers that programmers will need to develop
30applications which will use libgnomecanvasmm, part of gnomemm - the C++
31interface to the GTK+ GUI library.
32
33%prep
34%setup -q
35
36%build
37# ...hope this can be removed soon
38%ifarch alpha
39        ARCH_FLAGS="--host=alpha-linux-gnu"
40%endif
41
42%configure
43
44if [ "$SMP" != "" ]; then
45  make -j$SMP "MAKE=make -j$SMP"
46  make
47else
48  make
49fi
50
51%install
52if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
53%makeinstall
54
55%post -p /sbin/ldconfig
56
57%postun -p /sbin/ldconfig
58
59%clean
60if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
61
62%files
63%defattr(-, root, root)
64%doc AUTHORS COPYING ChangeLog INSTALL NEWS README
65%{_libdir}/*.so.*
66
67%files  devel
68%defattr(-, root, root)
69%{_includedir}/libgnomecanvasmm-2.6
70%exclude %{_libdir}/*.la
71#{prefix}/lib/*.a # uncomment this one for static libs
72%{_libdir}/*.so
73%{_libdir}/libgnomecanvasmm-2.6
74%{_libdir}/pkgconfig/*.pc
75
76%changelog
77* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.26.0-2
78- build with rpm-4.8.1-1 for pkg-config file
79
80* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
81- new upstream release
82
83* Sat Oct  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
84- new upstream release
85
86* Fri Sep 19 2008 Shu KONNO <owa@bg.wakwak.com> 2.16.0-2vl5
87- applied new versioning policy
88- excluded *.la
89
90* Fri May 11 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.0-1vl3
91- rebuilt with new toolchains
92
93* Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.0-1vl2
94- rebuilt with new gtkmm, libgnomecanvas
95
96* Fri Nov  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.0-1vl1
97- initial build for Vine Linux
98
99* Sun Dec 21 2003 Eric Bourque <ericb@computer.org>
100- fixed dependency to gtkmm2 instead of gtkmm
101
102* Thu Sep 25 2003 Eric Bourque <ericb@computer.org>
103- updated for libgnomecanvasmm-2.0
104* Tue Mar 20 2001 Eric Bourque <ericb@computer.org>
105- added gnome--.m4 to files devel section
106
107* Sat Mar 10 2001 Herbert Valerio Riedel <hvr@gnu.org>
108- improved examples.conf
109- fixed example build problems
110
111* Thu May 11 2000 Herbert Valerio Riedel <hvr@gnu.org>
112- removed lib/gtkmm from files section
113- removed empty obsolete tags
114
115* Sun Jan 30 2000 Karl Einar Nelson <kenelson@sourceforge.net>
116- adapted from gtk--.spec
Note: See TracBrowser for help on using the repository browser.