source: projects/specs/branches/6/lib/libg/libgnomecanvas/libgnomecanvas-vl.spec @ 2041

Revision 2041, 7.1 KB checked in by Takemikaduchi, 14 years ago (diff)

update to GNOME-2.32.0

Line 
1%define gettext_package libgnomecanvas-2.0
2
3%define gtk2_version 2.22.0
4%define libart_lgpl_version 2.3.21
5%define libglade2_version 2.6.0
6
7%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
8
9Summary: GnomeCanvas widget
10Name: libgnomecanvas
11Version: 2.30.2
12Release: 1%{?_dist_release}
13URL: http://www.gnome.org/
14Source0: %{name}-%{version}.tar.bz2
15License: LGPL
16Group: System Environment/Libraries
17BuildRoot: %{_tmppath}/%{name}-root
18Requires: gtk2 >= %{gtk2_version}
19BuildRequires: gtk2-devel >= %{gtk2_version}
20BuildRequires: libart_lgpl-devel >= %{libart_lgpl_version}
21BuildRequires: libglade2-devel >= %{libglade2_version}
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: daisuke, takemikaduchi
26
27%description
28The canvas widget allows you to create custom displays using stock items
29such as circles, lines, text, and so on. It was originally a port of the
30Tk canvas widget but has evolved quite a bit over time.
31
32%package devel
33Summary: Libraries and headers for libgnomecanvas.
34Group: Development/Libraries
35Requires: %{name} = %{version}-%{release}
36Conflicts: gnome-libs-devel < 1.4.1.2
37Requires: gtk2-devel >= %{gtk2_version}
38Requires: libart_lgpl-devel >= %{libart_lgpl_version}
39Requires: libglade2-devel >= %{libglade2_version}
40
41%description devel
42The canvas widget allows you to create custom displays using stock items
43such as circles, lines, text, and so on. It was originally a port of the
44Tk canvas widget but has evolved quite a bit over time.
45
46# compat32
47%package -n compat32-%{name}
48Summary: GnomeCanvas widget
49Group: System Environment/Libraries
50Requires: %{name} = %{version}-%{release}
51
52%description -n compat32-%{name}
53The canvas widget allows you to create custom displays using stock items
54such as circles, lines, text, and so on. It was originally a port of the
55Tk canvas widget but has evolved quite a bit over time.
56
57%package -n compat32-%{name}-devel
58Summary: Libraries and headers for libgnomecanvas.
59Group: Development/Libraries
60Requires: %{name}-devel = %{version}-%{release}
61Requires: compat32-%{name} = %{version}-%{release}
62Requires: compat32-gtk2-devel >= %{gtk2_version}
63Requires: compat32-libart_lgpl-devel >= %{libart_lgpl_version}
64Requires: compat32-libglade2-devel >= %{libglade2_version}
65
66%description -n compat32-%{name}-devel
67The canvas widget allows you to create custom displays using stock items
68such as circles, lines, text, and so on. It was originally a port of the
69Tk canvas widget but has evolved quite a bit over time.
70
71%prep
72%setup -q
73
74%build
75
76%configure --enable-glade
77make %{?_smp_mflags}
78
79%install
80rm -rf %{buildroot}
81make install DESTDIR=$RPM_BUILD_ROOT
82
83rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
84rm -f $RPM_BUILD_ROOT%{_libdir}/libglade/2.0/*.{a,la}
85
86%find_lang %{gettext_package}
87
88%clean
89rm -rf %{buildroot}
90
91%post -p /sbin/ldconfig
92%postun -p /sbin/ldconfig
93
94%post -n compat32-%{name} -p /sbin/ldconfig
95%postun -n compat32-%{name} -p /sbin/ldconfig
96
97%files -f %{gettext_package}.lang
98%defattr(-,root,root)
99%doc ChangeLog NEWS
100%{_libdir}/lib*.so.*
101%{_libdir}/libglade/2.0/libcanvas.so
102
103%files devel
104%defattr(-,root,root)
105%{_libdir}/lib*.so
106%{_libdir}/pkgconfig/*
107%{_includedir}/*
108%{_datadir}/gtk-doc
109
110# compat32
111%if %{build_compat32}
112%files -n compat32-%{name}
113%defattr(-,root,root)
114%{_libdir}/lib*.so.*
115%{_libdir}/libglade/2.0/libcanvas.so
116
117%files -n compat32-%{name}-devel
118%defattr(-,root,root)
119%{_libdir}/lib*.so
120%{_libdir}/pkgconfig/*
121%endif
122
123%changelog
124* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
125- new upstream release
126
127* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.1-2
128- build with rpm-4.8.1-1 for pkg-config file
129
130* Tue May 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-1
131- new upstream release
132- add --enable-glade configure option
133  - re-add libcanvas.so to %%files
134
135* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
136- new upstream release
137
138* Sun Jul 12 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.0-2
139- added compat32 package for x86_64 arch support
140
141* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
142- new upstream release
143- remove BR: gail-devel
144- remove static libs
145
146* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1.1-1vl5
147- rebuilt with gtk-2.12.9, gail-1.22.0
148- used %%{?_dist_release} macro
149
150* Sun Jan 20 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.20.1.1-0vl2
151- added BuildRequires: gail-devel
152
153* Tue Dec 11 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1.1-0vl1
154- new upstream release
155
156* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
157- new upstream release
158
159* Mon Mar 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.0-0vl1
160- new upstream release
161
162* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
163- new upstream release
164
165* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.1-0vl1
166- new upstream release
167
168* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
169- new upstream version
170
171* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
172- new upstream release
173
174* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
175- new upstream release
176
177* Tue Jun 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
178- new upstream release
179
180* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
181- new upstream release
182
183* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
184- new upstream release
185
186* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90-0vl1
187- new upstream release
188
189* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
190- new upstream release
191
192* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
193- build for Vine Linux
194
195* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
196- 2.0.2
197
198* Fri Jul 12 2002 Havoc Pennington <hp@redhat.com>
199- fix gettext package name
200
201* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
202- remove empty AUTHORS/README
203
204* Sat Jun 15 2002 Havoc Pennington <hp@redhat.com>
205- 2.0.1
206- check file list, add glade module and gtk-doc docs
207
208* Sun May 26 2002 Tim Powers <timp@redhat.com>
209- automated rebuild
210
211* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
212- rebuild in different environment
213
214* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
215- rebuild in different environment
216
217* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
218- 1.117.0
219
220* Thu May  2 2002 Havoc Pennington <hp@redhat.com>
221- rebuild for new libglade
222- 1.116.0
223
224* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
225- 1.114.0
226
227* Tue Feb 19 2002 Alex Larsson <alexl@redhat.com>
228- Add nasty version check stuff.
229
230* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
231- 1.111.0
232
233* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
234- Version 1.110.0
235
236* Fri Jan 25 2002 Havoc Pennington <hp@redhat.com>
237- rebuild in rawhide
238
239* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
240- 1.108.0.90 cvs snap
241
242* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
243- cvs snap 1.105.0.90, gtk 1.3.11
244
245* Fri Oct 26 2001 Havoc Pennington <hp@redhat.com>
246- new cvs snap, rebuild for gtk 1.3.10,
247  add libglade dep, fix libart dep
248
249* Fri Oct  5 2001 Havoc Pennington <hp@redhat.com>
250- rebuild cvs snap for new glib/gtk
251
252* Fri Sep 21 2001 Havoc Pennington <hp@redhat.com>
253- new cvs snap with upstream changes
254
255* Thu Sep 13 2001 Havoc Pennington <hp@redhat.com>
256- Initial build.
257
258
Note: See TracBrowser for help on using the repository browser.