source: projects/specs/branches/6/lib/libg/libgnome-keyring/libgnome-keyring-vl.spec @ 2041

Revision 2041, 4.4 KB checked in by Takemikaduchi, 14 years ago (diff)

update to GNOME-2.32.0

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define glib2_version 2.26.0
4%define dbus_version 1.4.0
5%define eggdbus_version 0.6
6%define gcrypt_version 1.4.6
7
8Summary: Framework for managing passwords and other secrets
9Name: libgnome-keyring
10Version: 2.32.0
11Release: 1%{?_dist_release}
12License: GPLv2+ and LGPLv2+
13Group: System Environment/Libraries
14Source: http://ftp.gnome.org/pub/GNOME/sources/libgnome-keyring/2.32/libgnome-keyring-%{version}.tar.bz2
15URL: http://live.gnome.org/GnomeKeyring
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18BuildRequires: glib2-devel >= %{glib2_version}
19BuildRequires: dbus-devel >= %{dbus_version}
20BuildRequires: eggdbus-devel >= %{eggdbus_version}
21BuildRequires: libgcrypt-devel >= %{gcrypt_version}
22BuildRequires: intltool
23Conflicts: gnome-keyring < 2.29.4
24
25
26%description
27gnome-keyring is a program that keep password and other secrets for
28users. The library libgnome-keyring is used by applications to integrate
29with the gnome-keyring system.
30
31%package devel
32Summary: Development files for libgnome-keyring
33License: LGPLv2+
34Group: Development/Libraries
35Requires: %{name} = %{version}-%{release}
36Requires: glib2-devel
37Requires: pkgconfig
38Requires: gtk-doc
39Conflicts: gnome-keyring-devel < 2.29.4
40
41%description devel
42The libgnome-keyring-devel package contains the libraries and
43header files needed to develop applications that use libgnome-keyring.
44
45
46# compat32
47%package -n compat32-%{name}
48Summary: Framework for managing passwords and other secrets
49Group: System Environment/Libraries
50Requires: %{name} = %{version}-%{release}
51
52%description -n compat32-%{name}
53gnome-keyring is a program that keep password and other secrets for
54users. The library libgnome-keyring is used by applications to integrate
55with the gnome-keyring system.
56
57
58%package -n compat32-%{name}-devel
59Summary: Development files for libgnome-keyring
60License: LGPLv2+
61Group: Development/Libraries
62Requires: compat32-%{name} = %{version}-%{release}
63Requires: compat32-glib2-devel
64Conflicts: compat32-gnome-keyring-devel < 2.29.4
65
66%description -n compat32-%{name}-devel
67The libgnome-keyring-devel package contains the libraries and
68header files needed to develop applications that use libgnome-keyring.
69
70
71%prep
72%setup -q -n libgnome-keyring-%{version}
73
74%build
75%configure --disable-gtk-doc
76sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
77sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
78
79# avoid unneeded direct dependencies
80sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' libtool
81
82make %{?_smp_mflags}
83
84%install
85rm -rf $RPM_BUILD_ROOT
86make install DESTDIR=$RPM_BUILD_ROOT
87rm $RPM_BUILD_ROOT%{_libdir}/*.la
88
89%find_lang libgnome-keyring
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94
95%post -p /sbin/ldconfig
96
97%postun -p /sbin/ldconfig
98
99
100%files -f libgnome-keyring.lang
101%defattr(-, root, root, -)
102%doc AUTHORS NEWS README COPYING HACKING
103%{_libdir}/lib*.so.*
104
105%files devel
106%defattr(-, root, root, -)
107%{_libdir}/lib*.so
108%{_libdir}/pkgconfig/*
109%{_includedir}/*
110%doc %{_datadir}/gtk-doc/html/gnome-keyring/
111
112# compat32
113%if %{build_compat32}
114%files -n compat32-%{name}
115%defattr(-, root, root, -)
116%{_libdir}/lib*.so.*
117
118%files -n compat32-%{name}-devel
119%defattr(-, root, root, -)
120%{_libdir}/lib*.so
121%{_libdir}/pkgconfig/*
122%endif
123
124%changelog
125* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.32.0-1
126- new upstream release
127
128* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.1-2
129- build with rpm-4.8.1-1 for pkg-config file
130
131* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.30.1-1
132- new upstream release
133
134* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.30.0-1
135- initial build for Vine Linux
136
137
138* Mon Mar 22 2010 Tomas Bzatek <tbzatek@redhat.com> - 2.29.92-git20100322.1
139- Update to a new git snapshot
140
141* Wed Mar 17 2010 Tomas Bzatek <tbzatek@redhat.com> - 2.29.92-git20100317.1
142- Update to 2.29.92 git snapshot
143
144* Wed Feb 17 2010 Tomas Bzatek <tbzatek@redhat.com> - 2.29.4-4
145- When no password is found, return GNOME_KEYRING_RESULT_NO_MATCH
146
147* Tue Feb 16 2010 Tomas Bzatek <tbzatek@redhat.com> - 2.29.4-3
148- Fix assertion when password is not found
149
150* Mon Jan 25 2010 Tomas Bzatek <tbzatek@redhat.com> - 2.29.4-2
151- Fix assertion calling deprecated acl function
152- Clear the client's session when the service disconnects
153- Implement setting of Type property in gnome_keyring_item_set_info()
154
155* Thu Jan  7 2010 Tomas Bzatek <tbzatek@redhat.com> - 2.29.4-1
156- Initial packaging
Note: See TracBrowser for help on using the repository browser.