source: projects/specs/branches/6/lib/libg/libgksu/libgksu-vl.spec @ 4221

Revision 4221, 7.7 KB checked in by daisuke, 13 years ago (diff)

libgksu: add revert forkpty patch

Line 
1Summary: GKSu libraries
2SUmmary(ja): GKSu ライブラリ
3Name: libgksu
4Version: 2.0.12
5Release: 2%{?_dist_release}
6Url: http://www.nongnu.org/gksu/
7Group: System Environment/Libraries
8License: GPL
9
10Vendor: Project Vine
11Distribution: Vine Linux
12Packager: daisuke
13
14Source: http://people.debian.org/~kov/gksu/%{name}-%{version}.tar.gz
15Source10: libgksu-2.0.9-ja.po
16Patch0: libgksu-2.0.5-i18n.patch
17Patch1: libgksu-2.0.9-ja.patch
18
19# patches from ubuntu
20Patch9: libgksu-2.0.9-multihead.patch
21Patch12: libgksu-2.0.9-no_password_dialog.patch
22Patch13: libgksu-2.0.9-startup_notification.diff
23Patch14: libgksu-2.0.9-polish_startup.diff
24Patch15: libgksu-2.0.12-extra_paranoia_for_gconf.diff.patch
25Patch17: libgksu-2.0.9-composited_fade.patch
26Patch18: libgksu-2.0.9-g_markup_escape_text_for_command.patch
27Patch20: libgksu-2.0.9-better_usleep.patch
28Patch21: libgksu-2.0.9-composited_rgba_addition.patch
29Patch22: libgksu-2.0.9-sudo_keep_env.patch
30Patch30:  libgksu-2.0.12-revert-forkpty.patch
31
32Patch100: libgksu-2.0.12-default-sudo_mode.patch
33
34BuildRoot: %{_tmppath}/%{name}-buildroot
35BuildRequires: glib2-devel
36BuildRequires: gtk-doc
37BuildRequires: libgtop2-devel
38BuildRequires: startup-notification-devel
39BuildRequires: gnome-keyring-devel
40BuildRequires: libgnome-keyring-devel
41BuildRequires: GConf2-devel
42BuildRequires: gtk2-devel
43BuildRequires: libglade2-devel
44BuildRequires: perl-XML-Parser
45BuildRequires: desktop-file-utils
46
47%description
48GKSu is a library that provides a Gtk+ frontend to su and sudo. It
49supports login shells and preserving environment when acting as a su
50 frontend. It is useful to menu items or other graphical programs
51that need to ask a user's password to run another program as another user.
52
53%package devel
54Summary: Development package for %{name}
55Group: Development/Libraries
56Requires: %{name} = %{version}
57
58%description devel
59Development package for %{name}
60
61GKSu is a library that provides a Gtk+ frontend to su and sudo. It
62supports login shells and preserving environment when acting as a su
63 frontend. It is useful to menu items or other graphical programs
64that need to ask a user's password to run another program as another user.
65
66%package -n gksu-utils
67Summary: Utilities package for %{name}
68Group: Applications/System
69Requires: %{name} = %{version}
70
71%description -n gksu-utils
72Utilities package for %{name}
73
74GKSu is a library that provides a Gtk+ frontend to su and sudo. It
75supports login shells and preserving environment when acting as a su
76 frontend. It is useful to menu items or other graphical programs
77that need to ask a user's password to run another program as another user.
78
79# '
80%prep
81%setup -q
82%patch0 -p1 -b .i18n
83%patch1 -p1 -b .ja
84
85%patch9 -p1 -b .multihead
86%patch12 -p1 -b .no_password_dialog
87%patch13 -p1 -b .startup_notification
88%patch14 -p1 -b .polish_startup
89%patch17 -p1 -b .composited_fade
90%patch18 -p0 -b .g_markup_escape_text_for_command
91%patch20 -p1 -b .better_usleep
92%patch21 -p1 -b .composited_rgba_addition
93%patch22 -p1 -b .sudo_keep_env
94%patch30 -p1 -b .revert_forkpty
95
96%patch100 -p1 -b .default-sudo_mode
97
98## For x86_64, we use /usr/lib64/libgksu/gksu-run-helper
99%__sed -i 's@\(gchar auxcommand\[\] = PREFIX "/\)lib\(/" PACKAGE "/gksu-run-helper";\)@\1%{_lib}\2@' libgksu/libgksu.c
100
101
102cp -f %{SOURCE10} po/ja.po
103
104
105
106%build
107intltoolize -f
108touch README NEWS
109autoreconf -f -i
110%configure
111%__make %{?_smp_mflags}
112
113%install
114rm -rf $RPM_BUILD_ROOT
115%makeinstall
116
117sed -i -e 's/Icon=gksu.png/Icon=gksu/g' $RPM_BUILD_ROOT%{_datadir}/applications/*
118desktop-file-install --vendor="" \
119  --remove-category="Application" \
120  --remove-category="AdvancedSettings" \
121  --add-category="Settings" \
122  --add-category="X-GNOME-SystemSettings" \
123  --dir $RPM_BUILD_ROOT%{_datadir}/applications $RPM_BUILD_ROOT%{_datadir}/applications/*
124
125%find_lang %{name}
126
127rm $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
128
129%clean
130rm -rf $RPM_BUILD_ROOT
131
132%post -p /sbin/ldconfig
133%postun -p /sbin/ldconfig
134
135%post -n gksu-utils
136export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
137gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gksu.schemas > /dev/null ||:
138
139%preun -n gksu-utils
140if [ "$1" -eq 0 ]; then
141  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
142  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gksu.schemas > /dev/null ||:
143fi
144
145%files -f %{name}.lang
146%defattr(-,root,root)
147%{_libdir}/*.so.*
148%{_libdir}/%{name}
149
150%files devel
151%defattr(-,root,root)
152%doc INSTALL ChangeLog AUTHORS
153%{_libdir}/*.so
154%{_includedir}/*
155%{_libdir}/pkgconfig/*
156%{_datadir}/gtk-doc/html/%{name}
157
158%files -n gksu-utils
159%defattr(-,root,root)
160%{_sysconfdir}/gconf/schemas/gksu.schemas
161%{_bindir}/gksu-properties
162%{_datadir}/applications/gksu-properties.desktop
163%{_datadir}/libgksu/gksu-properties.ui
164%{_datadir}/pixmaps/gksu.png
165%{_mandir}/man1/gksu-properties.1*
166
167%changelog
168* Wed Jun 22 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.12-2
169- add patch30 from ubuntu
170  + revert the upstream change to run sudo in a forkpty()
171    environment, this is incompatible with our default sudo
172    tty_tickets configuration
173
174* Tue Jun 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.12-1
175- update to 2.0.12
176- add patch100 to enable sudo_mode by default.
177- add BR: libgnome-keyring-devel
178
179* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.0.9-5
180- rebuilt with rpm-4.8.1 for pkg-config
181
182* Sun Aug 09 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.9-4
183- add Categories=X-GNOME-SystemSettings for .desktop
184
185* Thu Jun 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.0.9-3
186- use /usr/lib64/libgksu/gksu-run-helper for x86_64
187
188* Wed Jun 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.9-2
189- import Patch9-22 from ubuntu
190  - Patch9: fix multihead
191  - Patch12: don't show password dialog if no password was needed
192  - Patch13: make startup notification more reliable
193  - Patch14: improve startup notification messages
194  - Patch17: nicer fadeout on composited display
195  - Patch18: fix missing g_markup_escape when commands are displayed
196  - Patch20: add small usleep() to avoid race condition when
197             the hostname can not be resolved.
198  - Patch21: bling
199  - Patch22: If gksudo -k is used, pass the -E option to sudo
200             to preserve the environment if we're allowed to do so
201- update ja.po
202
203* Wed May 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.9-1
204- new upstream release
205- remove static library
206
207* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.7-1
208- new upstream release
209- new versioning policy
210
211* Sat Aug 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.5-0vl1
212- initial build for Vine Linux
213
214* Tue Jul 03 2007 Emmanuel Andry <eandry@mandriva.org> 2.0.5-1mdv2008.0
215+ Revision: 47621
216- new version
217
218* Fri Jun 22 2007 Thierry Vignaud <tvignaud@mandriva.com> 2.0.4-2mdv2008.0
219+ Revision: 43013
220- remove "AdvancedSettings" category from menu
221- kill X-MandrivaLinux-System-Configuration-Other
222- fix group
223
224
225* Tue Mar 06 2007 Emmanuel Andry <eandry@mandriva.org> 2.0.4-1mdv2007.0
226+ Revision: 134081
227- New version 2.0.4
228- disable gtk-doc (build problem)
229
230* Tue Feb 20 2007 G旦tz Waschk <waschk@mandriva.org> 2.0.3-5mdv2007.1
231+ Revision: 123029
232- fix scripts
233
234* Sat Jan 27 2007 Emmanuel Andry <eandry@mandriva.org> 2.0.3-4mdv2007.1
235+ Revision: 114416
236- xdg menu
237  handles gconf schemas
238
239* Sat Jan 06 2007 Emmanuel Andry <eandry@mandriva.org> 2.0.3-3mdv2007.1
240+ Revision: 104863
241- fix provides
242
243* Sat Jan 06 2007 Emmanuel Andry <eandry@mandriva.org> 2.0.3-2mdv2007.1
244+ Revision: 104797
245- rebuild
246
247* Sat Jan 06 2007 Emmanuel Andry <eandry@mandriva.org> 2.0.3-1mdv2007.1
248+ Revision: 104663
249- buildrequires perl-XML-Parser
250- buildrequires libglade2.0-devel
251- buildrequires libGConf2-devel
252  buildrequires gtk+2-devel
253- buildrequires startup-notification-devel
254  gnome-keyring-devel
255- New version 2.0.3
256  fix provides
257  buildrequires libgtop2.0-devel
258
259  + J辿r担me Soyer <saispo@mandriva.org>
260    - Import libgksu
261
Note: See TracBrowser for help on using the repository browser.