source: projects/specs/branches/6/lib/libe/libexo/libexo-vl.spec @ 3945

Revision 3945, 6.1 KB checked in by inagaki, 13 years ago (diff)

update: libexo, garcon
new: xfce4-power-manager

Line 
1%define srcname exo
2
3Summary: extension library to Xfce
4Summary(ja): Xfce の拡張ライブラリ
5Name: libexo
6Version: 0.6.1
7Release: 1%{?_dist_release}
8
9Group: System Environment/Libraries
10License: LGPLv2
11URL: http://www.xfce.org/
12
13Source0: http://archive.xfce.org/src/xfce/exo/0.6/%{srcname}-%{version}.tar.bz2
14
15# FIXME: upstream this patch
16Patch0:  exo-0.5.4-x86_64-build.patch
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: glib2-devel >= 2.27.0
20BuildRequires: gtk2-devel >= 2.14.0
21BuildRequires: libSM-devel
22BuildRequires: intltool >= 0.31
23BuildRequires: libxfce4util-devel >= 4.8.0
24BuildRequires: libnotify-devel >= 0.4.0
25BuildRequires: python-devel
26BuildRequires: pygtk2-devel
27BuildRequires: perl-URI
28BuildRequires: chrpath
29Requires(post): gtk2
30Requires(postun): gtk2
31
32Provides: %{srcname} = %{version}-%{release}
33
34Vendor: Project Vine
35Distribution: Vine Linux
36
37%description
38libexo is the extension library to Xfce developed by os-cillation.
39While Xfce ships with quite a few libraries that are primarly targeted
40at desktop development, libexo is targeted at application development,
41with a focus on applications for Xfce.
42
43%description -l ja
44libexo は os-cillation により開発された Xfce の拡張ライブラリです.
45Xfce はデスクトップ環境の開発を第一の目的としたごくわずかのライブラリ
46と共に作成されていますが,libexo はアプリケーションの開発,それも
47Xfce 用のアプリケーション開発に焦点を定めています.
48
49%package -n %{name}-devel
50Summary: Header files and libraries for developing apps which will use %{name}
51Summary(ja): libexo の開発用ヘッダファイル及びライブラリ
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54Requires: gtk2-devel >= 2.6.0
55Requires: libxfce4util-devel >= 4.2.2
56Provides: %{srcname}-devel = %{version}-%{release}
57
58%description -n %{name}-devel
59The libexo-devel package contains the header files and libraries needed
60to develop programs that use the libexo library.
61
62%description -n %{name}-devel -l ja
63libexo-develはlibexoライブラリを用いるプログラムの開発に
64必要なヘッダファイル及びライブラリを含むパッケージです。
65
66%prep
67%setup -q -n %{srcname}-%{version}
68%patch0 -p1 -b .x86_64-build
69
70%build
71%configure --disable-static
72%__make
73
74%install
75rm -rf $RPM_BUILD_ROOT
76make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
77
78rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
79rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
80
81chrpath --delete $RPM_BUILD_ROOT%{_bindir}/exo-desktop-item-edit
82chrpath --delete $RPM_BUILD_ROOT%{_bindir}/exo-open
83chrpath --delete $RPM_BUILD_ROOT%{_libdir}/xfce4/exo-*/exo-helper-*
84chrpath --delete $RPM_BUILD_ROOT%{_libdir}/python*/site-packages/exo-*/_exo.so
85#chrpath --delete $RPM_BUILD_ROOT%{_libdir}/gio/modules/libexo-module-*.so
86
87rm -rf _docs_to_include
88mkdir -p _docs_to_include
89mv $RPM_BUILD_ROOT%{_docdir}/exo/html _docs_to_include/
90rm -rf $RPM_BUILD_ROOT%{_docdir}/exo
91
92%find_lang exo-1
93
94%clean
95rm -rf $RPM_BUILD_ROOT
96
97%post
98/sbin/ldconfig
99touch --no-create %{_datadir}/icons/hicolor
100
101%postun
102/sbin/ldconfig
103if [ $1 -eq 0 ]; then
104    touch --no-create %{_datadir}/icons/hicolor
105    /usr/bin/gtk-update-icon-cache -qf %{_datadir}/icons/hicolor;
106fi
107
108%posttrans
109gtk-update-icon-cache %{_iconsdir}/icons/hicolor &> /dev/null || :
110
111
112%files -f exo-1.lang
113%defattr(-,root,root)
114%doc AUTHORS COPYING ChangeLog README THANKS TODO
115%doc _docs_to_include/*
116%config(noreplace) %{_sysconfdir}/xdg/xfce4/helpers.rc
117%{_bindir}/*
118%{_libdir}/lib*.so.*
119%{_libdir}/python?.?/site-packages/*
120%{_libdir}/xfce4/*
121%{_datadir}/applications/*.desktop
122%{_datadir}/icons/hicolor/*/apps/*.png
123%{_datadir}/pixmaps/exo-1
124%{_datadir}/pygtk/2.0/*
125%{_datadir}/xfce4/helpers
126%{_mandir}/man1/*
127
128%files -n %{name}-devel
129%defattr(-,root,root)
130%{_libdir}/lib*.so
131%{_libdir}/pkgconfig/*.pc
132%{_includedir}/exo-1
133%{_datadir}/gtk-doc/html/exo-1
134
135%changelog
136* Mon May 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.1-1
137- new upstrem release
138
139* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.0-2
140- add BuildRequires: libSM-devel
141
142* Mon Mar 28 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.0-1
143- new upstrem release
144
145* Thu Sep 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.107-2
146- rebuilt with rpm-4.8.1 for pkg-config
147
148* Sun May 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.107-1
149- new upstrem release
150- built with new toolchain
151
152* Mon Feb  8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.106-1
153- new upstrem release
154- added BR: perl-URI
155
156* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.3.105-2
157- rebuilt with python-2.6.4
158
159* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.105-1
160- new upstrem release
161
162* Fri May 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.101-1
163- new upstrem release
164- removed lib*.a from devel package
165
166* Sun Aug 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.4-1
167- applied with new versioning policy
168- spec in UTF-8
169
170* Fri Jan 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.3.4-0vl3
171- add BuildRequires: libnotify >= 0.4.0, xfce-mcs-plugins >= 4.2.2
172
173* Sun Dec 23 2007 UECHI Yasumasa <uechi@potaway.net> 0.3.4-0vl2
174- new upstream release.
175
176* Sun Jul 29 2007 UECHI Yasumasa <uechi@potaway.net> 0.3.2-0vl2
177- build for VineSeed
178
179* Sat Jul 28 2007 UECHI Yasumasa <uechi@potaway.net> 0.3.2-0vl1
180- new upstream version
181- add %{_sysconfdir}/xdg/xfce4/helpers.rc in files section.
182- add %{_bindir}/* in files section.
183- add %{_libdir}/xfce4 in files section.
184- add %{_libexecdir}/* in files section.
185- add %{_datadir}/icons/hicolor/*/apps/*.png in files section.
186- add %{_mandir}/man1/* in files section.
187- add %{_datadir}/xfce4/doc/*/* in files section.
188- add %{_datadir}/xfce4/helpers in files section.
189- remove %{_datadir}/gtk-doc/html/exo in files section.
190- update icon-cache in %post and %postun.
191
192* Fri Aug 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl3
193- changed Group to System Environment/Libraires
194- changed devel Group to Development/Libraries
195- added %post and %postun section
196
197* Fri Apr 22 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.3.0-0vl2
198- rebuild for VineSeed
199
200* Sun Apr 17 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.3.0-0vl1
201- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.