source: projects/specs/branches/6/lib/libd/libdvdread/libdvdread-vl.spec @ 5086

Revision 5086, 5.9 KB checked in by munepi, 12 years ago (diff)

libdvdnav, libmp4v2: changed to plus category; updated libdvdnav, libdvdread: new upstream release

Line 
1# -*- coding: utf-8-unix -*-
2Name:           libdvdread
3Summary:        A library for reading DVD video discs based on Ogle code
4Version:        4.2.0
5Release:        1%{?_dist_release}
6
7Group:          System Environment/Libraries
8License:        GPLv2+
9Source0:        http://dvdnav.mplayerhq.hu/releases/libdvdread-%{version}.tar.bz2
10# dvdread-config: use pkg-config instead of hard-coded
11# multilib-conflicting values
12Patch1:         %{name}-multilib.patch
13
14Obsoletes:      self-build-libdvdread
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18Vendor:         Project Vine
19Distribution:   Vine Linux
20Packager:       munepi
21
22
23%description
24libdvdread provides a simple foundation for reading DVD video disks.
25It provides the functionality that is required to access many DVDs.
26
27%package        devel
28Summary:        Development files for libdvdread
29Group:          Development/Libraries
30Requires:       %{name} = %{version}-%{release}
31Requires:       pkgconfig
32
33%description    devel
34libdvdread provides a simple foundation for reading DVD video disks.
35It provides the functionality that is required to access many DVDs.
36
37This package contains development files for libdvdread.
38
39%prep
40%setup -q
41%patch1 -p1 -b .multilib
42
43%build
44./configure2 \
45    --disable-opts \
46    --disable-static \
47    --disable-strip \
48    --extra-cflags="%{optflags}" \
49    --libdir=%{_libdir} \
50    --prefix=%{_prefix} \
51    --shlibdir=%{_libdir} \
52    ;
53%{__make} %{?_smp_mflags}
54
55%install
56%{__rm} -rf %{buildroot}
57%{__make} install DESTDIR=%{buildroot}
58
59%clean
60%{__rm} -rf %{buildroot}
61
62%post -p /sbin/ldconfig
63
64%postun -p /sbin/ldconfig
65
66%files
67%defattr(-,root,root,-)
68%doc AUTHORS COPYING ChangeLog README
69%{_libdir}/libdvdread.so.*
70
71%files devel
72%defattr(-,root,root,-)
73%doc DEVELOPMENT-POLICY.txt TODO
74%{_bindir}/dvdread-config
75%{_includedir}/dvdread
76%{_libdir}/libdvdread.so
77%{_libdir}/pkgconfig/dvdread.pc
78
79%changelog
80* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 4.2.0-1
81- updated to 4.2.0 release
82- dropped obsolete endianness check patch
83- simplified multilib patch from Fedora rawhide
84- added some docs
85- added Vendor, Distribution, Packager tags
86
87* Sat Sep 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.1.3-4
88- rebuilt with rpm-4.8.1 for pkg-config
89
90* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.1.3-3
91- add Patch10: fix DVD playback failure on ppc (big endian, more precisely)
92
93* Fri Nov 07 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.1.3-2
94- obsolete self-build-libdvdread
95
96* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.1.3-1
97- initial bulid based on Fedora package
98
99* Tue Sep 09 2008 Dominik Mierzejewski <rpm@greysector.net> 4.1.3-1
100- update to 4.1.3 final
101
102* Sun Aug 31 2008 Dominik Mierzejewski <rpm@greysector.net> 4.1.3-0.3.rc1
103- update to 4.1.3rc1
104- fix include path
105
106* Thu Jul 17 2008 Dominik Mierzejewski <rpm@greysector.net> 4.1.3-0.2
107- resurrect package from new upstream
108
109* Sun Jan 27 2008 Dominik Mierzejewski <rpm@greysector.net> 0.9.7-4
110- fix missing <inttypes.h> include (bug 428910)
111
112* Wed Aug 29 2007 Dominik Mierzejewski <rpm@greysector.net> 0.9.7-3
113- rebuild for BuildID
114- update license tag
115
116* Wed Nov 26 2006 Dominik Mierzejewski <rpm@greysector.net> 0.9.7-2
117- Rebuild.
118
119* Fri Oct  6 2006 Dams <anvil[AT]livna.org> - 0.9.7-1
120- Updated to 0.9.7
121
122* Wed Sep 20 2006 Ville Skytt霎ー <ville.skytta at iki.fi> - 0.9.6-2
123- Rebuild.
124
125* Sun Jul 23 2006 Ville Skytt霎ー <ville.skytta at iki.fi> - 0.9.6-1
126- 0.9.6.
127- Specfile cleanup.
128
129* Thu Mar 16 2006 Ville Skytt霎ー <ville.skytta at iki.fi> - 0.9.4-4
130- Fix linking with libdl on x86_64.
131- Don't ship static libs.
132- Build with dependency tracking disabled.
133- Convert specfile and docs to UTF-8.
134- Improve package descriptions.
135
136* Thu Mar 16 2006 Dams <anvil[AT]livna.org> - 0.9.4-3
137- We BuildConflicting libdvdcss-devel at build time
138
139* Mon Mar 13 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> 0.9.4-2
140- Drop Epoch completely
141
142* Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
143- switch to new release field
144- drop Epoch
145
146* Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
147- add dist
148
149* Thu Apr  3 2003 Marius Johndal <mariuslj at ifi.uio.no> 0:0.9.4-0.fdr.1
150- Initial Fedora RPM release.
151
152* Mon Mar 31 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
153- Rebuilt for Red Hat Linux 9.
154- Exclude .la file.
155
156* Sun Feb 16 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
157- Update to 0.9.4.
158
159* Thu Sep 26 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
160- Updated to the latest cvs release.
161- Rebuilt for Red Hat Linux 8.0.
162- Updated URLs.
163
164* Mon May 27 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
165- Update to 0.9.3.
166
167* Wed May 15 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
168- Fixed the libdvdcss.so.0/1/2 problem again.
169
170* Thu May  2 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
171- Back to using libdvdcss 1.1.1, now it's all merged and fine.
172- Rebuilt against Red Hat Linux 7.3.
173- Added the %{?_smp_mflags} expansion.
174
175* Sat Jan 12 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
176- Reverted back to using libdvdcss 0.0.3.ogle3 since it works MUCH better
177  than 1.0.x. Doh!
178
179* Tue Nov 13 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
180- Rebuilt against libdvdcss 1.0.0 (added a patch).
181
182* Mon Oct 29 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
183- Spec file cleanup and fixes.
184
185* Thu Oct 11 2001 Martin Norb霎ーck <d95mback@dtek.chalmers.se>
186- Updated to version 0.9.2
187
188* Tue Sep 25 2001 Martin Norb霎ーck <d95mback@dtek.chalmers.se>
189- Added small patch to fix the ldopen of libdvdcss
190
191* Tue Sep 18 2001 Martin Norb霎ーck <d95mback@dtek.chalmers.se>
192- Updated to version 0.9.1
193
194* Fri Sep 14 2001 Martin Norb霎ーck <d95mback@dtek.chalmers.se>
195- Split into normal and devel package
196
197* Thu Sep 6 2001 Martin Norb霎ーck <d95mback@dtek.chalmers.se>
198- Updated to version 0.9.0
199
200* Tue Jul 03 2001 Martin Norb霎ーck <d95mback@dtek.chalmers.se>
201- initial version
202
203
Note: See TracBrowser for help on using the repository browser.