source: projects/specs/branches/6/lib/libc/libcrystalhd/libcrystalhd-vl.spec @ 3815

Revision 3815, 5.0 KB checked in by Takemikaduchi, 13 years ago (diff)

fix for ppc

Line 
1Summary:        Broadcom Crystal HD device interface library
2Name:           libcrystalhd
3Version:        3.5.1
4Release:        2%{?_dist_release}
5License:        LGPLv2
6Group:          System Environment/Libraries
7#Source:         http://www.broadcom.com/docs/support/crystalhd/crystalhd_linux_20100703.zip
8# This tarball and README are inside the above zip file...
9Source0:        crystalhd_07032010.tbz2
10Source1:        README_07032010
11# We're going to use even newer firmware for now
12Source2:        bcm70012fw.bin
13Source3:        bcm70015fw.bin
14# LICENSE file is copy-n-pasted from http://www.broadcom.com/support/crystal_hd/
15Source4:        LICENSE
16Requires:       crystalhd-firmware
17URL:            http://www.broadcom.com/support/crystal_hd/
18# Patch generated from http://git.wilsonet.com/crystalhd.git/
19Patch0:         libcrystalhd-updates.patch
20# patch for ppc
21Patch1:         libcrystalhd-ppc.patch
22ExcludeArch:    s390 s390x
23BuildRequires:  autoconf automake
24
25%description
26The libcrystalhd library provides userspace access to Broadcom Crystal HD
27video decoder devices. The device supports hardware decoding of MPEG-2,
28h.264 and VC1 video codecs, up to 1080p at 40fps for the first-generation
29bcm970012 hardware, and up to 1080p at 60fps for the second-generation
30bcm970015 hardware.
31
32%package devel
33Summary:       Development libs for libcrystalhd
34Group:         Development/Libraries
35Requires:      %{name} = %{version}-%{release}
36
37%description devel
38Development libraries needed to build applications against libcrystalhd.
39
40%package -n crystalhd-firmware
41Summary:       Firmware for the Broadcom Crystal HD video decoder
42License:       Redistributable, no modification permitted
43BuildArch:     noarch
44Group:         System Environment/Kernel
45Requires:      %{name} = %{version}-%{release}
46
47%description -n crystalhd-firmware
48Firmwares for the Broadcom Crystal HD (bcm970012 and bcm970015)
49video decoders.
50
51%define        majorminor 0.10
52%define        _gst 0.10.30
53%define        _gstpb 0.10.30
54
55%package -n gstreamer-plugin-crystalhd
56Summary:       Gstreamer crystalhd decoder plugin
57Group:         Applications/Multimedia
58Requires:      %{name} = %{version}-%{release}
59Requires:      gstreamer-plugins-base
60BuildRequires: gstreamer-devel >= %{_gst}
61BuildRequires: gstreamer-plugins-base-devel >= %{_gstpb}
62
63%description -n gstreamer-plugin-crystalhd
64Gstreamer crystalhd decoder plugin
65
66%prep
67%setup -q -n 07032010
68%patch0 -p1 -b .git
69%ifarch ppc
70%patch1 -p1 -b .ppc
71%endif
72cp %{SOURCE1} %{SOURCE4} .
73
74%build
75pushd linux_lib/libcrystalhd/ > /dev/null 2>&1
76# FIXME: this doesn't work just yet...
77#make CPPFLAGS="%{optflags}" %{?_smp_mflags}
78make %{?_smp_mflags}
79popd > /dev/null 2>&1
80pushd filters/gst/gst-plugin/ > /dev/null 2>&1
81%configure
82make %{?_smp_mflags}
83popd > /dev/null 2>&1
84
85%install
86rm -rf $RPM_BUILD_ROOT
87pushd linux_lib/libcrystalhd/ > /dev/null 2>&1
88make install LIBDIR=%{_libdir} DESTDIR=$RPM_BUILD_ROOT
89popd > /dev/null 2>&1
90pushd filters/gst/gst-plugin/ > /dev/null 2>&1
91make install DESTDIR=$RPM_BUILD_ROOT
92rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-0.10/libgstbcmdec.{a,la}
93popd > /dev/null 2>&1
94cp -p %{SOURCE2} $RPM_BUILD_ROOT/lib/firmware/
95cp -p %{SOURCE3} $RPM_BUILD_ROOT/lib/firmware/
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%post -p /sbin/ldconfig
101
102%postun -p /sbin/ldconfig
103
104%files
105%defattr(-,root,root,0755)
106%doc README_07032010 LICENSE
107%{_libdir}/libcrystalhd.so.*
108
109%files devel
110%defattr(-,root,root,0755)
111%dir %{_includedir}/libcrystalhd
112%{_includedir}/libcrystalhd/*
113%{_libdir}/libcrystalhd.so
114
115%files -n crystalhd-firmware
116%defattr(-,root,root,0755)
117%doc LICENSE
118/lib/firmware/bcm70012fw.bin
119/lib/firmware/bcm70015fw.bin
120
121%files -n gstreamer-plugin-crystalhd
122%defattr(-,root,root,0755)
123%{_libdir}/gstreamer-%{majorminor}/*.so
124
125
126%changelog
127* Sun May 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.1-2
128- add Patch1 for ppc (libcrystalhd-ppc.patch)
129
130* Sun Feb 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 3.5.1-1
131- initial build based on Fedora rawhide
132
133* Sat Aug 28 2010 Jarod Wilson <jarod@redhat.com> - 3.5.1-1
134- Update to v3.5.1, now with nv12 support
135
136* Sun Jul 25 2010 Jarod Wilson <jarod@redhat.com> - 3.5.0-2
137- Tarball had object files in it, clean them out before building
138
139* Sat Jul 24 2010 Jarod Wilson <jarod@redhat.com> - 3.5.0-1
140- Rebase to 07032010 crystalhd sources
141- Large version-bump as driver and lib are now essentially 100%
142  in sync with the Windows driver and lib
143- Ship firmware, now that Broadcom has posted a redistribution,
144  no modification license to cover it
145- Build the gstreamer decoder plugin (will be moved to its own
146  package sooner or later)
147
148* Sun Apr 04 2010 Jarod Wilson <jarod@redhat.com> - 0.9.25-4
149- Fix segfault on firmware upload
150
151* Fri Mar 26 2010 Jarod Wilson <jarod@redhat.com> - 0.9.25-3
152- Update to pre-0.9.26 libcrystalhd, which contains support
153  for the new Broadcom BCM970015 Crystal HD decoder card
154
155* Thu Mar 11 2010 Jarod Wilson <jarod@redhat.com> - 0.9.25-2
156- Minor fixups to the as-yet-not-enabled firmware sub-package
157
158* Wed Jan 06 2010 Jarod Wilson <jarod@redhat.com> - 0.9.25-1
159- Initial package
Note: See TracBrowser for help on using the repository browser.