source: projects/specs/branches/6/lib/libc/libconfuse/libconfuse-vl.spec @ 1901

Revision 1901, 3.6 KB checked in by Takemikaduchi, 14 years ago (diff)

rebuild with rpm-4.8.1

Line 
1Name:           libconfuse
2Version:        2.6
3Release:        2%{?_dist_release}
4Summary:        A configuration file parser library
5Summary(ja):    設定ファイル解析ライブラリ
6
7Group:          System Environment/Libraries
8License:        ISC
9URL:            http://www.nongnu.org/confuse/
10Source0:        http://bzero.se/confuse/confuse-%{version}.tar.gz
11BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12
13BuildRequires:  check-devel, pkgconfig
14
15
16%description
17libConfuse is a configuration file parser library, licensed under
18the terms of the ISC license, and written in C. It supports
19sections and (lists of) values (strings, integers, floats,
20booleans or other sections), as well as some other features (such
21as single/double-quoted strings, environment variable expansion,
22functions and nested include statements). It makes it very
23easy to add configuration file capability to a program using
24a simple API.
25
26The goal of libConfuse is not to be the configuration file parser
27library with a gazillion of features. Instead, it aims to be
28easy to use and quick to integrate with your code.
29
30
31%description -l ja
32libConfuse は C で書かれた設定ファイル解析ライブラリで、
33ISC ライセンスで配布されています。文字列、整数、浮動小数点、
34真偽値などの値一覧およびセクションをサポートし、さらに
35シングルクオート/ダブルクオートされた文字列や環境変数の展開、関数、
36ネストしたインクルードもサポートしています。
37シンプルな API を使い、これらの設定ファイル解析昨日をプログラムに
38組み入れることが可能になります。
39
40
41%package devel
42Summary:        Development files for %{name}
43Summary(ja):    %{name} 開発用ファイル
44Group:          Development/Libraries
45Requires:       %{name} = %{version}-%{release}
46Requires:       pkgconfig
47
48
49%description devel
50Development files for %{name}.
51
52
53%description devel -l ja
54%{name} 用開発ファイル
55
56
57%prep
58%setup -q -n confuse-%{version}
59
60
61%build
62%configure --enable-shared --disable-static
63make %{?_smp_mflags} AM_CFLAGS="-Wall -Wextra"
64
65
66%check
67make check
68
69
70%install
71rm -rf $RPM_BUILD_ROOT
72make install DESTDIR=$RPM_BUILD_ROOT
73# Nuke libtool archive(s)
74rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
75# Install man pages
76mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3/
77cp -p doc/man/man3/*.3 $RPM_BUILD_ROOT%{_mandir}/man3/
78# Extract the example sources
79mkdir -p ex2/examples
80cp -p examples/{ftpconf.c,ftp.conf,simple.c,simple.conf,reread.c,reread.conf} \
81    ex2/examples/
82
83%find_lang confuse
84
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89
90%post -p /sbin/ldconfig
91
92
93%postun -p /sbin/ldconfig
94
95
96%files -f confuse.lang
97%defattr(-,root,root,-)
98%doc AUTHORS NEWS README
99%doc doc/html
100%{_libdir}/libconfuse.so.*
101%{_mandir}/man?/*.*
102
103
104%files devel
105%defattr(-,root,root,-)
106%doc ex2/examples
107%{_includedir}/confuse.h
108%{_libdir}/libconfuse.so
109%{_libdir}/pkgconfig/libconfuse.pc
110
111
112%changelog
113* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6-2
114- rebuild with rpm-4.8.1 for pkg-config file
115
116* Mon May 26 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6-1
117- initial build for Vine Linux
118
119* Mon Feb 04 2008 Jarod Wilson <jwilson@redhat.com> 2.6-1
120- New upstream release
121- Switch from LGPL to ISC license
122- Build fix from Hans Ulrich Niedermann
123
124* Tue Sep 05 2006 Jarod Wilson <jwilson@redaht.com> 2.5-3
125- Rebuild for new glibc
126
127* Wed Aug 16 2006 Jarod Wilson <jwilson@redhat.com> 2.5-2
128- Put -devel package in the right Group
129- Add defattr for -devel files
130
131* Wed Aug 16 2006 Jarod Wilson <jwilson@redhat.com> 2.5-1
132- Initial build
Note: See TracBrowser for help on using the repository browser.