source: projects/specs/branches/6/lib/libc/libchamplain/libchamplain-vl.spec @ 2110

Revision 2110, 11.3 KB checked in by Takemikaduchi, 14 years ago (diff)

libchamplain: add Requires, eog: add devel sub package

Line 
1Summary:        Map view for Clutter
2Summary(ja):    Clutter用のマップビューア
3Name:           libchamplain
4Version:        0.8.0
5Release:        2%{?_dist_release}
6License:        LGPLv2+
7Group: System Environment/Libraries
8URL: http://projects.gnome.org/libchamplain/
9Source0: http://download.gnome.org/sources/libchamplain/0.8/%{name}-%{version}.tar.bz2
10
11Requires: gobject-introspection
12
13BuildRequires: clutter-devel
14BuildRequires: clutter-gtk-devel
15BuildRequires: libsoup-devel
16BuildRequires: sqlite3-devel
17BuildRequires: gtk-doc >= 1.14
18BuildRequires: gobject-introspection-devel >= 0.6.8
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20
21%description
22Libchamplain is a C library aimed to provide a ClutterActor to display
23rasterized maps.
24
25%description -l ja
26Libchamplain はラスタライズされたマップを表示するために ClutterActor を提供することを目的とした C ライブラリです。
27
28%package devel
29Summary:        Development files for %{name}
30Group:          Development/Libraries
31
32Requires:       gobject-introspection-devel
33Requires:       gtk-doc
34Requires:       clutter-devel
35Requires:       sqlite3-devel
36Requires:       libsoup-devel
37Requires:       %{name} = %{version}-%{release}
38
39%description devel
40This package contains development files for %{name}.
41
42%package gtk
43Summary:        Gtk+ widget wrapper for %{name}
44Group:          System Environment/Libraries
45
46Requires:       %{name} = %{version}-%{release}
47
48%description gtk
49Libchamplain-gtk is a library providing a GtkWidget to embed %{name}
50into Gtk+ applications.
51
52%package gtk-devel
53Summary:        Development files for %{name}-gtk
54Group:          Development/Libraries
55
56Requires:       gtk-doc
57Requires:       clutter-gtk-devel
58Requires:       gtk2-devel
59Requires:       %{name}-devel = %{version}-%{release}
60Requires:       %{name}-gtk = %{version}-%{release}
61
62%description gtk-devel
63This package contains development files for %{name}-gtk.
64
65%prep
66%setup -q
67
68%build
69%configure --disable-debug --disable-static --enable-gtk --enable-gtk-doc \
70  --enable-introspection=yes --enable-silent-rules
71
72# Omit unused direct shared library dependencies.
73sed --in-place --expression 's! -shared ! -Wl,--as-needed\0!g' libtool
74
75make %{?_smp_mflags}
76
77%install
78rm -rf $RPM_BUILD_ROOT
79
80make install INSTALL="%{__install} -p" DESTDIR=$RPM_BUILD_ROOT
81find $RPM_BUILD_ROOT -type f -name "*.la" -delete
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%post -p /sbin/ldconfig
87
88%postun -p /sbin/ldconfig
89
90%post gtk -p /sbin/ldconfig
91
92%postun gtk -p /sbin/ldconfig
93
94%files
95%defattr(-,root,root,-)
96%doc AUTHORS
97%doc ChangeLog
98%doc COPYING
99%doc NEWS
100%{_libdir}/girepository-1.0/Champlain-0.8.typelib
101%{_libdir}/%{name}-0.8.so.*
102%{_datadir}/vala/vapi/*
103
104%files devel
105%defattr(-,root,root,-)
106%doc demos/animated-marker.c
107%doc demos/launcher.c
108%doc demos/markers.c
109%doc demos/markers.h
110%doc demos/polygons.c
111%doc demos/url-marker.c
112%{_datadir}/gir-1.0/Champlain-0.8.gir
113%{_libdir}/%{name}-0.8.so
114%{_libdir}/pkgconfig/champlain-0.8.pc
115
116%dir %{_datadir}/gtk-doc/html/libchamplain
117%doc %{_datadir}/gtk-doc/html/libchamplain/*
118
119%dir %{_includedir}/%{name}-0.8
120%{_includedir}/%{name}-0.8/champlain
121
122%files gtk
123%defattr(-,root,root,-)
124%{_libdir}/girepository-1.0/GtkChamplain-0.8.typelib
125%{_libdir}/%{name}-gtk-0.8.so.*
126
127%files gtk-devel
128%defattr(-,root,root,-)
129%doc demos/launcher-gtk.c
130%doc demos/markers.c
131%{_datadir}/gir-1.0/GtkChamplain-0.8.gir
132%{_libdir}/%{name}-gtk-0.8.so
133%{_libdir}/pkgconfig/champlain-gtk-0.8.pc
134
135%dir %{_datadir}/gtk-doc/html/libchamplain-gtk
136%doc %{_datadir}/gtk-doc/html/libchamplain-gtk/*
137
138%dir %{_includedir}/%{name}-gtk-0.8
139%{_includedir}/%{name}-gtk-0.8/champlain-gtk
140
141%changelog
142* Tue Oct 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-2
143- add Requires: sqlite3-devel, libsoup-devel (-devel package)
144- add Requires: gtk2-devel (-gtk-devel package)
145
146* Mon Oct 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
147- new upstream release
148- remove BuildRequires: gir-repository-devel
149- fix %files (change version)
150
151* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-2
152- rebuild with rpm-4.8.1 for pkg-config file
153
154* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-1
155- new upstream release
156
157* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.6-1
158- new upstream release
159
160* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.5-1
161- new upstream release
162- fix BuildRequires: gtk-doc >= 1.14
163- add Requires: clutter-devel (devel package)
164- add Requires: clutter-gtk-devel (gtk-devel package)
165
166* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.4-1
167- Initial build for Vine Linux
168- add BuildRequires: sqlite3-devel, gtk-doc, gobject-introspection
169
170
171* Thu Oct 29 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.4.2-1
172- Version bump to 0.4.2.
173  * Fixed acceptable values of "decel-rate". (GNOME Bugzilla #595552)
174  * Fixed GObject Introspection build failure. (GNOME Bugzilla #598942)
175  * http://download.gnome.org/sources/libchamplain/0.4/libchamplain-0.4.2.news
176  * http://download.gnome.org/sources/libchamplain/0.4/libchamplain-0.4.2.changes
177
178* Mon Oct 19 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.4.1-1
179- Version bump to 0.4.1.
180  * Added champlain_view_remove_layer.
181  * ChamplainSelectionLayer now has a "changed" signal.
182  * Added champlain_marker_get_highlighted_text_color,
183    champlain_marker_set_highlighted_text_color and
184    Added champlain_marker_get_highlighted_color.
185  * Fixed slowdowns with big caches.
186  * Don't emit invalid latitude and longitude notifications.
187  * Ensure map is displayed in Eye of GNOME's champlain plugin. (GNOME
188    Bugzilla #598106)
189  * http://download.gnome.org/sources/libchamplain/0.4/libchamplain-0.4.1.news
190  * http://download.gnome.org/sources/libchamplain/0.4/libchamplain-0.4.1.changes
191
192- Enabled GObject Introspection, and added 'Requires: gobject-introspection'
193  and 'BuildRequires: gir-repository-devel'. Patched to fix build failure.
194  (GNOME Bugzilla #598942)
195- Explicitly disabled debug code.
196- RPaths fixed by upstream. Removed 'BuildRequires: chrpath'.
197
198* Mon Sep 21 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.4.0-1
199- Version bump to 0.4.0.
200  * ChamplainView now has keyboard shortcuts (but not when used with
201    GtkChamplainEmbed).
202  * Removed deprecated symbols introduced in 0.3.
203  * Fixed X error when using GtkChamplainEmbed. (GNOME Bugzilla #590692)
204  * Events were not being sent until the mouse moved. (GNOME Bugzilla #590727)
205  * Fixed memory leak in ChamplainLayer. (GNOME Bugzilla #593505)
206  * Initial center_on should not result on the map being in Antarctica.
207    (GNOME Bugzilla #594963)
208  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.92.news
209  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.92.changes
210
211* Mon Aug 24 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.91-1
212- Version bump to 0.3.91.
213  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.91.news
214
215* Tue Aug 11 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.90-1
216- Version bump to 0.3.90.
217  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.90.news
218  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.90.changes
219
220* Mon Aug  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.6-1
221- Version bump to 0.3.6.
222  * New marker animation API.
223  * Ported to Clutter 1.0. (GNOME Bugzilla #576391)
224  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.6.news
225  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.6.changes
226
227* Sat Aug 02 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.3.5-1
228- Version bump to 0.3.5.
229  * Marker selection API. (GNOME Bugzilla #577909)
230  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.5.news
231  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.4.news
232  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.5.changes
233  * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.4.changes
234
235* Fri Jul 24 2009 Release Engineering <rel-eng@fedoraproject.org> - 0.3.3-2
236- Autorebuild for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
237
238* Sat Jul 11 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.3.3-1
239- Version bump to 0.3.3.
240  * Support for custom map sources and listing available map sources.
241  * Smooth movement to a new position. (GNOME Bugzilla #557641)
242  * Keep the center of the map in the center after a resize. (GNOME Bugzilla
243    #557642)
244  * Double click to zoom and center. (GNOME Bugzilla #557644)
245  * Added a way to know the maximum and minimum zoom level. (GNOME Bugzilla
246    #557965)
247  * Fixed unwanted wrap effect when panning at zoom level >= 8. (GNOME
248    Bugzilla #558020)
249  * Fixed center on and zooming in behavior. (GNOME Bugzilla #558026)
250  * Lack of user feedback during loading of tiles. (GNOME Bugzilla #559522)
251  * Added missing zoom level to OpenStreetMap Mapnik. (GNOME Bugzilla
252    #559446)
253  * Fixed wrong elastic effect affecting Emapthy's map view. (GNOME Bugzilla
254    #561700)
255  * Added disk cache management. (GNOME Bugzillla #568931)
256  * Host application should be able to limit the maximum and minimum zoom
257    levels. (GNOME Bugzilla #571702)
258  * Allow host applications to draw lines/routes on the map. (GNOME Bugzilla
259    #572377)
260  * Support proxies. (GNOME Bugzilla #573937)
261  * Provide a way to make visible a bunch of markers. (GNOME Bugzilla #574809)
262  * Do not allow negative zoom levels. (GNOME Bugzilla #575138)
263  * Fixed corrupted map when double-clicking at maximum level. (GNOME Bugzilla
264    #575139)
265  * Prevent ChamplainNetworkMapSource from crashing when setting "proxy-uri".
266    (GNOME Bugzilla #575902).
267  * Implemented advanced markers. (GNOME Bugzilla #576055)
268  * Various memory management fixes for ChamplainTile. (GNOME Bugzilla
269    #576159)
270  * Any go_to should stop a previous and not yet finished go_to. (GNOME
271    Bugzilla #576832)
272  * Prevent segmentation fault on 32 bit platforms. (GNOME Bugzilla #576698)
273  * Introduced a new signal called ChamplainView::animation-completed. (GNOME
274    Bugzilla #577169)
275  * Set decel-rate correctly. (GNOME Bugzilla #580785)
276  * champlain_network_map_source_fill_tile should be private. (GNOME Bugzilla
277    #582786)
278  * Fixed champlain_view_center_on. (GNOME Bugzilla #583502)
279  * Fixed "longitude" and "latitude" properties, which were reversed. (GNOME
280    Bugzilla #584365)
281  * Make the cache work the first time. (GNOME Bugzilla #584390)
282  * GNOME Goal: use accessor functions instead direct access. (GNOME Bugzilla
283    #585698)
284- Added 'BuildRequires: chrpath' for removing rpaths.
285
286* Wed Mar 18 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.2.9-1
287- Version bump to 0.2.9.
288  * Fixed elastic effect.
289  * Reduced exported symbols.
290
291* Wed Feb 25 2009 Release Engineering <rel-eng@fedoraproject.org> - 0.2.8-3
292- Autorebuild for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
293
294* Wed Jan 28 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.2.8-2
295- Removed 'Requires: clutter-devel >= 0.8 pkgconfig' from libchamplain-devel
296  for all distributions, except Fedora 10.
297- Fixed sample code to not use generic headers.
298
299* Wed Jan 14 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.2.8-1
300- Initial build. Imported SPEC from openSUSE.
301  * Added a new constructor for ChamplainMarkers made of an image.
302  * Double clicking on the map will now zoom and recenter.
303  * When resizing a ChamplainView, the centered content will still be
304    centered after the resizing. Can be disabled.
305  * The Map's license is displayed by default on the lower right corner.
306  * Fixed map centering on startup.
307  * Fixed missing zoom level in OpenStreetMap Mapnik.
308  * Fixed zooming and centering behaviour. (GNOME Bugzilla #558026)
Note: See TracBrowser for help on using the repository browser.