source: projects/specs/branches/6/lib/libc/libcdio/libcdio-vl.spec @ 1865

Revision 1865, 5.9 KB checked in by inagaki, 14 years ago (diff)

built with rpm-4.8.1: libcdio, libexif, libmowgli, libplist, libusb, exif, mcs

Line 
1Summary: CD-ROM input and control library
2Summary(ja): CD-ROM 入力・制御ライブラリ
3Name: libcdio
4Version: 0.82
5Release: 2%{?_dist_release}
6
7Group: System Environment/Libraries
8License: GPLv3+
9URL: http://www.gnu.org/software/libcdio/
10
11Source0: http://ftp.gnu.org/gnu/libcdio/libcdio-%{version}.tar.bz2
12Source1: http://ftp.gnu.org/gnu/libcdio/libcdio-%{version}.tar.bz2.sig
13Source2: libcdio-no_date_footer.hml
14Patch1: libcdio-0.80-paranoia-fix.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: pkgconfig doxygen
18BuildRequires: ncurses-devel
19BuildRequires: libcddb-devel
20BuildRequires: help2man
21BuildRequires: gcc-c++
22Requires(post): /sbin/install-info
23Requires(preun): /sbin/install-info
24
25%description
26This library provides an interface for CD-ROM access. It can be used
27by applications that need OS- and device-independent access to CD-ROM
28devices.
29
30%package        devel
31Summary:        Development files for %{name}
32Summary(ja):    %{name} の開発用ファイル
33Group:          Development/Libraries
34Requires:       %{name} = %{version}-%{release}
35
36%description devel
37This package contains development files for %{name}.
38
39
40%prep
41%setup -q
42#patch1 -p1 -b .paranoia_pc
43
44f=src/cd-paranoia/doc/ja/cd-paranoia.1.in
45iconv -f euc-jp -t utf-8 -o $f.utf8 $f && mv $f.utf8 $f
46
47%build
48#libtoolize --force  || :
49#aclocal  || :
50#autoheader  || :
51#automake  || :
52#autoconf  || :
53%configure \
54    --disable-vcd-info \
55    --disable-dependency-tracking \
56    --disable-rpath \
57    --enable-cddb \
58    --disable-static
59
60#    --disable-cddb \
61
62make %{?_smp_mflags}
63cd doc/doxygen
64sed -i -e "s,HTML_FOOTER.*$,HTML_FOOTER = libcdio-no_date_footer.hml,g" Doxyfile
65cp %{SOURCE2} .
66./run_doxygen
67
68
69%install
70rm -rf $RPM_BUILD_ROOT
71make install DESTDIR=$RPM_BUILD_ROOT
72
73rm -f $RPM_BUILD_ROOT%{_infodir}/dir
74find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
75
76mv $RPM_BUILD_ROOT%{_mandir}/{jp,ja}
77
78rm -rf examples
79mkdir -p examples/C++
80cp -a example/{*.c,README} examples
81cp -a example/C++/{*.cpp,README} examples/C++
82
83
84%check
85# disable test using local CDROM
86%{__sed} -i -e  "s,testiso9660\$(EXEEXT),,g" \
87            -e "s,check_paranoia.sh check_opts.sh, check_opts.sh,g" \
88            test/Makefile
89make check
90
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95
96%post
97/sbin/ldconfig
98/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir 2>/dev/null || :
99
100%preun
101if [ $1 = 0 ]; then
102        /sbin/install-info --delete %{_infodir}/%{name}.info \
103                %{_infodir}/dir 2>/dev/null || :
104fi
105
106%postun -p /sbin/ldconfig
107
108%files
109%defattr(-,root,root,-)
110%doc AUTHORS COPYING NEWS README README.libcdio THANKS TODO
111%{_bindir}/*
112%{_libdir}/*.so.*
113%{_infodir}/*
114%{_mandir}/man1/*
115%lang(ja) %{_mandir}/ja/man1/*
116
117
118%files devel
119%defattr(-,root,root,-)
120%doc doc/doxygen/html examples
121%{_includedir}/cdio
122%{_includedir}/cdio++
123%{_libdir}/*.so
124%{_libdir}/pkgconfig/*.pc
125
126
127%changelog
128* Tue Sep 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwa.com> 0.82-2
129- rebuilt with rpm-4.8.1 for pkg-config
130- added --enable-cddb
131
132* Fri May 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwa.com> 0.82-1
133- new upstream release
134- dropt Patch1
135- removed static libraries from devel package
136
137* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.80-1
138- initial build for Vine Linux
139
140* Wed Jun  4 2008 Tomas Bzatek <tbzatek@redhat.com> - 0.80-2
141- added patch enabling libcdio_paranoia.pc
142
143* Thu May 29 2008 Adrian Reber <adrian@lisas.de> - 0.80-1
144- updated to 0.80
145- removed upstreamed patches
146- last GPLv2+ release
147
148* Thu Feb 14 2008 Adrian Reber <adrian@lisas.de> - 0.79-3
149- added patch to compile with gcc43
150
151* Fri Jan 04 2008 Adrian Reber <adrian@lisas.de> - 0.79-2
152- fixed security fix (was off by two)
153
154* Wed Jan 02 2008 Adrian Reber <adrian@lisas.de> - 0.79-1
155- updated to 0.79
156- fixes #427197 (Long Joliet file name overflows cdio's buffer)
157- fixes #341981 (multiarch conflicts in libcdio)
158
159* Fri Aug 24 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-3
160- rebuilt
161
162* Mon Jul 23 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-2
163- updated to 0.78.2 (#221359) (this time for real)
164
165* Thu Jan 04 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-1
166- updated to 0.78.2 (#221359)
167
168* Thu Oct 05 2006 Adrian Reber <adrian@lisas.de> - 0.77-3
169- disabled iso9660 test case (fails for some reason with date problems)
170  this seems to be a known problem according to the ChangeLog
171
172* Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.77-2
173 - rebuilt for unwind info generation, broken in gcc-4.1.1-21
174
175* Fri Sep 22 2006 Adrian Reber <adrian@lisas.de> - 0.77-1
176- Updated to 0.77
177
178* Mon Sep 18 2006 Adrian Reber <adrian@lisas.de> - 0.76-3
179- Rebuilt
180
181* Mon Sep 26 2005 Adrian Reber <adrian@lisas.de> - 0.76-2
182- Rebuilt
183
184* Mon Sep 26 2005 Adrian Reber <adrian@lisas.de> - 0.76-1
185- Updated to 0.76.
186- Included doxygen generated documentation into -devel
187- Included examples into -devel
188
189* Mon Aug 01 2005 Adrian Reber <adrian@lisas.de> - 0.75-4
190- disable test accessing local CDROM drive (#164266)
191
192* Wed Jul 27 2005 Adrian Reber <adrian@lisas.de> - 0.75-3
193- Rebuilt without libcddb dependency (#164270)
194
195* Tue Jul 26 2005 Adrian Reber <adrian@lisas.de> - 0.75-2
196- Rebuilt
197
198* Thu Jul 14 2005 Adrian Reber <adrian@lisas.de> - 0.75-1
199- Updated to 0.75.
200
201* Fri Jun 03 2005 Adrian Reber <adrian@lisas.de> - 0.74-2
202- Updated to 0.74.
203
204* Sun Apr 24 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.73-2
205- BuildRequire ncurses-devel (for cdda-player and cd-paranoia).
206- Run test suite during build.
207- Install Japanese man pages.
208
209* Sun Apr 24 2005 Adrian Reber <adrian@lisas.de> - 0.73-1
210- Updated to 0.73.
211
212* Fri Mar 18 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.70-2
213- Fix FC4 build (#151468).
214- Build with dependency tracking disabled.
215
216* Sun Sep  5 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.70-0.fdr.1
217- Updated to 0.70.
218
219* Sat Jul 17 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.69-0.fdr.1
220- Updated to 0.69.
221- Removed broken iso-read.
222- Split Requires(pre,post).
223- Added BuildReq pkgconfig.
224
225* Mon Mar 29 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.68-0.fdr.1
226- Initial RPM release.
227
Note: See TracBrowser for help on using the repository browser.