source: projects/specs/branches/6/lib/libc/libcap/libcap-vl.spec @ 4082

Revision 4082, 6.2 KB checked in by Takemikaduchi, 13 years ago (diff)

chkconfig,libcap: fix BR, libxml2: fix debian security announce DSA-2255, wireshark: new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: Library for getting and setting POSIX.1e capabilities
4Summary(ja): POSIX.1e ケーパビリティを取得・設定するためのライブラリ
5Name: libcap
6Version: 2.16
7Release: 3%{?_dist_release}
8
9License: LGPLv2
10Group: System Environment/Libraries
11
12Source: http://www.kernel.org/pub/linux/libs/security/linux-privs/kernel-2.6/%{name}-%{version}.tar.gz
13
14Patch0: libcap-2.16-headerfix.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: libattr-devel
18BuildRequires: pam-devel
19
20%description
21libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
22draft 15 capabilities.
23
24%package devel
25Summary: Development files for libcap
26Summary(ja): libcap の開発用ファイル
27Group: Development/Libraries
28Requires: %{name} = %{version}-%{release}
29
30%description devel
31Development files (Headers, libraries for static linking, etc) for libcap.
32
33libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
34draft 15 capabilities.
35
36Install libcap-devel if you want to develop or compile applications using
37libcap.
38
39# compat32
40%package -n compat32-%{name}
41Summary: Library for getting and setting POSIX.1e capabilities
42Summary(ja): POSIX.1e ケーパビリティを取得・設定するためのライブラリ
43Group: System Environment/Libraries
44
45%description -n compat32-%{name}
46libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
47draft 15 capabilities.
48
49%package -n compat32-%{name}-devel
50Summary: Development files for libcap
51Summary(ja): libcap の開発用ファイル
52Group: Development/Libraries
53Requires: compat32-%{name} = %{version}-%{release}
54Requires: %{name}-devel = %{version}-%{release}
55
56%description -n compat32-%{name}-devel
57Development files (Headers, libraries for static linking, etc) for libcap.
58
59libcap is a library for getting and setting POSIX.1e (formerly POSIX 6)
60draft 15 capabilities.
61
62Install libcap-devel if you want to develop or compile applications using
63libcap.
64
65%prep
66%setup -q
67%patch0 -p1
68
69%build
70# libcap can not be build with _smp_mflags:
71make PREFIX=%{_prefix} LIBDIR=%{_libdir} SBINDIR=%{_sbindir} \
72     INCDIR=%{_includedir} MANDIR=%{_mandir} COPTFLAG="$RPM_OPT_FLAGS"
73
74%install
75rm -rf $RPM_BUILD_ROOT
76make install DESTDIR=${RPM_BUILD_ROOT} \
77             LIBDIR=${RPM_BUILD_ROOT}/%{_lib} \
78             SBINDIR=${RPM_BUILD_ROOT}/%{_sbindir} \
79             INCDIR=${RPM_BUILD_ROOT}/%{_includedir} \
80             MANDIR=${RPM_BUILD_ROOT}/%{_mandir}/ \
81             COPTFLAG="$RPM_OPT_FLAGS"
82mkdir -p ${RPM_BUILD_ROOT}/%{_mandir}/man{2,3,8}
83#mv -f doc/*.2 ${RPM_BUILD_ROOT}/%{_mandir}/man2/
84mv -f doc/*.3 ${RPM_BUILD_ROOT}/%{_mandir}/man3/
85
86# remove static lib
87rm -f ${RPM_BUILD_ROOT}/%{_lib}/libcap.a
88
89chmod +x $RPM_BUILD_ROOT/%{_lib}/*.so.*
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%post -p /sbin/ldconfig
95
96%postun -p /sbin/ldconfig
97
98%post -n compat32-%{name} -p /sbin/ldconfig
99
100%postun -n compat32-%{name} -p /sbin/ldconfig
101
102%files
103%defattr(-,root,root)
104%doc doc/capability.notes License
105/%{_lib}/*.so.*
106%{_sbindir}/*
107%{_mandir}/man8/*
108/%{_lib}/security/pam_cap.so
109
110%files devel
111%defattr(-,root,root)
112%{_includedir}/*
113/%{_lib}/*.so
114%{_mandir}/man3/*
115
116# compat32
117%if %{build_compat32}
118%files -n compat32-%{name}
119%defattr(-,root,root)
120/%{_lib}/*.so.*
121
122%files -n compat32-%{name}-devel
123%defattr(-,root,root)
124/%{_lib}/*.so
125%endif
126
127%changelog
128* Tue Jun 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16-3
129- add BuildRequires: pam-devel
130
131* Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16-2
132- rebuilt with current VineSeed
133
134* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16-1
135- new upstream release
136- remove compat library (libpcap-1.10)
137
138* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.06-2
139- added compat32 package for x86_64 arch support
140
141* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.06-1
142- source updated
143- built with libattr 2.4.41
144
145* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-22vl2
146- rebuilt
147
148* Sun Mar 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-22vl1
149- initial build for Vine Linux based on FC package
150
151* Wed Mar 02 2005 Karsten Hopp <karsten@redhat.de> 1.10-22
152- build with gcc-4
153
154* Wed Feb 09 2005 Karsten Hopp <karsten@redhat.de> 1.10-21
155- rebuilt
156
157* Tue Aug 31 2004 Phil Knirsch <pknirsch@redhat.com> 1.10-20
158- Fix wrong typedef in userland patch (#98801)
159
160* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
161- rebuilt
162
163* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
164- rebuilt
165
166* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
167- rebuilt
168
169* Tue Jan 27 2004 Karsten Hopp <karsten@redhat.de> 1.10-17
170- use _manpath
171
172* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
173- rebuilt
174
175* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
176- rebuilt
177
178* Sat Jan  4 2003 Jeff Johnson <jbj@redhat.com> 1.10-14
179- set execute bits on library so that requires are generated.
180
181* Thu Nov 21 2002 Mike A. Harris <mharris@redhat.com> 1.10-13
182- Removed %%name macro sillyness from package Summary, description text, etc.
183- Removed archaic Prefix: tag
184- lib64 fixes everywhere to use _lib, _libdir, etc
185- Removed deletion of RPM_BUILD_DIR from %%clean section
186- Added -q flag to setup macro
187- Severely cleaned up spec file, and removed usage of perl
188
189* Fri Jul 19 2002 Jakub Jelinek <jakub@redhat.com> 1.10-12
190- CFLAGS was using COPTFLAG variable, not COPTFLAGS
191- build with -fpic
192- apply the IA-64 patch everywhere, use capget/capset from glibc,
193  not directly as _syscall (as it is broken on IA-32 with -fpic)
194- reenable alpha
195
196* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
197- automated rebuild
198
199* Wed May 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.10-10
200- Exclude alpha for now, apparent gcc bug.
201
202* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.10-6
203- Fix sys/capabilities.h header (#55727)
204- Move to /lib, some applications seem to be using this rather early
205  (#55733)
206
207* Mon Jul 16 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
208- Add post,postun scripts
209
210* Tue Jul 10 2001 Jakub Jelinek <jakub@redhat.com>
211- don't build libcap.so.1 with ld -shared, but gcc -shared
212
213* Wed Jun 20 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
214- Rebuild - it was missing for alpha
215
216* Wed Jun 06 2001 Florian La Roche <Florian.LaRoche@redhat.de>
217- add s390/s390x support
218
219* Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.10-1
220- initial RPM
221- fix build on ia64
Note: See TracBrowser for help on using the repository browser.