source: projects/specs/branches/6/lib/libb/libburn/libburn-vl.spec @ 1901

Revision 1901, 5.0 KB checked in by Takemikaduchi, 14 years ago (diff)

rebuild with rpm-4.8.1

Line 
1%define tbpostfix pl01
2
3Summary:        Library for reading, mastering and writing optical discs
4Summary(ja):    光学ディスクの読み込み・マスタリング・書き込みを行うライブラリ
5
6Name:           libburn
7Version:        0.6.0
8Release:        2%{?_dist_release}
9
10Group:          System Environment/Libraries
11License:        GPLv2
12URL:            http://libburnia-project.org/
13Source0:        http://files.libburnia-project.org/releases/%{name}-%{version}.%{tbpostfix}.tar.gz
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16BuildRequires:   libtool intltool gettext doxygen graphviz
17
18
19%description
20Libburn is an open-source library for reading, mastering and writing
21optical discs. For now this means only CD-R and CD-RW.
22
23The project comprises of several more or less interdependent parts which
24together strive to be a usable foundation for application development.
25These are libraries, language bindings, and middleware binaries which emulate
26classical (and valuable) Linux tools.
27
28
29%package        devel
30Summary:        Development files for %{name}
31Summary(ja):    %{name} の開発ファイル
32Group:          Development/Libraries
33Requires:       %{name} = %{version}-%{release}
34Requires:       pkgconfig
35
36%description    devel
37The %{name}-devel package contains libraries and header files for
38developing applications that use %{name}.
39
40
41%package -n     cdrskin
42Summary:        Limited cdrecord compatibility wrapper to ease migration to libburn
43Summary(ja):    libburn への移行を容易にするための限定的な cdrecord 互換ラッパー
44Group:          Applications/Multimedia
45Requires:       %{name} = %{version}-%{release}
46
47%description -n cdrskin
48A limited cdrecord compatibility wrapper which allows to use some libburn
49features from the command line.
50
51
52%prep
53%setup -q
54
55
56%build
57%configure --disable-static
58make %{?_smp_mflags}
59doxygen doc/doxygen.conf
60
61
62%install
63rm -rf $RPM_BUILD_ROOT
64make install DESTDIR=$RPM_BUILD_ROOT
65install -d $RPM_BUILD_ROOT%{_bindir}
66install -m 0755 cdrskin/.libs/cdrskin $RPM_BUILD_ROOT%{_bindir}/cdrskin
67install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html
68install -m 0644 doc/html/* $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html/
69find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
70
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75
76%post -p /sbin/ldconfig
77
78%postun -p /sbin/ldconfig
79
80
81%files
82%defattr(-,root,root,-)
83%doc AUTHORS COPYING COPYRIGHT README
84%{_libdir}/%{name}*.so.*
85
86%files devel
87%defattr(-,root,root,-)
88%doc doc/html
89%{_includedir}/%{name}
90%{_libdir}/%{name}*.so
91%{_libdir}/pkgconfig/%{name}*.pc
92
93%files -n cdrskin
94%defattr(-,root,root,-)
95%doc
96%{_mandir}/*/*
97%{_bindir}/cdrskin
98
99
100%changelog
101* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.0-2
102- rebuild with rpm-4.8.1 for pkg-config file
103
104* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-1
105- initial build for Vine Linux
106
107* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-3
108- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
109
110* Sat Jan 24 2009 Denis Leroy <denis@poolshark.org> - 0.6.0-2
111- Updating to pl01 tarball from upstream
112- Fixed project URL
113
114* Wed Jan 07 2009 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.0-1
115- New upstream version
116
117* Tue Aug  5 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.8-2
118- fix license tag
119
120* Wed Jun 11 2008 Denis Leroy <denis@poolshark.org> - 0.4.8-1
121- Update to upstream 0.4.8
122
123* Thu Feb 14 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.0-2
124- Autorebuild for GCC 4.3
125
126* Thu Dec 13 2007 Denis Leroy <denis@poolshark.org> - 0.4.0-1
127- Update to 0.4.0
128
129* Wed Oct 10 2007 Jesse Keating <jkeating@redhat.com> - 0.3.8-2
130- Rebuild for BuildID
131
132* Fri Aug 10 2007 Denis Leroy <denis@poolshark.org> - 0.3.8-1
133- Update to upstream 0.3.8
134- Fixed project URL
135
136* Sun Mar 25 2007 Denis Leroy <denis@poolshark.org> - 0.2.6.3-3
137- Fixed unowned include directory (#233860)
138
139* Tue Mar 20 2007 Denis Leroy <denis@poolshark.org> - 0.2.6.3-2
140- Moved documentation into devel package, #228372
141- Updated source URL to new upstream location
142
143* Tue Jan 02 2007 Jesse Keating <jkeating@redhat.com> - 0.2.6.3-1
144- Update to 0.2.6.3
145- Remove libisofs stuff as it's packaged seperately now.
146- Add a manpage for cdrskin
147
148* Sat Oct 21 2006 Jesse Keating <jkeating@redhat.com> - 0.2-2-2
149- Point to a real URL in source, now that we have a tarball
150
151* Fri Oct 20 2006 Jesse Keating <jkeating@redhat.com> - 0.2-2-1
152- 0.2.2 release
153
154* Tue Sep 12 2006 Jesse Keating <jkeating@redhat.com> - 0.2-5.20060808svn
155- Create doxygen docs
156
157* Fri Sep  8 2006 Jesse Keating <jkeating@redhat.com> - 0.2-4.20060808svn
158- rebuild with new snapshot
159
160* Sun Aug 27 2006 Jesse Keating <jkeating@redhat.com> - 0.2-3.20060823svn
161- don't install dupe headers in -devel packages
162- libisofs requires libburn devel for directory ownership
163
164* Sun Aug 27 2006 Jesse Keating <jkeating@redhat.com> - 0.2-2.20060823svn
165- Fix cdrskin require
166- Fix tabs
167- Added doc files
168
169* Wed Aug 23 2006 Jesse Keating <jkeating@redhat.com> - 0.2-1.20060823svn
170- Initial package for review
Note: See TracBrowser for help on using the repository browser.