source: projects/specs/branches/6/lib/libb/libbonoboui/libbonoboui-vl.spec @ 2041

Revision 2041, 9.6 KB checked in by Takemikaduchi, 14 years ago (diff)

update to GNOME-2.32.0

Line 
1%define libxml2_version 2.7.7
2%define orbit2_version 2.14.19
3%define libbonobo_version 2.32.0
4%define libgnomecanvas_version 2.30.2
5%define libgnome_version 2.32.0
6%define libart_lgpl_version 2.3.12
7%define gtk2_version 2.22.0
8%define libglade2_version 2.6.0
9
10%define po_package libbonoboui-2.0
11
12%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
13
14Summary: Bonobo user interface components
15Summary(ja): Bonobo ユーザインタフェースコンポーネント
16Name: libbonoboui
17Version: 2.24.4
18Release: 1%{?_dist_release}
19URL: http://ftp.gnome.org/
20Source0: http://ftp.gnome.org/pub/GNOME/sources/libbonoboui/2.24/%{name}-%{version}.tar.bz2
21Source2: bonoboui-fixed-ltmain.sh
22
23License: LGPL
24Group: System Environment/Libraries
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26
27Requires: libxml2 >= %{libxml2_version}
28Requires: ORBit2 >= %{orbit2_version}
29Requires: libbonobo >= %{libbonobo_version}
30Requires: libgnomecanvas >= %{libgnomecanvas_version}
31Requires: libgnome >= %{libgnome_version}
32Requires: libart_lgpl >= %{libart_lgpl_version}
33Requires: gtk2 >= %{gtk2_version}
34Requires: libglade2 >= %{libglade2_version}
35
36BuildRequires: libxml2-devel >= %{libxml2_version}
37BuildRequires: ORBit2-devel >= %{orbit2_version}
38BuildRequires: libbonobo-devel >= %{libbonobo_version}
39BuildRequires: libgnomecanvas-devel >= %{libgnomecanvas_version}
40BuildRequires: libgnome-devel >= %{libgnome_version}
41BuildRequires: libart_lgpl-devel >= %{libart_lgpl_version}
42BuildRequires: gtk2-devel >= %{gtk2_version}
43BuildRequires: libglade2-devel >= %{libglade2_version}
44BuildRequires: popt-devel
45BuildRequires: intltool >= 0.14-1
46BuildRequires: libtool >= 1.5
47
48%description
49Bonobo is a component system based on CORBA, used by the GNOME
50desktop.  libbonoboui contains the user interface related components
51that come with Bonobo.
52
53%package devel
54Summary: Libraries and headers for libbonoboui
55Group: Development/Libraries
56Requires: %{name} = %{version}-%{release}
57Requires: libxml2-devel >= %{libxml2_version}
58Requires: ORBit2-devel >= %{orbit2_version}
59Requires: libbonobo-devel >= %{libbonobo_version}
60Requires: libgnomecanvas-devel >= %{libgnomecanvas_version}
61Requires: libgnome-devel >= %{libgnome_version}
62Requires: libart_lgpl-devel >= %{libart_lgpl_version}
63Requires: gtk2-devel >= %{gtk2_version}
64Requires: libglade2-devel >= %{libglade2_version}
65Conflicts: bonobo-devel < 1.0.8
66
67%description devel
68Bonobo is a component system based on CORBA, used by the GNOME desktop.
69libbonoboui contains GUI components that come with Bonobo.
70
71This package contains header files used to compile programs that
72use libbonoboui.
73
74# compat32
75%package -n compat32-%{name}
76Summary: Bonobo user interface components
77Summary(ja): Bonobo ユーザインタフェースコンポーネント
78Group: System Environment/Libraries
79Requires: %{name} = %{version}-%{release}
80
81%description -n compat32-%{name}
82Bonobo is a component system based on CORBA, used by the GNOME
83desktop.  libbonoboui contains the user interface related components
84that come with Bonobo.
85
86%package -n compat32-%{name}-devel
87Summary: Libraries and headers for libbonoboui
88Group: Development/Libraries
89Requires: %{name}-devel = %{version}-%{release}
90Requires: compat32-%{name} = %{version}-%{release}
91Requires: compat32-libxml2-devel >= %{libxml2_version}
92Requires: compat32-ORBit2-devel >= %{orbit2_version}
93Requires: compat32-libbonobo-devel >= %{libbonobo_version}
94Requires: compat32-libgnomecanvas-devel >= %{libgnomecanvas_version}
95Requires: compat32-libgnome-devel >= %{libgnome_version}
96Requires: compat32-libart_lgpl-devel >= %{libart_lgpl_version}
97Requires: compat32-gtk2-devel >= %{gtk2_version}
98Requires: compat32-libglade2-devel >= %{libglade2_version}
99
100%description -n compat32-%{name}-devel
101Bonobo is a component system based on CORBA, used by the GNOME desktop.
102libbonoboui contains GUI components that come with Bonobo.
103
104This package contains header files used to compile programs that
105use libbonoboui.
106
107%prep
108%setup -q -n %{name}-%{version}
109
110%build
111%configure
112export tagname=CC
113%__make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
114
115
116%install
117rm -rf $RPM_BUILD_ROOT
118export tagname=CC
119make install DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool
120
121rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
122rm -f $RPM_BUILD_ROOT%{_libdir}/libglade/2.0/*.a
123rm -f $RPM_BUILD_ROOT%{_datadir}/applications/bonobo-browser.desktop
124
125%find_lang %{po_package}
126
127%clean
128rm -rf $RPM_BUILD_ROOT
129
130%post -p /sbin/ldconfig
131
132%postun -p /sbin/ldconfig
133
134%post -n compat32-%{name} -p /sbin/ldconfig
135
136%postun -n compat32-%{name} -p /sbin/ldconfig
137
138%files -f %{po_package}.lang
139%defattr(-,root,root)
140%doc COPYING ChangeLog NEWS README
141%{_libdir}/lib*.so.*
142%{_libdir}/libglade/2.0/*.so
143%{_libdir}/libglade/2.0/*.la
144%{_libdir}/bonobo
145%{_datadir}/gnome-2.0
146
147%files devel
148%defattr(-,root,root)
149#{_libdir}/lib*.a
150%{_libdir}/lib*.so
151%{_libdir}/pkgconfig/*.pc
152%{_includedir}/*
153%{_bindir}/*
154%{_libdir}/bonobo-2.0
155%{_datadir}/gtk-doc
156
157# compat32
158%if %{build_compat32}
159%files -n compat32-%{name}
160%defattr(-,root,root)
161%{_libdir}/lib*.so.*
162%{_libdir}/libglade/2.0/*.so
163%{_libdir}/libglade/2.0/*.la
164%{_libdir}/bonobo
165
166%files -n compat32-%{name}-devel
167%defattr(-,root,root)
168#{_libdir}/lib*.a
169%{_libdir}/lib*.so
170%{_libdir}/pkgconfig/*.pc
171%{_libdir}/bonobo-2.0
172%endif
173
174%changelog
175* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.4-1
176- new upstream release
177
178* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.3-2
179- build with rpm-4.8.1-1 for pkg-config file
180
181* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.3-1
182- new upstream release
183
184* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
185- new upstream release
186
187* Sun Jul 19 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.24.1-2
188- removed static libraries
189- added compat32 package for x86_64 arch support
190
191* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.1-1
192- new upstream release
193- added BuildRequires: popt-devel
194
195* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
196- new upstream release
197
198* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
199- new upstream release
200
201* Tue Dec 11 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
202- new upstream release
203
204* Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
205- new upstream release
206
207* Wed Mar 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
208- new upstream release
209
210* Mon Mar 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.1-0vl1
211- new upstream release
212
213* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
214- new upstream release
215
216* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
217- new upstream release
218
219* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
220- remove bonobo-activation dependency
221
222* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-0vl1
223- new upstream release
224
225* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
226- new upstream release
227
228* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.3-0vl1
229- new upstream release
230
231* Mon Dec 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
232- new upstream release
233- rebuild with new toolchains
234
235* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
236- new upstream release
237
238* Wed Aug 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4-0vl1
239- new upstream release
240
241* Tue Jun 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
242- new upstream release
243
244* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
245- new upstream release
246
247* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.2-0vl1
248- new upstream release
249
250* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.1-0vl1
251- build for Vine Linux
252
253* Thu Aug 29 2002 Havoc Pennington <hp@redhat.com>
254- libtoolize with our latest libtool to try fixing rpaths
255
256* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
257- 2.0.1
258
259* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
260- Fix find_lang
261
262* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
263- 2.0.0
264- include sample server in libdir
265- remove .a files from glade module dir
266
267* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
268- rebuild in different environment
269
270* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
271- 1.118.0
272- remove empty AUTHORS file
273
274* Sun May 26 2002 Tim Powers <timp@redhat.com>
275- automated rebuild
276
277* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
278- rebuild in different environment
279
280* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
281- 1.117.0
282
283* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
284- 1.116.0
285
286* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
287- 1.113.0
288
289* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
290- 1.111.0
291
292* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
293- Version 1.110.0
294- Reintoolize to fix DBM problems
295
296* Mon Jan 28 2002 Havoc Pennington <hp@redhat.com>
297- rebuild in rawhide
298
299* Mon Jan  7 2002 Havoc Pennington <hp@redhat.com>
300- 1.108.1.90 cvs snap
301
302* Tue Nov 27 2001 Havoc Pennington <hp@redhat.com>
303- 1.107.0.90 snap, explicit requires lines for dependencies
304- add libtool hack to avoid relinking
305
306* Mon Oct 29 2001 Havoc Pennington <hp@redhat.com>
307- add glade dependency, add glade module to file list
308
309* Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
310- rebuild with glib 1.3.10, new cvs snap
311
312* Mon Oct 15 2001 Havoc Pennington <hp@redhat.com>
313- rebuild, hoping build root is fixed
314
315* Mon Oct 15 2001 Havoc Pennington <hp@redhat.com>
316- grumble, build require newer gtk
317- require libart_lgpl-devel not the non-devel package
318
319* Mon Oct 15 2001 Havoc Pennington <hp@redhat.com>
320- cvs snap with menu stuff fixed so gnome-terminal works
321
322* Fri Oct  5 2001 Havoc Pennington <hp@redhat.com>
323- new tarball, rebuild for new glib
324
325* Mon Sep 24 2001 Havoc Pennington <hp@redhat.com>
326- new cvs snap, fix up prereqs/requires a bit
327
328* Tue Sep 18 2001 Havoc Pennington <hp@redhat.com>
329- Initial build.
330
331
Note: See TracBrowser for help on using the repository browser.