source: projects/specs/branches/6/lib/libb/libbonobo/libbonobo-vl.spec @ 2041

Revision 2041, 9.3 KB checked in by Takemikaduchi, 14 years ago (diff)

update to GNOME-2.32.0

Line 
1%define dbus_version 1.4.0
2%define dbus_glib_version 0.88
3%define libxml2_version 2.7.7
4%define orbit2_version 2.14.19
5
6%define po_package libbonobo-2.0
7
8%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
9
10Summary: Bonobo component system
11Summary(ja): Bonobo コンポーネントシステム
12Name: libbonobo
13Version: 2.32.0
14Release: 1%{?_dist_release}
15URL: http://ftp.gnome.org/
16Source0: %{name}-%{version}.tar.bz2
17Patch10: %{name}-2.14.0-i18n-help.patch
18License: LGPL
19Group: System Environment/Libraries
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: libxml2-devel >= %{libxml2_version}
22BuildRequires: ORBit2-devel >= %{orbit2_version}
23BuildRequires: dbus-devel >= %{dbus_version}
24BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
25BuildRequires: popt-devel
26BuildRequires: flex
27BuildRequires: byacc
28Obsoletes: bonobo-activation
29Provides: bonobo-activation
30
31%description
32Bonobo is a component system based on CORBA, used by the GNOME desktop.
33
34%description -l ja
35Bonobo は GNUME デスクトップで使われている CORBA ベースのコンポーネント
36システムです。
37
38%package devel
39Summary: Libraries and headers for libbonobo
40Summary: libbonobo のライブラリおよびヘッダ
41Group: Development/Libraries
42Requires:  %{name} = %{version}-%{release}
43Requires:  ORBit2-devel >= %{orbit2_version}
44Requires:  libxml2-devel >= %{libxml2_version}
45Obsoletes: bonobo-activation-devel
46Provides:  bonobo-activation-devel
47Conflicts: bonobo-devel < 1.0.8
48
49%description devel
50Bonobo is a component system based on CORBA, used by the GNOME desktop.
51
52This package contains header files used to compile programs that
53use Bonobo.
54
55%description devel -l ja
56Bonobo は GNOME デスクトップで使われている CORBA ベースのコンポーネント
57システムです。
58
59このパッケージは Bonobo を使うプログラムをコンパイルするために必要な
60ヘッダファイルが収録されています。
61
62# compat32
63%package -n compat32-%{name}
64Summary: Bonobo component system
65Summary(ja): Bonobo コンポーネントシステム
66Group: System Environment/Libraries
67Requires:  %{name} = %{version}-%{release}
68
69%description -n compat32-%{name}
70Bonobo is a component system based on CORBA, used by the GNOME desktop.
71
72%description -n compat32-%{name} -l ja
73Bonobo は GNUME デスクトップで使われている CORBA ベースのコンポーネント
74システムです。
75
76%package -n compat32-%{name}-devel
77Summary: Libraries and headers for libbonobo
78Summary: libbonobo のライブラリおよびヘッダ
79Group: Development/Libraries
80Requires:  %{name}-devel = %{version}-%{release}
81Requires:  compat32-%{name} = %{version}-%{release}
82Requires:  compat32-ORBit2-devel >= %{orbit2_version}
83Requires:  compat32-libxml2-devel >= %{libxml2_version}
84
85%description -n compat32-%{name}-devel
86Bonobo is a component system based on CORBA, used by the GNOME desktop.
87
88This package contains header files used to compile programs that
89use Bonobo.
90
91%description -n compat32-%{name}-devel -l ja
92Bonobo は GNOME デスクトップで使われている CORBA ベースのコンポーネント
93システムです。
94
95このパッケージは Bonobo を使うプログラムをコンパイルするために必要な
96ヘッダファイルが収録されています。
97
98%prep
99%setup -q -n %{name}-%{version}
100#patch1 -p1 -b .env-leak
101%patch10 -p1 -b .i18n-help
102
103%build
104%configure --disable-static
105make
106
107%install
108rm -rf $RPM_BUILD_ROOT
109%makeinstall
110
111## just kill this wherever it lives
112rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo-2.0/samples/bonobo-echo-2
113rm -f $RPM_BUILD_ROOT%{_prefix}/lib/bonobo-2.0/samples/bonobo-echo-2
114                       
115## kill other stuff
116rm $RPM_BUILD_ROOT%{_bindir}/echo-client-2
117rm $RPM_BUILD_ROOT%{_libdir}/*.la
118rm $RPM_BUILD_ROOT%{_libdir}/bonobo/monikers/*.*a
119rm $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.*a
120                       
121
122%find_lang %{po_package}
123
124%clean
125rm -rf $RPM_BUILD_ROOT
126
127%post -p /sbin/ldconfig
128
129%postun -p /sbin/ldconfig
130
131%post -n compat32-%{name} -p /sbin/ldconfig
132
133%postun -n compat32-%{name} -p /sbin/ldconfig
134
135%files -f %{po_package}.lang
136%defattr(-,root,root)
137%doc AUTHORS COPYING ChangeLog NEWS README
138%{_libdir}/lib*.so.*
139%{_libdir}/bonobo
140%{_libdir}/orbit-2.0/*.so*
141%{_bindir}*
142%{_libexecdir}/*
143%{_sbindir}/*
144%dir %{_sysconfdir}/bonobo-activation
145%config %{_sysconfdir}/bonobo-activation/*
146%{_mandir}/man*/*
147
148%files devel
149%defattr(-,root,root)
150#{_libdir}/lib*.a
151%{_libdir}/lib*.so
152%{_libdir}/pkgconfig/*.pc
153%{_includedir}/*
154%{_datadir}/idl
155%{_datadir}/gtk-doc
156
157# compat32
158%if %{build_compat32}
159%files -n compat32-%{name}
160%defattr(-,root,root)
161%{_libdir}/lib*.so.*
162%{_libdir}/bonobo
163%{_libdir}/orbit-2.0/*.so*
164
165%files -n compat32-%{name}-devel
166%defattr(-,root,root)
167#{_libdir}/lib*.a
168%{_libdir}/lib*.so
169%{_libdir}/pkgconfig/*.pc
170%endif
171
172%changelog
173* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
174- new upstream release
175
176* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.3-2
177- build with rpm-4.8.1-1 for pkg-config file
178
179* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.3-1
180- new upstream release
181- add BuildRequires: dbus-devel, dbus-glib-devel, popt-devel, flex, byacc
182
183* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
184- new upstream release
185
186* Sun Jul 19 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.24.1-2
187- added --disable-static configure option
188- added compat32 package for x86_64 arch support
189
190* Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
191- new upstream release
192
193* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
194- new upstream release
195
196* Sun Jan 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.3-0vl1
197- new upstream release
198
199* Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
200- new upstream release
201
202* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl2
203- add upstream patch1
204
205* Tue Apr 24 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
206- new upstream release
207
208* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
209- update Patch0 to fix more help message translation.
210
211* Fri May 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
212- add bindtextdomain_codeset in bonobo-activation initialize
213  to fix corruption of help option message.(Patch0)
214
215* Wed Mar 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
216- new upstream release
217
218* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.1-0vl1
219- new upstream release
220
221* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
222- new upstream release
223
224* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
225- new upstream release
226
227* Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
228- new upstream release
229
230* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-0vl1
231- new upstream release
232
233* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
234- new upstream release
235
236* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.3-0vl1
237- new upstream release
238
239* Mon Dec 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
240- new upstream release
241- rebuild with new toolchains
242
243* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
244- new upstream release
245
246* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
247- new upstream release
248
249* Wed Aug 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
250- new upstream release
251
252* Tue Jun 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
253- new upstream release
254
255* Fri Apr 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
256- new upstream release
257
258* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
259- new upstream release
260
261* Sat Dec 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.0-0vl1
262- build for Vine Linux
263
264* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
265- Fix find_lang
266
267* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
268- rebuild in different environment
269
270* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
271- 2.0.0
272
273* Sun May 26 2002 Tim Powers <timp@redhat.com>
274- automated rebuild
275
276* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
277- rebuild in different environment
278
279* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
280- 1.117.0
281
282* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
283- 1.116.0
284
285* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
286- 1.113.0
287
288* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
289- 1.111.0
290
291* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
292- Version 1.110.0
293- Rebuild for dependencies
294- Intltoolize, the included version has problems with our Perl
295
296* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
297- automake-1.4
298
299* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
300- 1.108.0.90 cvs snap
301
302* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
303- 1.107.0, glib 1.3.11
304
305* Fri Oct 26 2001 Havoc Pennington <hp@redhat.com>
306- rebuild for new glib, new snap
307
308* Fri Oct  5 2001 Havoc Pennington <hp@redhat.com>
309- rebuild for new glib
310
311* Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
312- move to 1.103.0 tarball
313- call automake after patching Makefile.am
314- patch for parallel install
315
316* Fri Sep 21 2001 Havoc Pennington <hp@redhat.com>
317- add some requires
318
319* Tue Sep 18 2001 Havoc Pennington <hp@redhat.com>
320- conflict with bonobo < 1.0.8 to avoid header conflicts
321- update group
322
323* Mon Sep 17 2001 Havoc Pennington <hp@redhat.com>
324- moved IDL files into subdir
325- remove smp_mflags, libbonobo does not like those
326
327* Thu Sep 13 2001 Havoc Pennington <hp@redhat.com>
328- remove IDL files as temporary hack
329
330* Wed Sep 12 2001 Havoc Pennington <hp@redhat.com>
331- Initial build.
332
333
Note: See TracBrowser for help on using the repository browser.