source: projects/specs/branches/6/lib/liba/libatomic_ops/libatomic_ops-vl.spec @ 521

Revision 521, 2.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# No debug information gets generated from a static lib, so
2# debuginfo will be empty.
3%define debug_package %{nil}
4
5Summary:        Atomic memory update operations
6Name:           libatomic_ops
7Version:        1.2
8Release:        1%{?_dist_release}
9
10Group:          Development/Libraries
11License:        GPL/MIT
12URL:            http://www.hpl.hp.com/research/linux/atomic_ops/
13Source0:        http://www.hpl.hp.com/research/linux/atomic_ops/download/%{name}-%{version}.tar.gz
14Patch1:         libatomic_ops-1.2-ppclwzfix.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17
18
19%description
20Provides implementations for atomic memory update operations on a
21number of architectures. This allows direct use of these in reasonably
22portable code. Unlike earlier similar packages, this one explicitly
23considers memory barrier semantics, and allows the construction of code
24that involves minimum overhead across a variety of architectures.
25
26
27%package devel
28Summary:        Atomic memory update operations
29Group:          Development/Libraries
30
31%description devel
32Provides implementations for atomic memory update operations on a
33number of architectures. This allows direct use of these in reasonably
34portable code. Unlike earlier similar packages, this one explicitly
35considers memory barrier semantics, and allows the construction of code
36that involves minimum overhead across a variety of architectures.
37
38
39%prep
40%setup -q
41%patch1 -p1
42chmod a-x src/*.h
43
44%build
45%configure
46make %{?_smp_mflags}
47
48
49%install
50rm -rf $RPM_BUILD_ROOT
51make install DESTDIR=$RPM_BUILD_ROOT
52
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57
58%files devel
59%defattr(-,root,root,-)
60%doc AUTHORS ChangeLog COPYING INSTALL NEWS README
61%{_includedir}/atomic_ops.h
62%{_includedir}/atomic_ops_malloc.h
63%{_includedir}/atomic_ops_stack.h
64%{_includedir}/atomic_ops
65%{_libdir}/%{name}*.a
66%{_datadir}/%{name}
67
68
69%changelog
70* Thu Jul 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-1
71- initial build for Vine Linux
72
73* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2-3
74- Autorebuild for GCC 4.3
75
76* Tue May 29 2007 Pierre Ossman <drzeus@drzeus.cx> 1.2-2
77- Added fix for PPC AO_load_acquire.
78
79* Fri Nov 10 2006 Pierre Ossman <drzeus@drzeus.cx> 1.2-1
80- Update to 1.2.
81
82* Sat Sep  9 2006 Pierre Ossman <drzeus@drzeus.cx> 1.1-2
83- Fix naming of package.
84- General cleanup of spec file.
85
86* Wed Aug 30 2006 Pierre Ossman <drzeus@drzeus.cx> 1.1-1
87- Initial package for Fedora Extras.
Note: See TracBrowser for help on using the repository browser.