source: projects/specs/branches/6/lib/liba/libaio/libaio-vl.spec @ 3488

Revision 3488, 7.7 KB checked in by inagaki, 13 years ago (diff)

update: libaio, lzma

Line 
1Summary: Linux-native asynchronous I/O access library
2Name: libaio
3Version: 0.3.106
4Release: 3%{?_dist_release}
5
6License: LGPLv2+
7Group:  System Environment/Libraries
8
9Source: %{name}-%{version}.tar.gz
10
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12ExclusiveArch: %{ix86} x86_64 ia64 s390 s390x ppc ppc64 ppc64pseries ppc64iseries alpha alphaev6
13
14%description
15The Linux-native asynchronous I/O facility ("async I/O", or "aio") has a
16richer API and capability set than the simple POSIX async I/O facility.
17This library, libaio, provides the Linux-native API for async I/O.
18The POSIX async I/O facility requires this library in order to provide
19kernel-accelerated async I/O capabilities, as do applications which
20require the Linux-native async I/O API.
21
22%package devel
23Summary: Development files for Linux-native asynchronous I/O access
24Group: Development/Libraries
25Requires: libaio = %{version}-%{release}
26
27%description devel
28This package provides header files to include and libraries to link with
29for the Linux-native asynchronous I/O facility ("async I/O", or "aio").
30
31%prep
32%setup -q -a 0
33mv %{name}-%{version} compat-%{name}-%{version}
34
35%build
36# A library with a soname of 1.0.0 was inadvertantly released.  This
37# build process builds a version of the library with the broken soname in
38# the compat-libaio-0.3.103 directory, and then builds the library again
39# with the correct soname.
40cd compat-%{name}-%{version}
41make soname='libaio.so.1.0.0' libname='libaio.so.1.0.0'
42cd ..
43make
44
45%install
46[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
47cd compat-%{name}-%{version}
48install -D -m 755 src/libaio.so.1.0.0 \
49  $RPM_BUILD_ROOT/%{_libdir}/libaio.so.1.0.0
50cd ..
51make install prefix=$RPM_BUILD_ROOT/usr \
52 libdir=$RPM_BUILD_ROOT/%{_libdir} \
53 root=$RPM_BUILD_ROOT
54
55
56%clean
57[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
58
59%post -p /sbin/ldconfig
60
61%postun -p /sbin/ldconfig
62
63%files
64%defattr(-,root,root)
65%attr(0755,root,root) %{_libdir}/libaio.so.*
66%doc COPYING TODO
67
68%files devel
69%defattr(-,root,root)
70%attr(0644,root,root) %{_includedir}/*
71%attr(0755,root,root) %{_libdir}/libaio.so
72%attr(0644,root,root) %{_libdir}/libaio.a
73
74%changelog
75* Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.106-3
76- rebuilt with current VineSeed
77
78* Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.106-2
79- changed Group to Development/Libraries
80
81* Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 0.3.106-1vl5
82- applied new versioning policy, spec in utf-8
83
84* Mon Nov 12 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.106-0vl1
85- initial build for Vine Linux
86
87* Mon Jul 17 2006 Jeff Moyer <jmoyer@redhat.com> - 0.3.106-3.2
88- rebuild
89
90* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.3.106-3.1
91- rebuild
92
93* Wed Jun  7 2006 Jeremy Katz <katzj@redhat.com> - 0.3.106-3
94- rebuild for -devel deps
95
96* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.3.106-2.2
97- bump again for double-long bug on ppc(64)
98
99* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.3.106-2.1
100- rebuilt for new gcc4.1 snapshot and glibc changes
101
102* Wed Jan 04 2006 Jeff Moyer <jmoyer@redhat.com> - 0.3.106-2
103- Update to the latest sources, which contain the following change:
104  Add a .proc directive for the ia64_aio_raw_syscall macro.  This sounds a lot
105  like the previous entry, but that one fixed the __ia64_raw_syscall macro,
106  located in syscall-ia64.h.  This macro is in raw_syscall.c, which pretty much
107  only exists for ia64.  This bug prevented the package from building with
108  newer version of gcc.
109
110* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
111- rebuilt
112
113* Fri Apr  1 2005 Jeff Moyer <jmoyer@redhat.com> - 0.3.104-2
114- Add Alpha architecture support.  (Sergey Tikhonov <tsv@solvo.ru>)
115
116* Wed Mar 16 2005 Jeff Moyer <jmoyer@redhat.com> - 0.3.103-6
117- Rebuild with gcc 4.
118
119* Mon Feb 14 2005 Jeff Moyer <jmoyer@redhat.com> - 0.3.103-4
120- Build the library twice.  Once with the old SONAME and once with the new
121  one.  This fixes the wrong SONAME problem by keeping a library around with
122  the wrong name (libaio.so.1.0.0) and generating a new one (libaio.so.1.0.1).
123
124* Thu Oct 14 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.102-1
125- update to 102.  Fixes build errors on s390:
126  - S390 asm had a bug; I forgot to update the clobber list.  Lucky for me,
127    newer compilers complain about such things.
128  - Also update the s390 asm to look more like the new kernel variants.
129
130* Wed Oct 13 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.101-1
131- update to 101.  Fixes bz 133253 -  libaio backwards compatibility severely
132  broken.
133
134* Tue Sep 14 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.100-1
135- update to 100.  Fixes bz 129910.  Add pseries and iseries to
136  exclusivearch.
137
138* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
139- rebuilt
140
141* Tue Mar 30 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.99-2
142- Apparently the 0.3.93 patch was not meant for 0.3.96.  Backed it out.
143
144* Tue Mar 30 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.99-1
145- Fix compat calls.
146- make library .so.1.0.0 and make symlinks properly.
147- Fix header file for inclusion in c++ code.
148
149* Thu Feb 26 2004 Jeff Moyer <jmoyer@redhat.com> 0.3.98-2
150- bah.  fix version nr in changelog.
151
152* Thu Feb 26 2004 Jeff Moyer <jmoyer@redhat.com> 0.3.98-1
153- fix compiler warnings.
154
155* Thu Feb 26 2004 Jeff Moyer <jmoyer@redhat.com> 0.3.97-2
156- make srpm was using rpm to do a build.  changed that to use rpmbuild if
157  it exists, and fallback to rpm if it doesn't.
158
159* Tue Feb 24 2004 Jeff Moyer <jmoyer@redhat.com> 0.3.97-1
160- Use libc syscall(2) instead of rolling our own calling mechanism.  This
161  change is inspired due to a failure to build with newer gcc, since clobber
162  lists were wrong.
163- Add -fpic to the CFLAGS for all architectures.  Should address bz #109457.
164- change a #include from <linux/types.h> to <sys/types.h>.  Fixes a build
165  issue on s390.
166
167* Wed Jul  7 2003 Bill Nottingham <notting@redhat.com> 0.3.96-3
168- fix paths on lib64 arches
169
170* Wed Jun 18 2003 Michael K. Johnson <johnsonm@redhat.com> 0.3.96-2
171- optimization in io_getevents from Arjan van de Ven in 0.3.96-1
172- deal with ia64 in 0.3.96-2
173
174* Wed May 28 2003 Michael K. Johnson <johnsonm@redhat.com> 0.3.95-1
175- ppc bugfix from Julie DeWandel
176
177* Tue May 20 2003 Michael K. Johnson <johnsonm@redhat.com> 0.3.94-1
178- symbol versioning fix from Ulrich Drepper
179
180* Mon Jan 27 2003 Benjamin LaHaise <bcrl@redhat.com>
181- bump to 0.3.93-3 for rebuild.
182
183* Mon Dec 16 2002 Benjamin LaHaise <bcrl@redhat.com>
184- libaio 0.3.93 test release
185- add powerpc support from Gianni Tedesco <gianni@ecsc.co.uk>
186- add s/390 support from Arnd Bergmann <arnd@bergmann-dalldorf.de>
187
188* Fri Sep 12 2002 Benjamin LaHaise <bcrl@redhat.com>
189- libaio 0.3.92 test release
190- build on x86-64
191
192* Thu Sep 12 2002 Benjamin LaHaise <bcrl@redhat.com>
193- libaio 0.3.91 test release
194- build on ia64
195- remove libredhat-kernel from the .spec file
196
197* Thu Sep  5 2002 Benjamin LaHaise <bcrl@redhat.com>
198- libaio 0.3.90 test release
199
200* Mon Apr 29 2002 Benjamin LaHaise <bcrl@redhat.com>
201- add requires initscripts >= 6.47-1 to get boot time libredhat-kernel
202  linkage correct.
203- typo fix
204
205* Thu Apr 25 2002 Benjamin LaHaise <bcrl@redhat.com>
206- make /usr/lib/libredhat-kernel.so point to /lib/libredhat-kernel.so.1.0.0
207
208* Mon Apr 15 2002 Tim Powers <timp@redhat.com>
209- make the post scriptlet not use /bin/sh
210
211* Sat Apr 12 2002 Benjamin LaHaise <bcrl@redhat.com>
212- add /lib/libredhat-kernel* to %files.
213
214* Fri Apr 12 2002 Benjamin LaHaise <bcrl@redhat.com>
215- make the dummy install as /lib/libredhat-kernel.so.1.0.0 so
216  that ldconfig will link against it if no other is installed.
217
218* Tue Jan 22 2002 Benjamin LaHaise <bcrl@redhat.com>
219- add io_getevents
220
221* Tue Jan 22 2002 Michael K. Johnson <johnsonm@redhat.com>
222- Make linker happy with /usr/lib symlink for libredhat-kernel.so
223
224* Mon Jan 21 2002 Michael K. Johnson <johnsonm@redhat.com>
225- Added stub library
226
227* Sun Jan 20 2002 Michael K. Johnson <johnsonm@redhat.com>
228- Initial packaging
Note: See TracBrowser for help on using the repository browser.