source: projects/specs/branches/6/lib/libX/libXxf86vm/libXxf86vm-vl.spec @ 7730

Revision 7730, 6.8 KB checked in by Takemikaduchi, 11 years ago (diff)

security fix

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXxf86vm runtime library
4Summary(ja): X.Org X11 libXxf86vm ランタイムライブラリ
5Name: libXxf86vm
6Version: 1.1.1
7Release: 2%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14# fix CVE-2013-2001
15Patch0: libXxf86vm-1.1.1-CVE-2013-2001.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires: pkgconfig
19BuildRequires: xorg-x11-proto-devel
20BuildRequires: libX11-devel
21BuildRequires: libXext-devel
22BuildRequires: autoconf
23BuildRequires: xorg-x11-util-macros
24Obsoletes: XFree86-libs, XOrg-libs
25
26%description
27X.Org X11 libXxf86vm runtime library
28
29%package devel
30Summary: X.Org X11 libXxf86vm development package
31Summary(ja): X.Org X11 libXxf86vm 開発パッケージ
32Group: Development/Libraries
33Requires(pre): xorg-x11-filesystem
34Requires: %{name} = %{version}-%{release}
35Requires: xorg-x11-proto-devel
36Obsoletes: XFree86-devel, XOrg-devel
37
38%description devel
39X.Org X11 libXxf86vm development package
40
41# compat32
42%package -n compat32-%{name}
43Summary: X.Org X11 libXxf86vm runtime library
44Summary(ja): X.Org X11 libXxf86vm ランタイムライブラリ
45Group: System Environment/Libraries
46Requires: %{name} = %{version}-%{release}
47
48%description -n compat32-%{name}
49X.Org X11 libXxf86vm runtime library
50
51%package -n compat32-%{name}-devel
52Summary: X.Org X11 libXxf86vm development package
53Summary(ja): X.Org X11 libXxf86vm 開発パッケージ
54Group: Development/Libraries
55Requires(pre): xorg-x11-filesystem
56Requires: compat32-%{name} = %{version}-%{release}
57Requires: %{name}-devel = %{version}-%{release}
58
59%description -n compat32-%{name}-devel
60X.Org X11 libXxf86vm development package
61
62%prep
63%setup -q
64%patch0 -p1
65
66# Disable static library creation by default.
67%define with_static 0
68
69%build
70autoreconf -if
71%configure \
72%if ! %{with_static}
73        --disable-static
74%endif
75make
76
77%install
78rm -rf $RPM_BUILD_ROOT
79
80make install DESTDIR=$RPM_BUILD_ROOT
81
82# We intentionally don't ship *.la files
83rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%post -p /sbin/ldconfig
89%postun -p /sbin/ldconfig
90
91%post -n compat32-%{name} -p /sbin/ldconfig
92%postun -n compat32-%{name} -p /sbin/ldconfig
93
94%files
95%defattr(-,root,root,-)
96# FIXME: missing some of these files %doc AUTHORS COPYING README INSTALL ChangeLog
97%doc COPYING ChangeLog
98%{_libdir}/libXxf86vm.so.1
99%{_libdir}/libXxf86vm.so.1.*
100
101%files devel
102%defattr(-,root,root,-)
103%{_includedir}/X11/extensions/*.h
104%if %{with_static}
105%{_libdir}/libXxf86vm.a
106%endif
107%{_libdir}/libXxf86vm.so
108%{_libdir}/pkgconfig/xxf86vm.pc
109%{_mandir}/man3/*.3*
110
111# compat32
112%if %{build_compat32}
113%files -n compat32-%{name}
114%defattr(-,root,root,-)
115%{_libdir}/libXxf86vm.so.1
116%{_libdir}/libXxf86vm.so.1.*
117
118%files -n compat32-%{name}-devel
119%defattr(-,root,root,-)
120%if %{with_static}
121%{_libdir}/libXxf86vm.a
122%endif
123%{_libdir}/libXxf86vm.so
124%{_libdir}/pkgconfig/xxf86vm.pc
125%endif
126
127%changelog
128* Sat Jun 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-2
129- add Patch0 (libXxf86vm-1.1.1-CVE-2013-2001.patch)
130- add BuildRequires: autoconf, xorg-x11-util-macros
131
132* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-1
133- new upstream release
134
135* Fri Sep 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-3
136- rebuild with rpm-4.8.1 for pkg-config file
137
138* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-2
139- add xf86vmode.h
140
141* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
142- new upstream release
143
144* Sun Jun 28 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.2-2
145- added compat32 package for x86_64 arch support
146
147* Fri Jul 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
148- new upstream release
149
150* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
151- new versioning policy
152
153* Thu Jan 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-0vl1
154- initial build for Vine Linux
155
156* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.1-4
157- Rebuild for build id
158
159* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control
160- rebuild
161
162* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
163- Added "Requires: xorg-x11-proto-devel"
164- Remove package ownership of mandir/libdir/etc.
165
166* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
167- Added "BuildRequires: pkgconfig" for (#193509)
168- Use "make install DESTDIR=..." instead of makeinstall macro, to fix (#192731)
169
170* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-1
171- Update to 1.0.1
172
173* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.2
174- bump again for double-long bug on ppc(64)
175
176* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.1
177- rebuilt for new gcc4.1 snapshot and glibc changes
178
179* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
180- Bumped and rebuilt
181
182* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
183- Updated libXxf86vm to version 1.0.0 from X11R7 RC4
184
185* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
186- Updated libXxf86vm to version 0.99.2 from X11R7 RC3
187- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
188  that /usr/lib/X11 and /usr/include/X11 pre-exist.
189- Removed 'x' suffix from manpage directories to match RC3 upstream.
190
191* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
192- rebuilt
193
194* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-3
195- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
196- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
197
198* Tue Nov 01 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
199- Bump release and rebuild to satiate beehive wonkiness.
200
201* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
202- Updated libXxf86vm to version 0.99.1 from X11R7 RC1
203- Updated file manifest to find manpages in "man3x"
204
205* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
206- Renamed package to remove xorg-x11 from the name due to unanimous decision
207  between developers.
208- Use Fedora Extras style BuildRoot tag.
209- Disable static library creation by default.
210- Add missing defattr to devel subpackage
211- Add missing documentation files to doc macro
212
213* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
214- Renamed package to prepend "xorg-x11" to the name for consistency with
215  the rest of the X11R7 packages.
216- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
217  subpackage to ensure the devel package matches the installed shared libs.
218- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
219  allow applications to use implementation agnostic dependencies.
220- Added post/postun scripts which call ldconfig.
221- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
222  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
223
224* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
225- Initial build.
Note: See TracBrowser for help on using the repository browser.