source: projects/specs/branches/6/lib/libX/libXvMC/libXvMC-vl.spec @ 7730

Revision 7730, 6.2 KB checked in by Takemikaduchi, 11 years ago (diff)

security fix

Line 
1Summary: X.Org X11 libXvMC runtime library
2Summary(ja): X.Org X11 libXvMC ランタイムライブラリ
3Name: libXvMC
4Version: 1.0.6
5Release: 2%{?_dist_release}
6License: MIT/X11
7Group: System Environment/Libraries
8URL: http://www.x.org
9
10Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
11
12# fix CVE-2013-1990 and CVE-2013-1999
13Patch0: libXvMC-1.0.6-CVE-2013-1990_and_1999.patch
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
16BuildRequires: pkgconfig
17BuildRequires: xorg-x11-proto-devel
18BuildRequires: libX11-devel
19BuildRequires: libXext-devel
20BuildRequires: libXv-devel
21BuildRequires: autoconf
22BuildRequires: xorg-x11-util-macros
23Obsoletes: XFree86-libs, XOrg-libs
24
25%description
26X.Org X11 libXvMC runtime library
27
28%package devel
29Summary: X.Org X11 libXvMC development package
30Summary(ja): X.Org X11 libXvMC 開発パッケージ
31Group: Development/Libraries
32Requires(pre): xorg-x11-filesystem
33Requires: %{name} = %{version}-%{release}
34Requires: libXv-devel, xorg-x11-proto-devel
35Obsoletes: XFree86-devel, XOrg-devel
36
37%description devel
38X.Org X11 libXvMC development package
39
40%prep
41%setup -q
42%patch0 -p1
43
44# Disable static library creation by default.
45%define with_static 0
46
47%build
48autoreconf -if
49%configure \
50%if ! %{with_static}
51        --disable-static
52%endif
53make
54
55%install
56rm -rf $RPM_BUILD_ROOT
57
58make install DESTDIR=$RPM_BUILD_ROOT
59
60# Touch XvMCConfig for rpm to package the ghost file. (#192254)
61{
62    mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11
63    touch $RPM_BUILD_ROOT%{_sysconfdir}/X11/XvMCConfig
64}
65
66# We intentionally don't ship *.la files
67rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
68
69# remove xml and txt file
70rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75%post -p /sbin/ldconfig
76%postun -p /sbin/ldconfig
77
78%files
79%defattr(-,root,root,-)
80%doc AUTHORS COPYING README ChangeLog
81%{_libdir}/libXvMC.so.1
82%{_libdir}/libXvMC.so.1.0.0
83%{_libdir}/libXvMCW.so.1
84%{_libdir}/libXvMCW.so.1.0.0
85%ghost %config(missingok,noreplace) %verify (not md5 size mtime) %{_sysconfdir}/X11/XvMCConfig
86
87%files devel
88%defattr(-,root,root,-)
89%dir %{_includedir}/X11
90%dir %{_includedir}/X11/extensions
91%{_includedir}/X11/extensions/XvMClib.h
92%if %{with_static}
93%{_libdir}/libXvMC.a
94%{_libdir}/libXvMCW.a
95%endif
96%{_libdir}/libXvMC.so
97%{_libdir}/libXvMCW.so
98%{_libdir}/pkgconfig/xvmc.pc
99
100%changelog
101* Sat Jun 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-2
102- add Patch0 (libXvMC-1.0.6-CVE-2013-1990_and_1999.patch)
103- add BuildRequires: autoconf, xorg-x11-util-macros
104
105* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
106- new upstream release
107
108* Fri Sep 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-2
109- rebuild with rpm-4.8.1 for pkg-config file
110
111* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-1
112- new upstream release
113
114* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-2
115- spec in utf-8
116
117* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
118- new versioning policy
119
120* Thu Jan 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl1
121- initial build for Vine Linux
122
123* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.4-3
124- Rebuild for build id
125
126* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.4-2
127- Don't install INSTALL
128
129* Fri Jan 05 2007 Adam Jackson <ajax@redhat.com> 1.0.4-1
130- Update to 1.0.4
131
132* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.0.3-1
133- Update to 1.0.3
134
135* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.2-2.1
136- rebuild
137
138* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-2
139- Added "BuildRequires: pkgconfig" for (#193506)
140- Replace "makeinstall" with "make install DESTDIR=..."
141- Touch XvMCConfig during install phase, and add to file manifest as a ghost
142  file, so that it is owned by the package if the user creates it. (#192254)
143
144* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
145- Update to 1.0.2.  Drop #180902 patch, already fixed upstream.
146
147* Tue Feb 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
148- Added libXvMC-1.0.1-libXvMC-XConfigDir-fix-bug180902.patch to fix (#180902)
149
150* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-2.2
151- bump again for double-long bug on ppc(64)
152
153* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-2.1
154- rebuilt for new gcc4.1 snapshot and glibc changes
155
156* Tue Jan 31 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
157- Added "Requires: libXv-devel, xorg-x11-proto-devel" to fix (#176862)
158
159* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
160- Updated libXvMC to version 1.0.1 from X11R7.0
161
162* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
163- Updated libXvMC to version 1.0.0 from X11R7 RC4
164
165* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
166- Updated libXvMC to version 0.99.2 from X11R7 RC3
167- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
168  that /usr/lib/X11 and /usr/include/X11 pre-exist.
169- Removed 'x' suffix from manpage directories to match RC3 upstream.
170
171* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
172- rebuilt
173
174* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
175- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
176- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
177
178* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
179- Updated libXvMC to version 0.99.1 from X11R7 RC1
180
181* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
182- Renamed package to remove xorg-x11 from the name due to unanimous decision
183  between developers.
184- Use Fedora Extras style BuildRoot tag.
185- Disable static library creation by default.
186- Add missing defattr to devel subpackage
187- Add missing documentation files to doc macro
188
189* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
190- Renamed package to prepend "xorg-x11" to the name for consistency with
191  the rest of the X11R7 packages.
192- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
193  subpackage to ensure the devel package matches the installed shared libs.
194- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
195  allow applications to use implementation agnostic dependencies.
196- Added post/postun scripts which call ldconfig.
197- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
198  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
199
200* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
201- Initial build.
Note: See TracBrowser for help on using the repository browser.