source: projects/specs/branches/6/lib/libX/libXv/libXv-vl.spec @ 7730

Revision 7730, 6.9 KB checked in by Takemikaduchi, 11 years ago (diff)

security fix

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXv runtime library
4Summary(ja): X.Org X11 libXv ランタイムライブラリ
5Name:    libXv
6Version: 1.0.6
7Release: 2%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14# fix CVE-2013-1989 and CVE-2013-2066
15Patch0: libXv-1.0.6-CVE-2013-1989_and_2066.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires: pkgconfig
19BuildRequires: xorg-x11-proto-devel
20BuildRequires: libX11-devel
21BuildRequires: libXext-devel
22BuildRequires: autoconf
23BuildRequires: xorg-x11-util-macros
24Obsoletes: XFree86-libs, XOrg-libs
25
26%description
27X.Org X11 libXv runtime library
28
29%package devel
30Summary: X.Org X11 libXv development package
31Summary(ja): X.Org X11 libXv 開発パッケージ
32Group: Development/Libraries
33Requires(pre): xorg-x11-filesystem
34Requires: %{name} = %{version}-%{release}
35Requires: libXext-devel
36Requires: xorg-x11-proto-devel
37Obsoletes: XFree86-devel, XOrg-devel
38
39%description devel
40X.Org X11 libXv development package
41
42# compat32
43%package -n compat32-%{name}
44Summary: X.Org X11 libXv runtime library
45Summary(ja): X.Org X11 libXv ランタイムライブラリ
46Group: System Environment/Libraries
47Requires: %{name} = %{version}-%{release}
48
49%description -n compat32-%{name}
50X.Org X11 libXv runtime library
51
52%package -n compat32-%{name}-devel
53Summary: X.Org X11 libXv development package
54Summary(ja): X.Org X11 libXv 開発パッケージ
55Group: Development/Libraries
56Requires(pre): xorg-x11-filesystem
57Requires: %{name}-devel = %{version}-%{release}
58Requires: compat32-%{name} = %{version}-%{release}
59Requires: compat32-libXext-devel
60
61%description -n compat32-%{name}-devel
62X.Org X11 libXv development package
63
64%prep
65%setup -q
66%patch0 -p1
67
68# Disable static library creation by default.
69%define with_static 0
70
71%build
72autoreconf -if
73%configure \
74%if ! %{with_static}
75        --disable-static
76%endif
77make
78
79%install
80
81rm -rf $RPM_BUILD_ROOT
82make install DESTDIR=$RPM_BUILD_ROOT
83
84# We intentionally don't ship *.la files
85rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%post -p /sbin/ldconfig
91%postun -p /sbin/ldconfig
92
93%post -n compat32-%{name} -p /sbin/ldconfig
94%postun -n compat32-%{name} -p /sbin/ldconfig
95
96%files
97%defattr(-,root,root,-)
98%doc AUTHORS COPYING README ChangeLog
99%{_libdir}/libXv.so.1
100%{_libdir}/libXv.so.1.0.0
101
102%files devel
103%defattr(-,root,root,-)
104%dir %{_includedir}/X11
105%dir %{_includedir}/X11/extensions
106%{_includedir}/X11/extensions/Xvlib.h
107%if %{with_static}
108%{_libdir}/libXv.a
109%endif
110%{_libdir}/libXv.so
111%{_libdir}/pkgconfig/xv.pc
112%{_mandir}/man3/*.3*
113
114# compat32
115%if %{build_compat32}
116%files -n compat32-%{name}
117%defattr(-,root,root,-)
118%{_libdir}/libXv.so.1
119%{_libdir}/libXv.so.1.0.0
120
121%files -n compat32-%{name}-devel
122%defattr(-,root,root,-)
123%if %{with_static}
124%{_libdir}/libXv.a
125%endif
126%{_libdir}/libXv.so
127%{_libdir}/pkgconfig/xv.pc
128%endif
129
130%changelog
131* Wed May 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-2
132- add Patch0 (libXv-1.0.6-CVE-2013-1989_and_2066.patch)
133- add BuildRequires: autoconf, xorg-x11-util-macros
134
135* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
136- new upstream release
137
138* Fri Sep 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-2
139- rebuild with rpm-4.8.1 for pkg-config file
140
141* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-1
142- new upstream release
143
144* Wed Jul 08 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.4-2
145- added compat32 package for x86_64 arch support
146
147* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
148- new upstream release
149
150* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-1
151- new versioning policy
152
153* Thu Jan 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-0vl1
154- initial build for Vine Linux
155
156* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.3-3
157- Rebuild for build id
158
159* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.3-2
160- Don't install INSTALL
161
162* Fri Jan 05 2007 Adam Jackson <ajax@redhat.com> 1.0.3-1
163- Update to 1.0.3
164
165* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.0.2-1.fc7
166- Update to 1.0.2
167
168* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-4.1
169- rebuild
170
171* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-4
172- Added "Requires: xorg-x11-proto-devel" to devel package for xv.pc
173
174* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
175- Added "BuildRequires: pkgconfig" for (#193505)
176- Replace "makeinstall" with "make install DESTDIR=..."
177- Remove package ownership of mandir/libdir/etc.
178
179* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
180- Added "Requires: libXext-devel" to libXv-devel subpackage, to avoid all
181  packages that depend on libXv-devel from having to manually specify that
182  dependency themselves, as it is required by Xv.  (#192167)
183
184* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
185- bump again for double-long bug on ppc(64)
186
187* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
188- rebuilt for new gcc4.1 snapshot and glibc changes
189
190* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
191- Updated libXv to version 1.0.1 from X11R7.0
192
193* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
194- Updated libXv to version 0.99.2 from X11R7 RC3
195- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
196  that /usr/lib/X11 and /usr/include/X11 pre-exist.
197- Removed 'x' suffix from manpage directories to match RC3 upstream.
198
199* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
200- rebuilt
201
202* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
203- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
204- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
205
206* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
207- Updated libXv to version 0.99.1 from X11R7 RC1
208- Updated file manifest to find manpages in "man3x"
209
210* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
211- Renamed package to remove xorg-x11 from the name due to unanimous decision
212  between developers.
213- Use Fedora Extras style BuildRoot tag.
214- Disable static library creation by default.
215- Add missing defattr to devel subpackage
216- Add missing documentation files to doc macro
217
218* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
219- Renamed package to prepend "xorg-x11" to the name for consistency with
220  the rest of the X11R7 packages.
221- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
222  subpackage to ensure the devel package matches the installed shared libs.
223- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
224  allow applications to use implementation agnostic dependencies.
225- Added post/postun scripts which call ldconfig.
226- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
227  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
228
229* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
230- Initial build.
Note: See TracBrowser for help on using the repository browser.