source: projects/specs/branches/6/lib/libX/libXtst/libXtst-vl.spec @ 7730

Revision 7730, 6.9 KB checked in by Takemikaduchi, 11 years ago (diff)

security fix

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXtst runtime library
4Summary(ja): X.Org X11 libXtst ランタイムライブラリ
5Name: libXtst
6Version: 1.2.0
7Release: 3%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14# fix CVE-2013-2063
15Patch0: libXtst-CVE-2013-2063.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires: pkgconfig
19BuildRequires: xorg-x11-proto-devel
20BuildRequires: libX11-devel
21BuildRequires: libXext-devel
22BuildRequires: libXi-devel
23BuildRequires: autoconf
24BuildRequires: xorg-x11-util-macros
25
26Obsoletes: XFree86-libs, XOrg-libs
27
28%description
29X.Org X11 libXtst runtime library
30
31%package devel
32Summary: X.Org X11 libXtst development package
33Summary(ja): X.Org X11 libXtst 開発パッケージ
34Group: Development/Libraries
35Requires(pre): xorg-x11-filesystem
36Requires: %{name} = %{version}-%{release}
37Requires: xorg-x11-proto-devel
38Requires: libXi-devel
39Obsoletes: XFree86-devel, XOrg-devel
40
41%description devel
42X.Org X11 libXtst development package
43
44# compat32
45%package -n compat32-%{name}
46Summary: X.Org X11 libXtst runtime library
47Summary(ja): X.Org X11 libXtst ランタイムライブラリ
48Group: System Environment/Libraries
49
50%description -n compat32-%{name}
51X.Org X11 libXtst runtime library
52
53%package -n compat32-%{name}-devel
54Summary: X.Org X11 libXtst development package
55Summary(ja): X.Org X11 libXtst 開発パッケージ
56Group: Development/Libraries
57Requires(pre): xorg-x11-filesystem
58Requires: compat32-%{name} = %{version}-%{release}
59Requires: %{name}-devel = %{version}-%{release}
60
61%description -n compat32-%{name}-devel
62X.Org X11 libXtst development package
63
64%prep
65%setup -q
66%patch0 -p1
67
68# Disable static library creation by default.
69%define with_static 0
70
71%build
72autoreconf -if
73%configure \
74%if ! %{with_static}
75        --disable-static
76%endif
77make
78
79%install
80rm -rf $RPM_BUILD_ROOT
81
82make install DESTDIR=$RPM_BUILD_ROOT
83
84# We intentionally don't ship *.la files
85rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
86
87# remove xml and txt file
88rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
89rm -rf $RPM_BUILD_ROOT%{_mandir}
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%post -p /sbin/ldconfig
95%postun -p /sbin/ldconfig
96
97%post -n compat32-%{name} -p /sbin/ldconfig
98%postun -n compat32-%{name} -p /sbin/ldconfig
99
100%files
101%defattr(-,root,root,-)
102%doc AUTHORS COPYING README ChangeLog
103%{_libdir}/libXtst.so.6
104%{_libdir}/libXtst.so.6.*
105
106%files devel
107%defattr(-,root,root,-)
108%{_includedir}/X11/extensions/*.h
109%if %{with_static}
110%{_libdir}/libXtst.a
111%endif
112%{_libdir}/libXtst.so
113%{_libdir}/pkgconfig/xtst.pc
114
115# compat32
116%if %{build_compat32}
117%files -n compat32-%{name}
118%defattr(-,root,root,-)
119%{_libdir}/libXtst.so.6
120%{_libdir}/libXtst.so.6.*
121
122%files -n compat32-%{name}-devel
123%defattr(-,root,root,-)
124%if %{with_static}
125%{_libdir}/libXtst.a
126%endif
127%{_libdir}/libXtst.so
128%{_libdir}/pkgconfig/xtst.pc
129%endif
130
131%changelog
132* Sat Jun 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-3
133- add Patch0 (libXtst-CVE-2013-2063.patch)
134- add BuildRequires: autoconf, xorg-x11-util-macros
135
136* Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-2
137- add Requires: libXi-devel (devel package)
138
139* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
140- new upstream release
141
142* Fri Sep 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-3
143- rebuild with rpm-4.8.1 for pkg-config file
144- add BuildRequires: libXi-devel
145- fix %files (remove man3)
146
147* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-2
148- add XTest.h/record.h to libXtst-devel
149
150* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
151- new upstream release
152
153* Sat May 09 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.3-3
154- added compat32 package for x86_64 arch support
155
156* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-2
157- spec in utf-8
158
159* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-1
160- new versioning policy
161
162* Thu Jan 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-0vl1
163- initial build for Vine Linux
164
165* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 1.0.3-1
166- libXtst 1.0.3
167
168* Wed Aug 22 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-2
169- Rebuild for PPC toolchain bug
170
171* Sat Jun 23 2007 Adam Jackson <ajax@redhat.com> 1.0.2-1.
172- libXtst 1.0.2
173
174* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 1.0.1-4
175- Don't install INSTALL
176
177* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-3.1
178- rebuild
179
180* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
181- Added "Requires: xorg-x11-proto-devel" to devel package for xtst.pc
182
183* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
184- Added "BuildRequires: pkgconfig" for (#193504)
185- Replace "makeinstall" with "make install DESTDIR=..."
186- Remove package ownership of mandir/libdir/etc.
187
188* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
189- bump again for double-long bug on ppc(64)
190
191* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
192- rebuilt for new gcc4.1 snapshot and glibc changes
193
194* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
195- Updated libXtst to version 1.0.1 from X11R7.0
196
197* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
198- Updated libXtst to version 1.0.0 from X11R7 RC4
199
200* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-1
201- Updated libXtst to version 0.99.3 from X11R7 RC3
202- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
203  that /usr/lib/X11 and /usr/include/X11 pre-exist.
204- Removed 'x' suffix from manpage directories to match RC3 upstream.
205
206* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
207- rebuilt
208
209* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
210- Updated libXtst to version 0.99.2 from X11R7 RC2
211- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
212- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
213
214* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
215- Updated libXtst to version 0.99.1 from X11R7 RC1
216
217* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
218- Renamed package to remove xorg-x11 from the name due to unanimous decision
219  between developers.
220- Use Fedora Extras style BuildRoot tag.
221- Disable static library creation by default.
222- Add missing defattr to devel subpackage
223- Add missing documentation files to doc macro
224
225* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
226- Renamed package to prepend "xorg-x11" to the name for consistency with
227  the rest of the X11R7 packages.
228- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
229  subpackage to ensure the devel package matches the installed shared libs.
230- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
231  allow applications to use implementation agnostic dependencies.
232- Added post/postun scripts which call ldconfig.
233- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
234  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
235
236* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
237- Initial build.
Note: See TracBrowser for help on using the repository browser.