source: projects/specs/branches/6/lib/libX/libXt/libXt-vl.spec @ 7730

Revision 7730, 10.5 KB checked in by Takemikaduchi, 11 years ago (diff)

security fix

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXt runtime library
4Summary(ja): X.Org X11 libXt ランタイムライブラリ
5Name: libXt
6Version: 1.1.1
7Release: 2%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14# fix CVE-2013-2005
15Patch0: libXt-CVE-2013-2005.patch
16# fix CVE-2013-2002
17Patch1: libXt-CVE-2013-2002.patch
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20BuildRequires: pkgconfig
21BuildRequires: xorg-x11-proto-devel
22BuildRequires: libX11-devel
23BuildRequires: libSM-devel
24Obsoletes: XFree86-libs, XOrg-libs
25
26%description
27X.Org X11 libXt runtime library
28
29%package devel
30Summary: X.Org X11 libXt development package
31Group: Development/Libraries
32Requires(pre): xorg-x11-filesystem
33Requires: %{name} = %{version}-%{release}
34Requires: xorg-x11-proto-devel
35Requires: libX11-devel
36Requires: libSM-devel
37Obsoletes: XFree86-devel, XOrg-devel
38
39%description devel
40X.Org X11 libXt development package
41
42# compat32
43%package -n compat32-%{name}
44Summary: X.Org X11 libXt runtime library
45Summary(ja): X.Org X11 libXt ランタイムライブラリ
46Group: System Environment/Libraries
47
48%description -n compat32-%{name}
49X.Org X11 libXt runtime library
50
51%package -n compat32-%{name}-devel
52Summary: X.Org X11 libXt development package
53Group: Development/Libraries
54Requires(pre): xorg-x11-filesystem
55Requires: compat32-%{name} = %{version}-%{release}
56Requires: %{name}-devel = %{version}-%{release}
57Requires: compat32-libX11-devel
58Requires: compat32-libSM-devel
59
60%description -n compat32-%{name}-devel
61X.Org X11 libXt development package
62
63%prep
64%setup -q
65%patch0 -p1
66%patch1 -p1
67
68# Disable static library creation by default.
69%define with_static 0
70
71%build
72# FIXME: Work around pointer aliasing warnings from compiler for now
73export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
74%configure \
75%if ! %{with_static}
76        --disable-static \
77%endif
78        --with-xfile-search-path="%{_sysconfdir}/X11/%%L/%%T/%%N%%C%%S:%{_sysconfdir}/X11/%%l/%%T/\%%N%%C%%S:%{_sysconfdir}/X11/%%T/%%N%%C%%S:%{_sysconfdir}/X11/%%L/%%T/%%N%%S:%{_sysconfdir}/X\11/%%l/%%T/%%N%%S:%{_sysconfdir}/X11/%%T/%%N%%S:%{_datadir}/X11/%%L/%%T/%%N%%C%%S:%{_datadir}/X1\1/%%l/%%T/%%N%%C%%S:%{_datadir}/X11/%%T/%%N%%C%%S:%{_datadir}/X11/%%L/%%T/%%N%%S:%{_datadir}/X11/%%\l/%%T/%%N%%S:%{_datadir}/X11/%%T/%%N%%S"
79
80make
81
82%install
83rm -rf $RPM_BUILD_ROOT
84
85make install DESTDIR=$RPM_BUILD_ROOT
86# NOTE: Create app-defaults directory so this package can be the canonical
87# owner of the directory.
88mkdir -p -m 0755 $RPM_BUILD_ROOT%{_datadir}/X11/app-defaults
89
90# We intentionally don't ship *.la files
91rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
92
93%clean
94rm -rf $RPM_BUILD_ROOT
95
96%post -p /sbin/ldconfig
97%postun -p /sbin/ldconfig
98
99%post -n compat32-%{name} -p /sbin/ldconfig
100%postun -n compat32-%{name} -p /sbin/ldconfig
101
102%files
103%defattr(-,root,root,-)
104%doc COPYING README ChangeLog
105%{_libdir}/libXt.so.*
106%dir %{_datadir}/X11/app-defaults
107
108%files devel
109%defattr(-,root,root,-)
110%dir %{_includedir}/X11
111# Listed explicitly instead of with glob, in order for rpm to autodetect
112# when any additions or removals happen.  ie: New Xprint support that we
113# do not want.
114%{_includedir}/X11/CallbackI.h
115%{_includedir}/X11/Composite.h
116%{_includedir}/X11/CompositeP.h
117%{_includedir}/X11/ConstrainP.h
118%{_includedir}/X11/Constraint.h
119%{_includedir}/X11/ConvertI.h
120%{_includedir}/X11/Core.h
121%{_includedir}/X11/CoreP.h
122%{_includedir}/X11/CreateI.h
123%{_includedir}/X11/EventI.h
124%{_includedir}/X11/HookObjI.h
125%{_includedir}/X11/InitialI.h
126%{_includedir}/X11/Intrinsic.h
127%{_includedir}/X11/IntrinsicI.h
128%{_includedir}/X11/IntrinsicP.h
129%{_includedir}/X11/Object.h
130%{_includedir}/X11/ObjectP.h
131%{_includedir}/X11/PassivGraI.h
132%{_includedir}/X11/RectObj.h
133%{_includedir}/X11/RectObjP.h
134%{_includedir}/X11/ResConfigP.h
135%{_includedir}/X11/ResourceI.h
136%{_includedir}/X11/SelectionI.h
137%{_includedir}/X11/Shell.h
138%{_includedir}/X11/ShellI.h
139%{_includedir}/X11/ShellP.h
140%{_includedir}/X11/StringDefs.h
141%{_includedir}/X11/ThreadsI.h
142%{_includedir}/X11/TranslateI.h
143%{_includedir}/X11/VarargsI.h
144%{_includedir}/X11/Vendor.h
145%{_includedir}/X11/VendorP.h
146%{_includedir}/X11/Xtos.h
147%if %{with_static}
148%{_libdir}/libXt.a
149%endif
150%{_libdir}/libXt.so
151%{_libdir}/pkgconfig/xt.pc
152%{_mandir}/man3/*.3*
153
154# compat32
155%if %{build_compat32}
156%files -n compat32-%{name}
157%defattr(-,root,root,-)
158%{_libdir}/libXt.so.6
159%{_libdir}/libXt.so.6.0.0
160
161%files -n compat32-%{name}-devel
162%defattr(-,root,root,-)
163%if %{with_static}
164%{_libdir}/libXt.a
165%endif
166%{_libdir}/libXt.so
167%{_libdir}/pkgconfig/xt.pc
168%endif
169
170%changelog
171* Wed May 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-2
172- add Patch0 (libXt-CVE-2013-2005.patch)
173- add Patch1 (libXt-CVE-2013-2002.patch)
174
175* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-1
176- new upstream release
177
178* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
179- new upstream release
180- remove Patch0
181
182* Fri Sep 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-2
183- rebuild with rpm-4.8.1 for pkg-config file
184
185* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.8-1
186- new upstream release
187
188* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.7-1
189- new upstream release
190
191* Tue May 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.5-2
192- added compat32 package for x86_64 arch support
193
194* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-1
195- new upstream release
196
197* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
198- new versioning policy
199
200* Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl1
201- initial build for Vine Linux
202
203* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.4-3
204- Rebuild for build id
205
206* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.4-2
207- Don't install INSTALL
208
209* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.0.4-1.fc7
210- Update to 1.0.4
211
212* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.2-3.1.fc6
213- rebuild
214
215* Tue Jul 11 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-3.fc6
216- Add the {_datadir}/X11/app-defaults directory to the file manifest, as
217  libXt is the canonical owner of the directory.  Discovered in (#198025).
218
219* Wed Jun 28 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-2
220- Added libXt-1.0.2-libsm-fix.patch to remove libSM from the Requires: line
221  in the installed pkgconfig file.  Apps should link against libSM if they
222  need it, but we shouldn't force them to link against it if they don't.
223
224* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-1
225- Updated libXt to version 1.0.2 from X11R7.1
226
227* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
228- Added "Requires: xorg-x11-proto-devel" to devel package for xt.pc
229
230* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
231- Added "BuildRequires: pkgconfig" for (#193503)
232- Replace "makeinstall" with "make install DESTDIR=..."
233- Remove package ownership of mandir/libdir/etc.
234
235* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-1
236- Update to 1.0.1
237
238* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.2
239- bump again for double-long bug on ppc(64)
240
241* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.1
242- rebuilt for new gcc4.1 snapshot and glibc changes
243
244* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
245- Bumped and rebuilt
246
247* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
248- Updated libXt to version 1.0.0 from X11R7 RC4
249- Added makestrs and it's manpage to the devel subpackage.
250
251* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-1
252- Updated libXt to version 0.99.3 from X11R7 RC3
253- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
254  that /usr/lib/X11 and /usr/include/X11 pre-exist.
255- Removed 'x' suffix from manpage directories to match RC3 upstream.
256
257* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
258- rebuilt
259
260* Fri Dec 02 2005 Kristian H淡gsberg <krh@redhat.com> 0.99.2-3
261- Use the default value from configure.ac for --with-xfile-search-path
262  except with %%{_datadir} instead of $(libdir), so Xt can search for
263  app-default files as usual.
264- Move the --with-xfile-search-path outside the with_static condition.
265
266* Tue Nov 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
267- Invoke ./configure --with-xfile-search-path=%%{_datadir}/X11/app-defaults
268  to make sure Xt is looking in the right place for app-defaults files.
269
270* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
271- Updated libXt to version 0.99.2 from X11R7 RC2
272- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
273- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
274
275* Wed Nov 02 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-3
276- Actually spell RPM_OPT_FLAGS correctly this time.
277
278* Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
279- Build with -fno-strict-aliasing to work around possible pointer aliasing
280  issue
281
282* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
283- Updated libXt to version 0.99.1 from X11R7 RC1
284- Updated file manifest to find manpages in 'man3x'
285
286* Thu Oct 06 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-5
287- Added Requires: libX11-devel to libXt-devel subpackage, as Xt headers
288  include Xlib headers causing xterm and other things to fail to compile.
289
290* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-4
291- Renamed package to remove xorg-x11 from the name due to unanimous decision
292  between developers.
293- Use Fedora Extras style BuildRoot tag.
294- Disable static library creation by default.
295- Add missing defattr to devel subpackage
296- Add missing documentation files to doc macro
297- Fix BuildRequires to use new style X library package names
298
299* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
300- Changed all virtual BuildRequires to the "xorg-x11-" prefixed non-virtual
301  package names, as we want xorg-x11 libs to explicitly build against
302  X.Org supplied libs, rather than "any implementation", which is what the
303  virtual provides is intended for.
304
305* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
306- Renamed package to prepend "xorg-x11" to the name for consistency with
307  the rest of the X11R7 packages.
308- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
309  subpackage to ensure the devel package matches the installed shared libs.
310- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
311  allow applications to use implementation agnostic dependencies.
312- Added post/postun scripts which call ldconfig.
313- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
314  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
315
316* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
317- Initial build.
Note: See TracBrowser for help on using the repository browser.