source: projects/specs/branches/6/lib/libX/libXp/libXp-vl.spec @ 7730

Revision 7730, 9.0 KB checked in by Takemikaduchi, 11 years ago (diff)

security fix

Line 
1# libXp will be removed from future release.
2%define without_devel   0
3
4%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
5
6Summary: X.Org X11 libXp runtime library
7Summary(ja): X.Org X11 libXp ランタイムライブラリ
8Name: libXp
9Version: 1.0.1
10Release: 2%{?_dist_release}
11License: MIT/X11
12Group: System Environment/Libraries
13URL: http://www.x.org
14
15Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
16
17Patch0: libXp-1.0.1-add-proto-files.patch
18
19# fix CVE-2013-2062
20Patch1: libXp-CVE-2013-2062.patch
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
23BuildRequires: pkgconfig
24BuildRequires: xorg-x11-util-macros
25BuildRequires: xorg-x11-proto-devel
26BuildRequires: libX11-devel
27BuildRequires: libXext-devel
28BuildRequires: libXau-devel
29BuildRequires: libtool automake autoconf gettext
30Obsoletes: XFree86-libs, XOrg-libs
31
32%description
33X.Org X11 libXp runtime library
34
35%package devel
36Summary: X.Org X11 libXp development package
37Summary(ja): X.Org X11 libXp 開発パッケージ
38Group: Development/Libraries
39Requires(pre): xorg-x11-filesystem
40Requires: libXau-devel
41Requires: libXext-devel
42Requires: %{name} = %{version}-%{release}
43BuildRequires: xorg-x11-proto-devel
44Obsoletes: XFree86-devel, XOrg-devel
45
46%description devel
47X.Org X11 libXp development package
48
49# compat32
50%package -n compat32-%{name}
51Summary: X.Org X11 libXp runtime library
52Summary(ja): X.Org X11 libXp ランタイムライブラリ
53Group: System Environment/Libraries
54Requires: %{name} = %{version}-%{release}
55
56%description -n compat32-%{name}
57X.Org X11 libXp runtime library
58
59%package -n compat32-%{name}-devel
60Summary: X.Org X11 libXp development package
61Summary(ja): X.Org X11 libXp 開発パッケージ
62Group: Development/Libraries
63Requires(pre): xorg-x11-filesystem
64Requires: %{name}-devel = %{version}-%{release}
65Requires: compat32-%{name} = %{version}-%{release}
66Requires: compat32-libXau-devel
67
68%description -n compat32-%{name}-devel
69X.Org X11 libXp development package
70
71%prep
72%setup -q
73
74%patch0 -p1 -b .add-proto-files
75%patch1 -p1
76
77# Disable static library creation by default.
78%define with_static 0
79
80%build
81
82# There is a patch that changes configure.ac, so we have
83# run autoreconf
84
85autoreconf -if
86CPPFLAGS="$CPPFLAGS -I$RPM_BUILD_ROOT%{_includedir}"
87export CPPFLAGS
88
89autoreconf -v --install
90
91%configure \
92%if ! %{with_static}
93        --disable-static
94%endif
95make
96
97%install
98rm -rf $RPM_BUILD_ROOT
99
100make install DESTDIR=$RPM_BUILD_ROOT
101
102%if %{without_devel}
103{
104   rm -f $RPM_BUILD_ROOT%{_libdir}/libXp.a
105   rm -f $RPM_BUILD_ROOT%{_libdir}/libXp.so
106   rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
107   rm -rf $RPM_BUILD_ROOT%{_mandir}
108}
109%endif
110
111# Don't encourage people to use the deprecated Xprint APIs.
112rm -rf $RPM_BUILD_ROOT%{_mandir}
113
114# We intentionally don't ship *.la files
115rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%post -p /sbin/ldconfig
121%postun -p /sbin/ldconfig
122
123%post -n compat32-%{name} -p /sbin/ldconfig
124%postun -n compat32-%{name} -p /sbin/ldconfig
125
126%files
127%defattr(-,root,root,-)
128%doc AUTHORS COPYING README INSTALL ChangeLog
129%{_libdir}/libXp.so.6
130%{_libdir}/libXp.so.6.2.0
131
132%if ! %{without_devel}
133%files devel
134%defattr(-,root,root,-)
135%if %{with_static}
136%{_libdir}/libXp.a
137%endif
138%{_includedir}/X11/extensions/Print.h
139%{_includedir}/X11/extensions/Printstr.h
140%{_libdir}/pkgconfig/printproto.pc
141# FIXME: Should we remove the shared lib during deprecation, so that things
142# that keep linking to libXp, will always get the static lib and not break
143# when we eventually drop libXp?
144%{_libdir}/libXp.so
145%{_libdir}/pkgconfig/xp.pc
146#%dir %{_mandir}/man3x
147#%{_mandir}/man3/*.3x*
148%endif
149
150# compat32
151%if %{build_compat32}
152%files -n compat32-%{name}
153%defattr(-,root,root,-)
154%{_libdir}/libXp.so.6
155%{_libdir}/libXp.so.6.2.0
156
157%if ! %{without_devel}
158%files -n compat32-%{name}-devel
159%defattr(-,root,root,-)
160%if %{with_static}
161%{_libdir}/libXp.a
162%endif
163%{_libdir}/pkgconfig/printproto.pc
164# FIXME: Should we remove the shared lib during deprecation, so that things
165# that keep linking to libXp, will always get the static lib and not break
166# when we eventually drop libXp?
167%{_libdir}/libXp.so
168%{_libdir}/pkgconfig/xp.pc
169%endif
170%endif
171
172%changelog
173* Thu May 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-2
174- add Patch1 (libXp-CVE-2013-2062.patch)
175
176* Sat Jan 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-1
177- new upstream release
178- update Patch0 (libXp-1.0.1-add-proto-files.patch)
179- add Requires: libXext-devel (devel package)
180
181* Fri Sep 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-4
182- rebuild with rpm-4.8.1 for pkg-config file
183
184* Mon Jul 20 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.0-3
185- added compat32 package for x86_64 arch support
186
187* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
188- spec in utf-8
189
190* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
191- new versioning policy
192
193* Mon Jan 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl1
194- initial build for Vine Linux
195
196* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.0-8
197- Rebuild for build id
198
199* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-8
200- rebuilt for unwind info generation, broken in gcc-4.1.1-21
201
202* Wed Sep 20 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0.7
203- Add requires for the devel package on libXau-devel (173530)
204
205* Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-6
206- Add the proto files directly instead of attempting to build a separate
207  tarball. Also remove last traces of printproto-1.0.3.tar.gz
208
209* Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com>
210- Remove printproto source.
211
212* Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-6
213- BuildRequire autoconf automake libtool gettext
214
215* Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-6
216- Run autoreconf to make sure changes to configure.ac take effect
217
218* Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-6
219- Add patch to not check for printproto.pc. (Since it's part of this
220  package now, it isn't installed at the time libXp is configured).
221
222* Thu Aug 17 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-5
223- Moved Print.h, Printstr.h and printproto.pc into the devel package here
224  (they used to be in xorg-x11-proto-devel).
225
226* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control
227- rebuild
228
229* Mon Jul 10 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-4
230- Renamed libXp_deprecated rpm macro to "with_devel" to avoid confusion.  This
231  library is still deprecated, we just decided to remove the word "deprecated"
232  from the package name for library naming consistency.
233
234* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-3
235- Replace "makeinstall" with "make install DESTDIR=..."
236- Added "Requires: xorg-x11-proto-devel" to devel for xp.pc
237- Remove package ownership of mandir/libdir/etc.
238
239* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.2
240- bump again for double-long bug on ppc(64)
241
242* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.1
243- rebuilt for new gcc4.1 snapshot and glibc changes
244
245* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
246- Bumped and rebuilt
247
248* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
249- Updated libXp to version 1.0.0 from X11R7 RC4
250
251* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
252- Updated libXp to version 0.99.2 from X11R7 RC3
253- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
254  that /usr/lib/X11 and /usr/include/X11 pre-exist.
255- Removed 'x' suffix from manpage directories to match RC3 upstream.
256
257* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
258- rebuilt
259
260* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-3
261- Added "Obsoletes: xorg-x11-deprecated-libs" to runtime package, and
262  "Obsoletes: xorg-x11-deprecated-libs-devel" to devel package.
263
264* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
265- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
266- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
267
268* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
269- Updated libXp to version 0.99.1 from X11R7 RC1
270
271* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
272- Renamed package to remove xorg-x11 from the name due to unanimous decision
273  between developers.
274- Use Fedora Extras style BuildRoot tag.
275- Disable static library creation by default.
276- Add missing defattr to devel subpackage
277- Add missing documentation files to doc macro
278
279* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
280- Renamed package to prepend "xorg-x11" to the name for consistency with
281  the rest of the X11R7 packages.
282- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
283  subpackage to ensure the devel package matches the installed shared libs.
284- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
285  allow applications to use implementation agnostic dependencies.
286- Added post/postun scripts which call ldconfig.
287- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
288  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
289
290* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
291- Initial build.
Note: See TracBrowser for help on using the repository browser.