source: projects/specs/branches/6/lib/libX/libXmu/libXmu-vl.spec @ 2203

Revision 2203, 8.4 KB checked in by Takemikaduchi, 13 years ago (diff)

update Xorg libraries and xserver, and rebuild driver

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXmu/libXmuu runtime libraries
4Summary(ja): X.Org X11 libXmu/libXmuu ランタイムライブラリ
5Name: libXmu
6Version: 1.1.0
7Release: 1%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-util-macros
17BuildRequires: libX11-devel
18BuildRequires: libXext-devel
19BuildRequires: libXt-devel
20BuildRequires: libXau-devel
21Obsoletes: XFree86-libs, XOrg-libs
22
23%description
24X.Org X11 libXmu/libXmuu runtime libraries
25
26%package devel
27Summary: X.Org X11 libXmu development package
28Group: Development/Libraries
29Requires(pre): xorg-x11-filesystem
30Requires: %{name} = %{version}-%{release}
31Requires: pkgconfig
32Requires: xorg-x11-util-macros
33Requires: xorg-x11-proto-devel libX11-devel libXt-devel libXext-devel
34Obsoletes: XFree86-devel, XOrg-devel
35
36%description devel
37X.Org X11 libXmu development package
38
39# compat32
40%package -n compat32-%{name}
41Summary: X.Org X11 libXmu/libXmuu runtime libraries
42Summary(ja): X.Org X11 libXmu/libXmuu ランタイムライブラリ
43Group: System Environment/Libraries
44Requires: %{name} = %{version}-%{release}
45
46%description -n compat32-%{name}
47X.Org X11 libXmu/libXmuu runtime libraries
48
49%package -n compat32-%{name}-devel
50Summary: X.Org X11 libXmu development package
51Group: Development/Libraries
52Requires(pre): xorg-x11-filesystem
53Requires: %{name}-devel = %{version}-%{release}
54Requires: compat32-%{name} = %{version}-%{release}
55Requires: compat32-libX11-devel compat32-libXt-devel compat32-libXext-devel
56
57%description -n compat32-%{name}-devel
58X.Org X11 libXmu development package
59
60%prep
61%setup -q
62
63# Disable static library creation by default.
64%define with_static 0
65
66%build
67%configure \
68%if ! %{with_static}
69        --disable-static
70%endif
71make
72
73%install
74rm -rf $RPM_BUILD_ROOT
75
76make install DESTDIR=$RPM_BUILD_ROOT
77
78# We intentionally don't ship *.la files
79rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
80
81# remove xml and txt file
82rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%post -p /sbin/ldconfig
88%postun -p /sbin/ldconfig
89
90%post -n compat32-%{name} -p /sbin/ldconfig
91%postun -n compat32-%{name} -p /sbin/ldconfig
92
93%files
94%defattr(-,root,root,-)
95%doc AUTHORS COPYING README ChangeLog
96%{_libdir}/libXmu.so.6
97%{_libdir}/libXmu.so.6.2.0
98%{_libdir}/libXmuu.so.1
99%{_libdir}/libXmuu.so.1.0.0
100
101%files devel
102%defattr(-,root,root,-)
103%dir %{_includedir}/X11
104%dir %{_includedir}/X11/Xmu
105%{_includedir}/X11/Xmu/Atoms.h
106%{_includedir}/X11/Xmu/CharSet.h
107%{_includedir}/X11/Xmu/CloseHook.h
108%{_includedir}/X11/Xmu/Converters.h
109%{_includedir}/X11/Xmu/CurUtil.h
110%{_includedir}/X11/Xmu/CvtCache.h
111%{_includedir}/X11/Xmu/DisplayQue.h
112%{_includedir}/X11/Xmu/Drawing.h
113%{_includedir}/X11/Xmu/Editres.h
114%{_includedir}/X11/Xmu/EditresP.h
115%{_includedir}/X11/Xmu/Error.h
116%{_includedir}/X11/Xmu/ExtAgent.h
117%{_includedir}/X11/Xmu/Initer.h
118%{_includedir}/X11/Xmu/Lookup.h
119%{_includedir}/X11/Xmu/Misc.h
120%{_includedir}/X11/Xmu/StdCmap.h
121%{_includedir}/X11/Xmu/StdSel.h
122%{_includedir}/X11/Xmu/SysUtil.h
123%{_includedir}/X11/Xmu/WhitePoint.h
124%{_includedir}/X11/Xmu/WidgetNode.h
125%{_includedir}/X11/Xmu/WinUtil.h
126%{_includedir}/X11/Xmu/Xct.h
127%{_includedir}/X11/Xmu/Xmu.h
128%if %{with_static}
129%{_libdir}/libXmu.a
130%{_libdir}/libXmuu.a
131%endif
132%{_libdir}/libXmu.so
133%{_libdir}/libXmuu.so
134%{_libdir}/pkgconfig/xmu.pc
135%{_libdir}/pkgconfig/xmuu.pc
136
137# compat32
138%if %{build_compat32}
139%files -n compat32-%{name}
140%defattr(-,root,root,-)
141%{_libdir}/libXmu.so.6
142%{_libdir}/libXmu.so.6.2.0
143%{_libdir}/libXmuu.so.1
144%{_libdir}/libXmuu.so.1.0.0
145
146%files -n compat32-%{name}-devel
147%defattr(-,root,root,-)
148%if %{with_static}
149%{_libdir}/libXmu.a
150%{_libdir}/libXmuu.a
151%endif
152%{_libdir}/libXmu.so
153%{_libdir}/libXmuu.so
154%{_libdir}/pkgconfig/xmu.pc
155%{_libdir}/pkgconfig/xmuu.pc
156%endif
157
158%changelog
159* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-1
160- new upstream release
161- fix %%install, %%files
162
163* Fri Sep 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-2
164- rebuild with rpm-4.8.1 for pkg-config file
165
166* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-1
167- new upstream release
168
169* Mon Jul 20 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.4-2
170- added compat32 package for x86_64 arch support
171
172* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
173- new upstream release
174
175* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-1
176- new versioning policy
177
178* Mon Jan 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-0vl1
179- initial build for Vine Linux
180
181* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.3-3
182- Rebuild for build id
183
184* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.3-2
185- Don't install INSTALL
186
187* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.0.3-1.fc7
188- Update to 1.0.3
189
190* Fri Oct 13 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-6.fc7
191- Also add Requires for libXext-devel for development package (#210123)
192- Add pkgconfig dependency for -devel package.
193
194* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.2-5
195- Add Requires on libXt (bug 202558)
196
197* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control
198- rebuild
199
200* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-4
201- Rebuild, brew doesn't pick up buildroot changes fast enough.
202
203* Wed Jun 28 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-3
204- Rebuild for libXt pkgconfig fixes.
205
206* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-2
207- Replace "makeinstall" with "make install DESTDIR=..."
208- Added "Requires: xorg-x11-proto-devel, libX11-devel, libXt-devel" to devel
209  subpackage needed by xmu.pc, xmuu.pc
210- Remove package ownership of mandir/libdir/etc.
211
212* Fri May 12 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
213- Update to 1.0.2
214
215* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-1
216- Update to 1.0.1
217
218* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.2
219- bump again for double-long bug on ppc(64)
220
221* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.1
222- rebuilt for new gcc4.1 snapshot and glibc changes
223
224* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
225- Bumped and rebuilt
226
227* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
228- Updated libXmu to version 1.0.0 from X11R7 RC4
229
230* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
231- Updated libXmu to version 0.99.2 from X11R7 RC3
232- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
233  that /usr/lib/X11 and /usr/include/X11 pre-exist.
234- Removed 'x' suffix from manpage directories to match RC3 upstream.
235- Added "BuildRequires: pkgconfig, libXau-devel, xorg-x11-util-macros" to
236  fix build dependencies.
237
238* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
239- rebuilt
240
241* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
242- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
243- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
244
245* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
246- Updated libXmu to version 0.99.1 from X11R7 RC1
247
248* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-4
249- Renamed package to remove xorg-x11 from the name due to unanimous decision
250  between developers.
251- Use Fedora Extras style BuildRoot tag.
252- Disable static library creation by default.
253- Add missing defattr to devel subpackage
254- Add missing documentation files to doc macro
255- Fix BuildRequires to use new style X library package names
256
257* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
258- Changed all virtual BuildRequires to the "xorg-x11-" prefixed non-virtual
259  package names, as we want xorg-x11 libs to explicitly build against
260  X.Org supplied libs, rather than "any implementation", which is what the
261  virtual provides is intended for.
262
263* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
264- Renamed package to prepend "xorg-x11" to the name for consistency with
265  the rest of the X11R7 packages.
266- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
267  subpackage to ensure the devel package matches the installed shared libs.
268- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
269  allow applications to use implementation agnostic dependencies.
270- Added post/postun scripts which call ldconfig.
271- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
272  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
273
274* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
275- Initial build.
Note: See TracBrowser for help on using the repository browser.