source: projects/specs/branches/6/lib/libX/libXext/libXext-vl.spec @ 7730

Revision 7730, 7.0 KB checked in by Takemikaduchi, 11 years ago (diff)

security fix

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXext runtime library
4Summary(ja): X.Org X11 libXext ランタイムライブラリ
5Name: libXext
6Version: 1.2.0
7Release: 2%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14# fix CVE-2013-1982
15Patch0: libXext-1.2.0-CVE-2013-1982.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires: pkgconfig
19BuildRequires: xorg-x11-proto-devel
20BuildRequires: libX11-devel
21BuildRequires: libXau-devel
22BuildRequires: autoconf
23BuildRequires: xorg-x11-util-macros
24
25Obsoletes: XFree86-libs, XOrg-libs
26
27%description
28X.Org X11 libXext runtime library
29
30%package devel
31Summary: X.Org X11 libXext development package
32Group: Development/Libraries
33Requires(pre): xorg-x11-filesystem >= 0.99.2-3
34Requires: %{name} = %{version}-%{release}
35Requires: libX11-devel
36Requires: xorg-x11-proto-devel >= 7.5
37Conflicts: xorg-x11-proto-devel < 7.5
38Obsoletes: XFree86-devel, XOrg-devel
39
40%description devel
41X.Org X11 libXext development package
42
43# compat32
44%package -n compat32-%{name}
45Summary: X.Org X11 libXext runtime library
46Summary(ja): X.Org X11 libXext ランタイムライブラリ
47Group: System Environment/Libraries
48
49%description -n compat32-%{name}
50X.Org X11 libXext runtime library
51
52%package -n compat32-%{name}-devel
53Summary: X.Org X11 libXext development package
54Group: Development/Libraries
55Requires(pre): xorg-x11-filesystem >= 0.99.2-3
56Requires: compat32-%{name} = %{version}-%{release}
57Requires: %{name}-devel = %{version}-%{release}
58Requires: compat32-libX11-devel
59
60%description -n compat32-%{name}-devel
61X.Org X11 libXext development package
62
63%prep
64%setup -q
65%patch0 -p1
66
67# Disable static library creation by default.
68%define with_static 0
69
70%build
71autoreconf -if
72%configure \
73%if ! %{with_static}
74        --disable-static
75%endif
76make
77
78%install
79rm -rf $RPM_BUILD_ROOT
80
81make install DESTDIR=$RPM_BUILD_ROOT
82
83# We intentionally don't ship *.la files
84rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
85
86# remove xml and txt file
87rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%post -p /sbin/ldconfig
93%postun -p /sbin/ldconfig
94
95%post -n compat32-%{name} -p /sbin/ldconfig
96%postun -n compat32-%{name} -p /sbin/ldconfig
97
98%files
99%defattr(-,root,root,-)
100%doc AUTHORS COPYING README ChangeLog
101%{_libdir}/libXext.so.6
102%{_libdir}/libXext.so.6.4.*
103
104%files devel
105%defattr(-,root,root,-)
106%{_includedir}/X11/extensions/*.h
107%if %{with_static}
108%{_libdir}/libXext.a
109%endif
110%{_libdir}/libXext.so
111%{_libdir}/pkgconfig/xext.pc
112%{_mandir}/man3/*.3*
113
114# compat32
115%if %{build_compat32}
116%files -n compat32-%{name}
117%defattr(-,root,root,-)
118%{_libdir}/libXext.so.6
119%{_libdir}/libXext.so.6.4.*
120
121%files -n compat32-%{name}-devel
122%defattr(-,root,root,-)
123%if %{with_static}
124%{_libdir}/libXext.a
125%endif
126%{_libdir}/libXext.so
127%{_libdir}/pkgconfig/xext.pc
128%endif
129
130%changelog
131* Wed May 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-2
132- add Patch0 (libXext-1.2.0-CVE-2013-1982.patch)
133- add BuildRequires: autoconf, xorg-x11-util-macros
134
135* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
136- new upstream release
137
138* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.2-2
139- rebuild with rpm-4.8.1 for pkg-config file
140
141* Fri Jul 30 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.2-1
142- new upstream release
143
144* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-1
145- new upstream release
146
147* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-1
148- new upstream release
149
150* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.4-2
151- added compat32 package for x86_64 arch support
152
153* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
154- new upstream release
155
156* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
157- new versioning policy
158
159* Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-0vl1
160- initial build for Vine Linux
161
162* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.1-4
163- Rebuild for build id
164
165* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.1-4
166- Don't install INSTALL
167
168* Tue Oct 3 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-3
169- Force xorg-x11-proto-devel on >= 7.1-10 (for LBX headers), and rebuild.
170
171* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-2.1
172- rebuild
173
174* Wed Jun 07 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
175- Replace "makeinstall" with "make install DESTDIR=..."
176- Remove package ownership of mandir/libdir/etc.
177
178* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-1
179- Update to 1.0.1
180
181* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-3.2
182- bump again for double-long bug on ppc(64)
183
184* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-3.1
185- rebuilt for new gcc4.1 snapshot and glibc changes
186
187* Tue Jan 31 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-3
188- Added "Requires: xorg-x11-proto-devel >= 7.0-1" to devel package (#173713)
189- Added "libX11-devel" to devel package (#176078)
190
191* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
192- Bumped and rebuilt
193
194* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
195- Updated libXext to version 1.0.0 from X11R7 RC4
196
197* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-1
198- Updated libXext to version 0.99.3 from X11R7 RC3
199- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
200  that /usr/lib/X11 and /usr/include/X11 pre-exist.
201- Removed 'x' suffix from manpage directories to match RC3 upstream.
202
203* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
204- rebuilt
205
206* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
207- Updated libXext to version 0.99.2 from X11R7 RC2
208- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
209- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
210
211* Fri Oct 21 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
212- Updated to libXext-0.99.1 from the X11R7 RC1 release.
213- Added manpages that were absent in X11R7 RC0, and updated the file lists
214  to find them in section "man3x".
215
216* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
217- Renamed package to remove xorg-x11 from the name due to unanimous decision
218  between developers.
219- Use Fedora Extras style BuildRoot tag.
220- Disable static library creation by default.
221- Add missing defattr to devel subpackage
222- Add missing documentation files to doc macro
223
224* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
225- Renamed package to prepend "xorg-x11" to the name for consistency with
226  the rest of the X11R7 packages.
227- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
228  subpackage to ensure the devel package matches the installed shared libs.
229- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
230  allow applications to use implementation agnostic dependencies.
231- Added post/postun scripts which call ldconfig.
232- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
233  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
234
235* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
236- Initial build.
Note: See TracBrowser for help on using the repository browser.