source: projects/specs/branches/6/lib/libX/libXdmcp/libXdmcp-vl.spec @ 2203

Revision 2203, 6.3 KB checked in by Takemikaduchi, 13 years ago (diff)

update Xorg libraries and xserver, and rebuild driver

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXdmcp runtime library
4Summary(ja): X.Org X11 libXdmcp ランタイムライブラリ
5Name: libXdmcp
6Version: 1.1.0
7Release: 1%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: pkgconfig
16BuildRequires: xorg-x11-proto-devel
17Obsoletes: XFree86-libs, XOrg-libs
18
19Vendor: Project Vine
20Distribution: Vine Linux
21Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
22
23%description
24X.Org X11 libXdmcp runtime library
25
26%package devel
27Summary: X.Org X11 libXdmcp development package
28Group: Development/Libraries
29Requires(pre): xorg-x11-filesystem
30Requires: %{name} = %{version}-%{release}
31Requires: xorg-x11-proto-devel
32Obsoletes: XFree86-devel, XOrg-devel
33
34%description devel
35X.Org X11 libXdmcp development package
36
37# compat32
38%package -n compat32-%{name}
39Summary: X.Org X11 libXdmcp runtime library
40Summary(ja): X.Org X11 libXdmcp ランタイムライブラリ
41Group: System Environment/Libraries
42
43%description -n compat32-%{name}
44X.Org X11 libXdmcp runtime library
45
46%package -n compat32-%{name}-devel
47Summary: X.Org X11 libXdmcp development package
48Group: Development/Libraries
49Requires(pre): xorg-x11-filesystem
50Requires: compat32-%{name} = %{version}-%{release}
51Requires: %{name}-devel = %{version}-%{release}
52
53%description -n compat32-%{name}-devel
54X.Org X11 libXdmcp development package
55
56%prep
57%setup -q
58
59# Disable static library creation by default.
60%define with_static 0
61
62%build
63%configure \
64%if ! %{with_static}
65        --disable-static
66%endif
67make
68
69%install
70rm -rf $RPM_BUILD_ROOT
71
72make install DESTDIR=$RPM_BUILD_ROOT
73
74# We intentionally don't ship *.la files
75rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
76
77# remove xml and txt file
78rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83%post -p /sbin/ldconfig
84%postun -p /sbin/ldconfig
85
86%post -n compat32-%{name} -p /sbin/ldconfig
87%postun -n compat32-%{name} -p /sbin/ldconfig
88
89%files
90%defattr(-,root,root,-)
91%doc AUTHORS COPYING README ChangeLog
92%{_libdir}/libXdmcp.so.6
93%{_libdir}/libXdmcp.so.6.0.0
94
95%files devel
96%defattr(-,root,root,-)
97%dir %{_includedir}/X11/
98%{_includedir}/X11/Xdmcp.h
99%if %{with_static}
100%{_libdir}/libXdmcp.a
101%endif
102%{_libdir}/libXdmcp.so
103%{_libdir}/pkgconfig/xdmcp.pc
104
105# compat32
106%if %{build_compat32}
107%files -n compat32-%{name}
108%defattr(-,root,root,-)
109%{_libdir}/libXdmcp.so.6
110%{_libdir}/libXdmcp.so.6.0.0
111
112%files -n compat32-%{name}-devel
113%defattr(-,root,root,-)
114%if %{with_static}
115%{_libdir}/libXdmcp.a
116%endif
117%{_libdir}/libXdmcp.so
118%{_libdir}/pkgconfig/xdmcp.pc
119%endif
120
121%changelog
122* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-1
123- new upstream release
124
125* Fri Sep 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-2
126- rebuild with rpm-4.8.1 for pkg-config file
127- fix typo
128
129* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-1
130- new upstream release
131
132* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.2-3
133- added compat32 package for x86_64 arch support
134
135* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
136- spec in utf-8
137
138* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
139- new versioning policy
140
141* Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
142- initial build for Vine Linux
143
144* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-4
145- Rebuild for build id
146
147* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.0.2-3
148- Don't install INSTALL
149
150* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.0.2-2.fc7
151- libXdmcp-1.0.2-namespace-pollution.patch: Hide Xalloc and friends from the
152  dynamic linker.
153
154* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.0.2-1
155- Update to 1.0.2
156
157* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-2.1
158- rebuild
159
160* Wed Jun 07 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
161- Added "BuildRequires: xorg-x11-proto-devel"
162- Added "Requires: xorg-x11-proto-devel" to devel package, needed by xdmcp.pc
163- Replace "makeinstall" with "make install DESTDIR=..."
164- Remove package ownership of mandir/libdir/etc.
165
166* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-1
167- Update to 1.0.1
168
169* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-2.2
170- bump again for double-long bug on ppc(64)
171
172* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-2.1
173- rebuilt for new gcc4.1 snapshot and glibc changes
174
175* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
176- Bumped and rebuilt
177
178* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
179- Updated libXdmcp to version 1.0.0 from X11R7 RC4
180
181* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
182- Updated libXdmcp to version 0.99.2 from X11R7 RC3
183- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
184  that /usr/lib/X11 and /usr/include/X11 pre-exist.
185- Removed 'x' suffix from manpage directories to match RC3 upstream.
186
187* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
188- rebuilt
189
190* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
191- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
192- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
193
194* Fri Oct 21 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
195- Update to libXdmcp-0.99.1 from X11R7 RC1 release.
196
197* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
198- Renamed package to remove xorg-x11 from the name due to unanimous decision
199  between developers.
200- Use Fedora Extras style BuildRoot tag.
201- Disable static library creation by default.
202- Add missing defattr to devel subpackage
203- Add missing documentation files to doc macro
204
205* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
206- Renamed package to prepend "xorg-x11" to the name for consistency with
207  the rest of the X11R7 packages.
208- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
209  subpackage to ensure the devel package matches the installed shared libs.
210- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
211  allow applications to use implementation agnostic dependencies.
212- Added post/postun scripts which call ldconfig.
213- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
214  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
215
216* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
217- Initial build.
Note: See TracBrowser for help on using the repository browser.