source: projects/specs/branches/6/lib/libX/libXcursor/libXcursor-vl.spec @ 7730

Revision 7730, 7.3 KB checked in by Takemikaduchi, 11 years ago (diff)

security fix

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: X.Org X11 libXcursor runtime library
4Summary(ja): X.Org X11 libXcursor ランタイムライブラリ
5Name: libXcursor
6Version: 1.1.11
7Release: 2%{?_dist_release}
8License: MIT/X11
9Group: System Environment/Libraries
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
13
14# fix CVE-2013-2003
15Patch0: libXcursor-CVE-2013-2003.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires: pkgconfig
19BuildRequires: xorg-x11-util-macros
20BuildRequires: xorg-x11-proto-devel
21BuildRequires: libX11-devel
22BuildRequires: libXfixes-devel
23BuildRequires: libXrender-devel
24Obsoletes: XFree86-libs, XOrg-libs
25
26%description
27X.Org X11 libXcursor runtime library
28
29%package devel
30Summary: X.Org X11 libXcursor development package
31Summary(ja): X.Org X11 libXcursor 開発パッケージ
32Group: Development/Libraries
33Requires(pre): xorg-x11-filesystem
34Requires: %{name} = %{version}-%{release}
35Requires: pkgconfig
36Requires: xorg-x11-proto-devel
37Obsoletes: XFree86-devel, XOrg-devel
38
39%description devel
40X.Org X11 libXcursor development package
41
42# compat32
43%package -n compat32-%{name}
44Summary: X.Org X11 libXcursor runtime library
45Summary(ja): X.Org X11 libXcursor ランタイムライブラリ
46Group: System Environment/Libraries
47
48%description -n compat32-%{name}
49X.Org X11 libXcursor runtime library
50
51%package -n compat32-%{name}-devel
52Summary: X.Org X11 libXcursor development package
53Summary(ja): X.Org X11 libXcursor 開発パッケージ
54Group: Development/Libraries
55Requires(pre): xorg-x11-filesystem
56Requires: compat32-%{name} = %{version}-%{release}
57Requires: %{name}-devel = %{version}-%{release}
58
59%description -n compat32-%{name}-devel
60X.Org X11 libXcursor development package
61
62%prep
63%setup -q
64%patch0 -p1
65
66# Disable static library creation by default.
67%define with_static 0
68
69%build
70#export CFLAGS="$RPM_OPT_FLAGS -DICONDIR=\"/usr/share/icons\""
71%configure \
72%if ! %{with_static}
73        --disable-static
74%endif
75make
76
77%install
78rm -rf $RPM_BUILD_ROOT
79
80make install DESTDIR=$RPM_BUILD_ROOT
81
82mkdir -p $RPM_BUILD_ROOT/usr/share/icons/default
83cat <<EOF > $RPM_BUILD_ROOT/usr/share/icons/default/index.theme
84[Icon Theme]
85Inherits=Vine
86EOF
87
88# We intentionally don't ship *.la files
89rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%post -p /sbin/ldconfig
95%postun -p /sbin/ldconfig
96
97%post -n compat32-%{name} -p /sbin/ldconfig
98%postun -n compat32-%{name} -p /sbin/ldconfig
99
100%files
101%defattr(-,root,root,-)
102%doc AUTHORS COPYING README ChangeLog
103%{_libdir}/libXcursor.so.1
104%{_libdir}/libXcursor.so.1.0.*
105%dir %{_datadir}/icons/default
106%config(noreplace) %verify(not md5 size mtime) %{_datadir}/icons/default/index.theme
107
108%files devel
109%defattr(-,root,root,-)
110%dir %{_includedir}/X11
111%dir %{_includedir}/X11/Xcursor
112%{_includedir}/X11/Xcursor/Xcursor.h
113%if %{with_static}
114%{_libdir}/libXcursor.a
115%endif
116%{_libdir}/libXcursor.so
117%{_libdir}/pkgconfig/xcursor.pc
118#%dir %{_mandir}/man3x
119%{_mandir}/man3/Xcursor*.3*
120
121# compat32
122%if %{build_compat32}
123%files -n compat32-%{name}
124%defattr(-,root,root,-)
125%{_libdir}/libXcursor.so.1
126%{_libdir}/libXcursor.so.1.0.*
127
128%files -n compat32-%{name}-devel
129%defattr(-,root,root,-)
130%if %{with_static}
131%{_libdir}/libXcursor.a
132%endif
133%{_libdir}/libXcursor.so
134%{_libdir}/pkgconfig/xcursor.pc
135%endif
136
137%changelog
138* Thu May 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.11-2
139- add Patch0 (libXcursor-CVE-2013-2003.patch)
140
141* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.11-1
142- new upstream release
143
144* Fri Sep 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.10-2
145- rebuild with rpm-4.8.1 for pkg-config file
146
147* Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.10-1
148- new upstream release
149
150* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.9-3
151- added compat32 package for x86_64 arch support
152
153* Wed Oct 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.9-2
154- set default cursor theme to Vine
155- spec in utf8
156
157* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.9-1
158- new versioning policy
159
160* Mon Jan 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.9-0vl1
161- initial build for Vine Linux
162
163* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 1.1.9-1
164- libXcursor 1.1.9
165
166* Wed Aug 22 2007 Adam Jackson <ajax@redhat.com> - 1.1.8-3
167- Rebuild for PPC toolchain bug
168
169* Sat Jul  7 2007 Matthias Clasen <mclasen@redhat.com> 1.1.8-3
170- Don't own /usr/share/icons
171- Require pkgconfig in -devel
172
173* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> 1.1.8-2
174- Don't install INSTALL
175
176* Mon Nov 20 2006 Adam Jackson <ajax@redhat.com> 1.1.8-1
177- Update to 1.1.8
178
179* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.1.7-1.1
180- rebuild
181
182* Wed Jun 07 2006 Mike A. Harris <mharris@redhat.com> 1.1.7-1
183- Update to 1.1.7 from X11R7.1
184
185* Wed Jun 07 2006 Mike A. Harris <mharris@redhat.com> 1.1.6-2
186- Added "BuildRequires: xorg-x11-proto-devel"
187- Added "Requires: xorg-x11-proto-devel" to devel package, needed by xcursor.pc
188- Replace "makeinstall" with "make install DESTDIR=..."
189- Remove package ownership of mandir/libdir/etc.
190
191* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.1.6-1
192- Update to 1.1.6
193
194* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.1.5.2-2.2
195- bump again for double-long bug on ppc(64)
196
197* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.1.5.2-2.1
198- rebuilt for new gcc4.1 snapshot and glibc changes
199
200* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.1.5.2-2
201- Bumped and rebuilt
202
203* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.1.5.2-1
204- Updated libXcursor to version 1.1.5.2 from X11R7 RC4
205
206* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 1.1.5.1-1
207- Updated libXcursor to version 1.1.5.1 from X11R7 RC3
208- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
209  that /usr/lib/X11 and /usr/include/X11 pre-exist.
210- Removed 'x' suffix from manpage directories to match RC3 upstream.
211- Added default index.theme file to set BlueCurve as the default cursor theme
212  to fix bug (#175532).
213
214* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
215- rebuilt
216
217* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 1.1.5-1
218- Updated libXcursor to version 1.1.5 from X11R7 RC2
219- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
220- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
221
222* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 1.1.4-1
223- Updated libXcursor to version 1.1.4 from X11R7 RC1
224
225* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 1.1.3-3
226- Renamed package to remove xorg-x11 from the name due to unanimous decision
227  between developers.
228- Use Fedora Extras style BuildRoot tag.
229- Disable static library creation by default.
230- Add missing defattr to devel subpackage
231- Add missing documentation files to doc macro
232
233* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 1.1.3-2
234- Renamed package to prepend "xorg-x11" to the name for consistency with
235  the rest of the X11R7 packages.
236- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
237  subpackage to ensure the devel package matches the installed shared libs.
238- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
239  allow applications to use implementation agnostic dependencies.
240- Added post/postun scripts which call ldconfig.
241- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
242  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
243
244* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 1.1.3-1
245- Initial build.
Note: See TracBrowser for help on using the repository browser.