source: projects/specs/branches/6/lib/libI/libIDL/libIDL-vl.spec @ 1856

Revision 1856, 6.2 KB checked in by iwaim, 14 years ago (diff)

build with rpm-4.8.1-1; see [VineSeed:21791]

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: Library for parsing IDL (Interface Definition Language)
4Summary(ja): IDL (インターフェース定義言語) 解析ライブラリ
5Name: libIDL
6Version: 0.8.14
7Release: 2%{?_dist_release}
8Source: ftp://ftp.gnome.org/pub/GNOME/sources/libIDL/0.8/%{name}-%{version}.tar.bz2
9Group: System Environment/Libraries
10License: LGPL
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: pkgconfig >= 0.8
13BuildRequires: glib2-devel >= 2.0
14BuildRequires: flex bison
15
16%description
17libIDL is a library for parsing IDL (Interface Definition Language).
18It can be used for both COM-style and CORBA-style IDL.
19
20%description -l ja
21libIDL は IDL (インターフェース定義言語) を解析するためのライブラリです.
22COM形式とCORBA形式の両方のIDLで利用することができます.
23
24%package devel
25Summary: Development libraries and header files for libIDL
26Summary(ja): libIDL の開発用ライブラリとヘッダファイル
27Group: Development/Libraries
28Requires: %{name} = %{version}-%{release}
29Requires: pkgconfig >= 0.8
30Requires: glib2-devel >= 2.0
31Requires(post): /sbin/install-info
32Requires(preun): /sbin/install-info
33
34%description devel
35libIDL is a library for parsing IDL (Interface Definition Language).
36It can be used for both COM-style and CORBA-style IDL.
37
38This package contains the header files and libraries needed to write
39or compile programs that use libIDL.
40
41# compat32
42%package -n compat32-%{name}
43Summary: Development libraries and header files for libIDL
44Summary(ja): libIDL の開発用ライブラリとヘッダファイル
45Group: Development/Libraries
46Requires: %{name} = %{version}-%{release}
47
48%description -n compat32-%{name}
49libIDL is a library for parsing IDL (Interface Definition Language).
50It can be used for both COM-style and CORBA-style IDL.
51
52%description -n compat32-%{name} -l ja
53libIDL は IDL (インターフェース定義言語) を解析するためのライブラリです.
54COM形式とCORBA形式の両方のIDLで利用することができます.
55
56%package -n compat32-%{name}-devel
57Summary: Development libraries and header files for libIDL
58Summary(ja): libIDL の開発用ライブラリとヘッダファイル
59Group: Development/Libraries
60Requires: %{name}-devel = %{version}-%{release}
61Requires: compat32-%{name} = %{version}-%{release}
62Requires: compat32-glib2-devel >= 2.0
63Requires(post): /sbin/install-info
64Requires(preun): /sbin/install-info
65
66%description -n compat32-%{name}-devel
67libIDL is a library for parsing IDL (Interface Definition Language).
68It can be used for both COM-style and CORBA-style IDL.
69
70This package contains the header files and libraries needed to write
71or compile programs that use libIDL.
72
73%prep
74%setup -q -n %{name}-%{version}
75
76%build
77%configure --disable-static
78make %{?_smp_mflags}
79
80%install
81rm -rf %{buildroot}
82%makeinstall
83
84rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
85rm -f $RPM_BUILD_ROOT%{_infodir}/dir
86
87%post -p /sbin/ldconfig
88
89%postun -p /sbin/ldconfig
90
91%post -n compat32-%{name} -p /sbin/ldconfig
92
93%postun -n compat32-%{name} -p /sbin/ldconfig
94
95%post devel
96/sbin/install-info --quiet %{_infodir}/libIDL2.info.gz %{_infodir}/dir
97
98%preun devel
99if [ $1 = 0 ]; then
100   /sbin/install-info --quiet --delete %{_infodir}/libIDL2.info.gz %{_infodir}/dir
101fi
102
103%clean
104rm -rf %{buildroot}
105
106%files
107%doc AUTHORS COPYING README NEWS
108%defattr(-,root,root)
109%{_libdir}/lib*.so.*
110
111%files devel
112%defattr(-,root,root)
113%{_bindir}/libIDL-config-2
114%{_includedir}/*
115%{_libdir}/%{name}-2.so
116%{_libdir}/pkgconfig/*.pc
117%{_infodir}/libIDL2.info.gz
118
119# compat32
120%if %{build_compat32}
121%files -n compat32-%{name}
122%defattr(-,root,root)
123%{_libdir}/lib*.so.*
124
125%files -n compat32-%{name}-devel
126%defattr(-,root,root)
127%{_libdir}/%{name}-2.so
128%{_libdir}/pkgconfig/*.pc
129%endif
130
131%changelog
132* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> - 0.8.14-2
133- build with rpm-4.8.1-1 for pkg-config file
134
135* Wed Apr  7 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.8.14-1
136- new upstream release
137
138* Sat Jul 11 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.8.13-2
139- added compat32 package for x86_64 arch support
140
141* Sun May  3 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.13-1
142- new upstream release
143- removed static library
144
145* Tue Sep 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.11-1
146- new upstream release
147- spec in UTF-8
148
149* Sat Jul 19 2008 Shu KONNO <owa@bg.wakwak.com> 0.8.10-2vl5
150- dropt libIDL-2.la
151
152* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-1vl5
153- new upstream release
154
155* Tue Oct  2 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
156- new upstream release
157
158* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl1
159- new upstream release
160
161* Wed Aug  2 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.7-0vl1
162- new upstream release
163
164* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-0vl1
165- new upstream release
166
167* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.5-0vl1
168- new upstream release
169
170* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.4-0vl1
171- new upstream release
172
173* Fri Jan 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.2-0vl2
174- rebuild with new toolchains
175
176* Fri Jul 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.2-0vl1
177- new upstream release
178- add Japanese summary and description
179
180* Sat Dec 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-0vl1
181- build for Vine Linux
182
183* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
184- 0.8.0
185
186* Sun May 26 2002 Tim Powers <timp@redhat.com>
187- automated rebuild
188
189* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
190- rebuild in different environment
191
192* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
193- rebuild in different environment
194
195* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
196- move include files to -devel
197- other spec file tweaks
198
199* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
200- 0.7.4
201
202* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
203- automated rebuild
204
205* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
206- cvs snap 0.7.1.91
207
208* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
209- cvs snap, rebuild on new glib 1.3.11
210
211* Fri Oct 26 2001 Havoc Pennington <hp@redhat.com>
212- glib 1.3.10
213
214* Thu Oct  4 2001 Havoc Pennington <hp@redhat.com>
215- rebuild for new glib
216
217* Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
218- initial build of standalone libIDL
219- fix braindamage
220
Note: See TracBrowser for help on using the repository browser.