source: projects/specs/branches/6/l/lyx/lyx-vl.spec @ 5501

Revision 5501, 8.6 KB checked in by munepi, 12 years ago (diff)

updated lyx-vl.spec

RevLine 
[5501]1%define _fontdir %{_datadir}/fonts/%{name}
2
[521]3%define texmf           %{_datadir}/texmf
4%define build_texmf     %{buildroot}%{texmf}
5
6%define exec_texhash  [ -x %{_bindir}/texhash     ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash 2>/dev/null
7
[4218]8Summary: WYSIWYM (What You See Is What You Mean) word processor with LaTeX output
9Summary(ja): LaTeX 形式で保存できるワードプロセッサ
[521]10Name: lyx
[5501]11Version: 2.0.2
12Release: 1%{?_dist_release}
[521]13License: GPLv2+
14Group: Applications/Editors
15URL: http://www.lyx.org/
[4218]16Source0: ftp://ftp.lyx.org/pub/lyx/stable/lyx-%{version}.tar.xz
[521]17
[4218]18Source1: lyxrc.dist
[521]19Source10: lyx.desktop
20
[4218]21## upstreamable patches
22# submitted, but upstream rejected it.  we currently agree to disagree.
[4848]23Patch50: lyx-2.0.1-xdg_open.patch
[4218]24
[4848]25## vine
26# reverted checkLatex to lyx-1.6.5
27Patch100: lyx-2.0.1-configurepy-vine.patch
[521]28
[4218]29
[521]30# BuildRequires: aiksaurus-devel
[4218]31# BuildRequires:   aspell-devel
32BuildRequires:   enchant-devel
33BuildRequires:   hunspell-devel
[521]34BuildRequires:   libboost-devel
35BuildRequires:   libboost-filesystem
36BuildRequires:   libboost-signals
[4218]37BuildRequires:   libboost-regex
[521]38BuildRequires:   desktop-file-utils
39BuildRequires:   gettext
40BuildRequires:   python
41BuildRequires:   xorg-x11-devel
42BuildRequires:   qt4-devel
43BuildRequires:   libpng-devel
44BuildRequires:   glib2-devel
45BuildRequires:   zlib-devel
46
[4218]47Requires(post):  texlive-common
48Requires(postun): texlive-common
[521]49Requires:        ghostscript
50Requires:        python
51
[5501]52# optional minimal qt4 dep
53%{?_qt_version:Requires: qt4 >= %{_qt4_version}}
54
55Requires:        %{name}-fonts = %{version}-%{release}
56
[4218]57Requires:        xdg-utils
58Requires:        rcs
[521]59
60BuildRoot: %{_tmppath}/%{name}-%{version}-root
61
62Vendor:       Project Vine
63Distribution: Vine Linux
64
65
66%description
67LyX is a modern approach to writing documents which breaks with the
68obsolete "typewriter paradigm" of most other document preparation
69systems.
70
71It is designed for people who want professional quality output
72with a minimum of time and effort, without becoming specialists in
73typesetting.
74
75The major innovation in LyX is WYSIWYM (What You See Is What You Mean).
76That is, the author focuses on content, not on the details of formatting.
77This allows for greater productivity, and leaves the final typesetting
78to the backends (like LaTeX) that are specifically designed for the task.
79
80With LyX, the author can concentrate on the contents of his writing,
81and let the computer take care of the rest.
82
83This is LyX built with the Qt frontend.
84
85%description -l ja
[4218]86LaTeX形式で出力もできるワードプロセッサです。数式の入力も簡単にできます。
[521]87特別な知識が無くても、最小限の努力でプロ並の出力を得られるように設計
88してあります。
89
90
[5501]91%package fonts
92Summary: Lyx/MathML fonts
93Group:   User Interface/X
94# The actual license says "The author of these fonts, Basil K. Malyshev, has
95# kindly granted permission to use and modify these fonts."
96# One of the font files (wasy10) is separately licensed GPL+.
97License: Copyright only and GPL+
98Obsoletes:       latex-xft-fonts
99BuildArch: noarch
100%description  fonts
101A collection of Math symbol fonts for %{name}.
102
103
[521]104%prep
105%setup -q
106
[4218]107%patch50 -p1 -b .xdg_open
[4848]108%patch100 -p1 -b .vine
[521]109
[4848]110#./autogen.sh
[521]111
[1528]112
[4218]113%build
[521]114%configure \
115    --disable-dependency-tracking \
116    --disable-rpath \
[4218]117    --enable-build-type=release \
[521]118    --disable-debug \
119    --enable-optimization="%{optflags}" \
[4218]120    --without-included-boost \
[5501]121    --disable-stdlib-debug \
[521]122    --enable-shared \
123    --disable-static \
124    \
125    --with-frontend=qt4 \
126    --without-aiksaurus \
[4218]127    --with-enchant \
128    --with-hunspell \
[521]129    ;
130%__make %{?_smp_mflags}
131
132# # make sure all .gmo files are regenerated from .po files
133# (cd po; make update-gmo)
134
135
136%install
137%__rm -rf ${RPM_BUILD_ROOT}
138%__make DESTDIR=${RPM_BUILD_ROOT} install
139
140# misc/extras
[4218]141%__install -p -m644 -D %{SOURCE1} %{buildroot}%{_datadir}/lyx/lyxrc.dist
[521]142
[4218]143# Set up the lyx-specific class files where TeX can see them
[521]144%__mkdir_p %{build_texmf}/tex/latex
[4218]145%__mv %{buildroot}%{_datadir}/lyx/tex %{build_texmf}/tex/latex/lyx
[521]146
147# desktop & icon
[4218]148desktop-file-install --vendor="vine" \
[521]149  --dir="${RPM_BUILD_ROOT}%{_datadir}/applications" %{SOURCE10}
150%__install -p -D -m644 lib/images/lyx.png \
151  %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/lyx.png
152
153# ghost'd files
154touch %{buildroot}%{_datadir}/lyx/lyxrc.defaults
155touch %{buildroot}%{_datadir}/lyx/{packages,textclass}.lst
156
[5501]157# fonts
158install -m 0755 -d %{buildroot}%{_fontdir}
159mv %{buildroot}%{_datadir}/lyx/fonts/*.ttf %{buildroot}%{_fontdir}/
160rm -rf %{buildroot}%{_datadir}/lyx/fonts
[521]161
162%find_lang %{name}
163
[4848]164%check
165# tests/test_filetools error bogus ( see http://bugzilla.redhat.com/723938 )
166%__make -k check ||:
[521]167
[4848]168
[521]169%clean
170%__rm -rf ${RPM_BUILD_ROOT}
171
172
173%post
174touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
175
176%postun
177if [ $1 -eq 0 ] ; then
178    %{exec_texhash} >& /dev/null
179    update-desktop-database -q &> /dev/null
180    touch --no-create %{_datadir}/icons/hicolor &> /dev/null
181    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
182fi
183
[4218]184%posttrans
185%{exec_texhash} >& /dev/null
186update-desktop-database -q &> /dev/null
187touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
188gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
[521]189
[5501]190%post fonts
191%__font_install_post %{_fontdir}
[4218]192
[5501]193%postun fonts
194%__font_install_postun %{_fontdir}
195
196
[521]197%files -f %{name}.lang
198%defattr(-,root,root,-)
199%doc ABOUT-NLS ANNOUNCE COPYING README UPGRADING NEWS lib/CREDITS
200%{_bindir}/*
201%{_datadir}/lyx/
202%{texmf}/tex/latex/lyx/
203%{_datadir}/applications/*.desktop
204%{_datadir}/icons/hicolor/*/*/*
205%{_mandir}/man*/*
206%config(noreplace) %{_datadir}/lyx/lyxrc.dist
207%ghost %{_datadir}/lyx/lyxrc.defaults
208%ghost %{_datadir}/lyx/*.lst
209%ghost %{_datadir}/lyx/doc/LaTeXConfig.lyx
210
[5501]211%files fonts
212%defattr(-,root,root,-)
213%dir %{_fontdir}/
214%{_fontdir}/*.ttf
[521]215
[5501]216
[521]217%changelog
[5501]218* Thu Jan 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.2-1
219- new upstream release
220- added subpackage "lyx-fonts"
221  - added Obsoletes: latex-xft-fonts
222
[4848]223* Sat Oct 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.1-2
224- applied lyx-2.0.1-configurepy-vine.patch
225  - reverted checkLatex to lyx-1.6.5
226
227* Fri Sep 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.1-1
228- new upstream release
229
[4218]230* Sat Jun 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-1
231- new upstream release
232- dropped BuildRequires: aspell-devel
233- added BuildRequires:
234  - libboost-regex
235  - enchant-devel
236  - hunspell-devel
237
[2373]238* Thu Dec 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.8-1
239- new upstream release
240
[1528]241* Sun Aug 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.7-1
242- new upstream release
243- TeX Live 2009
244  - dropped Requires: xdvik, dvipdfmx
245
[521]246* Sun Jan 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.5-1
247- new upstream release
248- updated Patch0: lyx-1.6.5-xdg_open.patch
249
250* Sun Jul 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.3-1
251- new upstream release
252  - dropped old source files
253- change License: GPLv2+
254- added lyx.desktop
255- added BuildRequires:
256  - aspell-devel
257  - desktop-file-utils
258  - gettext
259  - python
260  - qt4-devel
261  - zlib-devel
262  - libboost-devel
263  - libboost-filesystem
264  - libboost-signals
265  - libpng-devel
266  - glib2-devel
267- added Requires:
268  - ghostscript
269  - dvipdfmx
270  - xdvik
271  - qt4
272  - xdg-utils
273- optimized some configure options
274
275* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.4-1vl5
276- applied new versioning policy, spec in utf-8
277
278* Sat Apr 07 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.4-0vl1
279- updated to 1.4.4 with the most recent CJK patch
280- updated Patch1
281
282* Sat Dec 30 2006 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.4.2-0vl1
283- base spec file : Vine Linux BTS #219
284  * Mon Nov  6 2006 M.H
285  - new upstream release
286  - base spec file CJK-LyX-qt.spec and VinePlus lyx.spec
287
288* Wed Sep 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.4-0vl3
289- changed Group to Applications/Editors
290
291* Sat Jan 28 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org>
292- rebuild with qt-3.3.5
293
294* Sun Jun 13 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.3.4-0vl1
295- new upstream version
296- change frontend, xforms -> qt
297- require tetex, qt, latex-xft-fonts
298- change applnk file
299- change Group
300
301* Thu Aug 21 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.1.6fix4-0vl1
302- new upstream version
303- add mime-info
304- minor change in spec file
305
306* Sat Nov 11 2000 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
307- 1.0.3_jp-4
308- added BuildPrereq:
309
310* Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
311- 1.0.3_jp-3
312- minor change in spec file
313- build for Vine Linux 2.1
314
315* Wed Jan  5 2000 Jun Nishii <jun@vinelinux.org>
316- change group
317
318* Wed Dec 22 1999 Jun Nishii <jun@vinelinux.org>
319- updated to lyx-1.0.3
320- rebuild for Vine Linux 2.0
321
322* Wed May 5 1999 Jun Nishii <jun@vinelinux.org>
323- merged Japanese Documents
324
325* Tue May 4 1999 Jun Nishii <jun@vinelinux.org>
326- first build
327
Note: See TracBrowser for help on using the repository browser.