source: projects/specs/branches/6/l/lvm2/lvm2-vl.spec @ 3060

Revision 3060, 22.8 KB checked in by daisuke, 13 years ago (diff)

lvm2: update to 2.02.84, add device-mapper-static subpackage

Line 
1%define lvm_version 2.02.84
2%define device_mapper_version 1.02.63
3%define with_cluster 0
4
5Summary: Userland logical volume management tools
6Summary(ja): 論理ボリューム管理ツール
7Name: lvm2
8Version: %{lvm_version}
9Release: 1%{?_dist_release}
10License: GPL
11Group: System Environment/Base
12URL: http://sources.redhat.com/lvm2
13
14Source0: LVM2.%{lvm_version}.tgz
15Patch10: libdevmapper-static.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{lvm_version}-%{release}-buildroot
18BuildRequires: libtermcap-devel
19BuildRequires: ncurses-devel
20BuildRequires: readline-devel
21BuildRequires: libudev-devel
22Requires: device-mapper >= %{device_mapper_version}-%{release}
23Requires: device-mapper-event >= %{device_mapper_version}-%{release}
24Requires: %{name}-libs = %{version}-%{release}
25Conflicts: lvm
26Obsoletes: lvm
27
28%define _exec_prefix /usr
29
30%description
31LVM2 includes all of the support for handling read/write operations on
32physical volumes (hard disks, RAID-Systems, magneto optical, etc.,
33multiple devices (MD), see mdadd(8) or even loop devices, see
34losetup(8)), creating volume groups (kind of virtual disks) from one
35or more physical volumes and creating one or more logical volumes
36(kind of logical partitions) in volume groups.
37
38%package devel
39Summary: Development libraries and headers
40Group: Development/Libraries
41License: LGPLv2
42Requires: %{name} = %{version}-%{release}
43Requires: %{name}-libs = %{version}-%{release}
44Requires: device-mapper-devel >= %{device_mapper_version}-%{release}
45Requires: device-mapper-event-devel >= %{device_mapper_version}-%{release}
46Requires: pkgconfig
47
48%description devel
49This package contains files needed to develop applications that use
50the lvm2 libraries.
51
52%package libs
53Summary: lvm2 shared libraries
54License: LGPLv2
55Group: System Environment/Libraries
56
57%description libs
58This package contains shared lvm2 libraries for applications.
59
60%if %{with_cluster}
61# lvm2-cluster
62%package cluster
63Summary: Cluster extensions for userland logical volume management tools
64License: GPLv2
65Group: System Environment/Base
66Requires: lvm2 >= %{version}-%{lvm_release}
67Requires(post): chkconfig
68Requires(preun): chkconfig
69Requires(preun): device-mapper >= %{device_mapper_version}
70Requires(preun): lvm2 >= 2.02
71
72%description cluster
73Extensions to LVM2 to support clusters.
74%endif
75
76# device-mapper
77%package -n device-mapper
78Summary: Device mapper utility
79Version: %{device_mapper_version}
80Release: %{release}
81License: GPLv2
82Group: System Environment/Base
83URL: http://sources.redhat.com/dm
84Requires: device-mapper-libs = %{device_mapper_version}-%{release}
85Requires: libudev
86Requires: util-linux-ng >= 2.15
87
88%description -n device-mapper
89This package contains the supporting userspace utility, dmsetup,
90for the kernel device-mapper.
91
92# device-mapper-devel
93%package -n device-mapper-devel
94Summary: Development libraries and headers for device-mapper
95Version: %{device_mapper_version}
96Release: %{release}
97License: LGPLv2
98Group: Development/Libraries
99Requires: device-mapper = %{device_mapper_version}-%{release}
100Requires: device-mapper-libs = %{device_mapper_version}-%{release}
101
102%description -n device-mapper-devel
103This package contains files needed to develop applications that use
104the device-mapper libraries.
105
106# device-mapper-static
107%package -n device-mapper-static
108Summary: Static libraries for device-mapper
109Version: %{device_mapper_version}
110Release: %{release}
111License: LGPLv2
112Group: Development/Libraries
113Requires: device-mapper-devel = %{device_mapper_version}-%{release}
114
115%description -n device-mapper-static
116This package contains the device-mapper static libraries.
117
118%package -n device-mapper-libs
119Summary: Device-mapper shared library
120Version: %{device_mapper_version}
121Release: %{release}
122License: LGPLv2
123Group: System Environment/Libraries
124Obsoletes: device-mapper < 1.02.30-1
125
126%description -n device-mapper-libs
127This package contains the device-mapper shared library, libdevmapper.
128
129%package -n device-mapper-event
130Summary: Device-mapper event daemon
131Group: System Environment/Base
132Version: %{device_mapper_version}
133Release: %{release}
134Requires: device-mapper = %{device_mapper_version}-%{release}
135Requires: device-mapper-event-libs = %{device_mapper_version}-%{release}
136
137%description -n device-mapper-event
138This package contains the dmeventd daemon for monitoring the state
139of device-mapper devices.
140
141%package -n device-mapper-event-libs
142Summary: Device-mapper event daemon shared library
143Version: %{device_mapper_version}
144Release: %{release}
145License: LGPLv2
146Group: System Environment/Libraries
147
148%description -n device-mapper-event-libs
149This package contains the device-mapper event daemon shared library,
150libdevmapper-event.
151
152%package -n device-mapper-event-devel
153Summary: Development libraries and headers for the device-mapper event daemon
154Version: %{device_mapper_version}
155Release: %{release}
156License: LGPLv2
157Group: Development/Libraries
158Requires: device-mapper-event = %{device_mapper_version}-%{release}
159Requires: pkgconfig
160
161%description -n device-mapper-event-devel
162This package contains files needed to develop applications that use
163the device-mapper event library.
164
165%prep
166%setup -q -n LVM2.%{lvm_version}
167%patch10 -p1
168
169%build
170%define _exec_prefix /
171%define _bindir /bin
172%define _sbindir /sbin
173%define _libdir /%{_lib}
174%define _udevbasedir /lib/udev
175%define _udevdir %{_udevbasedir}/rules.d
176
177%configure \
178  --enable-readline \
179  --enable-lvm1_fallback \
180  --enable-fsadm \
181  --with-pool=internal \
182  --with-staticdir=/sbin \
183  --with-user= --with-group= \
184  --with-usrlibdir=/usr/%{_lib} \
185  --with-usrsbindir=/usr/sbin \
186  --with-dmdir=device-mapper.%{device_mapper_version} \
187  --with-udevdir=%{_udevdir} \
188  --with-device-uid=0 --with-device-gid=6 \
189  --with-device-mode=0660 \
190  --enable-pkgconfig \
191  --enable-applib \
192  --enable-cmdlib \
193  --enable-dmeventd \
194  --enable-udev_sync
195
196make %{?_smp_mflags}
197
198%install
199rm -rf $RPM_BUILD_ROOT
200make install DESTDIR=$RPM_BUILD_ROOT
201install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/archive
202install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/backup
203install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/cache
204install -m 0700 -d $RPM_BUILD_ROOT/var/lock/lvm
205install -m 0600 /dev/null $RPM_BUILD_ROOT/etc/lvm/cache/.cache
206mkdir -p -m755 $RPM_BUILD_ROOT/etc/rc.d/init.d
207%if %{with_cluster}
208install scripts/clvmd_init_red_hat $RPM_BUILD_ROOT/etc/rc.d/init.d/clvmd
209install scripts/cmirrord_init_red_hat $RPM_BUILD_ROOT/etc/rc.d/init.d/cmirrord
210%endif
211install -m 0755 scripts/lvm2_monitoring_init_red_hat $RPM_BUILD_ROOT/etc/rc.d/init.d/lvm2-monitor
212install -m 0755 scripts/lvmconf.sh $RPM_BUILD_ROOT/sbin/lvmconf
213
214install -m 644 libdm/ioctl/libdevmapper.a $RPM_BUILD_ROOT/usr%{_libdir}
215
216%clean
217rm -rf $RPM_BUILD_ROOT
218
219%post
220/sbin/ldconfig
221/sbin/chkconfig --add lvm2-monitor
222
223%preun
224if [ "$1" = 0 ]; then
225        /sbin/chkconfig --del lvm2-monitor
226fi
227
228%post libs -p /sbin/ldconfig
229
230%postun libs -p /sbin/ldconfig
231
232%if %{with_cluster}
233%post cluster
234/sbin/chkconfig --add clvmd
235
236/sbin/lvmconf --lockinglibdir %{_libdir}
237
238%preun cluster
239if [ "$1" = 0 ]; then
240        /sbin/chkconfig --del clvmd
241        /sbin/lvmconf --disable-cluster
242fi
243%endif
244
245%post -n device-mapper-libs -p /sbin/ldconfig
246
247%postun -n device-mapper-libs -p /sbin/ldconfig
248
249%post -n device-mapper-event-libs -p /sbin/ldconfig
250
251%postun -n device-mapper-event-libs -p /sbin/ldconfig
252
253%files
254%defattr(-,root,root,-)
255%doc COPYING COPYING.LIB INSTALL README VERSION WHATS_NEW
256%attr(555,root,root) %{_sbindir}/fsadm
257%{_sbindir}/lvchange
258%{_sbindir}/lvconvert
259%{_sbindir}/lvcreate
260%{_sbindir}/lvdisplay
261%{_sbindir}/lvextend
262%{_sbindir}/lvm
263%{_sbindir}/lvmchange
264%{_sbindir}/lvmdiskscan
265%{_sbindir}/lvmdump
266%{_sbindir}/lvmsadc
267%{_sbindir}/lvmsar
268%{_sbindir}/lvreduce
269%{_sbindir}/lvremove
270%{_sbindir}/lvrename
271%{_sbindir}/lvresize
272%{_sbindir}/lvs
273%{_sbindir}/lvscan
274%{_sbindir}/pvchange
275%{_sbindir}/pvck
276%{_sbindir}/pvcreate
277%{_sbindir}/pvdisplay
278%{_sbindir}/pvmove
279%{_sbindir}/pvremove
280%{_sbindir}/pvresize
281%{_sbindir}/pvs
282%{_sbindir}/pvscan
283%{_sbindir}/vgcfgbackup
284%{_sbindir}/vgcfgrestore
285%{_sbindir}/vgchange
286%{_sbindir}/vgck
287%{_sbindir}/vgconvert
288%{_sbindir}/vgcreate
289%{_sbindir}/vgdisplay
290%{_sbindir}/vgexport
291%{_sbindir}/vgextend
292%{_sbindir}/vgimport
293%{_sbindir}/vgimportclone
294%{_sbindir}/vgmerge
295%{_sbindir}/vgmknodes
296%{_sbindir}/vgreduce
297%{_sbindir}/vgremove
298%{_sbindir}/vgrename
299%{_sbindir}/vgs
300%{_sbindir}/vgscan
301%{_sbindir}/vgsplit
302%{_sbindir}/lvmconf
303%{_mandir}/man5/lvm.conf.5.gz
304%{_mandir}/man8/fsadm.8.gz
305%{_mandir}/man8/lvchange.8.gz
306%{_mandir}/man8/lvconvert.8.gz
307%{_mandir}/man8/lvcreate.8.gz
308%{_mandir}/man8/lvdisplay.8.gz
309%{_mandir}/man8/lvextend.8.gz
310%{_mandir}/man8/lvm.8.gz
311%{_mandir}/man8/lvmchange.8.gz
312%{_mandir}/man8/lvmconf.8.gz
313%{_mandir}/man8/lvmdiskscan.8.gz
314%{_mandir}/man8/lvmdump.8.gz
315%{_mandir}/man8/lvmsadc.8.gz
316%{_mandir}/man8/lvmsar.8.gz
317%{_mandir}/man8/lvreduce.8.gz
318%{_mandir}/man8/lvremove.8.gz
319%{_mandir}/man8/lvrename.8.gz
320%{_mandir}/man8/lvresize.8.gz
321%{_mandir}/man8/lvs.8.gz
322%{_mandir}/man8/lvscan.8.gz
323%{_mandir}/man8/pvchange.8.gz
324%{_mandir}/man8/pvck.8.gz
325%{_mandir}/man8/pvcreate.8.gz
326%{_mandir}/man8/pvdisplay.8.gz
327%{_mandir}/man8/pvmove.8.gz
328%{_mandir}/man8/pvremove.8.gz
329%{_mandir}/man8/pvresize.8.gz
330%{_mandir}/man8/pvs.8.gz
331%{_mandir}/man8/pvscan.8.gz
332%{_mandir}/man8/vgcfgbackup.8.gz
333%{_mandir}/man8/vgcfgrestore.8.gz
334%{_mandir}/man8/vgchange.8.gz
335%{_mandir}/man8/vgck.8.gz
336%{_mandir}/man8/vgconvert.8.gz
337%{_mandir}/man8/vgcreate.8.gz
338%{_mandir}/man8/vgdisplay.8.gz
339%{_mandir}/man8/vgexport.8.gz
340%{_mandir}/man8/vgextend.8.gz
341%{_mandir}/man8/vgimport.8.gz
342%{_mandir}/man8/vgimportclone.8.gz
343%{_mandir}/man8/vgmerge.8.gz
344%{_mandir}/man8/vgmknodes.8.gz
345%{_mandir}/man8/vgreduce.8.gz
346%{_mandir}/man8/vgremove.8.gz
347%{_mandir}/man8/vgrename.8.gz
348%{_mandir}/man8/vgs.8.gz
349%{_mandir}/man8/vgscan.8.gz
350%{_mandir}/man8/vgsplit.8.gz
351%{_udevdir}/11-dm-lvm.rules
352%dir /etc/lvm
353%ghost /etc/lvm/cache/.cache
354%config(noreplace) /etc/lvm/lvm.conf
355%dir /etc/lvm/backup
356%dir /etc/lvm/cache
357%dir /etc/lvm/archive
358%dir /var/lock/lvm
359/etc/rc.d/init.d/lvm2-monitor
360
361%files devel
362%defattr(-,root,root,-)
363/usr%{_libdir}/liblvm2app.so
364/usr%{_libdir}/liblvm2cmd.so
365%{_includedir}/lvm2app.h
366%{_includedir}/lvm2cmd.h
367/usr%{_libdir}/pkgconfig/lvm2app.pc
368/usr%{_libdir}/libdevmapper-event-lvm2.so
369
370%files libs
371%attr(755,root,root) %{_libdir}/liblvm2app.so.*
372%attr(755,root,root) %{_libdir}/liblvm2cmd.so.*
373%attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2.so.*
374%dir %{_libdir}/device-mapper
375%{_libdir}/device-mapper/libdevmapper-event-lvm2mirror.so
376%{_libdir}/device-mapper/libdevmapper-event-lvm2snapshot.so
377%{_libdir}/libdevmapper-event-lvm2mirror.so
378%{_libdir}/libdevmapper-event-lvm2snapshot.so
379
380%if %{with_cluster}
381%files cluster
382%defattr(-,root,root,-)
383%attr(755,root,root) /usr/sbin/clvmd
384%{_mandir}/man8/clvmd.8.gz
385/etc/rc.d/init.d/clvmd
386%endif
387
388%files -n device-mapper
389%defattr(-,root,root,-)
390%doc COPYING COPYING.LIB WHATS_NEW_DM VERSION_DM README INSTALL udev/12-dm-permissions.rules
391%attr(755,root,root) /sbin/dmsetup
392%{_mandir}/man8/dmsetup.8.gz
393%dir %{_udevbasedir}
394%dir %{_udevdir}
395%{_udevdir}/10-dm.rules
396%{_udevdir}/13-dm-disk.rules
397%{_udevdir}/95-dm-notify.rules
398
399%files -n device-mapper-devel
400%defattr(-,root,root,-)
401%attr(755,root,root) /usr%{_libdir}/libdevmapper.so
402%{_includedir}/libdevmapper.h
403/usr%{_libdir}/pkgconfig/devmapper.pc
404
405%files -n device-mapper-static
406%defattr(-,root,root,-)
407/usr%{_libdir}/libdevmapper.a
408
409%files -n device-mapper-libs
410%attr(755,root,root) %{_libdir}/libdevmapper.so.*
411
412%files -n device-mapper-event
413%defattr(-,root,root,-)
414%{_sbindir}/dmeventd
415%{_mandir}/man8/dmeventd.8.gz
416
417%files -n device-mapper-event-libs
418%{_libdir}/libdevmapper-event.so.*
419
420%files -n device-mapper-event-devel
421%defattr(-,root,root,-)
422%attr(755,root,root) /usr%{_libdir}/libdevmapper-event.so
423%{_includedir}/libdevmapper-event.h
424/usr%{_libdir}/pkgconfig/devmapper-event.pc
425
426%changelog
427* Mon Mar 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.84-1
428- new upstream release
429- enable static libs, add device-mapper-static subpackage
430
431* Sat Feb 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.83-1
432- new upstream release
433
434* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.02.79-1
435- new upstream release
436
437* Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.02.78-1
438- new upstream release
439- fix %%files
440
441* Fri Oct 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.02.62-3
442- rebuilt with rpm-4.8.1 for pkg-config
443
444* Sun Apr 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.62-2
445- add missing file
446  - %{_udevdir}/11-dm-lvm.rules
447
448* Mon Mar 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.62-1
449- new upstream release
450- add libs,devel subpackage
451  - liblvm2{app,cmd},libdevmapper-event-lvm2
452- enable dmeventd
453  - add device-mapper-event{,-libs,-devel}
454- enable udev sync code
455  - add BR: libudev-devel, R: libudev
456- disable static libs and binaries
457
458* Sun Feb 14 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.02.60-1
459- new upstream release
460
461* Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.48-1
462- new upstream release
463
464* Tue Jun 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.47-1
465- new upstream release
466
467* Wed Feb 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.44-2
468- add libdevmapper.a
469
470* Thu Jan 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.44-1
471- new upstream release
472- upstream merge of device-mapper and lvm2 source.
473- move all binaries to /sbin
474- move libraries to /%%{_lib}
475
476* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.42-1
477- new upstream release
478
479* Sun Oct 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.41-1
480- new upstream release
481
482* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.40-1
483- new upstream release
484
485* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.39-1
486- new upstream release
487
488* Thu Jun 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.38-1
489- new upstream release
490
491* Thu Apr 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.35-1
492- new upstream release
493
494* Sat Dec 01 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.28-0vl1
495- new upstream release
496
497* Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.13-0vl1
498- new upstream release
499
500* Sat Aug 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.06-0vl1
501- initial build for Vine Linux
502
503* Tue Aug  1 2006 Jeremy Katz <katzj@redhat.com> - 2.02.06-3
504- require new libselinux to avoid segfaults on xen (#200783)
505
506* Thu Jul 27 2006 Jeremy Katz <katzj@redhat.com> - 2.02.06-2
507- free trip through the buildsystem
508
509* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.02.06-1.2.1
510- rebuild
511
512* Tue Jun  6 2006 Stephen C. Tweedie <sct@redhat.com> - 2.02.06-1.2
513- Rebuild to pick up new nosegneg libc.a for lvm.static
514
515* Mon May 22 2006 Alasdair Kergon <agk@redhat.com> - 2.02.06-1.1
516- Reinstate archs now build system is back.
517- BuildRequires libsepol-devel.
518
519* Fri May 12 2006 Alasdair Kergon <agk@redhat.com> - 2.02.06-1.0
520- New upstream release.
521
522* Sat Apr 22 2006 Alasdair Kergon <agk@redhat.com> - 2.02.05-1.1
523- Exclude archs that aren't building.
524
525* Fri Apr 21 2006 Alasdair Kergon <agk@redhat.com> - 2.02.05-1.0
526- Fix VG uuid comparisons.
527
528* Wed Apr 19 2006 Alasdair Kergon <agk@redhat.com> - 2.02.04-1.0
529- New release upstream, including better handling of duplicated VG names.
530
531* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.02.01-1.2.1
532- bump again for double-long bug on ppc(64)
533
534* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.02.01-1.2
535- rebuilt for new gcc4.1 snapshot and glibc changes
536
537* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
538- rebuilt
539
540* Fri Dec  2 2005 Peter Jones <pjones@redhat.com> - 2.02.01-1
541- update to 2.02.01
542
543* Tue Nov  8 2005 Jeremy Katz <katzj@redhat.com> - 2.01.14-4
544- add patch for xen block devices
545
546* Sat Oct 15 2005 Florian La Roche <laroche@redhat.com>
547- add -lselinux -lsepol to the static linking -ldevice-mapper requires it
548
549* Wed Sep 14 2005 Jeremy Katz <katzj@redhat.com> - 2.01.14-2
550- the distro doesn't really work without a 2.6 kernel, so no need to require it
551
552* Thu Aug 4 2005 Alasdair Kergon <agk@redhat.com> - 2.01.14-1.0
553- And a few more bugs fixes.
554
555* Wed Jul 13 2005 Alasdair Kergon <agk@redhat.com> - 2.01.13-1.0
556- Fix several bugs discovered in the last release.
557
558* Tue Jun 14 2005 Alasdair Kergon <agk@redhat.com> - 2.01.12-1.0
559- New version upstream with a lot of fixes and enhancements.
560
561* Wed Apr 27 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-2.1
562- Add /etc/lvm
563
564* Wed Apr 27 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-2.0
565- No longer abort read operations if archive/backup directories aren't there.
566- Add runtime directories and file to the package.
567
568* Tue Mar 22 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-1.0
569- Improve detection of external changes affecting internal cache.
570- Add clustered VG attribute.
571- Suppress rmdir opendir error message.
572
573* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.3
574* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.2
575* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.1
576- Suppress some new compiler messages.
577
578* Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.0
579- Remove build directory from built-in path.
580- Extra /dev scanning required for clustered operation.
581
582* Thu Mar 03 2005 Alasdair Kergon <agk@redhat.com> - 2.01.06-1.0
583- Allow anaconda to suppress warning messages.
584
585* Fri Feb 18 2005 Alasdair Kergon <agk@redhat.com> - 2.01.05-1.0
586- Upstream changes not affecting Fedora.
587
588* Wed Feb 09 2005 Alasdair Kergon <agk@redhat.com> - 2.01.04-1.0
589- Offset pool minors; lvm2cmd.so skips open fd check; pvmove -f gone.
590
591* Tue Feb 01 2005 Alasdair Kergon <agk@redhat.com> - 2.01.03-1.0
592- Fix snapshot device size & 64-bit display output.
593
594* Fri Jan 21 2005 Alasdair Kergon <agk@redhat.com> - 2.01.02-1.0
595- Minor fixes.
596
597* Mon Jan 17 2005 Alasdair Kergon <agk@redhat.com> - 2.01.01-1.0
598- Update vgcreate man page.  Preparation for snapshot origin extension fix.
599
600* Mon Jan 17 2005 Alasdair Kergon <agk@redhat.com> - 2.01.00-1.0
601- Fix metadata auto-correction. Only request open_count when needed.
602
603* Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> - 2.00.33-2.0
604- Rebuilt for new readline.
605
606* Fri Jan 7 2005 Alasdair Kergon <agk@redhat.com> - 2.00.33-1.0
607- pvcreate wipes ext label
608- several clvm fixes
609
610* Thu Jan 6 2005 Alasdair Kergon <agk@redhat.com> - 2.00.32-2.0
611- Remove temporary /sbin symlinks no longer needed.
612- Include read-only pool support in the build.
613
614* Wed Dec 22 2004 Alasdair Kergon <agk@redhat.com> - 2.00.32-1.0
615- More fixes (143501).
616
617* Sun Dec 12 2004 Alasdair Kergon <agk@redhat.com> - 2.00.31-1.0
618- Fix pvcreate install issues.
619
620* Fri Dec 10 2004 Alasdair Kergon <agk@redhat.com> - 2.00.30-1.0
621- Additional debugging code.
622- Some trivial man page corrections.
623
624* Tue Nov 30 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.3
625- Reinstate all archs.
626
627* Sun Nov 28 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.2
628- Try excluding more archs.
629
630* Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.1
631- Exclude s390x which fails.
632
633* Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1
634- Fix last fix.
635
636* Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.28-1
637- Endian fix to partition/md signature detection.
638
639* Wed Nov 24 2004 Alasdair Kergon <agk@redhat.com> - 2.00.27-1
640- Fix partition table detection & an out of memory segfault.
641
642* Tue Nov 23 2004 Alasdair Kergon <agk@redhat.com> - 2.00.26-1
643- Several installation-related fixes & man page updates.
644
645* Mon Oct 25 2004 Elliot Lee <sopwith@redhat.com> - 2.00.25-1.01
646- Fix 2.6 kernel requirement
647
648* Wed Sep 29 2004 Alasdair Kergon <agk@redhat.com> - 2.00.25-1
649- Fix vgmknodes return code & vgremove locking.
650
651* Fri Sep 17 2004 Alasdair Kergon <agk@redhat.com> - 2.00.24-2
652- Obsolete old lvm1 packages; refuse install if running kernel 2.4. [bz 128185]
653
654* Thu Sep 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.24-1
655- More upstream fixes.  (Always check WHATS_NEW file for details.)
656- Add requested BuildRequires. [bz 124916, 132408]
657
658* Wed Sep 15 2004 Alasdair Kergon <agk@redhat.com> - 2.00.23-1
659- Various minor upstream fixes.
660
661* Thu Sep  3 2004 Alasdair Kergon <agk@redhat.com> - 2.00.22-1
662- Permission fix included upstream; use different endian conversion macros.
663
664* Thu Sep  2 2004 Jeremy Katz <katzj@redhat.com> - 2.00.21-2
665- fix permissions on vg dirs
666
667* Thu Aug 19 2004 Alasdair Kergon <agk@redhat.com> - 2.00.21-1
668- New upstream release incorporating fixes plus minor enhancements.
669
670* Tue Aug 17 2004 Jeremy Katz <katzj@redhat.com> - 2.00.20-2
671- add patch for iSeries viodasd support
672- add patch to check file type using stat(2) if d_type == DT_UNKNOWN (#129674)
673
674* Sat Jul 3 2004 Alasdair Kergon <agk@redhat.com> - 2.00.20-1
675- New upstream release fixes 2.6 kernel device numbers.
676
677* Tue Jun 29 2004 Alasdair Kergon <agk@redhat.com> - 2.00.19-1
678- Latest upstream release.  Lots of changes (see WHATS_NEW).
679
680* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> - 2.00.15-5
681- rebuilt
682
683* Wed May 26 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-4
684- clone %description from LVM rpm
685
686* Wed May 26 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-3
687- vgscan shouldn't return error status when no VGs present
688
689* Thu May 06 2004 Warren Togami <wtogami@redhat.com> - 2.00.15-2
690- i2o patch from Markus Lidel
691
692* Tue Apr 20 2004 Bill Nottingham <notting@redhat.com> - 2.00.15-1.1
693- handle disabled SELinux correctly, so that LVMs can be detected in a
694  non-SELinux context
695 
696* Mon Apr 19 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-1
697- Fix non-root build with current version of 'install'.
698
699* Fri Apr 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.14-1
700- Use 64-bit file offsets.
701
702* Fri Apr 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.13-1
703- Avoid scanning devices containing md superblocks.
704- Integrate ENOTSUP patch.
705
706* Thu Apr 15 2004 Jeremy Katz <katzj@redhat.com> - 2.00.12-4
707- don't die if we get ENOTSUP setting selinux contexts
708
709* Thu Apr 15 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-3
710- Add temporary pvscan symlink for LVM1 until mkinitrd gets updated.
711
712* Wed Apr 14 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-2
713- Mark config file noreplace.
714
715* Wed Apr 14 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-1
716- Install default /etc/lvm/lvm.conf.
717- Move non-static binaries to /usr/sbin.
718- Add temporary links in /sbin to lvm.static until rc.sysinit gets updated.
719
720* Thu Apr 08 2004 Alasdair Kergon <agk@redhat.com> 2.00.11-1
721- Fallback to using LVM1 tools when using a 2.4 kernel without device-mapper.
722
723* Wed Apr 07 2004 Alasdair Kergon <agk@redhat.com> 2.00.10-2
724- Install the full toolset, not just 'lvm'.
725
726* Wed Apr 07 2004 Alasdair Kergon <agk@redhat.com> 2.00.10-1
727- Update to version 2.00.10, which incorporates the RH-specific patches
728  and includes various fixes and enhancements detailed in WHATS_NEW.
729
730* Wed Mar 17 2004 Jeremy Katz <katzj@redhat.com> 2.00.08-5
731- Fix sysfs patch to find sysfs
732- Take patch from dwalsh and tweak a little for setting SELinux contexts on
733  device node creation and also do it on the symlink creation. 
734  Part of this should probably be pushed down to device-mapper instead
735
736* Thu Feb 19 2004 Stephen C. Tweedie <sct@redhat.com> 2.00.08-4
737- Add sysfs filter patch
738- Allow non-root users to build RPM
739
740* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
741- rebuilt
742
743* Fri Dec  5 2003 Jeremy Katz <katzj@redhat.com> 2.00.08-2
744- add static lvm binary
745
746* Tue Dec  2 2003 Jeremy Katz <katzj@redhat.com>
747- Initial build.
748
749
Note: See TracBrowser for help on using the repository browser.