source: projects/specs/branches/6/l/lvm/lvm-vl.spec @ 521

Revision 521, 6.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Linux Logical Volume Manager utilities.
2Name: lvm
3Version: 1.0.3
4Release: 19vl1
5License: GPL
6Group: System Environment/Base
7URL: http://www.sistina.com/products_lvm.htm
8BuildRoot: %{_tmppath}/%{name}-%{version}-root
9Source: ftp://linux.msede.com/lvm/1.0/lvm_%{version}.tar.gz
10Source2: pvscan.8
11Patch0: lvm-1.0.3-evilinstall.patch
12Patch1: lvm-0.9-paths.patch
13Patch2: lvm-0.9-broken.patch
14Patch3: lvm-1.0.3-dietlibc.patch
15Patch4: lvm-1.0.3-dietllseek.patch
16Patch5: lvm-1.0.3-wrapper2.patch
17Patch6: lvm-1.0.3-pvmove.patch
18Patch7: lvm-1.0.3-fixit.patch
19Patch8: lvm-1.0.3-cookie.patch
20Patch9: lvm-1.0.3-vgscanfix.patch
21Patch10: lvm-1.0.3-signals.patch
22Patch11: lvm-1.0.3-nomsdoschecks.patch
23Patch12: lvm-1.0.3-viodasd.patch
24Patch13: lvm-1.0.3-kdevt.patch
25
26%description
27LVM includes all of the support for handling read/write operations on
28physical volumes (hard disks, RAID-Systems, magneto optical, etc.,
29multiple devices (MD), see mdadd(8) or even loop devices, see
30losetup(8)), creating volume groups (kind of virtual disks) from one
31or more physical volumes and creating one or more logical volumes
32(kind of logical partitions) in volume groups.
33
34%prep
35
36%setup -q -n LVM
37%patch0 -p1 -b .evilinstall
38%patch3 -p1 -b .diet
39%patch6 -p1 -b .pvmove
40%patch7 -p1
41%patch8 -p1
42%patch9 -p1 -b .vgscanfix
43%patch10 -p1 -b .signals
44%patch11 -p1 -b .nomsdos
45%patch12 -p1 -b .viodasd
46%patch13 -p1 -b .kdevt
47
48cd %{version}
49
50# ugly hack to build diet-ized vgchange and vgscan
51%ifarch i386
52patch -p2 -i %{PATCH4}
53export CC="diet gcc"
54%endif
55
56
57# make the wrapper
58patch -p2 -i %{PATCH5}
59
60%build
61
62cd %{version}
63# make static versions of vgchange and vgscan (diet-ized on i386)
64%configure --prefix=%{_prefix} --sbindir=%{_syssbindir} --libdir=/%{_lib} --enable-static_link
65
66pushd tools/lib
67make
68cd ..
69make vgwrapper
70mv vgwrapper vgwrapper.static
71make clean
72popd
73
74
75patch -p2 -R -i %{PATCH5}
76
77%ifarch i386
78patch -p2 -R -i %{PATCH4}
79export CC=gcc
80%endif
81
82rm -f tools/vgwrapper.c tools/vgwrapper.o
83rm config.cache
84%configure --prefix=%{_prefix}  --sbindir=%{_syssbindir} --libdir=/%{_lib}
85make
86
87%install
88[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
89mkdir -p $RPM_BUILD_ROOT/%{_lib} \
90         $RPM_BUILD_ROOT%{_syssbindir} \
91         $RPM_BUILD_ROOT%{_mandir}/man8
92cd %{version}
93make DESTDIR=$RPM_BUILD_ROOT install
94
95# install static versions
96install -m 755 tools/vgwrapper.static $RPM_BUILD_ROOT%{_syssbindir}/vgwrapper
97ln $RPM_BUILD_ROOT%{_syssbindir}/vgwrapper $RPM_BUILD_ROOT%{_syssbindir}/vgchange.static
98ln $RPM_BUILD_ROOT%{_syssbindir}/vgwrapper $RPM_BUILD_ROOT%{_syssbindir}/vgscan.static
99
100#
101install -m 644 %SOURCE2 $RPM_BUILD_ROOT/%{_mandir}/man8/pvscan.8
102
103#pushd $RPM_BUILD_ROOT/sbin
104#for i in *; do
105#  mv $i $i.lvm1
106#done
107#popd
108
109# remove unpackaged files from the buildroot
110rm -rf $RPM_BUILD_ROOT/usr/lib
111#rm -fr $RPM_BUILD_ROOT/usr/share/
112
113%clean
114[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
115
116%post -p /sbin/ldconfig
117%postun -p /sbin/ldconfig
118
119%files
120%defattr(-,root,root)
121%doc %{version}/ABSTRACT %{version}/CHANGELOG %{version}/CONTRIBUTORS
122%doc %{version}/LVM-HOWTO %{version}/README %{version}/TODO
123%doc %{version}/WHATSNEW %{version}/FAQ
124%{_mandir}/man8/*
125/%{_lib}/*
126%{_syssbindir}/*
127
128%changelog
129* Thu Jun 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-19vl1
130- rebuild for Vine Linux based on Fedora 1.0.3-19.0
131- fixed %file section to add man8 man-pages
132- use better macros
133
134* Tue Apr 07 2004 Alasdair Kergon <agk@redhat.com> 1.0.3-19.0
135- Add .lvm1 suffix to all binaries; LVM2 is now the default.
136  This package is only useful to Fedora users reverting to a 2.4 kernel.
137
138* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
139- rebuilt
140
141* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
142- rebuilt
143
144* Sun Dec 14 2003 Jeremy Katz <katzj@redhat.com> 1.0.3-17
145- fix build with minimal glibc-kernheaders
146
147* Thu Dec 11 2003 Florian La Roche <Florian.LaRoche@redhat.de> 1.0.3-16
148- remove man8 man-pages to not conflict with lvm2 rpm
149
150* Tue Jun 17 2003 Jeremy Katz <katzj@redhat.com> 1.0.3-15
151- add patch to work with viodasd
152- improve fix for vgscan segfaults to work correctly on big endian platforms
153
154* Thu Jun 12 2003 Jeremy Katz <katzj@redhat.com> 1.0.3-14
155- stop making all kinds of silly assumptions and using msdos partition
156  table parsing.  just use BLKGETSIZE and be happy (#97275)
157
158* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
159- rebuilt
160
161* Wed Feb 19 2003 Bill Nottingham <notting@redhat.com> 1.0.3-12
162- don't set SIGCHLD to SIG_IGN and call wait() (#84100)
163
164* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
165- rebuilt
166
167* Wed Nov 27 2002 Tim Powers <timp@redhat.com> 1.0.3-10
168- lib64'ize
169- remove unpackaged files from the buildroot
170
171* Mon Sep 02 2002 Michael Fulbright <msf@redhat.com> 1.0.3-9
172- Fix vgscan to not segfault from corrupt data on disk (if disk was reformatted
173  and some LVM structures still exist, will die trying to parse)
174
175* Thu Jul 11 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.0.3-7
176- Fix pvscan.8 - it was the pvcreate one (#66273)
177
178* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
179- automated rebuild
180
181* Thu May 23 2002 Tim Powers <timp@redhat.com>
182- automated rebuild
183
184* Wed Mar 27 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.0.3-4
185- Have a cookie
186
187* Wed Feb 20 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.0.3-2
188- sct's patch updated
189
190* Tue Feb 19 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.0.3-1
191- 1.0.3
192- Redo most patches.
193
194* Mon Feb 18 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.0.2-2
195- Make it build with new kernel headers
196- Hey ho, hey ho, off into the buildsystem we go (with sct's changes)
197- Added URL
198
199* Thu Feb 14 2002 Stephen C. Tweedie <sct@redhat.com>
200- Add support for new (non-data-corrupting) pvmove kernel ioctl
201
202* Mon Jan 28 2002 Jeremy Katz <katzj@redhat.com>
203- update to 1.0.2
204- add a static vgwrapper which can run both vgchange and vgscan for
205  initrds; uses diet on i386
206
207* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
208- automated rebuild
209
210* Fri Jan 04 2002 Florian La Roche <Florian.LaRoche@redhat.de>
211- remove the "mawk" requirement
212
213* Mon Dec 17 2001 Trond Eivind Glomsrød <teg@redhat.com> 1.0.1-1
214- 1.0.1
215- s/Copyright/License/
216- patch away evil use of user/group during installation
217- change install procedure
218
219* Wed Jan 24 2001 Than Ngo <than@redhat.com>
220- updated to 0.9
221- hacked for building on ia64 and sparc
222
223* Mon Dec 11 2000 Bill Nottingham <notting@redhat.com>
224- build library code with -fPIC
225 
226* Wed Nov  1 2000 Matt Wilson <msw@redhat.com>
227- initialization of spec file.
Note: See TracBrowser for help on using the repository browser.