source: projects/specs/branches/6/l/lv/lv-vl.spec @ 3309

Revision 3309, 4.5 KB checked in by daisuke, 13 years ago (diff)

lv: rebuild for Vine6

Line 
1%define major   4
2%define minor   51
3%define teeny   0
4
5%if %{teeny}
6%define srcname %{name}%{major}%{minor}%{teeny}
7%else
8%define srcname %{name}%{major}%{minor}
9%endif
10
11Summary: a powerful multilingual file viewer
12Summary(ja): パワフルな多言語対応ファイルビュウワー
13Name: lv
14Version: %{major}.%{minor}.%{teeny}
15Release: 2%{?_dist_release}
16License: GPL
17Group: Applications/Text
18Source: http://www.ff.iij4u.or.jp/~nrt/freeware/%{srcname}.tar.gz
19URL: http://www.ff.iij4u.or.jp/~nrt/lv/
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21
22Provides: pager
23Requires(post,preun): alternatives
24BuildRequires: ncurses-devel >= 5.6
25
26Vendor: Project Vine
27Distribution: Vine Linux
28
29%description
30lv is a powerful file viewer like less.  lv can decode and encode
31multilingual streams through many coding systems: ISO-8859, ISO-2022,
32EUC, SJIS, Big5, HZ, Unicode.  It recognizes multi-bytes patterns as
33regular expressions, lv also provides multilingual grep.  In addition,
34lv can recognize ANSI escape sequences for text devoration.
35
36%description -l ja
37lv は less に似たパワフルなファイルビュウワーです。lv は多言語文字列を
38ISO-8859, ISO-2022, EUC, SJIS, Big5, HZ, Unicode といった様々な文字コー
39ドにエンコード・デコードできます。また多バイト正規表現をサポートしてお
40り、多言語 grep としての機能も備えています。さらに lv は ANSI エスケー
41プシーケンスによるテキスト装飾を扱うこともできます。
42
43
44%prep
45
46
47%setup -q -c
48
49
50%build
51cd %{srcname}/build
52../src/configure %{_target_platform} \
53  --prefix=%{_prefix} \
54  --exec-prefix=%{_exec_prefix} \
55  --bindir=%{_bindir} \
56  --sbindir=%{_sbindir} \
57  --sysconfdir=%{_sysconfdir} \
58  --datadir=%{_datadir} \
59  --includedir=%{_includedir} \
60  --libdir=%{_libdir} \
61  --libexecdir=%{_libexecdir} \
62  --localstatedir=%{_localstatedir} \
63  --sharedstatedir=%{_sharedstatedir} \
64  --mandir=%{_mandir} \
65  --infodir=%{_infodir}
66make
67cd ../..
68
69
70%install
71rm -rf ${RPM_BUILD_ROOT}
72mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
73mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1
74
75# installing binaries ...
76cd %{srcname}/build
77%makeinstall
78cd ../..
79
80# listing all files in drb-all.files
81(find \
82  $RPM_BUILD_ROOT%{_bindir} \
83  $RPM_BUILD_ROOT%{_mandir} \
84      -type f -o -type l) |
85 sort | sed -e "s,^$RPM_BUILD_ROOT,," \
86            -e "s,\(/man/man./.*\)$,\1*," > lv-all.files
87
88
89%clean
90rm -rf ${RPM_BUILD_ROOT}
91rm -f *.files
92
93
94#%post -p /sbin/ldconfig -n lv
95%post
96%{_syssbindir}/update-alternatives --install %{_bindir}/pager pager %{_bindir}/lv 20
97
98%preun
99if [ "$1" = "0" ]; then
100  %{_syssbindir}/update-alternatives --remove pager %{_bindir}/lv
101fi
102
103#%postun -p /sbin/ldconfig -n lv
104
105
106%files -f lv-all.files
107%defattr(-, root, root)
108%doc %{srcname}/GPL.txt
109%doc %{srcname}/README
110%doc %{srcname}/hello.sample
111%doc %{srcname}/hello.sample.gif
112%doc %{srcname}/index.html
113%doc %{srcname}/relnote.html
114%{_libdir}/lv
115
116
117%changelog
118* Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.51.0-2
119- rebuild for Vine 6
120
121* Sun Aug 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.51.0-1
122- new versioning policy
123- build with ncurses-5.6
124
125* Fri Apr 13 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 4.51.0-0vl6
126- add Provides: pager
127- add Requires(post,preun): alternatives
128
129* Mon Apr 09 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 4.51.0-0vl5
130- add update-alternatives: pager in %%post and %%preun scriptlet
131
132* Tue Apr 20 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.51.0-0vl4
133- rebuild on VineSeed
134
135* Tue Apr 20 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.51.0-0vl3
136- add (Build)Requires: libtermcap(-devel)
137- add Vendor/Distribution tag
138- add GPL.txt
139
140* Wed Feb 11 2004 KAZUKI SHIMURA <rito@pos.to> 4.51.0-0vl2
141- rebuild on VineSeed
142
143* Wed Feb 11 2004 KAZUKI SHIMURA <rito@pos.to> 4.51.0-0vl1
144- upstream release
145- drop obsolete patch lv-Makefile.in.patch (Patch1)
146
147* Sat Jan 10 2004 KAZUKI SHIMURA <rito@pos.to> 4.50.0-0vl1
148- upstream release
149- define %%{srcname}
150- s/Copyright/License/
151
152* Thu May 15 2003 IWAI Masaharu <iwai@alib.jp> 4.49.5-0vl2
153- rebuild on VineSeed
154
155* Thu May 15 2003 IWAI Masaharu <iwai@alib.jp> 4.49.5-0vl1
156- SECURITY FIX - upstream release
157   - fix CAN-2003-0188: possible local root exploit using config files
158
159* Mon Mar 24 2003 IWAI Masaharu <iwai@alib.jp> 4.49.4-0vl4
160- rebuild with new toolchain
161
162* Fri Sep 20 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.49.4-0vl3
163- URL was incorrect (http was hhttp)... Fixed the typo.
164
165* Sun Jul 21 2002 IWAI Masaharu <iwai@alib.jp> 4.49.4-0vl2
166- added the help file for executing with h option
167
168* Wed Jan 10 2001 akira yamada <akira@vinelinux.org>
169- Initial packaging.
Note: See TracBrowser for help on using the repository browser.