source: projects/specs/branches/6/l/lua-rex/lua-rex-vl.spec @ 3526

Revision 3526, 2.4 KB checked in by owa, 13 years ago (diff)

rebuilt

Line 
1%define luaver %(pkg-config --variable=V lua || echo missing)
2%define lualibdir %{_libdir}/lua/%{luaver}
3
4Name:           lua-rex
5Version:        2.4.0
6Release:        5%{?_dist_release}
7Summary:        Regular expression handling library for Lua
8Summary(ja):    正規表現を扱うための Lua ライブラリ
9
10Group:          Development/Libraries
11License:        MIT
12URL:            http://lrexlib.luaforge.net/
13Source0:        http://luaforge.net/frs/download.php/3599/lrexlib-2.4.0.zip
14Patch0:         lrexlib-2.4.0-pmake.patch
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
16
17BuildRequires:  oniguruma-devel
18BuildRequires:  pcre-devel
19BuildRequires:  lua-devel
20BuildRequires:  pkgconfig
21BuildRequires:  unzip
22Requires:       lua = %{luaver}
23Provides:       lrexlib = %{version}
24
25%description
26Lrexlib are bindings of three regular expression library APIs (POSIX, PCRE
27and Oniguruma) to Lua.
28
29
30%prep
31%setup -q -n lrexlib-%{version}
32%patch0 -p1 -b .pmake
33
34
35%build
36make %{?_smp_mflags} LD=cc MYCFLAGS="%{optflags} -fPIC %(pcre-config --cflags)" build
37
38
39%install
40rm -rf $RPM_BUILD_ROOT
41install -d $RPM_BUILD_ROOT%{lualibdir}
42cp -P */*/rex_{onig,pcre,posix}.so* $RPM_BUILD_ROOT%{lualibdir}
43
44
45%check
46make %{?_smp_mflags} test
47
48
49%clean
50rm -rf $RPM_BUILD_ROOT
51
52
53%files
54%defattr(-,root,root,-)
55%{lualibdir}/*
56%doc ChangeLog LICENSE NEWS README doc
57
58
59%changelog
60* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 2.4.0-5
61- rebuilt with rpm-4.8.1-3
62
63* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.0-4
64- rebuilt with gcc-4.4.3-3 on ppc
65
66* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.0-3
67- rebuilt with rpm-4.8.0-3 (on ppc)
68
69* Wed Feb 03 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.0-2
70- added BR: unzip
71
72* Wed Feb 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
73- initial build for Vine Linux
74
75* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-5
76- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
77
78* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-4
79- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
80
81* Thu Dec 23 2008 Lubomir Rintel <lkundrak@v3.sk> - 2.4.0-3
82- Compile shared library as PIC
83
84* Wed Dec 17 2008 Lubomir Rintel <lkundrak@v3.sk> - 2.4.0-2
85- Add doc directory to documentation
86- Allow parallel make runs
87
88* Tue Dec 16 2008 Lubomir Rintel <lkundrak@v3.sk> - 2.4.0-1
89- Initial packaging
Note: See TracBrowser for help on using the repository browser.