source: projects/specs/branches/6/l/lsof/lsof-vl.spec @ 521

Revision 521, 5.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A utility which lists open files on a Linux/UNIX system.
2Summary(ja): 開かれているファイルの一覧を表示するツール
3Name: lsof
4Version: 4.78
5Release: 9%{?_dist_release}
6License: Distributable
7Group: Applications/System
8Distribution: Vine Linux
9
10# lsof contains licensed code that we cannot ship.  Therefore we use
11# upstream2downstream.sh script to remove the code before shipping it.
12#
13# The script you can found in CVS or download from:
14# http://cvs.fedoraproject.org/viewcvs/rpms/lsof/devel/upstream2downstream.sh
15#
16%define lsofrh lsof_4.78C-rh
17Source0: %{lsofrh}.tar.bz2
18URL: ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20
21Patch1: lsof_4.78C-threads.patch
22Patch2: lsof_4.78C-inode.patch
23Patch3: lsof_4.78C-selinux.patch
24
25%description
26Lsof stands for LiSt Open Files, and it does just that: it lists
27information about files that are open by the processes running on a
28UNIX system.
29
30%description -l ja
31Lsof は UNIX 特有の診断ツールです。その名前は LiSt Open Files を意味し、
32文字通りの動作 (開かれているファイルの一覧を表示) をします。
33このプログラムは、システムで現在動作しているプロセスによって開かれている
34全てのファイルに関する情報を表示します。
35
36%prep
37%setup -q -n %{lsofrh}
38# 184338 - allow lsof access nptl threads
39%patch1 -p1
40# 243976 - mmap'd files with large inode numbers confuse lsof
41%patch2 -p1
42# 280651 - lsof prints entries in multiple lines when SElinux is disabled
43%patch3 -p1
44
45%build
46LSOF_VSTR=2.6.23 LINUX_BASE=/proc ./Configure -n linux
47
48make DEBUG="$RPM_OPT_FLAGS" %{?_smp_mflags}
49
50#LSOF_VERS=24018 LSOF_VSTR=2.4.18 LINUX_BASE=/proc \
51#       ./Configure -n linux
52
53%install
54rm -rf ${RPM_BUILD_ROOT}
55mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
56install -p -m 0755 lsof ${RPM_BUILD_ROOT}%{_prefix}/sbin
57mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man8
58install -p lsof.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
59
60%clean
61rm -rf ${RPM_BUILD_ROOT}
62
63%files
64%defattr(644,root,root,755)
65%doc 00*
66%attr(0755,root,root) %{_sbindir}/lsof
67%{_mandir}/man*/*
68
69%changelog
70* Sun Apr 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.78-9
71- changed Group to Applicaions/System
72
73* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 4.78-8vl5
74- applied new versioning policy, spec in utf-8
75
76* Mon Oct 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.78-7vl2
77- rebuilt for VineSeed
78
79* Mon Oct 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.78-7vl1
80- rebuilt for VinePlus/4.0
81- s/Copyright/License/
82- based on Fedora Core
83
84* Fri Jan 21 2005 OOI Keita <ooik.ovwqlsjxcqwg4dc@privango.jp>
85- 4.73-1vl1
86- based on Fedora Core 3
87
88* Mon Dec 13 2004 Karel Zak <kzak@redhat.com> 4.73-1
89- update to 4.73
90- remove lsof_4.72-sock.patch, already in the upstream code
91
92* Fri Jul 30 2004 Jakub Jelinek <jakub@redhat.com> 4.72-1
93- update to 4.72
94- use st_dev/st_ino comparison for sockets by name if possible
95  (#126419)
96
97* Fri Jul 18 2003 Jakub Jelinek <jakub@redhat.com> 4.68-1
98- update to 4.68 (#99064)
99
100* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
101- rebuilt
102
103* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
104- rebuilt
105
106* Thu Dec 12 2002 Tim Powers <timp@redhat.com> 4.63-3
107- rebuild on all arches
108
109* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
110- automated rebuild
111
112* Fri Jun 21 2002 Jakub Jelinek <jakub@redhat.com> 4.63-1
113- update to 4.63 (#66333).
114
115* Thu May 23 2002 Tim Powers <timp@redhat.com>
116- automated rebuild
117
118* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
119- automated rebuild
120
121* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
122- Bump release + rebuild.
123
124* Thu Sep  7 2000 Jeff Johnson <jbj@redhat.com>
125- update to 4.51.
126
127* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
128- automatic rebuild
129
130* Wed Jun 14 2000 Jeff Johnson <jbj@redhat.com>
131- FHS packaging.
132
133* Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
134- change to root:root perms
135
136* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
137- fix description
138- man pages are compressed
139
140* Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
141- update to 4.47.
142
143* Tue Aug  3 1999 Jeff Johnson <jbj@redhat.com>
144- update to 4.45.
145
146* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
147- update to 4.44.
148
149* Fri May 14 1999 Jeff Johnson <jbj@redhat.com>
150- upgrade to 4.43 with sparc64 tweak (#2803)
151
152* Thu Apr 08 1999 Preston Brown <pbrown@redhat.com>
153- upgrade to 4.42 (security fix)
154
155* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
156- auto rebuild in the new build environment (release 5)
157
158* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
159- turn off setgid kmem "just in case".
160
161* Thu Feb 18 1999 Jeff Johnson <jbj@redhat.com>
162- buffer overflow patch.
163- upgrade to 4.40.
164
165* Wed Dec 30 1998 Jeff Johnson <jbj@redhat.com>
166- update to "official" 4.39 release.
167
168* Wed Dec 16 1998 Jeff Johnson <jbj@redhat.com>
169- update to 4.39B (linux) with internal kernel src.
170
171* Tue Dec 15 1998 Jeff Johnson <jbj@redhat.com>
172- update to 4.39A (linux)
173
174* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
175- update to 4.37
176
177* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
178- update to 4.36
179
180* Thu Jul 23 1998 Jeff Johnson <jbj@redhat.com>
181- upgrade to 4.35.
182- rewrap for RH 5.2.
183
184* Mon Jun 29 1998 Maciej Lesniewski <nimir@kis.p.lodz.pl>
185  [4.34-1]
186- New version
187- Spec rewriten to use %{name} and %{version} macros
188- Removed old log enteries
189
190* Tue Apr 28 1998 Maciej Lesniewski <nimir@kis.p.lodz.pl>
191- Built under RH5
192- %install was changed
Note: See TracBrowser for help on using the repository browser.